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Chapter 1

Installing Photran

1.1

Prerelease installation instructions

Prerelease versions of Photran 7.0 must be installed as follows. (The insta-
llation instructions in subsequent sections are currently incorrect and will be
updated prior to the 7.0 release.)

1.

Download the latest release candidate build of the Eclipse 3.6 SDK or
Platform Runtime Binary (3.6RC1) from : http://download.eclipse.
org/eclipse/downloads/drops/S-3.6RC1-201005131500/

Download the latest release candidate build of CDT 7.0 from: http:
//download.eclipse.org/tools/cdt/builds/7.0.0/index.html

Download the latest release candidate build of PTP 4.0 from http://
wiki.eclipse.org/PTP/builds/4.0.0 (this includes Photran 7.0)

To start Eclipse...

1.

On Windows, unzip the file eclipse-xxxxx.zip that you downloaded above
into a directory of your choice, and launch eclipse.exe. You may need to
run it with administrator privileges.

On Linux or Mac OS X, untar the file eclipse-xxxxx.tar.gz that you down-
loaded above, and launch the eclipse binary.

Before you can install Photran into Eclipse, you will need to install CDT.
To install CDT...

1. Click on Help ; Install New Software...

2. Click on the ”Add...” button

3.

Click on the ”Archive...” button

4. Point it to the file cdt-master-7.0.0-12010xxxxxxxx.zip that you downloa-

ded above.
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Click OK to close the Add Site dialog. This will return you to the Install
dialog.

Expand ”CDT Main Features” and check the box next to ” Eclipse C/C++
Development Tools”

Click on the ”Next” button

Click the Finish button and agree to the license to complete the installa-
tion.

After CDT is installed, you will be asked to restart Eclipse. You may
then proceed to install Photran.

To install Photran, start Eclipse, then...

10.

. Click on Help ; Install New Software...

Click on the ”Add...” button

Click on the ” Archive...” button

. Point it to the file ptp-master-4.0.0-12010xxxxxxxx.zip that you down-

loaded above.

Click OK to close the Add Site dialog. This will return you to the Install
dialog.

Expand ”Fortran Development Tools (Photran)” and check the boxes
next to "Photran End-User Runtime” and ”Rephraser Engine End-User
Runtime” (the latter is a supporting component)

If you are running Linux and have the Intel Fortran Compiler installed,
or if you are on a Macintosh and have the IBM XL Fortran compiler
installed, expand ”Fortran Compiler Support” and select the appropriate
compiler. Note that you cannot install Intel Fortran compiler support
unless you are running Linux!

Click on the ”Next” button
If you get an error message, see below for troubleshooting information.

Click the Finish button and agree to the license to complete the installa-
tion.
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1.2 System Requirements

To install Photran 6.0...
You must have Eclipse 3.6 (Helios) installed.

1. You should have the C/C++ Development Tools (CDT) 7.0 installed. If
you do not...

a) If you downloaded Eclipse from eclipse.org and you will be following
the instructions below for ”Installing on a Machine With Internet
Access,” then CDT should be installed automatically when you ins-
tall Photran.

b) Otherwise, CDT probably will not be installed automatically. You
will need to install CDT manually. Follow the instructions below
for ”Installing on a Machine Without Internet Access.” You should
also follow these instructions if you did not download Eclipse from
eclipse.org (e.g., if you installed it from a Linux distribution like
Ubuntu).

2. Eclipse must be running on a Java 1.5 or later Java Virtual Machine
(JVM). To get reasonable performance, we recommend Sun’s JVM [1]
or IBM’s J9 [2]. OpenJDK (the default JVM on newer versions Fedora
Linux) also works well, although GNU Classpath (the default JVM on
older versions of Fedora) is generally too slow to be useful.

3. If you want to compile and build Fortran applications, you must have
a make program (such as GNU Make) and a Fortran compiler (such
as gfortran, the GNU Fortran compiler) in your system path. Many
Linux/Unix systems include these; details on installing them in Windows
and Mac are below.

1.3 Installation Procedure

Installing on a Machine With Internet Access

To install Photran, start Eclipse, then...
1. Click on Help »Install New Software...
2. Click on the ”Add...” button
3. In the Location field, type http://download.eclipse.org/tools/ptp/releases/helios

4. Click OK to close the Add Site dialog. This will return you to the Install
dialog.

)

5. Expand ”Fortran Development Tools (Photran)” and check the box next

to "Photran End-User Runtime”
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6. If you are running Linux and have the Intel Fortran Compiler installed,
or if you are on a Macintosh and have the IBM XL Fortran compiler
installed, expand ”Fortran Compiler Support” and select the appropriate
compiler. Note that you cannot install Intel Fortran compiler support
unless you are running Linux!

7. Click on the ”Next” button
8. If you get an error message, see below for troubleshooting information.
9. Click the Finish button and agree to the license to complete the installa-
tion.
Installing on a Machine Without Internet Access

You will the following files:
If you do not have CDT installed, you will need to download the latest 7.0.x
”CDT master update archive” from http://download.eclipse.org/tools/cdt/releases/helios/).
This should be a file named cdt-master-7.0.x.zip (for some value of x) To install
Photran, you will need the latest PTP update site archive from http://wiki.eclipse.org/PTP /builds/4.0.0
This should be a file named ptp-master-4.0.0-12010xxxxxxxx.2zip
If you do not have CDT installed, start Eclipse, then...

1. Click on Help »Install New Software...
2. Click on the ”Add...” button

3. Click on the ” Archive...” button

4. Point it to the file cdt-master-7.0.x.zip

5. Click OK to close the Add Site dialog. This will return you to the Install
dialog.

6. Expand ”CDT Main Features” and check the box next to ”Eclipse C/C++
Development Tools”

7. Click on the ”Next” button

8. Click the Finish button and agree to the license to complete the installa-
tion.

9. After CDT is installed, you will be asked to restart Eclipse. You may
then proceed to install Photran.

To install Photran, start Eclipse, then...
1. Click on Help »Install New Software...
2. Click on the "Add...” button

3. Click on the ” Archive...” button
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4. Point it to the file ptp-master-4.0.0-I12010xxxxxxXxX.Zip

5. Click OK to close the Add Site dialog. This will return you to the Install
dialog.

6. Expand "Fortran Development Tools (Photran)” and check the boxes
next to ”"Photran End-User Runtime” and ”Rephraser Engine End-User
Runtime” (the latter is a supporting component)

7. If you are running Linux and have the Intel Fortran Compiler installed,
or if you are on a Macintosh and have the IBM XL Fortran compiler
installed, expand ”Fortran Compiler Support” and select the appropriate
compiler. Note that you cannot install Intel Fortran compiler support
unless you are running Linux!

8. Click on the ”"Next” button
9. If you get an error message, see below for troubleshooting information.

10. Click the Finish button and agree to the license to complete the installa-
tion.

Troubleshooting

Eclipse’s installer gives notoriously cryptic error messages, which, unfortuna-
tely, are out of Photran’s control. Some of the more common ones are below.
If you run into a different error message and cannot resolve it, please ask for
help on the Photran mailing list.

Problem: You receive the following error message during installation.

Cannot complete the install because one or more required items could not
be found. Missing requirement: 125xxxxxxxxxx 0.0.0.125XXXXXXXXXX requires
‘org.eclipse.photran.intel.feature.group [5.0.0.xxxx]’ but it could not be found

Solution: You are attempting to install support for the Intel Fortran com-
piler, but you are not running Linux. Go back in the installation wizard, and
uncheck ”Linux Intel(R) Fortran Compiler Support.”

Problem: You receive the following error message during installation.

Cannot complete the install because one or more required items could not be
found. Software being installed: Photran End-User Runtime 7.0.X. XXXXXXXXXXXX
(org.eclipse.photran.feature.group 7.0.x.xxxxxxxxxxxx) Missing requirement:
Photran VPG CDT Interface Plug-in 7.0.x.xxxxxxxxxxxx (org.eclipse.photran.cdtinterface.vpg
7.0.x.xxxxxxxxxxxX) requires 'bundle org.eclipse.cdt.core 0.0.0’ but it could
not be found Cannot satisfy dependency: From: Photran End-User Runtime
7.0.x.xxxxxxxxx¥xxX (0rg.eclipse.photran.feature.group 7.0.x.xxxxxxxxxxxx) To:
org.eclipse.photran.cdtinterface.vpg [7.0.X. XXXXXXXXXXXX]



8 CHAPTER 1. INSTALLING PHOTRAN

Solution: You do not have CDT 7.0 installed, and it couldn’t be down-
loaded and installed automatically. Try installing CDT 7.0 first, then retry
installing Photran.

Additional Instructions for Windows Users

To compile and run Fortran programs in Photran, you will need to have a
Fortran compiler and make utility installed. gfortran and GNU Make are com-
monly used (and free). Most Linux/Unix distributions include these. Under
Windows, you will need to install Cygwin [3] (which optionally includes gfor-
tran and GNU Make) or MinGW [4] and put them on your Windows PATH.

Instructions for Cygwin

1. Install Cygwin; the defaults are mostly OK, but you will need to expli-
citly tell it to include the "Devel” packages (at least gccd-fortran, gdb,
and make) when the installer asks you to select what packages to ins-
tall. (If gced-fortran is not listed under the ”Devel” packages, you may
have chosen a bad mirror; restart the Cygwin installation, and choose
a different mirror instead. Georgia Tech’s mirror at gtlib.gatech.edu is
generally quite fast and reliable, for example.)

2. Add the Cygwin directories to your Windows PATH. Under Windows
XP, the process is as follows:

a) Make sure you are logged in under an administrator account.

b) Open the Control Panel.

c¢) Double-click the System icon.

d) Switch to the Advanced tab.
)
)

e) Click the Environment Variables button.

f) Under System Variables, find the variable ”Path” in the list, and

click on it.
Click Edit.
h) At the end of the ”Variable Value” text, add
i) Click OK, click OK, click OK, and close the Control Panel.

J

g

o —

Close and re-open Photran. Windows should now search

Additional Instructions for Mac OS X Users

If you install gfortran on Mac OS X, it may be installed in /usr/local/bin,
which is not (by default) on the PATH. If you are launching Eclipse from a
Terminal, the PATH can be set by modifying /etc/paths. However, if you are
launching Eclipse from the Finder (by double clicking on it) or the Dock, then
the PATH is not obtained from the shell or /etc/paths. Instead, it’s obtained
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from /.MacOSX/environment.plist. The format of the environment.plist file
is as follows (change the path appropriately). If you create or edit this file, you
will need to log out (or reboot) before the changes will take effect.

<?xml version="1.0" encoding="UTF-8"7>
<!DOCTYPE plist
PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DIDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>PATH</key>
<string>/usr/local/mpi/bin:/usr/local/bin:/bin:/sbin:/usr/bin:
/usr/sbin:/sbin:/usr/sbin:/Developer/Tools:/usr/texbin:/Users/greg/bin

</string>
</dict>
</plist>

1.4 Getting Started

Photran is an integrated development environment and refactoring tool for
Fortran 77, 90, 95, and 2003. It includes an editor with ”smart” syntax high-
lighting, a GUI debugger, CVS support, Makefile-based compilation, error mes-
sage recognition for many common Fortran compilers, Fortran language-based
search and code navigation, content assist, a Fortran declaration view, and
many refactorings, including popular refactorings such as Rename and Extract
Procedure as well as Fortran-specific refactorings like Introduce Implicit None.

Photran is based on Eclipse, and some of its components are reused from the
Eclipse C/C++ Development Tools (CDT). Throughout this documentation,
you will see references to relevant parts of the Eclipse and CDT documentation,
which can be accessed by clicking on the Help menu (inside Photran/Eclipse)
and clicking Help Contents.

If you have never used Eclipse before, please work through the Eclipse
Workbench tutorial before attempting to use Photran. Click on Help »Help
Contents in Eclipse, and navigate to Workbench User Guide ; Getting started ;,
Basic tutorial. This will introduce you to Eclipse concepts such as perspectives
and views; such terminology will be used throughout this manual.

1.5 Starting a New Project

One of the advantages (or disadvantages) of using Photran is that it does not
include a Fortran compiler. Instead, it uses make to compile Fortran programs.
This allows you to use any Fortran compiler you want, but it also means that
a Makefile must be written which tells the make program how to compile your
Fortran program.

e For small, simple projects, Photran can auto-generate a Makefile which
will use the GNU Fortran compiler (gfortran).

e For more complex projects, you can write a custom Makefile.
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For more information on project types, click on Help »Help Contents in Eclipse,
and navigate to C/C++ Development User Guide »Concepts »CDT Projects.

Starting a Project with an Auto-Generated Makefile

The following is a typical procedure for starting a new project using an auto-
generated Makefile. Your system must have the GNU Fortran (gfortran) compi-
ler installed for this procedure to work. To make sure that gfortran is installed,
you can open a command prompt (Windows) or terminal window (Linux/Mac)
and type 7gfortran” (without the quotes); it should respond with ”gfortran:
no input files”.

1. Click File »New »Fortran Project
2. Call it HelloFortran
3. Choose ”Executable (Gnu Fortran)” from the project type list

4. Choose ”GCC Toolchain” from the toolchain list (you may need to first
uncheck the ”Show project types...” check box at the bottom of the win-
dow before you can see this)

Click Next
Click on Advanced Settings

Expand C/C++ Build in the list on the left, and click on Settings

® N o

Click on the Binary Parsers tab. Check the appropriate parsers for your
platform. If you are using Windows, check PE Windows Parser and/or
Cygwin PE Parser; if you are using Linux, check Elf Parser; if you are
using Mac, check Mach-O parser.

9. Click on the Error Parsers tab. Check the error parser(s) for the Fortran
compiler(s) you will use.

10. Click OK

11. Click Finish

12. Click File »New »Source File
13. Call it hello.f90; click Finish

14. Type the standard ”Hello, World” program shown below, and click File
»Save.

15. Open the Console view, and make sure "make” ran OK and compiled
your program

16. In the Fortran Projects view, expand the Binaries entry, and click on
your executable (e.g., "HelloFortran.exe - [x86le]”)
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17. Run — Run As — Run Local Fortran Application

18. Choose GDB Debugger (Cygwin GDB Debugger if you’re under Win-
dows)

19. Check the Console view, and make sure ”"Hello World” appeared.

hello.f90:

program hello
print *, "Hello World"
end program

Starting a Project with a Hand-Written Makefile

The following is a typical procedure for starting a new project using a hand-
written Makefile. The following example uses the GNU Fortran (gfortran)
compiler, but any Fortran compiler can be used instead. We will assume that
you are familiar with how to write a Makefile. If not, there are plenty of
resources on the Web, including a tutorial from an introductory Computer
Science course at UIUC [5] and another from the University of Hawaii [6]...
and, of course, you can always read the entire manual for GNU Make [7].

1. Click File »New »Fortran Project
2. Call it HelloFortran

3. Expand "Makefile project” in the project type list (it has a folder icon),
and choose ”Empty Project”

4. Select "— Other Toolchain —” in the toolchain list in the right-hand co-
lumn, and click Next

5. Click on Advanced Settings
6. Expand C/C++ Build in the list on the left, and click on Settings

7. Click on the Binary Parsers tab. Check the appropriate parsers for your
platform. If you are using Windows, check PE Windows Parser and/or
Cygwin PE Parser; if you are using Linux, check Elf Parser; if you are
using Mac, check Mach-O parser.

8. Click on the Error Parsers tab. Check the error parser(s) for the Fortran
compiler(s) you will use.

9. Click OK
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24.
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Click Finish

Click File »New »Source File

Call it hello.f90

Click Finish

Type the standard ”Hello, World” program shown below.
Click File »New »File

Call it Makefile

Click Finish

Create a Makefile similar to the one shown below. Again, we assume you
are familiar with the structure of a Makefile. You cannot simply copy-
and-paste this example because the gfortran and rm lines must start with
a tab, not spaces. The -g switch instructs gfortran to include debugging
symbols in the generated executable so that it can be debugged later.
The -o switch tells it what to name the generated executable.

Click Project »Clean, then click OK

Open the Console view, and make sure "make” ran OK and compiled
your program

In the Fortran Projects view, expand the Binaries entry, and click on
your executable (e.g., “hello.exe - [x86le]”)

Click Run »Run As »Local Fortran Application

Choose GDB Debugger (Cygwin GDB Debugger if you’re under Win-
dows)

Check the Console view, and make sure ”Hello World” appeared.

hello.£90

program hello
print *, "Hello World"
end program

Makefile: (You MUST replace the spaces beginning the gfortran
and rm lines with a tab character!)

all: gfortran -o hello.exe -g hello.f90

clean: rm -f hello.exe
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Converting C/C++ Projects to Fortran Projects

Every Fortran project is also a C project, so CDT’s functionality will work

as expected on Fortran projects. However, a C/C++ is not a Fortran project

until it has been explicitly converted. (In the Fortran Projects view, a Fortran

project will have an ”F” icon, while a C/C++ project will have a ”C” icon.)
To convert an existing C/C++ project to a Fortran project:

1.
2.

1.7

Switch to the Fortran perspective.

In the Fortran Projects view, right-click on the project you want to con-
vert, and select Convert to Fortran Project from the pop-up menu.

The project should now have an ”F” icon in the Fortran Projects view.

CF) Fortran Projects &3 =08

S —

b =5 This_is_a_C_project

b =5 This_is_a_Fortran_project

Upgrading Projects Created with Earlier Versions
of Photran

There are three major changes in Photran 6 that affect users of previous ver-
sions of Photran:

1.

Projects must be converted to Fortran projects. In the past, Photran
would treat C projects and Fortran projects similarly. In fact, in Photran
4 and earlier versions, Photran’s new project wizard actually created C
projects! But in Photran 6, many of Photran’s features will only be
available after a project is converted to a Fortran project. (Every Fortran
project is a C project too, so CDT’s features will still work on the project.)
Learn how to convert projects.

Project properties must be reset. Photran 6 uses a new mechanism for
storing project properties. Unfortunately, this means that the project
properties for old projects must be re-created. This includes enabling
analysis /refactoring and setting include paths and module paths.

Source form settings must be set for the project. Previous versions of
Photran used Eclipse’s workspace-wide settings to distinguish free and
fixed form files. In Photran 6, each project has its own settings that
determine which filename extensions correspond to free and fixed source
form (and which files contain C preprocessor directives). Learn about
source form settings.
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1.8 Writing Code

Configuring Source Forms and Filename Extensions

Photran supports both fixed-form and free-form Fortran code. Photran also
supports C preprocessor directives, such as #define, #ifdef, #include, __FILE__,
and __LINE__ in Fortran code.

Fixed form is an older form designed for punch cards. It is more common in Fortran 77 and
earlier programs, although it is still part of Fortran 2003. In fixed form, a ”c¢”, 7C”, ”*” or "!”
in column 1 indicates a comment; columns 1 through 5 are used for a statement label; a character
in column 6 indicates a continuation line; and program statements are contained in columns 7
through 72. Anything after column 72 is ignored. (Although column 72 is specified in the Fortran
standard, most compilers allow you to change this to permit longer lines; Photran allows you to
change it as well, as described in the next section.)

Photran uses filename extensions to determine whether a file is in fixed-
or free-form and whether or not it is C-preprocessed. The default filename
extensions are as follows.

Filename Extensions Source Form/Preprocessing
A1, fix, for, .fpp,
ftn F, .F77, .FIX,
.FOR, .FTN, .FPP, .fpp Fixed source form
.f08, .f03, .f95, .f90 Free source form with INCLUDE lines
.FO08, .F03, .F95, .F90 | Free source form with C preprocessor directives

Configuring Source Form/Filename Extension Associations

The filename extensions listed above are the defaults for new Fortran projects.
To change them:

1. In the Fortran Projects view, right-click on a project, and choose Pro-
perties.

2. In the tree on the left, navigate to Fortran General »Source Form.

3. For each filename extension(s) you want to change, select the appropriate
source form from the dropdown box.

4. Click OK to close the dialog box.

Adding Additional Filename Extensions

Additional filename extensions can be added by changing the Eclipse Content
Type preferences.

1. Click on Window »Preferences... (Eclipse »Preferences... on Mac OS
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800 Properties for FreeFormParserBugs
" type filter text ' | Source Form S e
b Resource .
Builders The list of Fortran filename extensions is determined
pC/C++ Build by the workspace-wide content type settings. }
B C/C++ General 5 § il iati .
FFGITI’aI‘I Build ource (Jl’l'ﬁ,ll ename associations:
wFortran General File Name/Extension Source Form
Analysis /Refactoring *F Fixed Form - INCLUDE lines ignared j
Export Settings
Paths and Symbals *FD3 Free Form - C Preprocessed j |
L/ *.FO8 Free Form - C Preprocessed ’1 I
Project Facets — |
Praject References *F77 Fixed Form - INCLUDE lines ignored j | -
A A
i r'y
Run/Debug Settings * Fa0 Free Form - C Preprocessed - | T
Server hd —
./"fh ( cancel ) ek

a) In the "Content types:” tree in the right pane, navigate to Text
» Fortran Source File.

2. Click the Add... button.

3. To make all files with a ”.fre” filename extension be recognized as Fortran
source code, enter *.fre in the dialog. You can also specify individual
filenames by omitting the *. prefix; for example, entering old-fortran-
code.txt will make any file named old-fortran-code.txt be recognized as
Fortran source code, but not other .txt files.

4. Click OK to close the dialogs.

For more information on configuring content types, click on Help »Help Con-
tents in Eclipse and navigate to Workbench User Guide »Reference »Prefe-
rences »Content Types.

Configuring Fixed Form Line Width

While free source form allows lines to be arbitrarily long, in fixed form, there
is a predetermined maximum line width. Often, this is 72 characters (i.e.,
anything after column 72 is ignored and treated as a comment), although most
compilers allow you to change this to permit longer lines. Photran allows you
to change it as well.

To change the maximum line width in fixed form sources...

1. Open the workbench preferences. On Windows or Linux, click Window
» Preferences; on Mac OS X, click Eclipse »Preferences.

2. Expand the Fortran category, and choose Editor.

3. Change the value of the field labeled ”fixed form line length.” The value
must be at least 72.
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If you have any fixed form editors open, close and reopen them; notice that the
rightmost, gray vertical bar has been moved to the column indicated, and the
parser (which constructs the Outline view) has adjusted accordingly.

NOTE: This is a workspace-wide preference: It affects all fixed form files
in the workspace. It is not currently possible to adjust this setting per project
or per file.

The Fortran Perspective

When you write Fortran code, ordinarily you will work in the Fortran perspec-
tive. When you create a new Fortran project (as described above), the wizard
will ask if you want to switch to the Fortran perspective, or you can do it ma-
nually by clicking Window »Open Perspective »Other... and selecting Fortran
from the list.

For more information on perspectives, click on Help »Help Contents in
Eclipse, and navigate to Workbench User Guide »Concepts »Perspectives.
Perspectives are also covered in the Eclipse tutorial, which can be found in
Workbench User Guide »Getting started »Basic tutorial.

In particular, note that you can add views to a perspective by clicking
Window »Show View »Other... and selecting a new view from the Show View
dialog. You can also reset the current perspective to its original layout: From
the menu bar, choose Window »Reset Perspective.

By default, the Fortran perspective contains a central area for editing code,
as well as the following views:

e The Fortran Projects view displays your project(s) and any files and
folders in it.

e The Problems view will show errors from your Fortran compiler, if Pho-
tran can recognize them. (This requires configuring an error parser, des-
cribed elsewhere in this manual.)

e The Console view shows the output from your Fortran compiler. When
you run your Fortran program, its output is also displayed in the Console
view.

e The Fortran Declaration view is described in the Photran Advanced Fea-
tures manual.

e The Outline view shows the high-level structure of your program, i.e.,
the subprograms, modules, derived types, etc. comprising it.

e The Make Targets view allows you to quickly run make on a particular
target defined in a custom Makefile.

For more information on the Make Targets view, click on Help »Help Con-
tents in Eclipse, and navigate to C/C++ Development User Guide »Reference
»C/C++ Views and Editors »Make Targets view.
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The Fortran Projects View

The Fortran Projects view displays project files in a tree structure. In this
view you can do the following:

e Open files in the Fortran editor

e Manage existing files (cut, paste, delete, move or rename)
e Create new projects, files, or folders

e Import or Export files and projects

e Browse the high-level structures in Fortran files

e Open projects in a new window

e Perform some multi-file refactorings (such as Introduce Implicit None;
see the Photran Advanced Features Manual)

Files can be opened by double-clicking on the filename or by right-clicking on
the file and choosing ”Open With” from the context menu. Most other actions
are performed by right-clicking on the file and choosing an action from the
context menu.

The Fortran projects view is similar to the C/C++ Projects View. For
more information on the Fortran Projects view, refer to the documentation on
the C/C++ Projects view by clicking on Help »Help Contents in Eclipse and
navigating to C/C++ Development User Guide »Reference »C/C++ Views
and Editors »C/C++ Projects view.

1.9 Using the Fortran editor and Fortran perspective

Outline View

[F] hello.fa0 [F] commonTest.f30 [ common.fan 2 = O B= Outline 32 @ Mske Targets| = O
= = : - : : 7 BB e
program main "
< >
sae moreCommen I <Frec Form Source
; i @ main
implicit none o
change_¢
°
B external change_sb
commen a, b
integer :: a L
real it b

common /commen/ c,d,e, /common2/ £, g, /commeon3/ h
complex :: ¢

dimension c(3)

! double precision :: d, e, £, g, h

double precision ::
double precision ::
double precision ::
double precision ::
double precision ::

T omom o

a=1 -
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When a Fortran file is open in the Fortran editor, the Outline view shows
an outline of the structural elements of that file: subprograms, main programs,
modules, derived types, etc. The Outline view notes the content type of the file
(free form or fixed form); it will also note when there is an error in the code.
To add the Outline view to the current perspective go to Window »Show View
»Other... »General »QOutline.

o= Outline 52 @ Make Targets| — O
R e w7
m Syntax error: Unexpected identifier (c

Overview of the Fortran editor

The Fortran editor includes a number of features. The main features to note
are the horizontal ruler at the top of the editor, code folding, and syntax
highlighting.

The horizontal ruler measures the width of the editor in characters: There
is either a symbol (-/+) or number for each column in the editor. A plus sign
(4) is shown every fifth character, and every tenth character is numbered. It
is also possible to turn on the print margin (gray vertical line) in the 80th
column; this is discussed further below in the section titled ”Configuring the
Editor.”

[A hello.fo0 &2 =08

program hello -
implicit none
print *, "Hello!"

end program hello

Code folding is also supported in the free form editor, but turning on code
folding will disable the horizontal ruler; how to do this is described below as
well. When folding is turned on, a minus sign (-) will be displayed in the left
margin of the editor next to each program, function, subroutine, etc.; clicking
on the minus sign will temporarily collapse the display of that entity to a single
line.
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[F] common.f0 [F] maoreCommon.f0 &3 =g

“module moreCommon -
implicit none

integer :: blah
private :: blah
contains
@ subroutine change_ab[]
@ sobroutine stuffl]

end module moreCommon

The editors also support syntax highlighting. As you write programs in For-
tran, you will notice that different colors are applied to comments, identifiers,
intrinsics, keywords, and strings to make code more readable. It is possible
to change the colors for each of the previously mentioned code components in
the Fortran editor preferences (this is discussed in the section ” Configuring the
Editor,” below). Often, the editor can even distinguish between, for example,
the keyword "if” and a variable named ”if.” However, it is not perfect; it uses
a faster, but less reliable, heuristic than the actual Fortran parser that drives
the Outline view and all of the Advanced Features.

Comment /uncomment

Photran can comment or uncomment a block of Fortran statements, placing
an exclamation point (!) before the statements or removing it, respectively.
Select the statements in the Fortran editor. Then right-click the selection, and
choose Comment/Uncomment from the context menu.

character(len=1). function. char_at(self, - index) result{return)y
-------- class(string), -intent(in).::-selff
A s il s -, a

ty result(return)
Open Declaration F3
Show In LHEW P (string)
string

Cut #EX
Copy #C
Paste £

Probl Comment/Uncomment £

rORIe Shift Right

Setting bookmarks

Bookmarks are an Eclipse feature which allows you to mark important lines in
a file and then quickly jump to those lines using the Bookmarks view. To set
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a bookmark, right-click the grey bar on the left side of the editor at the line
where the bookmark should be located and select ” Add Bookmark...” from
the popup menu. A bookmark can also be placed on a line by locating the
cursor on the line, going to Edit » Add Bookmark... in the menu bar. Type
in the desired name for the bookmark in the dialog box and click OK. A blue
bookmark will show up in the grey bar on the left side of the editor.

Bookmarks can then be viewed in the Bookmarks view (Window »Show
View »Other..., select Bookmarks in the General folder).

Go to line (Ctrl+L)

The ”Go To Line...” feature allows you to jump to a specific line number in a
file when it is open in a Fortran editor. In the menu bar, go to Navigate »Go
To Line... (or press the hotkey, Ctrl+L on Windows/Linux or Command+L
on Mac) to open the Go To Line dialog box. Typing in the line you wish to
navigate to, and clickg OK. The cursor will be moved to the beginning of the
specified line.

Configuring The Editor

Tab wedth (0 to use the workspace defauk) 0

Foopd-forrm bre length

i
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Selecting horizontal ruler vs. folding

Fortran editors can either display the horizontal ruler, or they can have code
folding enabled, but not both. To determine which will be enabled, go to
Window »Preferences in the menu bar. Expand Fortran and select Editor.
Check the appropriate box(es) to enable folding in the free-form and/or fixed-
form Fortran editor. Setting colors for syntax highlighting

The colors for Fortran syntax highlighting can be modified in the Fortran
editor preferences. To modify the color settings, go to Window »Preferences
in the menu bar. Expand Fortran and select Editor. The color choosers for
Comments, Identifiers, Intrinsics, Keywords, and Strings are available on this

page.

Showing the print margin

Editors can optionally display a gray vertical bar at a specified column; ge-
nerally, this is set in column 80 to act as a visual ”print margin.” To enable
display of the print margin, go to Window »Preferences in the menu bar. Un-
der General, expand Editors, and select Text Editors. Check the box for ”Show
print margin”. Optionally, you can also change the column in which the print
margin will be displayed. Click Apply and the print margin should now display
in the editor.

Setting fixed-form line length

In fixed form, Fortran specifies that anything past column 72 (default) is a
comment. However, that can be changed to a value other than 72. To change
the length of the line, go to Window »Preferences in the menu bar. Under For-
tran, select Editor. Change the value of field labeled ”Fixed-form line length”
to the desired length of the line. Note that the accepted range for the length
of the line is 72-999 inclusive.

Converting tabs to spaces

To enable conversion of tabs to spaces, go to Window »Preferences in the
menu bar. Under General, expand Editors, and select Text Editors. Check the
box for ”Insert spaces for tabs” to have Eclipse automatically convert Tabs to
spaces.

Note that this will only apply to new tabs that you type; it will not change
your existing files.

It is easy to replace tabs with spaces in an existing file, as long as the tabs
all occur at the beginning of a line. (For tabs in the middle of a line, this won’t
work quite right.) (1) Move the cursor to the beginning of the file; (2) click on
Edit »Find/Replace...; (3) in the Find box, type ”” (without the quotes); (4)
in the Replace With box, type 4 or 8 spaces (each tab character will be replaced
with exactly what you type, so if you type four spaces, each tab character will
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be replaced with four spaces); (5) select Search: Forward and Scope: All; (6)
check the "regular expression” box; and (7) click Replace All. This will replace
every tab character with spaces.

Show whitespace

Whitespace characters can be displayed by going to Window »Preferences.
Under General »Editors »Text Editors, check the box next to ”Show whi-
tespace characters” and click Apply. Spaces, tabs, and newlines will now be
shown as light gray double-angle quotes (), dots (), and paragraph symbols (),
respectively.

Set Font

Photran uses the same font as the basic Eclipse text editor. To change it, click
on Window »Preferences in the menu bar. Under General, expand Appearance,
and select Colors and Fonts. Search for the font you want.

Colors and Fonts o- -
P
-

General Colors and Fonts (7 = any character, * = any string):

~ Appearance

Colors and Fonts

5 b lag Basic
Label Decoratior =
o b e Crc++
Capabilities .
b lay cvs
Compare/Patch ~
b e Debug h
Content Types .
b lag java
[ Editers o
P log Text Compare
Keys - .
b @ view and Editer Folders

-

MNetwork Cannectior
Perspectives

Search

=

Security

-

Startup and Shutdc
Web Browser

b workspace

Ant

Crc++

Fortran

Help

Install/Update

Description:

Java
Plug-in Develapment

Fun/Debug Preview:
Mo preview available.

v v T VT T T W T v

Team

- Restore usfauhs] [ Apply ‘
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Show line numbers

Line numbers can be displayed in the editor in the Text Editor preferences
page. Go to Window »Preferences. Under General »FEditors »Text Editors,
check the box ”Show line numbers” and click Apply.

e Preferences o=

t Text Editors =24 - -

= General See 'Colors and Fonts' to configure the font.

[ Appearance

Capabilities Undoe history size: | 200
Compare/patch Displayed tab width; |2
Content Types

[ Insert spaces for tabs
+ Editors
® Highlight current line
File Assaciations

(] Show print margin

b Text Editors
Keys
b Metwork Cannectior
Perspactivas Show range indicatar
Search [] Show whitespace characters
b Security [ Show affordance in hover on how to make it sticky
b Startup and Shutde ‘When mouse moyed into hover:
TR Enable drag and drop of text
b Workspace -
b oo Warn before editing a derved fille
b @ Smart caret positioning at line start and end
I+ Fortran Appearance color options:
b Help Line number foreground 1| color: -|
P instaljupdate current line highlight
b Java Print margin
P Plug-in Development Find scape
P RunfDebug selection foreground color
B Team

Selection background calor
Background colar

Foreground calor

Hyperlink [=]
Mare calors can be configured on the 'Calars and Fants'
preference page.

Restore Defaultsl [ apply |

Code Templates

Code templates are used to make coding faster and easier. After typing the
first letter of whatever you are typing, press Ctrl4+Space and a list of choices
will appear. Go to Windows »Preferences »Fortran »Templates to manage
which templates you want available.
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= Preferences = 3]

| | Templates f=p -
b General Create, edit or remove templates:
P ANt = =

Name Context Description Auto Inse [ MNew.. l
P Cc/c++

[¥] allocate ; Fortran | Allocate staterment on
=~ Fortran

V] ALLOCAT Fortran | Allocate staterment on
CDT Integration

#] call ... iFortran | Call statement (low on
Editor
[¥] CALL ... i Fortran | Call statement (upj on
Templates
b | [¥] deallocat Fortran | Deallocate statem on
He
P [¥] DEALLOC Fortran | Deallocate statem on
P InstallfUpdate . )
[¥] do while; Fortran | Do-while construct on
[¥] DO WHIL Fortran | Do-while construct on |
P Plug-in Development : L=l
3
P RunfDebug o !
Preview:
P Team

[Restore Qefaultsl [ Apply | l

D)

@ [ Cancel H oK I

1.10 Compiling Fortran Programs

To compile a project, Photran generally executes whatever make command is
on your system path. (On most systems, this will invoke GNU Make.) As noted
above, when you create a project, you can decide if Photran will auto-generate
a Makefile that uses GNU Fortran, Intel Fortran, or IBM XL Fortran, or you
can elect to hand-write your own Makefile.

To use an automatically generated Makefile, choose ” Executable (Gnu For-
tran on XYZ)” from the Project type menu, where XYZ is your platform
(Windows, Linux, or Mac OS X). There are similar options available for Intel
Fortran and IBM XL Fortran. To create a project using a custom Makefile, in
the project type selection box, expand the Makefile Project folder, and select
Empty Project.
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= Fortran Project | = = |
Fortran Project —
Create a Fortran project of the selected type |
Project name:  Fortran-test
Usze default location
Ch\Users\Kurt Hendle\dev-workspace\Fortran-test Browse...
default
Project type: Toolchains:
= Executable GCC Tool Chain
@ Empty Project
@ Hello World C++ Project
@ Hello World AMSI C Project
(= Shared Library
(7= Static Library
» Executable (Gnu Fortran)
& Executable (Gnu Fortran on MacOS X)
= Makefile project
@ Empty Project
@ Hello World C++ Project
[7] Show praoject types and toolchains only if they are supported on the platform
project typ DT e PP P
@] < Back Net> ||  Finsh || Cancel

1.11 Building Projects

Compiling Fortran projects is identical to compiling C/C++
Projects.

For more information on building projects, click on Help »Help Contents in
Eclipse, and navigate to C/C++ Development User Guide »Concepts »Build
»Building C/C++ Projects. [8]

Setting Make Targets

Setting make targets for Fortran programs is also identical to setting make
targets for C/C++ programs.

For more information on make targets, click on Help »Help Contents in
Eclipse, and navigate to C/C++ Development User Guide »Tasks »Building
projects »Creating a make target. [9]
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Marking Error Messages from Your Fortran Compiler (Error
Parsers)

When you build (compile) your Fortran program, the output from your Fortran
compiler (including any error messages) will be displayed in the Console view.
However, for many compilers, Photran can "recognize” error messages, placing
the problem description in the Problems view and marking the corresponding
line in the source file with a red X icon.

To do this, you must have the correct error parsers selected in your Fortran
project’s build settings. To modify these settings, right-click on your Fortran
project, go to Properties »-Fortran Build »Settings and select the Error Parsers
tab. A list of error parsers is displayed; select the one(s) corresponding to the
Fortran compiler(s) you are using and click OK.

= Properties for fortranCommon ElE=T
type filter text Settings f=18 4 > v
Resource
Builders
€/C++ Build Configuration: [DEbUg ‘] [Manage Conf\gurations...]
C/C++ General
Fartran Build
Discovery aptions | % Tool Settings | # Build Steps | 7 Build Artifact | b Binary Parsers| @ Error Parsers
Environment
Settings CDT GNU Make Error Parser Move Up
Tool chain editor Photran Error Parser for GNU Fortran (gfortran)
Variables CDT GNU C/C++ Error Parser Move Down
Fartran General CDT GNU Linker Error Parser
Project References CDT GNU Assembler Error Parser
Run/Debug Seftings [T] CDT Visual € Error Parser
Task Repository [] Photran Error Parser for Absoft Fortran
Tas.k Tags [C] Photran Error Parser for G95 Fortran
Validation [] Photran Error Parser for Lahey/Fujitsu Fortran 7.1
[] Photran Error Parser for NAG Fortran
[ Photran Error Parser for PGI Fortran
[] Photran Error Parser for Intel Fortran 8.1

Recognizing Executables (Binary Parsers)

In order to run (execute) your Fortran application, you will need to tell Eclipse
which Binary Parser(s) to use for your project. This can be done in the project
properties (Right-click project »Properties »Fortran Build »Settings »Binary
Parsers Tab).

Which binary parser you want to use will depend on the operating system
environment you are working in. For example, the default choice is the EIf
Parser which is for Linux environments. Windows users would need to deselect
the Elf Parser and select the PE Windows Parser and/or the Cygwin PE Parser.
Mac users should choose the Mach-O parser.
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-
== Properties for fortranCommon

27

=== T

type filter text Settings

Oov .

-

Resource
Builders

C/C++ General
Fartran Build

8

C/C++ Build Configuration: | Debug

Manage Configurations...

Discovery options ‘ & Tool Settings |  Build Steps

Environment
Settings
Tool chain editor
Variables
Faortran General
Project References
Run/Debug Settings

Binary parser:

Build Artifact | ) Binary Parsers | @ Error Parsers

PE Windows Parser
Cygwin PE Parser
[C] EIf Parser

[[] Mach-0 Parser

[F] HP-UX SOM Parser

Move Up

Move Down

Task Repository
Task Tags [C] GMU EIf Parser
Validation [[] AIX XCOFF32 Parser
["2 Fortran - test/hello.f90 - Eclipse Platiorm (=T x
File Edit Refactor Navigate Search Run Project Window Help
il = | & R~  H-O-Q- I F-E - DB ™S [ (FE Fortran | & Java
A New »
R FortranPra = 5(% outline 2 ~_@ MakeTavgeq =g
Golnto -
[~ PR e 7
455 commi Il sn G- Bl <Free Form Source>
3
> 1 Bin Eciyde from build.. bo: @ hello
&S s
> @ Del e
i@ Build Configurations »
Make targets »
¢ Build Project
@ Clean Project
> [@ md
El «ep Remove from Context Ctrl+Ale+Shift+Down
o M P9 copy
4 35 comm,
> Paste
> 4% Bin
s [ set %K Delete
> (= De Move.
> (@ co Rename...
=l ep
] prq i Import..
43S test |14 Expert.
> $ Bin
) et o Refresh
> (= Del Close Project -
5 [ hel
B < Run As »[E] 1 Local C/C++ Application
[x) pre Debug As » |[£] 2Local Fortran Application untime-EclipseApplication\test\Debughtest.exe (7/17/09 10:31 &
e Run Configurations.. f
Convert To..
Team »
Compare With »
Restore from Local History... -
PDE Tosls 3 E
" p
- Properties Alt~Enter

1.12 Running and Debugging Fortran Programs

To run a Fortran application, right-click the project in the Fortran Projects
view, and click Run As »Local Fortran Application. This will build and run
the Fortran application, and output will be printed to the console. (Remember,
if you are using a custom makefile, the makefile will need to be written correctly
for the project to be built.)

If you want to manage the run configuration (for example, if you want
to pass command line arguments to your Fortran application or set certain
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environment variables), right-click on the project in the Fortran Projects view,
click Run As »Run Configurations... Create a new launch configuration under
Fortran Local Application (or edit an existing one) and modify the settings as
needed.

Debugging programs works similarly, except you can choose Debug As »Lo-
cal Fortran Application or Debug Configurations from the context menu.

Running and debugging Fortran applications is similar to running and de-
bugging C/C++ applications. For more information on running and debugging
binary applications, click on Help »Help Contents in Eclipse, and navigate to
C/C++ Development User Guide »Tasks »Running and debugging projects.
10]

Setting Breakpoints

There are two ways to set breakpoints in the editor.

The easiest way to set a breakpoint in the editor is to double click in the left
margin (gray vertical bar) on the line at which you wish to set the breakpoint.
A blue dot will appear in the margin on the line where the breakpoint is set.
Double clicking again at the same location will remove the breakpoint.

You can also set a breakpoint by right-clicking in the left margin on the line
where you wish to set the breakpoint and clicking ”Toggle Breakpoint.” The
blue dot indicating the breakpoint will appear or disappear (if already set) in
the left margin of the editor.

[F] hello.fa0 [F] commeonfa0 3

external change c

OO 3 i a

Toggle Breakpoint
Disable Breakpoint

Breakpoint Properties... n2/ £, a, [common3/ h

Go to Annotation Ctrl+1
Add Bookmark... g, h
Add Task...

v Show Quick Diff Ctrl+Shift+Q

Show Line Numbers

Preferences...
b= 2.3
c = (4,3)

print ¥, a, b, ¢

When you switch to the Debug perspective, the breakpoints you set will be
listed in the Breakpoints view.

For more information on debugging, click on Help »Help Contents in Eclipse,
and navigate to C/C++ Development User Guide »Tasks »Running and de-
bugging projects »Debugging. Known Run/Debug Issues
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When using Cygwin in Windows, debugging a program can result in a
”cannot find gcec source” error as described in Bug 280492. Note that this
error does not have an effect on the running of the program. The program will
still run correctly in Debug mode.

1.13 Compiler-specific problems

G95

In debug mode, using the step button to step through the code line-by-line
sometimes jumps (”leapfrog” effect) around in the source code editor view. For
example, pressing F6 (step) after a breakpoint several times, might sometimes
result in a jump to line 1 and stepping again will return to the correct line in
the code.

gFortran

No known issues.

Intel Fortran Compiler

No known issues.

IBM XLF

No known issues.

1.14 Advanced Features

Photran 7.0 includes a number of sophisticated features that are designed to
make it easier to write, modify, search, and maintain Fortran code. These in-
clude content assist, which can ”auto-complete” variable and function names
as you type; a declaration view, which can show the leading comments for
the selected variable or procedure; Fortran Search, which allows you to find
declarations and references to modules, variables, procedures, etc.; and refac-
torings, which change your source code to improve its design while preserving
its behavior.

1.15 Troubleshooting

If you are experiencing problems installing or working with Photran, please
review the FAQ [11]. If you don’t find an answer there, please join the Pho-
tran mailing list [12]; a large number of users (as well as Photran’s develo-
pers) monitor that list, and they are generally eager to help. Retrieved from
"http:/ /wiki.eclipse.org/PTP /photran/documentation/photran7”






Chapter 2

Introduction

Photran 7.0 includes a number of sophisticated features that are designed to
make it easier to write, modify, search, and maintain Fortran code. These
include content assist, which can “auto-complete” variable and function names
as you type; a declaration view, which can show the leading comments for
the selected variable or procedure; Fortran Search, which allows you to find
declarations and references to modules, variables, procedures, etc.; and refac-
torings, which change your source code to improve its design while preserving
its behavior.

2.1 Enabling Advanced Features

In order to use any of the advanced features described in this document, you
must specifically enable them as described below. After you do this, Photran
will index your project; that is, it will build a database of what modules,
subprograms, etc. are declared in every file in your project. This information
will be updated incrementally every time you save a file. Although this process
is usually reasonably fast, it may become disruptive when working on very
large projects, so it has been disabled by default. Note that the first time your
project is indexed, it may take a while, because Photran must analyze every
file in your project; after that, it will only index files that have changed (and
files that depend on a file that has changed), so it will generally be much faster.

How to Enable Advanced Features

1. Right-click on your project in the Fortran Projects view
2. Click on Properties

3. Expand Fortran General in the list on the left, and click on Analy-
sis/Refactoring (see screenshot fig. 2.3)

4. Check the "Enable Fortran analysis/refactoring” check box,

31
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If you want to enable content assist, the Fortran Declaration view, etc.,
check those boxes as well

You may also want to set module and include paths at this point (see
fig.2.3)

Click OK

Setting Module and Include Paths

If your source code contains INCLUDE lines or USE lines referencing modules
in other files, Photran needs to know where to look in order to find these. It
will not figure this out automatically. For each project in which you plan to
use refactoring support,

1.
2.

Right-click on your project’s folder in the Fortran Projects view
Click on Properties

Expand Fortran General in the list on the left, and click on Analy-
sis/Refactoring

. List the folders in which Photran should search for INCLUDE files and

modules when refactoring. They will be searched in order from the first
folder listed to the last. Subfolders are not searched automatically; you
must include them explicitly.

Click OK

Advanced Features and C Preprocessed Code

Starting with Photran 6, C preprocessor directives are supported in Fortran
code, as described in the Photran User’s Guide. While most of the advanced
features described in this manual can handle C preprocessed code, refactorings
currently cannot. If you attempt to refactor C preprocessed code, you will
receive an error message.
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i (< N Properties for MyProject
" type filter text Analysis /Refactoring . r -
Resource To enable Open Declaration, Find All References, the Fortran Declaration
Builders view, content assist, and refactoring in Fortran programs, check the
. following box. A program database (index) will be updated every time
» E"E*'*' E.Gmld I a Fortran file is created or saved.
4 ++ General
/ . E Enable Fortran analysis/refactoring
» Fortran Build
¥ Fortran Ceneral E Enable Fortran Declaration view
Analysis /Refactoring E Enable Fortran content assist (Ctrl+Space)
Paths and symbols E Enable Fortran Hover tips
Project References
Run/Debug Settings The following specify the paths searched for modules
» Task Repository and INCLUDE files during analysis and refactoring.
Task Tags These MAY BE DIFFERENT from the settings used by
validation your compiler to build your project.
Folders to be searched for modules, in order of preference:
IMyProject L New.. ]
Remove
Up
Down
&) RIC
Folders to be searched for INCLUDE files, in order of preference:
/MyProject/include (W
Remove
Up
Down
&) R
( Restore Defaults \ ( Apply \
@ f Cancel \ ( OK )
P4

Figure 2.1: Enable Fortran analysis/refactoring

2.2 Advanced Editing Features

Content Assist

As you are typing a Fortran program, content assist pops up a list of the
subprograms, variables, intrinsics, etc. that are in scope. It is invoked by
pressing Ctrl4+Space. As you start typing a name, the list is refined based on
what you have typed; you can then use the arrow keys to choose from the list
and press Enter to complete the definition. Content assist is useful when you
don’t remember the exact name of a function, or when a function has a long
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name and you don’t want to type all of it. An example is shown below.

) mesuis0 55

1 program-test,

2. implicit none

3....integer.::.a.=.o

4 call g

5 end progr.  a - Local variable - integer A

§ . @ hi - Subroutine

7 subroutin e

4Pt o world - subroutine

9 end. aubra 2bs - Intrinsic

10 achar - Intrinsic

11 subroutin acos - Intrinsic

12 - pring 3
adjustl - Intrinsic

13 end subrg "

e adjustr - Intrinsic

aimag - Intrinsic

aint - Intrinsic

To use content assist, you will need to open the project properties, switch
to the Fortran Analysis/Refactoring category, and check the ”Enable Fortran
content assist (Ctrl+space)” box. You will need to close and re-open any
Fortran editors before you can start using content assist, however.

Fortran Declaration View

The Fortran Declaration view displays the statement where a variable, pro-
gram, or subprogram is declared. If you place the text editor cursor within
(or highlight) a variable name or the name of a subroutine in a CALL state-
ment, the Fortran Declaration view will then display the actual declaration.
For variables, the declaration view displays the variable declaration as well
as a comment regarding the type of variable and other information, such as
dimension information for an array as shown in the example below. For sub-
programs, it displays the FUNCTION or SUBROUTINE statement, including
any comments that precede it.

[F] common.f20 £% . [F) moreCommon.f90 =0

common &, b
integer :: a2
real i1 b

common /common/ k,d,e, /common2/ £, g, /common3/ h
complex :: c
dimension c(3)

! double precision ::

double precision
double precision ::
double precision
double precision
double precision :: I

L,

a=1
b=2.3

c = (4,5)

print *, a, b, ¢
call change_ab
call stuff

print =, "Now the first two variables below should have garbage values”
print *, "and the third should be (5,6):"
nrint & 2 R e

[E Problems [ E] Console [ [, Fortran Declaration 33

Local

complex ::

iable - complex(3)
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Hover Tips

Hover tips display the same text as the Fortran Declaration view (described
above); however, they display it in a popup window when the mouse cursor is
hovered over an identifier.

Fortran hover tips are enabled in a project’s analysis/refactoring properties.
To turn them on or off, check the box labeled ”Enable Fortran Hover Tips”
in the project properties under Fortran General »Analysis/Refactoring. (Note
that Analysis/Refactoring must also be enabled.)

[F] test.fa0 53
1 program-test
Fs implicit-none
3 integer :: 0 =@
4 call-hi
5 end-progrn— *--*°
6

Isubroutine hi - prints Hello

B 1sUbroutl gupeoutine hi

9 subroutin
19 print =
11 end- subr Press 'F2" for focus
12
13 subroutine wor ld9

14 print*,." WORLD! "9
15 end- subroutine
16

2.3 Search and Navigation

Open Declaration

The Open Declaration command allows you to quickly find the declaration of
a particular variable or subprogram. In the Fortran editor, click on (or select)
an identifier. Then either

e click on the Navigate menu, and select Open Declaration, or
e right-click on the identifier, and, and select Open Declaration, or
e press the F3 key on your keyboard.

This feature is particularly useful when the declaration is in another file.
For example, if your program contains a CALL statement which invokes a
subroutine imported from a module in another file, invoking Open Declaration
on the subroutine name in the CALL statement will open the module in a new
editor, and the cursor will be located on the declaration of that subroutine.

Fortran Search

Fortran Search is a syntax-aware, multi-file search tool. Unlike textual searches,
Fortran Search ”understands” Fortran programs. It is used to search for a
particular type of declaration (e.g., only modules, or only subroutines), or it
can find all of the uses of a particular variable or subroutine. It also allows
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to you to limit the scope of the search (e.g., it can search every file in the
workspace, or just a particular project).
In order to use Fortran Search, click on the Search menu and select Fortran...

Ecit Refactor Navigat Run Project Window Help
rEel % e CieH - g5 [ i@ b IR ARl Ao
: File.. - : i =
R Fortran Proj 52 % Navi o~ [ [F] mainf90 &3 . [F] filel f90 | [A fixedForm.f =]
% g -+ ¢ — . = s S E—
— = | or— - - B —
£ > org.edipse.photran-sam g =
(# sre-fixed-form Text I |
(£ sre-fortran-and-c piel
References » B filel
(5 src-gaussian-eliminat

(3 sre-includes

peeees o

integer :: blah, adb
3 src-language-features e
5 src-line-fitting ; R
£ » sre-modules 5 .6

£ sre-scoping
£ sre-implicits-1

(& src-implicits-2 temp = § + k 4+ variable £
(3 sre-implicits-3
(3 sre-common contains

5 sre-cray-pointers
& »src-variable-encapsulation
(o >.settings
(& sre-fortran2003
(5 sre-liebmann-1-eoshift
(& sre-liebmann-2-arrays
(2 »src-liebmann-3-loops
[5§ -cvsignore 11
[¢} >liebmann {80 11
|5 «cdtproject 1.1
[5 ».cproject 16
%) project 1.2

call add (temp, variable, blah)

subroutine add(a,b,c)
integer :: result
result = a+bic
print =, result

end subroutine add

function mult(x,v,z)
integer :: res
Tes = xtytz
print *, res

end function mult

This will open the Eclipse Search dialog, and the Fortran tab will be active.

There, you can specify several things:

e The Search for frame allows you to specify whether it should search for
subroutines, functions, modules, variables, etc.

e The Scope frame allows you to specify what file(s) will be searched.

e The Limit to frame allows you to specify whether you want to find de-
clarations, references, or both.

c-variable-enc

lation/main-f30 - Ed

File Edit Refactor Navigate Search Run Proje
i | B iHr0-Q- Fraiv-Hr MO i[E il = e el
(5 Fortran Proj TN F&Nawgamf =) B modulel f90 Bﬂmamm B i@ filel 190 ‘\ [F] fixedForm.f ‘\7 = 5)(BE ougiine 5
u.\g§ér fffffffff P o) o -3 | 2 Search u@
5 >orgeclipse photran-samples  [dev. program moln
25 stc-fixed-form imliort pone £§7 Fortran Search |27 Java Search | 7 Plugein Search| 4

(§ sre-fortran-and-c
(3 sre-gaussian-elimination
2§ srceincludes 2
(#§ src-language-features
£ stc-line-fitting
5 »sre-modules
(4 sre-scoping
£ stc-implicits-1
5 stc-implicits-2
5 sre-implicits-3
4§ sr-commen
(2§ src-cray-pointers
3 >src-variable-encapsulation
@y > settings
2y sre-fortran2003
&y ste-liebmann-1-eoshift
&y stc-liebmann-2-arrays
@3 >sre-licbmann-3-loops
[54 cvsignore 11
[6) » licbmann.f0 1.1
5 .ccltproject 11
[ >cproject 16
(3} wproject 12

5

use modulel

external filel Search pattern;

ad?

integer :: blah, adb

(* = any string, ? = any character)

blah = filel

Search for
[¥] Common block [¥] Function
] Subrout | Modul
call add(temp,variable,blah) ieune FlModule
temp = 5 + k + variable [¥] Variable []program
contains Scope
subroutine add(z,b,c) =
{ 2 © Workspace  (© Selected resources
integer :: result
result = atbic ©) Working set:

print *, result

end subroutine add

© Enclosing projects

| [ Regular expression

Limit to

@) All occurrences

eclarations

©) References

fanction mult (x,v,z)
integer :: res
Tes = x*y*z
print x, res

end function mult

m
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Notice that only the declarations of variables/functions were found. Also
note the use of the wild-card character(?) in the search box

Wildcards

Wildcards are special symbols used for pattern matching. For more informa-
tion, click on Help »Help Contents in Eclipse, and navigate to Workbench User
Guide »Reference User interface information »Search.

e * _ represents any number of any symbols. For example, a search for *d
would match bad, rescued, d, assembled, etc.

e 7 - represents any one single character. For example, a search for 7ad
would match bad, mad, sad, dad, zad, etc.

Regular expressions are an even more advanced pattern matching languages.
For more information, click on Help »Help Contents in Eclipse and navigating
to Workbench User Guide »Getting started »Basic tutorial »Searching
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Refactoring

3.1 Introduction

What is Refactoring?

Refactorings are changes to a program that improve its internal design but do
not change its behavior. These include minor, coding style changes (like using
IMPLICIT NONE statements), code readability improvements (like replacing a
variable named N with one called NUM_POINTS), performance improvements
(like interchanging loops under certain conditions), and even larger-scale design
changes (like moving a procedure from one module to another).

Although these types of changes can be done by hand, making them is
often tedious and error-prone. Photran automates many such refactorings.
For example, the Refactor »Rename command can automatically locate the
declaration(s) and uses of a particular subroutine, and change its name in all
of those locations. It is ”smart,” too; if there is a subroutine named d and a
variable named d in a different context, it won’t confuse the two. Moreover,
before making such a change, Photran will attempt to verify that the change
is safe to make. For example, a subroutine A cannot be renamed to B if there
is already a variable named B in a context where that subroutine is called.

For more information on refactoring, see M. Fowler, Refactoring: Improving
the Design of Existing Code, Addison-Wesley, 1999.

Refactoring in Photran

Most refactorings can be accessed via the Refactor menu in the menu bar, as
described below. However, the most common refactorings also have hotkeys
(e.g., Alt+Shift+R for Rename; hotkeys are listed in the Refactoring menu next
to each command). Also, most refactorings can be accessed by right-clicking
in an editor and choosing Refactor from the popup menu.

Some refactorings (such as Introduce Implicit None and Replace Obsolete
Operators) can be applied to several files at once. As described below, this

39
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involves selecting one or more files in the Fortran Projects view, then right-
clicking on any of the selected filenames and choosing Refactor from the popup
menu.

e Clicking on a filename in the Fortran Projects view selects that file (and
only that file).

e Ctrl4click (Command+click on Mac OS X) can be used to select or
deselect additional files.

e To select a range of files, click on one filename, and Shift+click on a later
filename; those files and all of the files in between will be selected as well.

Caution: Photran can only refactor free-format Fortran source code. It is
not possible to refactor fixed-form code. Make sure that only free-form Fortran
files are selected. The Refactor menu may not be available if any of the files
are fixed-form or non-Fortran files.

Rename

e Description: Rename is essentially a ”smart” search and replace: It allows
you to change the name of a variable, subprogram, etc. It correctly
observes scoping and shadowing rules can also rename subprograms and
module entities across files.

e Applies To:

Local variablesl,2

Subprograms3 (including external and interface declarations)
Derived types

Module entities (variables and subprograms)

Main programs

Namelists

Common blocks

e B T o o

Block data subprograms

e Operation:

1. Click on the name of a local variable, subprogram, etc.

2. Click Refactor »Rename... The Rename dialog will appear. Rename
dialog

3. Enter a new name for the variable/subprogram/etc.
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i 8.0 Rename

Rename twice to [two_timesl

™ Match external subprograms with interfaces and external declarations

(Preview:-) ( Cancel \ ( OK )

4. If you are renaming an external subprogram or a subprogram de-
clared in an interface block, you may want to (un)check the box
labeled Match external subprograms with interfaces and external
declarations. If this is checked, the refactoring will attempt to find
all external subprograms, EXTERNAL statements, and subprogram
declarations in INTERFACE blocks that have the given name, and

they will all be renamed.

5. Click Preview to see what changes will be made, then click OK to

apply them.

e Example:

i 8.M Rename

Changes to be performed &4 ¢ |:{=::>v
E{ ¥ @3 Rename
™ @ RenameEx.f90 - LoopTest

[F] RenameEx.f90 Ay th A3 B

Original Source | |Refactored Source
[print *, twice(n) F—print *, two_times(n) |
end program ‘ end program o

! Returns the value that is twice n ! Returns the value that is twice n

integer function twice(n) integer function two_times(n)
| integer, intent(in) :: n [ | integer, intent(in) :: n [
twice = 2 * n two_times = 2 * n 1
end function twice end function two_times 3
1 I 1 I
Preview > ( Cancel \ ( oK 3

Dummy subprogram arguments cannot be renamed

2. Components of derived types cannot be renamed

3. Intrinsic subprograms and type-bound procedures (Fortran 2003) cannot be

renamed
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Extract Procedure

e Description: Extract Procedure removes a sequence of statements from a
procedure, places them into a new subroutine, and replaces the original
statements with a call to that subroutine. Any local variables used by
those statements will be passed as parameters to the new procedure. This
refactoring is generally used to make long procedures shorter.

e Applies To: A sequence of one or more action statements inside a proce-
dure or main program.

e Operation:

1. Select a sequence of one or more action statements in the editor.
Be sure to include the newline following the last statement in the
selection.

2. Click Refactor »Extract Procedure... The Extract Procedure dialog
will appear. Extract Procedure dialog

800 Extract Procedure

Extract selected code to a subroutine named | subroutine

Preview > Cancel ok )

3. Enter a name for the new procedure that will be created.

4. Click Preview to see what changes will be made, then click OK to
apply them.

e Example:

®no0 Extract Procedure

Changes to be performed S

™ v &3 Extract Procedure
™ @ ExtractExample.fo0 - LoopTest

[F] ExtractExample.f30

B
=
i)
g

| [Refactored Source

program ExtractExample program ExtractExample
real i@ array(5) real :: array(5)

[ _array - (7 5088, 4808, 388, 20, 1 /) || call subroutine(array)

|~ print ¥, array T [ priet ¥, array

end program contains

Original Source

o

subroutine subroutineCarray)

implicit none

real :: array(5)

array - (/ 5008, 408, 303, 28, 1 /)
end subroutine

end progranm

Preview > ) ( Cancel ) (r0K)
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Extract Local Variable

e Description: Extract Local Variable removes a subexpression from a lar-
ger expression and assigns that subexpression to a local variable, repla-
cing the original subexpression with a reference to that variable. This
refactoring is usually used to eliminate duplicated subexpressions or to
introduce explanatory variable names into complex expressions.

e Caveats: The refactoring will only be allowed to proceed if extracting the
subexpression will preserve the associativity and precedence of the ori-
ginal expression. This refactoring assumes that the extracted expression
has no side effects; it does not check whether moving the computation of
the extracted expression will change the behavior of the program.

e Operation:

1. Select an expression in the editor.

2. Click Refactor »Extract Local Variable... The Extract Local Varia-
ble dialog will appear.

3. Enter the type and name for the new local variable that will be
created.

4. Click Preview to see what changes will be made, then click OK to
apply them.
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3.2 Subprogram Refactorings

Add Subroutine Parameter
e Description: This refactoring will add a parameter to a subroutine.
e Applies To: A subroutine.
e Operation:

1. Select the subroutine name or subroutine statement

2. Click Refactoring »Subprogram »Add Subroutine Parameter (or
press Shift+Alt+P)

3. Use the input page to choose the type, intent, and name of the
parameter.

4. Type in numbers for the default value and position.

5. Click preview to view the changes without applying, or OK to apply
the changes.

e Example:

Changes to be performed & G| 3~

+ [¥] & Add Subroutine Parameter

[#)¢5 BFile.fo0 - MyProject

[) BFile.foo Vo N T
Original Source Refactored Source
module BFile module BFile
implicit none implicit none
‘contains contains
[ subroutine sub() i subroutine sub(newName)
integer, intent(in) :: newhName
end subroutine
end subroutine

end module BFile I

end module BFile

l < Back H Cancel H oK

Figure 3.1:

Example of Add Subroutine Parameter refactoring.
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Permute Subprogram Arguments

e Description: This refactoring will change the order of the arguments to
a subroutine and adjust all call sites accordingly.

e Applies To: All files calling the selected subroutine.
e Operation:

1. Select the subroutine name or subroutine statement
2. Click Refactoring »Subprogram »Change Subroutine Signature.

3. Use the input page’s up and down buttons to rearrange the order of
the arguments for the subroutine.

4. Click preview to view the changes without applying, or OK to apply
the changes.

e Example: Example of Change Subroutine Signature refactoring.

[ FeNe) Change Subroutine Signature

Changes to be performed IES
™ ¥ &2 Change Subroutine Signature

V) & subroutinesig.f90 - changesigtest

[F] subroutinesig.f90 2w A

Original Source Refactored Source

T end interface

call testsub(1,2,200,200,3,4,5,6)

) call testsub(1,Z,200,200,4,5,6,3) =
1 call testsub(1,Z,200,200,F~-3,0=4) d
E 1 call testsub(1,Z,200,200,0=4,F=3)
31200 print *, "hello, world!" 2 e .
end program testoptional 3200 print *, "hello, world!
. nd program testoptional
&'subroutine testsub(A,B,*,*,(,0,E,F) l<e<ee 0,1

integer, optional :: C

&'subroutine testsub(A,B,*,*,0,E,F,() la<ass
integer, optional :: C

integer, optional :: E

character(3) :: D

20end subroutine

integer, optional :: E
character(3) :: D
20 end subroutine

1
1
1
1
1
1
1
1
1
1

Cancel

Figure 3.2:
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Safe Delete

e Description: This refactoring will remove all Internal Subprograms from
a given Host. The refactoring fails if there are any references to the
subprogram.

e Applies To: A file.
e Operation:

1. Select the subroutine name or subroutine statement to remove

2. Click Refactoring »Subprogram »Safe Delete

3. Click preview to view the changes without applying, or OK to apply
the changes.

e Example: see figure 3.3

(" A
= Safe-Delete Non-Generic Internal Subprogram { | g
Changes to be performed EURRTS ‘ }:a -

4 [V] &) Safe-Delete Non-Generic Internal Subprogram

[/]@L tect.f90 - TestProject |

[F] test.f90 2 % 0 G
Original Source Refactored Source
integer :: 1,3,k program test e
implicit none

contains integer :: 1,3,k

subroutine s{)

integer :: i end program test

m

end subroutine s

end program test

4 3 4 b

<Beck [ ok ][ cancel

Figure 3.3: Example of the Safe-Delete Internal Subprograms refactoring.
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3.3 Module Refactorings

Make Private Entity Public

e Description: Changes a module variable or subprogram from PRIVATE
to PUBLIC visibility, and checks that it won’t conflict with any existing
name where that module is USEd.

Applies To: Variables, subroutines, functions.

Does Not Apply To: Intrinsics, Externals, Interfaces.

Operation:

1.
2.
3.

Select the name of the private entity you wish to make public.
Choose Refactor »Make Private Entity Public.

Click Preview to see what changes will be made, then click OK to
apply them.

Example: see figure 3.4 and 3.5

2 Mske Private Entity Public == = |
Changes to be performed T
[#] &3 Make Private Entity Public
[@] % private.f90 - makePrivPubTest
[F] privatefo0 AW R
Original Source Refactored Source
[ 4 integer, private, cpticnal :: priv, blal 4 integer, private, opticnal :: blah -
s real :: hi 5 integer, public, optiocnal :: priv
private :: hi 6 real :: hi u
7 private :: hi
intrinsic hello L
] external goodbye 9 intrinsic hello 3
10 private hello 10 external goodbye
1lcontains 11 private hello
12 subroutine hello 12contains
13 private 1 subroutine hello
14 end subroutine 14 private
ks and anhrnntina =
« i b < b
[ <Back J[ ok [ conca |

Figure 3.4: Example of make private entity public refactoring.
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Changes te be performed

4 [J] %) Make Private Entity Public
[#]45 private.f90 - makePrivPubTest

[F] private.f90

Original Source

integer, private, optional ::

real :: hi

Refactored Source
pri
real :: hi

integer, private,

£ R Ea

optional ::

public :: hi

s private :: hi

intrinsic hello
s external goodbys
1 private hello
1lcontains

subroutine hello

— -
8 intrinsic hello

external goodbye

10 private hello

1lcontains

12 subroutine hello

13 private

+ <[ e

n

[ <Bak |[ ok

J [ Cancel

)

Figure 3.5: Example 2 of make private entity public refactoring.

Encapsulate variable

e Description: Encapsulate variable creates getter and setter methods for
the selected variable in the module where it is defined and changes varia-
ble’s visibility to private. It also replaces all uses of that variable in all
files to use getter and setter method callsl.

o Applies To:

1. Variables defined in the module.

2. Variables of all basic as well as user-defined types

e Does Not Apply To:

1
2
3.
4
5

. Arrays

e Operation:

. Variables that are not defined in a module
Parameters (i.e. integer, parameter :: CANNOT_ENCAPSULATE)
. Pointers (i.e. real, pointer :: CANNOT_ENCAPSULATE)
. Targes (i.e. integer, target :: CANNOT_ENCAPSULATE)

1. Click on or select the name of variable you want to encapsulate.

2. Click Refactor »Encapsulate Variable. The Encapsulate Variable

dialog will appear.

Getter and setter name menu for encapsulating variable temp
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80 (@) Extract Procedure

Extract selected code to a subroutine named | subroutine

(“Preview> ) ( Cancel ) (0K )

Figure 3.6:

3. Enter names for getter and setter methods. You will be warned if
the names that you want to assign to your getter and setter methods
will be conflicting with some other identifier in any of the involved
files.

4. Click Preview to see what changes will be made, then click OK to
apply them.

e Example: see figure 3.7 and 3.8

2 Encopsulate Variable - - (=]

R

=T Gance

Figure 3.7: Simple example of Encapsulate Variable refactoring

1. If a variable is used as a parameter to a function/subroutine call, and
that function changes the value of the variable as a side-effect, that change will
not be preserved.
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Y

call add (getTemp(),variable,blah)
11 secTemp(s + k + varisble)

| ==

Figure 3.8: Another simple example of Encapsulate Variable refactoring

3.4 Use Statement Refactorings

Add ONLY Clause to USE Statement

e Description: Creates a list of the symbols that are being used from a
module, and adds it to the USE statement.

e Applies To: All modules containing public definitions.
e Does not apply to: Empty modules or modules with only private entities.

e Operation:
1. Select the name of the module in the USE statement you wish to
add an ONLY clause to.
2. Choose Refactor » Add ONLY clause to USE statement.

3. Select which module entities you wish to include in the ONLY list.
Any entities in an existing ONLY list will already be selected and
can be deselected to be removed. Add ONLY to USE dialog

"' @ Add ONLY clause to USE statement l=|E] = )

Select the module entities to add to the ONLY clause.

[ onlytest

[[] help_commen3

Click OK to add the ONLY clause to the selected USE statement.To see what changes will be made, click Preview.

[ preview> ][ ok ][ concel

Figure 3.9:

4. Click Preview to see what changes will be made, then click OK to
apply them.

e Example: see figure 3.10
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= Add OMLY clause to USE statement [E=ioa|

Changes to be performed 44|

@) Add ONLY clause to USE statement
[#] L) testl.f30 - addOnlyTest

[F] testl.0 £ W 4B

Original Seurce Refactored Source

[ 3use modules F— =use modules, only: onmivtest | -
<use module4, only: help common 4use module4, only: help_commond
Simplicit none Simplicit none g
& &

7common /block/ a, b, ¢, /mem/ r, £, T 7common fblock/ a, b, ¢, /mem/ x, £, ||E
Zinteger :: a Sinteger :: a

Sreal :: b Sreal :: b

10double precision :: ¢ 10double precisien :: c

i1zinteger :: r, £, © 12integer :: r, £, t

5
4.6
2.345

5 El

4.6 15b

>.345 &
» «

laa
e

i) o6 (G )

Figure 3.10: Example of Add ONLY clause to USE statement refactoring.

Minimize ONLY List

e Description: Deletes symbols that are not being used from the ONLY list
in a USE statement.

e Applies To: USE statements with an ONLY clause.
e Operation:

1. Select the name of the module in the USE statement you wish to
minimize the ONLY list for.

2. Choose Refactor »Minimized ONLY list for Selected module.

3. Click Preview to see what changes will be made, then click OK to
apply them.

e Example: see figure 3.11
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= Minimize ONLY List o] = |

Changes to be performed O 4|3~
[#] & Minimize ONLY List
[7]%) test2.f90 - minOnlyListTest

[F] test2.f90 y e Wl
Original Source Refactored Source
lprogram test2 lprogram test2
use module, only: i, helper 2 use module, only: helper |
implicit none 3 implicit none
4 call helper 4 call helper
Send program test2 Send program test2

[ <Baec [ ok ][ Cance |

Figure 3.11: Example of Minimize ONLY list refactoring.

3.5 Common Block Refactorings

Make COMMON Variable Names Consistent

e Description: Fortran allows different definitions of a COMMON block to
give the same variable different names. This is confusing. This refactoring
gives the variables the same names in all definitions of the COMMON
block.

e Applies To: All COMMON blocks with a valid name.
e Does not apply to: COMMON blocks with a NULL name.
e Operation:
1. Select the name of the COMMON block in the editor which you

wish to make variable names consistent for.

2. Choose Refactor »Make COMMON Variable Names Consistent form
the menu bar.

3. Enter the new names which you wish to give the COMMON varia-
bles. The default new names are the original names in the selected
block with ” _common” appended. Make common var names consis-
tent dialog

4. Click Preview to see what changes will be made, then click OK to
apply them.

e Example Example of Make COMMON variable names consistent refac-
toring.
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& Make COMMON variable names consistent l=l@] = ]
Original Name New Name
c _common
d d_common
e <_common
Preview> | [0k [ Concel

Original Source

& Make COMMON variable names consistent =lE] 2 |
Changes to be performed S| %
Make COMMON variable names consistent
common.f90 - commonStuff
(7] moreCemmon.fa0 - commeonStuff
Bl common a0 &8 8a

Refactored Source

commen /commen/ c,d,e, /commonz/ £, g

commen /common/ c_commen,d_commen, -

complex :: c — complex :: c_common
dimension c(3) dimension c_commen (3)
' double precision i: d, =, £, g, & " double precision :: 4, e, f, g
double precisicn i: & double precisien :: d_common
double precision :: e double precisicn :: e_commen il
double precision i: £ double precision i: £
double precision :: g double precision :: g g
double precision i: b double precision :i: h
a-1 a-1
b=2.3 b=2.3
c = (4,5 c_common = (4,5) -
< n » 4 L L3

Figure 3.12:

Move Saved Variables to Common Block

53

e Description: Move Saved Variables to Common Block creates a common
block for all ”saved” variables of a subprogram. Declarations of these
variables in the subprogram are transformed such that they are no longer

7saved” .

The generated common block is declared both in the main

PROGRAM and in the affected subprogram. Variables placed in the
common block are renamed such that they do not conflict or shadow other

variables. The current implementation assumes that the subprogram is
in the CONTAINS section of the PROGRAM.

e Applies To: Subprograms.

e Operation:

1. Click on the declaration statement of a subprogram.
2. Click Refactor »Move Saved Variables to Common Block.
3. Click Preview to see what changes will be made, then click OK to

apply them.
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@ Mske COMMON variable names consistent == 5= |
Lii=taels
Changes to be performed T

&) Make COMMON variable names consistent
@5 commen.f30 - commensStuff
5 moreCommen.f90 - commenStuff

[F] moreComman.f30 & B

Original Source Refactered Source
end subroutine end subroutine -
subroutine stuff subroutine stuff
common /common/ ¢, d,e common /common/ c_common, d_com
complex :: c — complex ©_common
dimension c(3} dimension c_common (3)
! double precision :: d, e | double precision :: d, e
double precision double precision :: d_common
double precision :: double precision :: e common [I
print *, "Stuff" print *, "Stuff" E
end subroutine stuff end subroutine stuff a
end module moreCommon end module moreCommon

Figure 3.13: Example of Make COMMON variable names consistent refacto-
ring.

e Example:
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& Move Saved Yariables to Global Common Block (=] 5}
Changes ta be performed T

[F] test.fon Pt ST
Original Source Refactored Source
PROGRAM MyProg PROGRAN HyProg 2
CLLL HySub
CONTAINS
SUBROUTINE HySub
| mTEGER ¢
| BEAL, mAVE i1 r “‘ CALL MySub
| swE s CONTAINS
END SUBROUTINE MySub SUBROUTINE HySub
END PROGRAN NyProg
] [
END SUBROUTINE My$ub
END PROGRAM MyProg
] F[ S5 1| -

Preview > | ok I Cancel

Figure 3.14:

3.6 Loop Refactoring

Interchange loops

e Description: Swaps inner and outer loops of the selected nested do-loopl.
This refactoring merely switches the inner and outer do-headers. It will
not make any changes to the body of the loop.

e Applies To: Selected nested do-loop
e Operation:

1. Select the nested loops you wish to interchange
2. Click Refactor »Interchange Loops. The Interchange loops dialog
will appear.

3. Click Preview to see what changes will be made, then click OK to
apply them.

e Example:

1. In order for refactoring to work correctly, there must be no state-
ments before the second loop. If such statements exist, correctness of the
refactoring is not guaranteed.
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Figure 3.15: Simple example of Interchange Loops refactoring

Fuse Loops

e Description: Takes two do-loops, normalizes their bounds, and finally
puts the loop bodies in a single do-loop.

e Applies To: Find the two do-loops you want to fuse, and select only the
first onel. If there are any statements in between the two loops, the
statements will remain after the fused do-loop. In order for the loops to
be compatible, the loops need to have the same number of iterations (the
bounds do not need to be the same, just the number of times the body
of the loop is accessed).

e Operation:

1. Select the first do-loop to be fused.
2. Click Refactor »Loop Fusion.
3. Click Preview to see a comparison view of the changes made, and

OK to apply the changes.

e Example: 1. The refactoring will find the next listed do-loop in your
code (even with other lines of code in between them).
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| B ]

_ ;
2 oo T, <k

Changes to be performed I
4 @] Loop Fusion

]/ testd.f90 - testd|
[E] testt 100 Vot WS N

Original Source

Refactored Source

teger fr

Implicit mome

do 1=1,10,2
print %1

end do

do 3=21,25,1
print %3

end do

integer :: i

a0 170,3,1
print ¥, (i*2+1)
print *, (1¥1+21)

end do

end program test

4

end program test

» «

<Back [ oK

[ cancel |

Figure 3.16:

Reverse Loop

e Description: Takes an incrementing or decrementing loop, swaps the lo-

Example of Loop Fusion with loops of different bounds

wer and upper bounds, and negates the step.

e Applies To: Selected do-loop

e Operation:

1. Select full do-loop or do-loop header

2. Click Refactor »Reverse Loop.

3. Click Preview to see a comparison view of the changes made, and

OK to apply the changes.

e Example:

_—— .
2 Reverse hecked) | L5
3 s s T L - i
Changes to be performed R
a everse Loop (Unchecked)
657 test! 790 - testd |
[ testt 190 5 RER

Original Source

Refactored Source

implicit none

implicit none

integer i 1 integer i: 1
do i-1,10,2 do i-10,1,-(2)

print %1 print *,1
end do end do

end progran test

<

end program test

0 4

<Back ][ oK

Figure 3.17: Example

of Reverse Loop Refactoring
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Unroll Loop

e Description: Takes the selected do-loop and either completely or partially
unrolls it. This will also optionally include a conditional statement to
make sure the loop stays in bounds.

e Applies To: A do-loop that doesn’t contain labels, and never writes to
the index variable (Ex: read(* ,* ) indexVar)

e Operation:

1. Select the loop to unroll (or just the header).
2. Click Refactoring »Loop Unrolling.

3. Select either the number of times you would like to unroll the loop, or
check the ”Complete unrolling” box. Uncheck the ”Include bounds
checking” box if you don’t want a conditional statement to ensure
proper loop bounds in numbered loop unrolling.

4. Click Preview to see the changes this refactoring will make, and OK
to make the changes.

o Example(Numbered):

T . m===
| Changes to be performed P
4 [7 &3 Loop Unrolling
[Z)@Z testd £90 - testd
B tests. 90 HdLa

Original Source Refactored Source
implicit none

integer i 1

do 3=1,10,2 ]
print %1 1+2) =|
end do if(1+4>10) exit

Brint *, (i+4)
print *, (1+6)
end program test end do

e o J e )

Figure 3.18: Preview of unrolling a loop four times including a bounds check

e Example(Complete):
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Changes to be performed sz
4 [7]4 Logp Unreliing

165 testd.F90 - testd
[ test.90 SaBn

Original Source

implicit none

integer :: 3

do 1=1,10,4
print %1
end do

end progranm test end program test

) o] (o)

Figure 3.19: Preview of completely unrolling a loop

Tile Loop

e Description: This refactoring takes a double nested do-loop, and creates
a nested do-loop with four levels of depth. Instead of iterating through
a two dimensional array (for example) by going through each row, it will
loop over smaller tile blocks

e Applies To: A double nested do-loop where both step values are 1.

e Inputs: o Tile Size: The size of the accessing block or tile. So, if the tile
size is 3, an array will be accessed in 3x3 blocks. o Tile Offset: Adjusts
where the blocks start (all the data will always be covered no matter
where it starts).

e Operation:
1. Select the whole nested do-loop, or the header of the top nested
do-loop.
2. Click Refactoring »Loop Tiling.

3. Enter a tile step and tile offset, then click preview to view changes,
or OK to apply changes.

4.

e Example:
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Changes to be performed L
<@ LoopTiing
/6Dt 0 e

S |

x(1,11),min (50, 11419)
do j=max(1,31),min (40, 31+19)
princ *,

end do ‘
end o I
aaaaa

| T )

Figure 3.20: Example of loop tiling with a tile size of 20 and a tile offset of 5.

3.7 Refactorings to Remove Obsolete Language Features

Remove Arithmetic If Statements

e Description: This refactoring will remove all arithmetic if statements, a
feature that became obsolete in Fortran 90, from a single file or all the
files in a project.

e Applies To: A project or file.
e Operation:

1. Select the project or file with arithmetic if statements to remove.

2. Click RefactoringsObsolete Language Features »Remove Arithme-
tic If Statements

3. Click preview to view the changes without applying, or OK to apply
the changes.

e Example:
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WO Remove Arithmetic If Statements
Changes to be performed 4 ¢ ‘:=:>
||+ @3 Remove Arithmetic If Statements
M 2B iftest.fo0 - if-test
[F] iftest.foo Pt
Original Source Refactored Source
program iftest ‘program iftest
integer :: x - -2 integer :: x - -2
[—iF ) 19,720,380 If(x< @) then
goto 10
18 print *,"x is negative!” else if(x == @) then
goto 48 | goto 20
20 print *,"x is zero!” else
goto 40 goto 10
38 print *,"x is positivel" end if
48 print *,"end transmission.” 10 print *,"x is negative!”
goto 48
and neanram 3 Frack 20 nrink * "y e varnl"

( <Back ) (( canel ) o)

4

Figure 3.21: Example of the Remove Arithmetic If Statement refactoring.

Remove Assigned Goto

e Description: This refactoring will remove all assigned goto statements
and replace them with case blocks.

e Applies To: All assigned goto statements.
e Operation:

1. Click Refactoring »Obsolete Language Features »Remove Assigned
Goto.

2. Choose Yes if you want to add a default case, otherwise choose No.

3. Click preview to view the changes without applying, or OK to apply
the changes.

e Example: Example of the Remove Arithmetic If Statement refactoring.
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G Removo Assianed Goto B
Changes to be performed e
= W4 Remove Assigned Goto
[ File f90 - MyProject
A File fan & a5 A
Criginal Source Refactored Source
[ real 1, j
real 1, | i = 100
ASSIGN 100 to 1 select case (i)
goto i case (100); goto 100
|100 print *, *100° case default; stop "Unknown Label® [
ASSIGN 200 to J end select
goto j 160 print *, *100°

select case (j)
case (200); goto 200
case default; stop "Unknown label®

200 print *, *200" \ = 200 ‘ ‘
end select

< Back H cancel H ok ]

Figure 3.22:

Remove Branch to End If

e Description: Removes the branch to END IF statements. The GOTO
statements carry outbranching. Branching to end if is replaced with
branching to CONTINUE statement that immediately follows the END
IF statement.

e Applies To: Selected end if statement
e Operation:

1. Select an end if statement with a statement label

2. Click Refactor »Obsolete Language Features »Remove Branch to
End If

3. Click Preview to see what changes will be made, then click OK to
apply them.

e Example:

Simple example of Remove Branch to End If refactoring
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FEATURES

Changes to be performed

— [¥] 4z Remove Branch to End If Statement

€ File.fg0 - MyProject

[F1 File.foo

Original Source
I DO 20, 1 =1, 10
IF (MoD(i,2).eq.0) THEN

Refactored Source
I D0 20, 1 =1, 10
IF (MoD(i,2).eq.0) THEl

[ GOTO 10

GOTO 20

END IF

1 1 +1
IF (j.ge.100) THEN
] =1+3

END IF

1 ] +1
IF (j.ge.100) THEN
] =1+7

|10 END IF

END IF

20 CONTINUE

20 CONTINUE

63

PRINT *, '3:', 1] PRINT *, '3:', ]

Figure 3.23:

Replace Character* with Character(len=)

e Description: Replaces character*n declaration with character(len=n) de-
claration.

e Applies To: All character declarations
e Operation:

1. Select one of the character declaration statements

2. Click Refactor »Obsolete Language Features »Replace Character*
with Character(len=)... The Replace Character* with Character(len=)
will appear.

3. Click Preview to see what changes will be made, then click OK to
apply them.

e Example:
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Changes to be performed 4 | S

= [¥] %3 Replace Character* with Character(len=)
¥4 File.fa0 - MyProject

[#) File fao AW 8 R

Original Source Refactored Source

character*7 name, location character(len=7]: :name

character*11 occupation .| character(len=7): :location

character mddle_initial character(len=11)::0ccupation
character(len=1) : :middle_initial

[ <gack |[ cancel |[ ok |

Figure 3.24: Simple example of Replace Character® with Character (len=)
refactoring

Remove Computed Goto

e Description: Replaces computed goto statement with select case state-
ment

e Applies To: Selected computed goto statement
e Operation:

1. Select the computed goto statement you wish to remove

2. Click Refactor »Obsolete Language Features »Remove Computed
Goto. The Remove Computed Goto dialog will appear.

3. Click Preview to see what changes will be made, then click OK to
apply them.

e Example:
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FEATURES 65
% Remove Computed Goto o | D
Changes to be performed R

4 [ & Remove Computed Goto
745 main.f90 - ComputedGoToExample

I/ B mainf0 5D 80
Original Source. Refactored Source
zead (+,%) n ! Enter n from the ki

! Will this disapp:
g0 to (10,20,30,40),n

[ e ) [0k ][ o ]

Figure 3.25: Simple example of Remove Computed Goto refactoring

Replace Obsolete Operators

e Description: Replace Obsolete Operators replaces all uses of old-style
comparison operators (such as .LT. and .EQ.) with their newer equiva-
lents (symbols such as j and ==). and adds explicit declarations for all
variables that were previously declared implicitly.

e Applies To: All uses of the following operators in one or more files: .LT.
.LE. .EQ. .NE. .GT. .GE.

e Operation:

1. This is a multiple-file refactoring.

— To Replace Obsolete Operators in a single file, open the file in
the editor and choose Refactor »Obsolete Language Features
»Replace Obsolete Operators from the menu bar.

— To Replace Obsolete Operators in multiple files, select the files
in the Fortran Projects view, right-click on any of the selected
filenames, and choose Refactor »Obsolete Language Features
»Replace Obsolete Operators from the popup menu.

2. Click Preview to see what changes will be made, then click OK to
apply them.

e Example:Example of the Replace Obsolete Operators refactoring
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‘e (&) Replace Obsolete Operators
Changes to be performed TS ‘3%”
E‘ v @3 Replace Obsolete Operators
El ¢4 Operators.f90 - LoopTest
[F] Operators.f90 &0 AT
Original Source ‘ ‘Rsfaclmsd Source
if (1 .1t. 2 .and. 3 .le. 4 & 1f (1 <2 .and. 3 == 4 &
Lor. 5 .ne. 6) & Lor. 5 /= 6) &
print *, ":-)* print *, "i-)"
end program end program 1
v

Preview _ Cancel ( oK 3

A

Figure 3.26:

Replace Old-Style Do Loops
e Description: Replaces old-style do loops with the modern style of do loops
e Applies To: All old-style do loops
e Operation:

1. Click Refactor »Obsolete Language Features »Remove Old-Style
Do Loops.

2. Click Preview to see what changes will be made, then click OK to
apply them.

e Example:

Simple example of Remove Old-Style Do Loop refactoring
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FEATURES 67

Changes to be performed & G| T
= [¥] & Replace Old-Style Do Loops l
W€ File.fa0 - MyProject

[F1 File foo A B 48 R
Original Source Refactored Source
[ do 2501 =1, 9 —{doi=1,89 |
250 print *, 1 250 print *, 1
“{EnD DO |
do 3801 =1, 9 =
300 print *, 1 | do1=1, g nl
300 print *, 1
END DO
l < Back ] [ Cancel ] i oK
Figure 3.27:

Remove Pause Statement

e Description: Replaces pause statement with empty print and read state-
ments

e Applies To: Selected pause statement
e Operation:

1. Select the pause statement you wish to remove

2. Click Refactor »Obsolete Language Features »Remove Pause Sta-
tement.

3. Click Preview to see what changes will be made, then click OK to
apply them.

e Example: Simple example of Remove Pause Statement refactoring
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Changes to be performed 4 ¢ | o
~ [¥] & Remove Pause Statement
]! File fo0 - MyProject
[F) File.foo Pt -
Original Source Refactored Source
‘print *, "memorize these numbers®, "4 8 15 16 23 42" print *, "memorize these numbers", "4 § 15 16 23 42"
[pause PRI o 0
READ (*, *)
o
<geck |[ cancel |[ ok
Figure 3.28:

Remove Real/Double Precision Loop Counter

e Description: Transforms a do or do while loop with control to a do or do
while loop without control.

e Applies To: Selected loop
e Operation:

1. Select the loop you wish to transform

2. Click Refactor »Obsolete Language Features »Remove Real/Double
Precision Loop Counter.

3. Choose either do loop or do while loop.
4. Click Preview to see what changes will be made, then click OK to
apply them.

e Example: Simple example of Remove Real/Double Precision Loop Coun-
ter refactoring
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= A Real/D e p ision L o @
Changes to be performed &4 4| -
+ [¥]& Remove Real/Double Precision Loop Counter
145! File f30 - MyProject .
[F] File.foo & B MR
Original Source Refactored Source
[ do1i=1, 10, .5 1=1
J=3+1 N
end do do
T=3+1
1=1+.5
IF(1 = 10) THEN
EXIT
END IF
end do
[ < Back ] [ cancel ] E oK
Figure 3.29:

3.8 Refactorings to Improve Coding Style

Add Identifier to End Statement

e Description: This refactoring will add the program/subprogram name to
an end statement.

e Applies To: A file or project.
e Operation:

1. Select the file or project.
2. Click Refactoring »Coding Style »Add Identifier to End Statement

3. Click preview to view the changes without applying, or OK to apply
the changes.

e Example: Example of Add Identifier to END statement refactoring.
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Fortran - identifiertest/identifier.f90 - Eclipse SDK

REFACTORING

0|

Iriene Add Identifer to END
=] =N
TH | | changes to be performed &4 9 ‘;‘:}m|ﬁ
# v &3 Add Identifier to END F
| 8 identifier.fo0 - identifiertest F
[P identifier.fo0 Pt WY
Original Source | |Refactored Source
module testmodule module testmodule
integer :: xfromtestmodule integer :: xfromtestmodule
[12 end 10 end module testmodule
1}
function testfunction(A) fFunction testfunction(A)
integer, intent(in) :: A integer, intent(in) :: A
testfunction - 4; testfunction - 4;
[28 end | A comment after the end! {28 end Function testfunction | A comment after the end! 0
program fortrantest program fortrantest
print *, "Main program!” print *, "Main program!”
contains contains
integer function testfunction(A) integer function testfunction(A)
integer, intent(in) :: A integer, intent(in) :: A
testfunction = 43 testfunction = 43
[38 end function |38 end function testfunction 0
subroutine do_stuff subroutine do_stuff
print *,"Hil" print *,"Hil"
40 end subroutine 40 end subroutine do_stuff D
end || end program fortrantest
|| |subroutine do_stuff subroutine do_stuff al
% print *,"Hil" print *,"Hil" O &
N ‘sa end |58 end subroutine do_stuff || j‘
( <sack ) ( cancel ) o)
| y
I b L R

Figure 3.30:

Change Keyword Case

e Description: Makes all applicable keywords the same case throughout the
selected Fortran program files.

e Applies To: All keywords except those listed below.

e Does not apply to:

1. Identifiers

2. All constants except for integer constants and real constants

e Operation:

1. This is a multiple-file refactoring.

— To Change Keyword Case in a single file, open the file in the edi-
tor and choose Refactor »Canonicalize Keyword Capitalization
from the menu bar.

— To Introduce Implicit None in multiple files, select the files in
the Fortran Projects view, right-click on any of the selected
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filenames, and choose Refactor »Change Keyword Case from
the popup menu.

2. Select Upper or Lower Case Canonicalize keyword capitalization dia-
log.

== = |

= Canonicalize Keyword Capitalization

Change keywords to:

@ Lower Case
(2 Upper Case
Click OK to change the case of all keywerds in the selected files. To see what changes will be made, click Preview.

Preview> | [ ok ][ cancel

3. Click Preview to see what changes will be made, then click OK to
apply them.

e Example Example of Change Keyword Case refactoring.

- 1
& Canonicalize Keyword Capitalization =l ™
Changes to be performed TR

4 [V] @ Canonicalize Keyword Capitalization
[#]¢) common.f30 - commonStuff
(7] hello.fa0 - test
[F] commen.fa0 A 9 R
Original Source | Refactored Source
PROGRAM main program main -
USE moreCommon — use moreCommon
IMPLICIT NONE implicit none 7 [I
1] It
EXTERNAL change_c — external change c |30
common a, b D
— integer ::
real i
[ ] O
COMMON /common/ c,d,e, /common2/ £, common /common/ c,d,e, /common2/ D
COMPLEX :: c complex :: C
NTMEMSTON ~ (31 A s ~= S
< m ] v 4 »

Preview >

Figure 3.31:
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Convert Between If Statement and If Construct

e Description: Converts a simple if statement to an if construct with a then
block and possible else block.

e Applies To: Selected if statement.
e Operation:

1. Refactor »Coding Style »Convert Between If Statement and If
Construct

2. Select whether or not you want an empty else block.

3. Click Preview to see what changes will be made, then click OK to
apply them.

e Example: Example of the Convert Between If Statement and If Construct
refactoring

Changes to be performed & | S

~ [¥] &3 Convert Between If Statement and If Construct

[ File.fao - MyProject

[7) File foo A 48 B
original Source Refactored Source
20 CONTINUE if (1 == 2] then

PRINT *, 'j:', ] print *, "i = 2"

lcan add more stateme
else
if(i == 2) print *, *'i = 2" lcan add more statemel
end if

] =]

[ < Back H Ccancel H oK

Figure 3.32:
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Convert Data Statement to Parameter Statements

e Description: When a variable declared in a DATA statement is intended
to be a constant, Data to Parameter can be used to change it to a variable
with the PARAMETER attribute. Using the PARAMETER attribute
makes it more clear which variables are constants and which ones are not;
it can also result in performance gains, since it may allow an optimizing
compiler to replace some variable accesses with the constant value.

e Applies To: All main programs, subprograms, and modules in one or
more files.

e Operation:

1. This is a multiple-file refactoring.

— To transform variables declared as data in variables declared
with parameter attribute in a single file, open the file in the

editor and choose Refactor »Data To Parameter from the menu
bar.

— To transform variables declared as data in variables declared
with parameter attribute in multiple files, select the files in the
Fortran Projects view, right-click on any of the selected filena-
mes, and choose Refactor »Data To Parameter from the popup
menu.

2. Click Preview to see what changes will be made, then click OK to
apply them.

e Example: Example of the Data To Parameter refactoring

= Data To Parameter =G
changes to ba performes &0
v % Date To Parameler

| 27 exemple 190 - Testador_Retatoracaoisrc

& B4

! sta
data
T
data

mementst
S1/2001.07

.51/ ) 95/16.17 1 corment

A=)

P, 37, maji2:3f

2, m2 and ma values have been modified, they are not parameters

! NOTE: ALL other Deta statements are Typs sarameters,
| because their values are not cnangsd 1n the source code.
nd progran oxarpls_Data_To_Parateter

+ NOTE: 411 other Dats
| because their values
snd program sxanple Dst

oK Canesl

Figure 3.33:
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Introduce Implicit None

e Description: Adds IMPLICIT NONE statements to a file and adds expli-
cit declarations for all variables that were previously declared implicitly.

e Applies To: All main programs, subprograms, and modules in one or
more files.

e Operation:

1. This is a multiple-file refactoring.

— To Introduce Implicit None in a single file, open the file in the
editor and choose Refactor »Introduce Implicit None from the
menu bar.

— To Introduce Implicit None in multiple files, select the files in
the Fortran Projects view, right-click on any of the selected

filenames, and choose Refactor »Introduce Implicit None from
the popup menu.

2. Click Preview to see what changes will be made, then click OK to
apply them.

e Example: Example of the Introduce Implicit None refactoring

a8ano Introduce Implicit None
Changes to be performed LTS ‘;%h
E‘ ¥ @3 Introduce Implicit None
i @) crazyimplicits.f90 - org.eclipse.photran-samples/src-implicits-3
[F] crazyimplicits.fo0 et Wl
Original Source ‘Rafaclorad Source
program p |program p [
=3 Tmplicit none
d =4 real :: a
stop real :: d |]
contains a =3
subroutine s d =4
implicit integer Ca-c,g), & stop
real (d-e), contains
type(t) Cf), & subroutine s
complex Ch) implicit none
type t; integer n; end type integer :: b
type(t) :: f
a-3 integer :: g
b -3 complex :: h
d=3.0 type t; integer n; end type
f¥n = 3
g=13 a=3
ho= (3, 4) b =3
end subroutine d=3.0
end program f¥n = 3
g=3
h = (3, 4)
end subroutine
end program

4

Figure 3.34:
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Make Save Attributes Explicit
e Description: Makes Save Attributes Explicit.
e Applies To: The entire program.
e Operation:

1. Refactor »Coding Style »Make Save Attributes Explicit

2. Click Preview to see what changes will be made, then click OK to
apply them.

e Example: Example of the Make Save Attributes Explicit refactoring

= Vialce Save Attributes EXplici! [i=][e31)
Changes to be performed RT3 4
= [¥] & Make Save Attributes Explicit

[¥¢5 BFile.foo - MyProject

[®1 BFile.foo e - N
Original Source Refactored Source

subroutine sub() ~subroutine sub()
‘ integer :: counter = 0 ”“—1 integer, SAVE :: counter = 0

cuunte; = counter + 1 counter = counter + 1 o
print *, counter print *, counter

end subroutine end subroutine

l < Back H Cancel H oK

Figure 3.35:
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Remove Unreferenced Labels
e Description: Removes any unreferenced labels.
e Applies To: All unreferenced labels.

e Operation:

1. Refactor »Coding Style »Remove Unreferenced Labels

2. Click Preview to see what changes will be made, then click OK to
apply them.

e Example: Example of the Remove Unreferenced Labels refactoring

Changes to be performed CURR T 2 g

< [¥] & Remove Unreferenced Labels

V] %~ File fao - MyProject

[ File foo ot - T
Original Source Refactored Source

doi=1,9 I doi=1,9

250 print *, 1 — print *, 1 |

END DO "~ END DO u
I do1=1,9 do1=1,9 F
| 300 print *, 1 — print *, 1 |

END DO END DO

| <Bsck |[ camcel |[ ok

Figure 3.36:
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Remove Unused Variables

e Description: Remove Unused Variables removes declarations of local va-
riables that are never used.

e Applies To: All main programs, subprograms, and modules in one or
more files.

e Operation:

1. This is a multiple-file refactoring.

— To Remove Unused Variables in a single file, open the file in the
editor and choose Refactor »Remove Unused Variables from the
menu bar.

— To Remove Unused Variables in multiple files, select the files
in the Fortran Projects view, right-click on any of the selected
filenames, and choose Refactor »Remove Unused Variables from
the popup menu.

2. Click Preview to see what changes will be made, then click OK to
apply them.

e Example: Example of the Remove Unused Variables refactoring

changes to be performes & *
= M4 Rernove Unused Varisbles
' exemple 155 - Testador_Retatoracaoisrc

| |
fao o o4l

Figure 3.37:
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Standardize Statements

e Description: Standardize Statements rewrites all variables declarations,
so that

— there is only one variable declaration per line, and

— every variable declaration contains a double colon (::).
This is intended to make the code more readable.

e Applies To: All main programs, subprograms, and modules in one or
more files.

e Operation:

1. This is a multiple-file refactoring.

— To Standardize Statements in a single file, open the file in the
editor and choose Refactor »Standardize Statements from the
menu bar.

— To Standardize Statements in multiple files, select the files in
the Fortran Projects view, right-click on any of the selected
filenames, and choose Refactor »Standardize Statements from
the popup menu.

2. Click Preview to see what changes will be made, then click OK to
apply them.

e Example: Example of the Standardize Statements refactoring

StanAr 2 ST et

Figure 3.38:
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3.9 Debugging

These refactorings are used to debug your program.

Highlight Variable Accesses

e Description: Creates a file of your code where the variables are highligh-
ted according to whether they are read or write variables.

e Applies To: The entire program.
e Operation: Refactor »Debugging »Highlight Variable Accesses

e Example: Example of the Highlight Variable Accesses refactoring



80 CHAPTER 3. REFACTORING

Display Symbol Table for Current File

e Description: Creates file with a list of all the variables. Lists the name
and type of variable and the line where the variable was declared.

e Applies To: The entire program.

e Operation: Refactor »Debugging »Display Symbol Table for Current
File

e Example: Example of the Display Symbol Table for Current File refac-
toring
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Find All Declarations in Scope

e Description: Gives a list of all the declarations that are in the scope of
the line you’re on.

e Operation: Refactor »Debugging »Find All Declarations in Scope You
will see a list of all the variables that are in scope. You can type in a
variable to see if it is in scope.

e Example: Example of the Find All Declarations in Scope refactoring
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Select Enclosing Scope

e Description: Highlights the entire range of source text corresponding to
a token?s enclosing ScopingNode.

e Operation: Click on a token in the editor. Refactor »Debugging »Select
Enclosing Scope
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Display Error/Warning Log
e Description: Creates file with a log of errors and warnings.

e Operation: Refactor »Debugging »Display Error/Warning Log
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Resolve Interface Binding

e Description: Resolves all interface binding.

e Operation: Refactor »Debugging »Resolve Interface Binding
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Find Matching Interface Declarations

e Description: Finds matching interface declaration for an identifier in a
subprogram declaration.

e Operation: Refactor »Debugging »Find Matching Interface Declarations
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Display Binder Statistics

e Description: Creates file with a list of average and maximum times for
ReferenceCollider, ModuleLoader, etc.

e Operation: Refactor »Debugging »Display Binder Statistics

e Example: Example of the Display Binder Statistics refactoring
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Reset Binder Statistics

Description: Resets the Binder Statistics. If you Display Binder Statis-
tics, there will be no data under Average Times.

Operation: Refactor »Debugging »Reset Binder Statistic Display Data-
base Statistics

Description: Creates file with stats on how many times methods such as
getIncomingEdgesTo, getAnnotation, and isOutOfDate have been called.

Operation: Refactor »Debugging »Display Database Statistics

Example: Example of the Display Database Statistics refactoring
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Reset Database Statistics

e Description: Resets the Database Statistics. If you Display Database
Statistics, there will be no data.

e Operation: Refactor »Debugging »Reset Database Statistic
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Display Database

e Description: Creates file with database statistics on dependencies, edges,
and modification stamps.

e Operation: Refactor »Debugging »Display Database

e Example: Example of the Display Database refactoring
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Display Edge Model of Current File
e Description: Creates file that has info on all of the edges.

e Operation: Refactor »Debugging »Display Edge Model of Current File

e Example: Example of the Display Edge Model of Current File refactoring
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Ensure Database is Up-to-Date

e Description: Makes sure that the database is up-to-date.

e Operation: Refactor »Debugging »Ensure Database is Up-to-Date
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Clear and Rebuild Database

e Description: Clears and rebuilds the database.

e Operation: Refactor »Debugging »Clear and Rebuild Database
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Browse VPG Database

e Description: Allows you to view all edges, dependencies, and annotations
for all files.

e Operation: Refactor »Debugging »Browse VPG Database Select a file
and switch between edges, dependencies, and annotations on the right
side of the box.

e Example: Example of the Browse VPG Database refactoring
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3.10 Not Yet Available

The following refactorings have been submitted but are not yet included in
Photran.

Add Use Of Named Entities

e Description: This refactoring adds the statement use M, only: ... to anot-
her module, if a similar statement does not already exist. It fails if this
will result in a naming conflict, the introduction of circular dependencies
between modules, or if a statement use M already exists but renames any
named entities.

e Applies To: A list of named entities.

e Operation: Move your cursor to the module you want to ”"use”. Click
Refactoring »Add Use Of Named Entities to Modules. Select the named
entities you would like to use, and the module you want to use them in.
Click preview to view the changes, and OK to apply the changes.

e Example: Example of the Add Use Stmt refactoring.

Move Module Entities

e Description: This refactoring moves a set of named entities from one
module to another, and updates all use statements that reference these
modules.

e Applies To: A list of named entities.

e Operation: Move your cursor to the module with the entities you would
like to move. Click Refactoring »Move Module Entities. Select the na-
med entities you would like to move, and the module you want to move
them to. Click preview to view the changes, and OK to apply the changes.

e Example: Move Module Entities example.

Change Subroutine to Function

e Description: This refactoring will change a subroutine to a function. The
refactoring fails if there are no intent out arguments.

e Applies To: A file.

e Operation: Select the subroutine name or subroutine statement that
needs to be changed to a function Click Refactoring »Change Subroutine
To Function. Click preview to view the changes without applying, or OK
to apply the changes.
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e Example: Example of Change Subroutine to Function refactoring.

Convert Specification Statement to Declaration Attribute

TODO

Toggle End Name
TODO

Standardize Input Output Format
TODO
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