
Module 3: Working with C/C++ 
 Objective 

 Learn basic Eclipse concepts: Perspectives, Views, … 
 Learn how to use Eclipse to manage a remote project 
 Learn how to use Eclipse to develop C programs 
 Learn how to launch and run a remote C program 

 Contents 
 Brief introduction to the C/C++ Development Tools 

(CDT) 
 Create a simple remote application 
 Learn to launch a remote C application 
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Login Information 

 The hands on portion of this module will be 
done on a remote system at NCSA 
 abe.ncsa.uiuc.edu 

  See the following URL for more information on the 
system 
  http://www.ncsa.illinois.edu/UserInfo/Resources/Hardware/

Intel64Cluster/ 

 Each student will be assigned an ID and 
password at the start of the tutorial 

 Please use only this ID 
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Eclipse Basics 
  A workbench contains the menus, toolbars, editors and 

views that make up the main Eclipse window 

perspective Module 3 

view 
view 

view 

editor 

  The workbench represents 
the desktop development 
environment 
  Contains a set of tools  

for resource mgmt 
  Provides a common way 

of navigating through  
the resources 

  Multiple workbenches  
can be opened at the 
same time 

  Only one workbench can 
be open on a workspace 
at a time 
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Perspectives 

 Perspectives define the layout of views and 
editors in the workbench 

 They are task oriented, i.e. they contain 
specific views for doing certain tasks: 
 There is a Resource Perspective for manipulating 

resources 
 C/C++ Perspective for manipulating compiled code  
 Debug Perspective for debugging applications 

  You can easily switch between perspectives 

 If you are on the Welcome screen now, select 
“Go to Workbench” now  
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Switching Perspectives 

  Three ways of changing 
perspectives 

  Choose the Window>Open 
Perspective menu option 

  Then choose Other… 

  Click on the Open 
Perspective button in the 
upper right corner of screen 

  Click on a perspective 
shortcut button 

 Switch perspective 
on next slide… 
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Switch to Remote C/C++ Perspective 
  Select Window>Open 

Perspective 
  Then choose Other… 
  Only needed if you’re not 

already in the perspective 

  What Perspective am in in? 
   See title Bar 
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Views 

 The workbench window is  
divided up into Views 

 The main purpose of a view is: 
 To provide alternative ways of presenting information 
 For navigation 
 For editing and modifying information  

 Views can have their own menus and toolbars 
 Items available in menus and toolbars are  

available only in that view 
 Menu actions only  

apply to the view 

 Views can be resized 

view 

view view 
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Stacked Views 

 Stacked views appear as tabs 
 Selecting a tab brings that view to the 

foreground 
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Help 

  To access help 
  Help>Help Contents 
  Help>Search 
  Help>Dynamic Help 

  Help Contents provides 
detailed help on different 
Eclipse features in a 
browser 

  Search allows you to 
search for help locally, or 
using Google or the Eclipse 
web site 

  Dynamic Help shows help 
related to the current 
context (perspective, view, 
etc.) 
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Preferences 
  Eclipse Preferences allow 

customization of almost everything 
  To open use 

  Mac: Eclipse>Preferences… 
  Others: Windows>Preferences… 

 The C/C++ preferences 
allow many options to 
be altered 

 In this example the 
Code Style preferences 
are shown 

 These allow code to be 
automatically  
formatted in different 
ways 
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Types of C/C++ Projects 
  C/C++ Projects can be 

  Local – source is located on local machine, builds happen locally 
  Remote – source is located on remote machine, builds take place 

on remote machine 
  Makefile-based – project contains its own makefile (or makefiles) 

for building the application 
  Managed– Eclipse manages the build process, no makefile 

required 
  Parallel programs can be run on the local machine or on a remote 

system 
  MPI needs to be installed 
  An application built locally probably can’t be run on a remote 

machine unless their architectures are the same 
  We will show you how to create, build and run the program on a 

remote machine 
  We will create a remote Makefile project 
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Remote Projects 
Remote Development Tools (RDT)  
  Source is located on remote machine 
  Eclipse is installed on the local machine and can be used for: 

  Editing 
  Building 
  Running 
 Debugging 

  Source indexing is performed on remote machine 
  Enables call hierarchy, type hierarchy, include browser, search, 

outline view, and more… 
  Builds are performed on remote machine 

  Supports both managed and makefile projects 
  Application is run and debugged remotely using the PTP resource 

managers 
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  Use File>New>Remote C/C++ Project to open the 
new project wizard 

  The wizard will take you through the steps for creating 
the project 

Creating a Remote C/C++ Project 
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Don’t see the “Remote C/C++ Project” choice? 
Make sure you are in the Remote C/C++ Perspective 



New Remote Project Wizard 

  Enter project name, e.g. “hello” 
  Select a Remote Provider 

  Remote providers supply different 
ways of accessing remote (or local) 
systems 

  Choose Remote Tools 

  A Connection specifies how to 
connect to the remote host 
  Click on the New… button to create a 

new connection 
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Remote Host Configuration 

  Enter a connection name (can be 
anything) for the Target name 
  Use “abe.ncsa.uiuc.edu” 

  The host is remote, so the Remote 
host option should be checked 

  Enter the host name or IP address 
of the remote host for the Host 
  Use “abe.ncsa.uiuc.edu” 

  Enter the user name and 
password supplied at the beginning 
of the tutorial for the User and 
Password 

  Click Finish 

3-14 Module 3 



Project Location 

  The Location is the directory on 
the remote host containing the 
source and executable files 

  Click on the browse button to 
browse for folders on the remote 
machine 
  You should see the folders in your 

home directory 
  Choose the “hello” directory 

  Click OK 
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Project Type 
  The Project type determines 

information about the project 
  If the project is managed or 

unmanaged (described later) 
  The tool chain (compiler, linker, etc.) 

to use when building 
  If the project creates an executable, 

static, or shared library 
  Options available depend on whether 

the project is local or remote 
  Under Remote Makefile 

Project, select Empty Project  
  For Toolchains, select Other 

Toolchain 
  Click on Finish to complete the 

wizard 
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  If you need to change remote connection 
information (such as username or 
password), use the Remote 
Environments view  

Changing Remote Connection Information 
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  Stop the remote 
connection first 

  Right-click and 
select Edit 

  Note: running server is shown in lower right 
 Opening any remote file restarts it 



Project Explorer View 
  Shows the user’s projects 
  Each project contains 

  Source files 
  Executable files 
  Folders 
 Metadata (not visible) 

  Can have any number of projects 
  We only have a single project so 

far 
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Editor and Outline View 
  Double-click on 

source file to open 
editor 

  Outline view is 
shown for file in 
editor 

  You should see red 
on the include files: 
we will fix this 
later 

  Console shows 
results of build 
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Editors 

  An editor for a resource (e.g. a file)  
opens when you double-click on  
a resource 

  The type of editor depends on the type of the resource 
  .c files are opened with the C/C++ editor 
  Some editors do not just edit raw text 

  When an editor opens on a resource, it stays open across 
different perspectives 

  An active editor contains menus and toolbars specific to that 
editor 

  When you change a resource, an asterisk on the editor’s 
title bar indicates unsaved changes 

editor 
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  Save the changes by using Command/
Ctrl-S or File>Save 



Source Code Editors & Markers 

  A source code editor is a 
special type of editor for 
manipulating source 
code 

  Language features are 
highlighted 

  Marker bars for showing 
  Breakpoints 
  Errors/warnings 
  Task Tags, Bookmarks 

  Location bar for 
navigating to interesting 
features in the entire file 

Icons: 
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Line Numbers 

  Text editors can show line numbers in the 
left column 

3-22 Module 3 

  To turn on line 
numbering: 
  Right-mouse click in 

the editor marker bar 
  Click on Show Line 

Numbers 



Include File Locations 

  Content assist and navigation 
requires knowledge of include file 
location on the remote system 

  The editor will highlight lines in 
red that have the problem 

  Problems View will display a 
warning 

  The project properties must be 
changed to resolve the problem 
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Indexer: Unresolved inclusion: <stdio.h> in 
file: /u/ac/etrain1/hello/hello.c:11.  Please re-
configure project's remote include paths or 
symbols. 



  Open the project properties by 
right-clicking on project and 
select Properties 

  Expand Remote 
Development 

  Select Remote Paths and 
Symbols 

  Select GNU C to change  
C paths and symbols 

  Click Add 
  Enter “/usr/include” 
  Click OK 

Changing the Project Properties 
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  Click OK  to save the Project 
Properties 

  You will be prompted to 
rebuild the index 
  Select Yes 

  Red warnings should be  
gone from editor, since 
Eclipse knows the location  
of the include files now 

Saving  the Project Properties  
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  On demand hyperlink 
  Hold down Command/Ctrl key 
  Click on element to navigate to 

its definition in the header file 
(Exact key combination  
depends on your OS) 

  E.g. Command/Ctrl and click on 
EXIT_SUCCESS 

  Open declaration 
  Right-click and select Open 

Declaration will also open the 
file in which the element is 
declared 

  E.g. right-click on stdio.h and 
select Open Declaration 

Navigating to Other Files 
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Content Assist & Templates 
  Type an incomplete function name e.g. “get” into the editor, 

and hit ctrl-space  
  Select desired completion value with cursor or mouse 
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Hit ctrl-space again 
for code templates    Code Templates: type 

‘for’ and Ctrl-space 



  To manually build, select 
the project and press the 
the “build” button 
  Alternatively, select Project>Build 

Project 

  The executable should appear in 
the project 

  The Console view shows  
build output 

Building the Project 

  The project should build automatically when created  
  If there is no makefile, then the build will fail 
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Executable 
‘hello’ 



Build Problems 

  If there are problems, they 
will be shown in a variety 
of ways 
  Marker on editor line 
  Marker on overview ruler 
  Listed in the Problems view  

  Double-click on line in 
Problems view to go to 
location of error 
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Fix Build Problems 

  Save the file 
  Rebuild by pressing build 

button 
  Problems view is now 

empty 
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  Fix errors by giving getenv an argument and fixing 
declarations as shown 



Create a Resource Manager 

  A Resource Manager specifies how/where 
programs will be launched 

  Switch to the Parallel Runtime perspective 
  Window>Open Perspective… 

  In the Resource Managers view,  
right-click and select Add Resource 
Manager… 

  Select Generic Remote Launch and Next > 
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Configure the Resource Manager 

  Choose Remote Tools for 
Remote service provider 

  Choose “abe.ncsa.uiuc.edu” 
for Connection name 
  This was the connection used 

when the project was created 

  Select SSH port forwarding 
for Tunneling Options 

  Click Finish 
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  Right-click on the new 
resource manager and select 
Start Resource Manager 
from the menu 

  If the resource manager 
starts successfully, the icon 
should turn green 

  An icon color of red indicates 
a problem occurred 

Start the Resource Manager 
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NOTE: On some Linux systems, starting a resource 
manager may appear to hang. Open the window 
you launched Eclipse from and check if there is a 
prompt for a kerberos username. Hit “enter” twice 
if you see the prompt. 



To run the application, create a  
Run Configuration 

  Open the run configurations  
dialog 
  Click on the arrow next to the run button 
  Or use Run>Run Configurations… 

  Select Parallel Application 
  Select the New button  

Create a Run Configuration 

Depending on which flavor of 
Eclipse you installed, you might 
have more choices of application 
types 
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Complete the Resources Tab 

  Select your Resource Manager 
  Should be selected automatically if it has been started 

  The Generic Remote Launch doesn’t require additional 
attributes 
  Other resource managers may have additional attributes, such as a 

queue name, etc. 
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Complete the Application Tab 
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  Make sure “hello” is selected 
for the Parallel Project 

  Browse to find the 
executable file for the 
Application program 

  Launch the application by 
clicking the Run button 



Viewing Program Output 

  When the program runs, the Console view should 
automatically become active 

  Any output will be displayed in this view 
  Stdout is shown in black 
  Stderr is shown in red 
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Other CDT features 

 Searching 
 Mark Occurrences 
 Open Declaration / hyperlinking between files 

in the editor 
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First, return to the “Remote C/C++ 
Perspective” 



Language-Based Searching 

  “Knows” what things can 
be declared in each 
language (functions, 
variables, classes, 
modules, etc.) 

  For example, search for 
every call to a function 
whose name starts with 
“get” 

  Search can be project- or 
workspace-wide 
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Mark Occurrences 

 Double-click on a variable in the CDT editor 
 All occurrences in the source file are 

highlighted to make locating the variable 
easier 

 Alt-shift-O to turn off 
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Open Declaration 

  Jumps to the declaration of 
a variable, function, etc., 
even if it’s in a different file 

  Right-click on an identifier 
  Click Open Declaration 

  Can also Ctrl-click (Mac: 
Cmd-click) on an identifier 
to “hyperlink” to its 
declaration 
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Remote Projects - Location 

  How to tell where a project 
resides? 

  Right-click Project 
  Select Properties… 

  In Properties dialog, 
select Resource 
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Remote Projects - Reopening 

  When re-opening Eclipse 
workbench, remote projects 
will be closed 

  To re-open a closed project, 
Right-click on closed project 
and select Open Project 

  Open project shows folder 
icon, and can be expanded to 
show contents of project 
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