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Tutorial Outline (morning)

Time Module Outcomes Presenter

8:30 - 8:45 | Tutorial Introduction + Overview of the tutorial Greg Watson
process and setup

8:45 - 9:15 | 1. Overview of Eclipse | + An understanding of the overall | Greg Watson
and PTP Eclipse and PTP architecture

9:15 - 10:00 | 2. Installing Eclipse + Eclipse installed on your laptop | Beth Tibbitts

10:00 - 10:30 | Break

10:30 - 11:30 | 3. Introduction to the | + Knowledge of the basic Craig

Eclipse IDE features of the Eclipse IDE Rasmussen

+ Building, running and
debugging a sample application

11:30 - 12:00 | 4. Advanced + Knowledge of some of the Craig
Development advanced features of the Rasmussen
Eclipse IDE

12:00 - 1:30 | Lunch Break
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Tutorial Outline (afternoon)

Time Module Outcomes Presenter
1:30 - 3:00 | 5. PTP and Parallel + Introduction to PTP Beth Tibbitts
Language Development | 4 Creating and launching a
Tools parallel application

+ Experience using PLDT tools
on a real application

3:00 - 3:30 | Break

3:30 - 4:30 | 6. Parallel Debugging + Introduction to the Eclipse Greg Watson
parallel debugger, locating
and correcting bugs in
parallel code

4:30 - 4:50 | 7. Where To Go Next + Further information about Greg Watson
Eclipse, PTP and related
tools
4:50 - 5:00 | Tutorial Wrap Up + Completed feedback forms Greg Watson
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A word on versions...

+ The current release of PTP (1.1.1) requires
CDT version 3.1.x and Eclipse 3.2.x. (Callisto)

+ The next release of PTP (2.0) will require CDT
4.0 and Eclipse 3.3 (Europa) which were
released in June 2007
+ PTP 2.0 will not be released until the end of 2007

+ The slides in this tutorial describe an early
access version of PTP 2.0, which requires
Eclipse 3.3.1.1 and CDT 4.0.2, so that you can
see the latest features that will be available

+ There may be some minor differences between PTP
that you see here and the final release version
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Module 1: Overview of Eclipse

and PTP
+ Objective
+ To introduce participants to the Eclipse platform and
PTP
+ Contents
+ History

+ What is Eclipse?
+ Who is using Eclipse?
+ What is PTP?

Module 1 SC 2007 1-0

History

+ Originally developed by Object Technology
International (OTI) and purchased by IBM for
use by internal developers

+ Released to open-source community in 2001,
managed by consortium

+ Eclipse Public License (EPL)
+ Based on IBM Common Public License (CPL)

+ Consortium reorganized into independent not-
for-profit corporation, the Eclipse Foundation,
in early 2004

+ Participants from over 100 companies

Module 1 SC 2007 1-1




Eclipse Foundation

+ Board of Directors drawn from four classes of
membership:

+ Strategic Developers, Strategic Consumer, Add-in
Providers, and Open Source project leaders

+ Full-time Eclipse management organization
+ Councils guide the development done by
Eclipse Open Source projects
+ Requirements
+ Architecture
+ Planning

+ Currently 9 projects and over 50 subprojects
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Members of Eclipse

June 2007

+ 162 members in June ‘07 (130 in March 2006)
+ 21 strategic members (16 in June 2006)
+ 794 committers, representing 48 organizations
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What is Eclipse?

+ A vendor-neutral open source development
platform

+ A universal platform for tool integration

+ Plug-in based framework to create, integrate
and utilize software tools

Java C/C++/Foriran Test and
Development Development Performance Parallel Tools
Tools Tools Tools
Platform
User
T Debug Update Help Team
Equinox
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+ OSGi framework implementation model

+ Formerly known as the Open Services Gateway

initiative

+ Standard for application lifecycle management
+ Provides the most fundamental Eclipse

infrastructure

+ Plug-ins (known as a bundle)

+ Bundle install, update and uninstall

+ Bootstrap and launching

+ Extension registry

+ Introduced in Eclipse 3.0
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Platform

+ Core frameworks and services with which all
plug-in extensions are created

+ Represents the common facilities required by
most tool builders:
+ Workbench user interface
+ Project model for resource management
+ Portable user interface libraries (SWT and JFace)

+ Automatic resource delta management for
incremental compilers and builders

+ Language-independent debug infrastructure

+ Distributed multi-user versioned resource
management (CVS supported in base install)

+ Dynamic update/install service
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Plug-ins

Java Development Tools (JDT)

Plug-in Development Environment (PDE)
C/C++ Development Tools (CDT)

Parallel Tools Platform (PTP)

Fortran Development Tools (Photran)

Test and Performance Tools Platform (TPTP)
Business Intelligence and Reporting Tools (BIRT)
Web Tools Platform (WTP)

Data Tools Platform (DTP)

Device Software Development Platform (DSDP)
Many more...

R T I
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Module 2: Installing Eclipse

+ Objective
+ To learn how to install Eclipse
+ To install Eclipse on your laptop
+ Contents
+ Software prerequisites
+ Installing Eclipse
+ Installing CDT, RSE and PTP
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Software Prerequisites

+ Java (1.5 or later)

+ Cygwin (for Windows)

+ make, gcc, and gdb (or other vendor compilers)

+ gfortran (only required for Fortran support)

+ OpenMPI or MPICH2 (only required for PTP Runtime)
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Pre-installation Overview

Java

Cygwin

make/gcc
/gdb

gfortran

OpenMPI

Windows

install

install

installed
by cygwin

install

N/A

Linux

install

check
installed

install

install

MacOS X

requires
Xcode

install

install
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Java Installation

+ Eclipse requires Sun or IBM versions of Java
+ Only need Java runtime environment (JRE)
+ Java 1.5 is the same as JRE 5.0
+ The GNU Java Compiler (GCJ) will not work!
+ Latest Sun JRE is in the java folder on tutorial CD:
+ jre-1_5_0_12-windows-i586-p.exe
+jre-1_5_0_12-windows-amd64.exe
+jre-1_5_0_12-linux-i586.bin
+jre-1_5_0_12-linux-amd64.bin

Module 2
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Java Installation (Linux)

+ Open a terminal window
+ Mount your CDROM if necessary

’ mount /nedi a/ cdrom

+ Enter the commands below:

+ Replace cdr omwith the location of your CDROM (usually
/ medi a/ cdrom) and ar ch with your computer architecture
(usually i 586)

cd
cdromjaval/jre-1_5 0_12-linux-arch.bin

+ Hit space until you are asked to agree to license, then
enter ‘yes’)

PATH=~/j rel.5.0_12/ bi n: $PATH

+ Add to your PATH in your login file if required
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Java Installation (Windows)

+ Open the TutorialCD in My Computer
+ Open the java folder
+ Double-click on jre-1_5_0_12-windows-arch
+ Replace arch with your computer architecture (most likely
i586-p)

+ Follow installer wizard prompts
+ Accept default options
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Eclipse and PTP Installation

+ Eclipse is installed in two steps

+ First, the ‘base’ Eclipse is downloaded and installed
+ This provides a number of pre-configured ‘features’

+ Additional functionality is obtained by adding more
‘features’

+ This can be done via an " update site’ that automatically
downloads and installs the features

+ Features can also be downloaded and manually installed
+ PTP requires the following features

+ C/C++ Development Tools (CDT)

+ Remote System Explorer (RSE)

+ Parallel Tools Platform (PTP)
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Eclipse and PTP Installation Overview

Eclipse CDT RSE PTP PTP

SDK Feature | Feature | Feature Proxy

Windows install update update | update N/A
Linux install update update | update install
MacOS X install update update | update install
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Eclipse SDK Installation

+ The base component of Eclipse is known as the Eclipse
SDK

+ The Eclipse SDK is downloaded as a single zip or
gzipped tar file

+ You must have the correct file for your operating
system and windowing system

+ Unzipping or untaring this file creates a directory
containing the main executable

+ Copies of the Eclipse SDK for each operating system
type are located in the eclipse folder on the tutorial CD
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Eclipse SDK Installation (Linux)

+ Open a terminal window
+ Mount CDROM if not already

+ Enter the commands below:

+ Replace cdr omwith the location of your CDROM (usually
/ medi a/ cdr om)

+ If your machine is not x86 based, use either the
- ppc or - x86_64 versions (not on CDROM)

cd
tar -zxvf cdronieclipse/eclipse-SDK-3.3.1.1-1inux-
gtk.tar.gz
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Eclipse SDK Installation (MacOS X)

+ From the Finder, open TutorialCD

+ Open the eclipse folder

+ Double-click on
eclipse-SDK-3.3.1.1-macosx-carbon.tar.gz

+ Will create new eclipse folder in your downloads location
+ Specified in Safari

+ Drag new eclipse folder to Applications (or wherever
you want to install it)
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Eclipse SDK Installation (Windows)

+ Open the TutorialCD in My Computer
+ Open the eclipse folder

+ Unzip the following file:
eclipse-SDK-3.3.1.1-win32.zip

+ Choose a location on your hard drive where you want to
install Eclipse (e.g. C:\)
+ An eclipse folder will be created at this location
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Starting Eclipse

+ Linux
+ From a terminal window, enter
cd
eclipsel/eclipse &

+ MacOS X

+ From finder, open the Applications»eclipse folder
+ Double-click on the Eclipse application
+ Windows
+ Open the eclipse folder
+ Double-click on the eclipse executable

+ Accept default workspace when asked
+ Select workbench icon from welcome page
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Adding Features

+ New functionality is added to Eclipse using features

+ Features are obtained and installed from an update site
(like a web site)

+ Features can also be installed manually by copying files
to the features and plugins directories in the main
eclipse directory
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Installing Eclipse Features
from an Update Site

+ Three types of update sites
+ Remote - download and install from remote server
+ Local - install from local directory
+ Archived - a local site packaged as a zip or jar file

+ Eclipse 3.3.1 comes preconfigured with a link to the
Europa Discovery Site

+ This is a remote site that contains a large number of official
features

+ Europa projects are guaranteed to work with Eclipse 3.3.1
+ Many other sites offer Eclipse features
+ Use at own risk
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Creating a Local Update Site

. i -
We have combined everything needed |update sites to visit »

for the tutoria| onto a |Oca| update site Select update sites to visit while looking for new features ‘ 7')5—
on the CDROM Sites tolnclude i search:

From the Help menu, choose - fﬂj::z:HS‘;:L;:;Z;‘L;M e
Software Updates»Find and
Insta " | New archived site...|

Select Search for new features to

install
Click Next > / portsices.. |
Click New Local Site... ‘

| Export sites

| New Local Site... |

Navigate to your CDROM, select the

updatesite folder and click Choose @ rere feaJ
i [ Automaticg Naops: Tutorial
(EO:( O;l- Ltlnu?()l for the N // URL: [flesmediajcdromiupdatesitel ‘
nter Tutorial r1or the Name

Click OK

OK | cancel |
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+

+ 4+ + 4+ +

Installing Tutorial Features

Make sure only Tutorial is selected,

;
other options as defaults Search Results P
Cl |Ck Fi nish Select features to install from the search result list. ; /‘,=‘~
From SearCh ReSUItsI seleCt \. Select the features to install:
Tutorial (open the twisty to see the ™| BEEETIZ | oesclectal |
contents)
Click Next >
Accept the license terms |select Required |
Click Next >
|' k Finish 1of 1selected.
C IC Show the latest version of a feature only
For Feature verification C|ICk [ Filter features included in other features on the list
!

Install All
Restart workbench when asked

@ Next > | cancel |
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Installing the PTP Proxy
(for information only)

+ Normally installed on a parallel machine
+ e.g. a cluster
+ Can install on a non-parallel system
+ Not available for Windows
+ Requires OpenMPI to be built and installed
+ This process depends on the type of machine
+ Beyond the scope of this tutorial
+ To install the proxy, do the following steps from a terminal
+ Change to your Eclipse installation directory
+ Change to pl ugi ns/ org. ecl i pse. ptp. os. arch_2. 0, where

os is your operating system (macosx or | i nux), arch is you
architecture (ppc, x86, or x86_64)

+ Run the command: sh BUI LD
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Module 3: Introduction to the
Eclipse IDE

+ Objective

+ Gain an understanding of how to use Eclipse to
develop applications

+ Contents
+ Brief introduction to the Eclipse IDE
+ Create a simple application
+ Run and debug simple application
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Platform Differences

+ Single button mouse (e.g. MacBook)
+ Use Control-click for right mouse / context menu
+ Context-sensitive help key differences
+ Windows: use F1 key
+ Linux: use Shift-F1 keys
+ MacOS X
+ Full keyboard, use Help key

+ MacBooks or aluminum keyboard, create a key binding
for Dynamic Help to any key you want

+ Accessing preferences
+ Windows & Linux: Window » Preferences...
+ MacOS X: Eclipse»Preferences...
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Specifying A Workspace

+ Eclipse prompts for a workspace location at
startup time

+ The workspace contains all user-defined data
+ Projects and resources such as folders and files

The prompt can be
turned off Workss
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Eclipse Welcome Page

+ Displayed when Eclipse is run for the first time
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Workbench

+ The Workbench Resource - Eclipse SDK =
represents the deSktOp File Edit Navigate Search gv?m Run  Window Help
. Civ & & @ | Qv | & SO Gy E_‘f-m ud
development environment | “ — ==
+ It contains a set of tools 8%~
for resource management
+ It provides a common F)Tasks £, B Corsole| & ® 3~ <O
way of navigating — ~=a [ Josm
through the resources mar Bbme TS
+ Multiple workbenches can
be opened at the same
tlme [«] iz [*]
name!
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Workbench Components

+ A Workbench contains perspectives
+ A Perspective contains views and editors

Resource - MyCproject/src/MyCproject.c - Eclipse SDK
Edit Refactor Navigate Search Project Run Window Help

e Ve al e e | 0§ e o o[ Resouee| >
perS peCtlve (25 Project Explorer &2 = 8 || [¢ MyCproject.c &2 =

8
i

Z

==
= #include <stdio.h>
= G£MyCproject #include <stdlib.h>
edItOr S int main(void) {

b [ Includes puts("!!!Hello World!!!"); /* prints !!!

/vg,( return EXIT_SUCCESS;
[ E:] '

< yeza >
b (= Debug L I Ll
I Tasks 8 . E Console G ® F Y=0O
o =
8= Outine 23 e

V|eWS B R s e T [v [t [Descrption Resource | F
ee——— | Y sun
T

g

©  mainiveid) : int [5] e

=
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Perspectives

+ Perspectives define the layout of views in the
Workbench

+ They are task oriented, i.e. they contain
specific views for doing certain tasks:

+ There is a Resource Perspective for manipulating
resources

+ C/C++ Perspective for manipulating compiled code
+ Debug Perspective for debugging applications

+ You can easily switch between perspectives

Module 3 SC 2007 3-6

+ You can switch

Switching Perspectives

PerSpeCtlveS by: File Edit Refactor Navigate Search Project Run _Window Help s
+ Choosing the -0
Window»Open F!
Perspective menu
Optl On return EXIT_SUCCESS; prames ! D
+ Clicking on the -~
- b (=Debug
Open Perspective | e B Comde &% 3w =0
button o= Outline R = ‘Elmemsl |D -
B RN e v | | Description [Resouce [F
+ Clicking on a i
perspective shortcut| - manin:m o .
button ¢ @
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+ By default, certain
perspectives are available
in the Workbench

+ We've also installed C/C++
perspective

ITRescurce
éDTeam Synchronizing

Module 3 SC 2007 3-8

Customizing Perspectives

+ Items such as shortcuts, menu items and
views may be customized
+ Window» Customize Perspective...
+ Rearrange views by dragging
+ Try moving the outline view
+ Save changes
+ Window» Save Perspective As...
+ Close Perspective
+ Right-click on perspective title and select Close

+ Reset Perspective

+ Window» Reset Perspective resets the current
perspective to its default layout
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+ The main purpose of a view is:

+ To provide alternative ways of presenting
information

+ For navigation
+ For editing and modifying information

+ Views can have their own menus and toolbars
+ Items available in menus and toolbars are available

only in that view
+ Menu actions only apply to the view \

o= Qutline 2 2 " e ¥ =O

o main() : int

Module 3 SC 2007

Stacked Views
+ Stacked views appear as tabs
+ Selecting a tab brings that view to the
foreground
Resource - MyCprojecy/src/MyCproject.c - Eclipse SDK
File Ngelit Refactor Navigate Search Project Run Window Help
e B B[ Qv | [ § e e Dy
(75 Project ExploM\E2 = B [@ MyCproject.c 2
55 71 #include <stdio.h>
¥ = MyCproject #include <stdlib.h>
b Binaries int main(void) {
b ailincludes puts("1 ! 1Hello World!!1"); /
< st return EXTT_SUCCESS;
b !
b = Debug N = I
| Tasks & . E Console
87 Outline 32 = O ems
% MW @ T v | [Desciption Resource | F
o stdioh
U stdlib.h
© main(void) : int [« [2]
0¢
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Project Explorer View

+ Represents user’s data

+ It is a set of user defined
resources

L) Project Explorer £3

+ Files -
~ B8 MyCproject
+ F0|derS [» ﬁbBinaries
+ PrOJeCtS i IQJJB'Inc\udes
+ Collections of files and b EMYCD,OJW_C
folders b = Debug
+ Plus meta-data
+ Resources are visible in
the Project Explorer View
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Opening a New View

+ To open a view:

+ Choose Window »Show View »Other... F _
= (= General lad
+ The Show View dialog comes up Weookmaks
+ Select the view to be shown S Cone
+ SeleCt OK ::\rlnemal Web Browser ‘
~Navigator
B2 Outline
[Z Problems
GProgress
It Project Explorer
E Properties
' Search
ETasks
b At
b E=C/C++ ol
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Fast Views (1)

+ Hidden views that can

be quickly opened and File Edit Refactor Navigate Search Project Run Window Help
q yop cie @@ B R | 9By G o & [Resowee| >

Resource - MyCproject/src/MyCproject.c - Eclipse SDK

closed
) [%5 Project Explorer &2 = B | [g MyCproject.c 2 =g
+ They take up space in 2 & TN linctude <etdio.t
the Workbench = LS MyCproject #include <stdlib.h>
. b ¥ Binaries int main(voi
+ FaSt VIEWS Can be b 5l Includes * putsg"!![!il?[ei{llo World!!!"); /* print:
. v (Bsrc return EXIT_SUCCESS;
created by: - 2 | ;
. . b & Debu < = B
+ Dragglng an open view ? : Tasks 2 El Console R

to the shortcut ba 0 tems
+ Selecting Fast View\ [+ [oecipien =

from the view’s menu
+ A Fast View is activated |'— _ K £

by clicking on its Fast i
View button —

\ Outline view has been hidden
in the shortcut bar
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Fast Views (2)

+ Clicking on the Fast View opens the view in the current
perspective

+ Clicking outside of R e e T o
i i File Edit Refactor Navigate Search Project Run Window Help
€ VIEW makKes |
hidden again redale e s s ees. o0 -
+ TU m Off the FaSt &F Outline 5 = O B[4 *MyCproject.c 3
. . B R e Y| Tl L e <stdio.h:
View by selecting 4 sigon 1| inetue otaiivm
Fast View from the i int main(void) {
. . main(void) : int ts("! ! Hello World!!!");
view’s menu again return BXIT_SUCCESS;
}
[*] A |
¥ Tasks 52 B Console “
0 items
|" |! |Descnm\on Resourc
[<I Ve I [2]
- m alo m®
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Editors

+ An editor for a resource opens when you double-click on a
resource

+ The type of editor depends on the type of the resource
+ .c files are opened with the C/C++ editor
+ Some editors do not just edit text

+ When an editor opens on a resource, it stays open across
different perspectives

+ An active editor contains menus and toolbars specific to that
editor

+ When you change a resource, an asterisk on the editor’s title
bar indicates unsaved changes

/

Lo *MyCproject.c 22
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Source Code Editors

A source code editor is @ | linear_function.c =n
Spec.lal type Of ed|t0r for ! :IFieturr.f- fix) =3.0% + 2.0
manIPUIatlng source doﬁh'l.e evaluate(double x)
code L
2 add semicolon to end of next line

Lgnggage features are  ...gomblay.=3.0% +.2.8 s
highlighted s §
Marker bars for showing

+ Breakpoints —_—

+ Errors/warnings

+ Tasks

Location bar for
navigating to interesting
features
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Preferences

+ Preferences provide a way for you to
customize your Workbench
+ By selecting Window b Preferences... or
Eclipse »Preferences...
+ Examples of preference settings
+ Use Emacs bindings for editor keys
+ Modify editor folding defaults
+E.g., fold all macro definitions
+ Associate file types with file extensions
+E.g., *.f03 with the Fortran editor
+ Toggle automatic builds
+ Change key sequence shortcuts
+E.g., Ctrl+/ for Comment
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Access help —
Ed Help - Eclipse SDK
+ Help 4 Help Contents Search: Search scope: All topics
+ Help »Search Contents & C | R e o]
. @ lava Development User Guide . -
H elp Conte nts pr0V|deS “ Platform Plug-in Developer Guid
detailed help on different gJDT Plug-in Developer Guide | Using the Eclipse help system |
H © Plug-in Devel it Envi
EC| | pse featu res [ PTupg :‘ar:r; ?::E"ph:f:r:"me Browse topics in the Contents framg (B on
Search allows you to 7 it arguge el 5 oo s [
search for help locally, or  Clcrr Develapment Use Guide| 1o 1" 18 MEIO ST 0PI
using Google or the Eclipse Searching
Web S|te To quickly locate topics on a particular
- subject in the documszntation, enter a query in
Dynamic Help shows help the Search field. Use the Search frame (%) to
related to the current e L
context (perspective, view, | - ]| sechons you are inteasted in l
etc.) N v =
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Creating A Simple Application

+ Outline:
+ Create a C Project
+ Add files
+ Source files (ending in .c)
+ A makefile is automatically created
+ Build application
+ Done automatically
+ Debug application
+ Create a Debug Configuration
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CDT Projects

+ A Project contains the resources of an
application

+ Projects and their resources are visible in
Project Explorer view

+ Some resources are “smart”

+ Binaries - collects all project executables together

+ Includes - shows all included files, including system
files

+ Archives - collects all project libraries together

Module 3 SC 2007 3-21
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Project Types

+ Project Type is very important
+ Determines how the project will be built
+ Selects the toolchain used to build the project
+ Defines the resulting object

+ There are two main types of projects
+ Automatic makefile generation
+ Executable - an ordinary executable binary

+ Shared Library - a shared library that can be
dynamically loaded

+ Static Library - a static library that can be linked into
an application executable
+ Externally supplied makefiles

+ Makefile project - builds anything the makefile
specifies
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Creating a C Project

Make sure the C/C++ Civ B0 o | [m | B | @G> &v [ G~
Perspective is selected
Choose File» New»C Project = G|

or select drop down next to

C Project <>

New Project button then Create C project of selcted type
C Project
Give it a name: e.g. Zproject Pz

Use default location

Select a project type from the
list of Project types —

(defa ult is OK) I Project types: Toolchain:
. # (= Executable Cyawin GCC
Click Next > & Shored Lbvary

= Static Library
(= Makefile project

Show project types and toalchains only if they are supported on the platform

@ Next = ” Finish H Cancel ]
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Selecting Configurations

A Configuration allows you to
customize the project for deployment
on a particular platform

By default, CDT will create Debug and
Release configurations

You can choose which configuration to
use when launching the application
You also have the chance to manually
set project properties by, clicking on
Advanced Settings

Select Finish to complete project
creation

Module 3 SC 2007

Select Configurations —

Select platforms and configurations you wish to deploy on

Project type: Executable
Tool-chains: Linux GCC
Configurations

[¥]4% Debug Select all
42 Release
Deselect all

Advanced seftings...

Use "Advanced settings" button to edit project's properties.

Additional configurations can be added after project creation.
Use "Manage configurations buttons either on toolbar or on property pa

<Back | Next> \| Einish H Cancel

Adding Resources

Resources can be added to a seleat

Import resources from the |ocal file system into an existing project. E - 5

project by:
+ Creating new resources

mport

Select an impaort source:

+ Importing existing resources o

ype filter text

from another location
We will import existing files
from file system
Right-click on project, select
Import...

Open the General folder and
select File System

Click Next >

(= General
I, Archive File
o2 Breakpoints
[ Existing Projects into Workspace
(), File System
=L preferences
[N
= ovs
(= Plug-in Development
(= Team
(= Other

Module 3 SC 2007
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Importing Resources

Click Browse... o
Navigate to and select the rieqsem
Samples folder On the Import resources from the local file system.
tutorial CD From directory: Volumes/TutorialCD/samples
Click on the samples ———= . ]
folder

Select check box next to
linear_function.c and

testz.c
Click Finish

mport

[ linear_function.c
M (9 testzc
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Outline View

+ WO rkb e n c h n OW = C/C++ - Iprojectftestz.c - Eclipse SDK g@
S h OWS p ro J' e Ct fl I es Fie Edit Refactor Navigate Search Project Run indow Help

G iE-E- G 5 50 0 (&5 E[Ro§ea
. P
+ DOUbIe CI ICk on [t projectexplorer 57 = 0| [d] testzc 5 [ Inear_function.c = O|[82 outine &\ @ vakeT | = O

testz.c source file = - e B T

5 & Zorojest U stdioh
|n the Pro'ect @ (g} Indudes X o zbh
J - [ linear_function.c G R L G LR ++ evaluate(double) : double
© g testre double myFn (double x): +4 myFn(dauble) : double
Explorer to open __~ ) o mantt, D) st
int main(int arge, chars argw 5 e,

C editor —

+ Outline view is
shown for file in e N

return 0

editor ' -

[£: problems | V% Tasks | Bl consle 53 . E properties B Gl
C-Buid [Zproject]

Tintf("A sample program”):
x = x + evaluate(x);
X=X + myFn (x)

Module 3 SC 2007 3-27

14



Fix Error in File

+ Build project: select build icon on toolbar: -
+ Project fails to build
+ Note red icon on filename

+ Click on Problems View tab

+ Fix error in linear_function.c

+ Double-click on the file in the C/C++ Projects view
to open an editor

+ Save file and rebuild project
+ File»Save (or Ctrl-S)
+ Select the build icon on the toolbar. %-

+ Look at console view to see build progress
+ There is still another error

Module 3 SC 2007 3-28

Project Properties

+ To fix the next error, the required library must
be added to the build process

+ This is done by editing the Linker tool
settings in the C/C++ Build properties for
the project

+ Right-click on the project and select
Properties menu item

+ Select the C/C++ Build item
Under that, select the Settings item

Module 3 SC 2007 3-29
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Adding A Library

From the Tool Settings tab: e
+ Windows Cygwin select ‘ } | sertines &
Cygwin C Linker»Libraries e Confiuration: [Debug ) [Manage conigurations] |
+ LinUX/MaC select GCC C \ ¥ Cfc++ Buid [:Tool settings | #Build steps | Build artifact | [xBinary parsers | & Error parsers
Linker»Libraries o

Click on *+’ icon next to e
Libraries (-I) to add library = - Debuaan
Enter 'z’ in the dialog box and

¥ ® GCC C Linker

select OK e s & General Seyeatnt 8
Select OK to close the Project
Properties
Rebuild project; there should :
be no errors [ — s
[ ok |[ cancel |
Module 3 SC 2007 3-30

Launch Configuration

+ A Launch Configuration is needed to run or
debug an application

+ This contains all the information associated
with the execution
+ Command-line arguments
+ Environment variables
+ Debugger options
+ Configuration to launch

+ All this information is remembered to make
re-launching the application simple

Module 3 SC 2007 3-31

16



A Debug Launch Configuration

+ Select Run»Open yrom
Debug Dialog... ’&

i

+ Select C/C++ Local b @ %[ E Name: [Zoroect ‘
Application ‘ )| Eman - Arguments BS Environment | 35 Debugger & Source | =1 Common

[€] C/C++ Attach to L

+ Click the New Launch | - ccis wcaiapice sroiect

Configuration button | FEEEEESEE  zooiec | growse.. |
. [£] C/C++ Postmorten C/C++ Application:
+ Everything should be © eclpse pplaton | pepugzproect | Search project - [ amwse.. |
. il Java Applet
already configured for = Java Applcation
) Connect process input output to a terminal.
the launch e lunit
35 Junit Plug-in Test
+ Click the Debug buttonsw @ 056 framework

el Application

to launch %, Remors
+ Select Yes to confirm

switching to the Debug | .. nanesizoran

Perspective after

launching

Apply || Revert |

@ Debug

+If cygwin (Windows) gives source path lookup error, see next slide
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Windows Cygwin debugging with CDT

From http://wiki.eclipse.org/CDT/User/FAQ
- look under Debugging:

I'm using cygwin and when launching the debugger, it complains
that it can't find the source file

+ You must provide a mapping from /cygdrive/c to c:\ (or whatever your drive

letter is).
+ To do this,
+ From the editor error page, select the "Edit Source Lookup Path..." button and
select the "Add..." button
+ Or, in the eclipse IDE, go to menu Window -> Preferences -> C/C++ ->
Debug-> Common Source Lookup Path -> Add.
From the list of lookup containers, choose Path Mapping and OK. You get a New
Mapping in the list.
+ Select the mapping and then Edit. In the Modify the path mappings dialog,
select Add, and then enter:
+ /cygdrive/c as the compilation path and
+ c:\ as the local file system path.
+ Select OK, OK, OK to finish the dialogs.
+ Terminate the debug session and restart; it should find your source files now.
+ This setting will apply to any debug sessions launched from this workspace.
+ You can also modify the settings in each individual launch configuration.
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Debug Perspective

Controls for
resuming, stepping, <
terminating, etc.
Debug view shows
stack frames and —>
threads

Source view shows
current line marker
and breakpoints >
Variables view
shows values of local
variables

Console shows ——

program output

© Debug - Zproject/testz.c - Eclipse SDK

Fle Edit Refactor Navigate Search Project Run Window Help

© o> 3 i e % B8 §
~ €] Zproject [C/C++ Local Application] Name Value
~ & gdb/mi (9/23/07 10:41 AM) (Suspended) =% -0.9575252538005797

< 4 Thread [0] (Suspended) »f 0x00579ff4

& [#5Debug| Ec/cH++ &java

o @ | B Ov Qv O |® B ey
:m\ﬂ =0 [w-Variables 52 % Breakpoints it Registers =\ Modules

+1 gdb (9/23/07 10:41 AM)

¢ linear_function.c l¢| testz.c 58 = B8 g outline 52

Zproject [C/C++ Local Application] homejgreg/runtime-workspace2/Zproject/Debug/Zproject (9/23/07 10:41 AM)

¢ -
doublle x; 2 e R e
Printf("A s u stdoh
fg
+ myFn(x); o zlibh
++ evaluate(double) : double|
gzFile f = gzopen(*xxx*, *r);
erlose(f); & myF(double) : double
) return ©; © main(int, char#{]) : int
[~ o myFn(double) : double v
o D @ D)
B Console 52 2 Tasks| [2. Problems| O Memory e N

Module 3
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Debugging (1)

+ Set a breakpoint by double-clicking on the left

vertical bar i
line
+ To continue

n the editor at x=x + myFn(x)

running, click on Resume button

+ Click on Step Into button to enter nyFn()

Resume

;

Step Into

spend Step Over
l Terminate lStep Return

L/

o I

IS A VH

Module 3

SC 2007 3-35
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+ Examine variables in Variables view
+ Clicking on a variable will display its value

+ Select a different stack frame in the Debug
view if desired

+ Back in the top stack frame, click on the Step
Return button

+ Finish by clicking on the Resume or
Terminate button

Module 3 SC 2007 3-36
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Module 4: Advanced Development

+ Objective

+ Create and build a Standard Make Project from
source files in CVS

+ Contents
+ Version control
+ Standard Make Projects
+ C/C++ Projects
+ Task Tags, Bookmarks
+ Refactoring
+ Searching

Module 4 SC 2007 4-0

Version Control (CVS)

+ Version control provided through the Project
Explorer View, in the Team context menu
+ Provides familiar actions:
+ Commit...
+ Update...
+ Also less used tasks:
+ Create/Apply Patch...
+ Tag as Version
+ Branch...
+ Merge...
+ Add to .cvsignore...
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+ 4+ ++

Add Repository Location

- £ Add CVS Repositol
Select Window » Open Add a new CVS Repository
Perspective » other. . Add a new CVS Repository to the CVS Repositories view lcvs]
Select CVS Repository Exploring Location ‘
then OK Host: N.NN.N ‘v
. . . . . Repository path: | home/YOUR_USERNAME v
Right-click in CVS Repositories e
View, then select User:  [YOUR_USERNAME ~)
New » Repository Location... e (O ‘
Set Host to the IP address of R p—
remote maChIne (@ Use default port
Set Repository path to | teeport:
/ hone/ YOUR_USERNAVE e emecton et
Fill in Username and Password b Saved pacsuort v stved o Yo computer 8 et
Set Connection type to extssh I —
Check Save password
Select Finish [ gmsn | [ cancel |
Module 4 SC 2007 4-2

Checkout Project Code

+ Open the repository, then open HEAD
+ Right-click on MyCVSProject»Check out As...

+ Make sure “Check out as a project configured using
the New Project Wizard” is selected

+ Select Finish
+ Select C»C project
+ Select Next>
+ Enter Project name (MyCVSProject) and location
+ Can put project in location other than workspace
+ Under Project Types, select Makefile project
+ Ensures that CDT will use existing makefiles
+ Select Finish
+ Switch to the C/C++ Perspective
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About Makefiles and autoconf

+ Can create project Makefiles with the Makefile
Editor
+ Syntax highlighting and Outline view

+ autoconf often used to create Makefiles for
open source projects
+ Must refresh after running configure script

+ Refresh whenever file system is modified
outside of Eclipse

Module 4 SC 2007 4-4

Configuring Project Code

+ Most projects will now have to be configured
+ This is project dependent
+ Do whatever is needed, e.qg.
+ Run ./configure from a terminal window
+ Create external command to run configure
+ This should create/configure all project Makefiles

+ Refresh the project to sync with file system
+ Right-click on project and select Refresh
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Building

=] ‘@‘ [25CVS Repo...

+ Create a Make Target

na med ‘a”’ = 8 | &= outline | @ Make Targets 52 =a
+ Right-click on the r = O
:

+ Select Add Make A
arged ame; /—
Target Z
Make Target

+ Select Create Make Target: = Go Into
Build command : -

+ Double click on new f———

make target to initiate suldcommand [0
the bU”d Build Setting

] stop on first build error.

project in Make TR
- < MIMPIPO | g ke Taget
Targets View /

Run all project builders,

Module 4 SC 2007 4-6

Create a Task Tag

€] Mysampleproject.c 53 =0

+ Task tags are identifiers in
C/C++ comments
+ TODO is a built-in task tag
+ The build locates task tags
during compilation
+ View task tags in Tasks View
+ If it's not shown, Window
» Show View » Other...
€] u (2]
Open General and select o Do =)

Fiter matched

Tasks .
+ Configure your own task tag
in Window » Preferences
+ Under C/C++, select Task
Tags
Module 4 SC 2007 4-7
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Create a Bookmark

+ A bookmark reminds you of useful information

+ Add a bookmark by right-clicking in the gray
border on left side of editor and select Add
Bookmark...

+ Provide a bookmark name, then select OK

+ View bookmarks by selecting Window» Show
View» Other...

+ Open General and select Bookmarks

Module 4 SC 2007 4-8

Commit Changes

+ Select the Project Explorer view
+ Notice the >’ before the file name(s)
+ Indicates a file has been modified
+ Right-click on the project
+ Select Team»Synchronize With Repository
+ Confirm switch to perspective if asked
+ Expand the project folder
+ Double-click on a file name to view differences
+ Commit changes

+ Right-click on the file name, select Commit... and
enter a comment

+ Select Finish
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Refactoring

= C/C++ - MyCproject/src/MyCproject.
File Edit | Refactor _Mavigate Search Proje

o, Renam. Al4SHiFR o
»

+ Rename
+ Select C/C++ Perspective {
+ Open a source file
+ Click in editor view on declaration of a variable
+ Select menu item Refactor»Rename

+ Or use context menu

+ Change variable name
+ Notice that change is semantic not textual

Module 4 SC 2007 4-10

Searching

+ Language-based searching

+ Search for Language Elements

+ e.g., C++ Class, Function, Method, Variable, Field,
Namespace

+ Limit search to Declarations, Definitions,
References

+ Type navigation
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Type Navigation

Open Element
Choose an element @ = any character, * = any string)
dope_vec

Visible element types:

+ Choose C/C++ Perspective T R T ——

V' (0 Enumeration V0 Unien v = Function V& Variable

+ Select Navigate»Open

Element...

T dope_vecod_Alpha N
© dope_vecod_Alpha_

dope_vecOd_PGI

@ dope_vecOd_PGl_

& (

+ Enter a name in text box T sopevecrs 7

+ All matching types are

) dope_vecld_PGI_
dope_vecld_SUNWspro
dope_vec2d_PGI

) dope_vec2d_PGI_ ]
T _done vec2d SUNWsnrn

@&

Qualified name and location:

T (global) dope_vec0d_Alpha - /chasm/include/compilers/Alpha_dv.h
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Module 5: PTP and Parallel
Language Development Tools

+ Objective
+ Learn to develop and run a parallel program
+ Contents

+ Learn to use PTP’s Parallel Language Development
Tools

+ Learn to launch a parallel job and view it via the PTP
Runtime Perspective

Module 5 SC 2007 5-0

Parallel Tools Platform (PTP)

+ The Parallel Tools Platform aims to provide a
highly integrated environment specifically
designed for parallel application development

+ Features include:

+ An integrated development environment (IDE) that
supports a wide range of parallel architectures and
runtime systems

+ A scalable parallel debugger

+ Parallel programming tools (MPI/OpenMP)

+ Support for the integration of parallel tools

+ An environment that simplifies the end-user
interaction with parallel systems

+ http://www.eclipse.org/ptp
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Parallel Language Development
Tools (1)

4+ Features

+ Analysis of C and C++ code to determine the location
of MPI and OpenMP Artifacts (Fortran planned)

+ "Artifact View" indicates locations of Artifacts found in
source code

+ Navigation to source code location of artifacts
+ Content assist via ctrl+space (“completion”)
+ Hover help

+ Reference information about the MPI and OpenMP calls
via Dynamic Help

Module 5 SC 2007 5-2

Parallel Language Development
Tools (2)

+ More PLDT features:

+ New project wizard automatically configures
managed build projects for MPI & OpenMP

+ OpenMP problems view of common errors

+ OpenMP “show #pragma region” action

+ OpenMP “show concurrency” action

+ MPI Barrier analysis - detects potential deadlocks
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PLDT Preferences

+ To use the PTP Parallel Language Development Tools feature for
MPI development, you need to

0
+ Specify the MPI include path ,, PI
+ Specify the MPI build command b Generl WP include paths
+ Open ::2;‘2++ Juslocalinclude
Window » Preferences... -
+ Open the PTP item S —

~ TP

+ Open the Parallel Language | ™77 " ueisidcomnoni [moce
Development Tools item

» I
/ OpenMP
+ Select MPI1 Resource Managers

Viewer

+ Select New... to add MPI b Rinebug
include path —_—
+ If running OpenMP, add its

include file location here too
(we will cover that later)

Module 5 SC 2007 5-4

Turn Autobuild Off

+ Because we assume you don’t have MPI
installed on your local machine, turn off auto-
build to avoid errors

+ Select Project » Build Automatically
+ It should now not be checked.
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MPI Managed Build Project (1)

Create a new MPI project o —
+ File>New»C Project S ss—
+ Name the project—’_____,___. Proget name: MyrieloProect \
‘MyHelloProject’ i e
. Location; [/nomeftiobitis/ews/runtime-sc07MyHelloProject || _Browse... |
+ Under Project types‘( under i o
Executable, seIec_t MPI — | e o
Hello World C Project” and © UPI PiC Prject
hit Next AN
+ On Basic Settings page, e
fill in information for your Miipolie
new project (Author name  Shared Lirary
etc.) and hit Next .
@ Back Nex> |[ Fmsh || Cancel
Module 5 SC 2007 5-6

MPI Managed

On the MPI Project Settings
wizard page, make sure Add
MPI project settings to this
project is checked.

Change default paths, etc. if
necessary (they are probgbl/
OK)

Hit Finish*.

*If you instead hit Next, the
on the Select Configurations

page, you can alter Project
settings. Hit Finish.

Build Project (2)

MPI Project Settings

Select the MPI include path, lib name, library search path, and build
command information to be automatically be added to the new project.

L 7] Add MPI project settings to this project!
Use default information

/ \nclude path

Module 5 SC?2

[rustiocainciude |[Browse...|
Library name: |mt>| ‘
Library search path: | justflocalib Hsmwsu |
MPI compile command: | mpicc \
MPI link command; | mpicc \
@ < Back ne> || Emsh || cance

007 5-7




Changing the Project Properties
Manually

+ If you wish to change the Zoacriceioinecrec )
way your MPI program is | " s ‘ H - ‘
bUIl t: vzj‘c‘f;um Configuration: | Debug || Manage configurations

+ Open the project propertipe? DISCOLE) RIS 5 oot serings| | Bl stegs] | Bud antac o Bian pusers o pases
+ Select C/C++ Build/v = '(A:;"::Xw.au —
+ Select Settings I
+ Select GCC C Compiler—~"7+ cc- e Sopmaaion
+ Change the command :'Te(:mf:":&: SVDVZTZ?”“;ZQ e s
+ Select GCC C Linkcl Run/Debug Settings v\ihng:i\:::ms fine pattem: ${COMMAND] ${FLAGS] ${OUT|
+ Change the command Z:fb‘
+ It’s also possible to change Bhiscelareus
compiler?linker argumengs g 53%?::1:3? s

+ The MPI Project wizard set -
these for you, so it isn't
necessary to change them. | @

Note: compiler/linker names will vary by platform.
Module 5 SC 2007 5-8

Content Assist

+ Open the C Editor by double-clicking on the
“MyHelloProject.c” source file, which may be in the ‘src
folder in your new MyHelloProject.

+ Type an incomplete MPI function name e.g. "MPI_Ini"
into the editor, and hit ctrl-space

+ Select desired com fOn value with cursor or mouse

Initializes MPL.

l4

MPI_Inil
® MPI_Init{int =, char ***) int
© £ind o Mpp_nit_thread(nt =, char ===, int, int *) int
MPI_Com e MPI_Initialized(int =) int

+ Hover over the MPI Artifact

/* find out process rank */
identified in the source file to MPI Colm_yank (MPI_COMM WORLD, &my_rank) :
see additional information PrototvBeSh NPT, Com_rarkHP1_Comm, nt )
. Description:
about that function call, for Rt o vark of the ol taskin the group associated with a communicator.
Press 'F2 for focus)

example
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Context Sensitive Help

Click mouse, then press
help key when the cursor is
within a function name

+ Windows: F1 key

+ Linux: ctrl-F1 key

+ MacOS X: Help key or

Help» Dynamic Help

A help view appears
(Related Topics) which
shows additional
information
Click on the function name
to see more information
Move the help view within
your Eclipse workbench, if
you like, by dragging its
title tab
Module 5

SC 2007

-4
MPT N
MPT_Gomm rBok ()
Name: MPI_Comm_rank
Protoype:int MPI_Comm_rank(MPI_Comm, int %)
nDescription:

COMM WORLD, &my_rank

Help £2

Related Topics

~ About

Click below to see help,

See also:

Bl Editor view click hera
B int MPI_Comm_raﬁ;_Comm. int =)

&

=g

-

Help £2

d|lwd| e

MPI Comm rank

int MPI Comm_vark (MBI Comm, int <)

Retumns the rank of the local
task in the group associated
with a communicator.

Enter the following

Ele Edit Refactor Navigate Seach Project Run Window Help

before the O A A A o [ BRG] S Repo.. 83w

MPI _Final i ze: - =) outo =\ G M Tage] =5
MPI _B e OO

Type ctrl-space g o s sl | o e

Select an MPI_Barrier W e, o,

from the list

After the “(*, enter

MPI _COW WORLD o

(use ctrl-space to help ’ — o —

type if you like)

S Ny e ooyt

Resulting line: i
MPI_Barrier( z .
|VP| _m_meD) ’ u:x:zyz:Ject.u” " /sre/MyHelloProject .c”
Save file e S
Build is not necessary |o—w
for this sample « T———
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MPI Artifacts

Select source file; Run
analysis by clicking on
drop-down menu next
to the analysis button
and selecting Show
MPI Artifacts

Markers indicate the
location of artifacts in
editor

In MPI Artifact View
sort by any column
(click on col. heading™
Navigate to source code
line by double-clicking
on the artifact

Run the analysis on
another file and its
markers will be added
to the view

Eile Edt R

Ev G Ev G

start up MPI

< Bsrc /
b (Debug

find out

find out

C/C++ - MyMPIproject/sic/MyMPIpro ect.c - Eclipse SDK'
o Navigite Search Project Run Window Help

& ©v |35y O Qv

MPL Tnit (darge, dargy);
rank
(MPI_COMM_WORLD, &my_rank);

ber of pr s
MPL. Comn,_size(MPT_COMM_WORLD, &nun_procs);

3 show MPI Artifacts
9 Show OpenMP Artifacts
T#Fi MPL Barrier Analysis

O |® ¥ |

Biv ilv
(5 Project Explorer &2 =0 | MyMPlproject.c &2 =0 Souwi 2 =0
= 1nt Source; A S
= int dest = 0; Hllmwwe
7 & MyMPlproject int tag = 05 o mpih
> g q ch: message[100]; =
5 Binaries WPI_Status status ; - .
b ilincludes o stingh

o calc_pi(nt, int)
Il

© mainint, char'

< J 0]

Remove markers via %

I []

Tasks & Console (2. Problems ¥ MPI Artifact View &3 1 8% =0O
™ [ avtitact [ Fitename [ ineNo [constet ]
» MPI_Bcast MyMPlproject.c 2 Function Call
P MPI_Reduce MyMPlproject.c 37 Function Call
» MPLInit MyMPlproject.c 57 Function Call
W MPI_Comm_size MyMPlproject.c 63 Function Call
» MPI_Send MyMPlproject.c 0 Function Call
P MPI_Recv MyMPlproject.c s Function Call
» MPI_Bcast MyMPlproject.c 8 Function Call
> MPI_Finalize MyMPlproject.c o Function Call

(K ——
O Wiitable SmartInsert | 60:18

Module 5 SC 2007 5-12
MPI Barrier Analysis
o e e T B e PR B —
o a e CRNcH $-0 Q- i®s O BEoc] Vel’lfy barrier
B ottt 7 O B o[ttt [ aarere 510 synchronization in

en
Gest, ctag, MPI_COMM WORLD)
MBI Barriex (MPT_COMM WORLD) ;

Module 5

SC 2007

C/MPI programs
Interprocedural static
analysis outputs:

+For verified programs,
lists barrier statements
that synchronize
together (match)

+ For synchronization
errors, reports counter
example that illustrates
and explains the error.




MPI Barrier Analysis - views

i MP1 Barriers §7 = B [[£: Problems | ¥ Tasks | Bl Console | % Barrier Matches &3 = O | [ Barrier Errors &1 i =08

i i~

Barrier Matching Set Function
=144 Error main
-4 Path 1(1barrier(s))
T#4) Poth 2 (0 barrier (s))
-84 Error main
& -#44i Loop (dynamic number of barriers)

Function Barrier Matching Set | Function Filenzme LineNo [+

W2 main W0 Barrier 1(2)  Barrier MyBarrier.c L]
WA main i Barrier 1 Barrier MyBarrier.c 8
Wh  main Ui Barrier 3 main MyBarrier.c 41
WA main =-Uh Barrier 2(1)  main MyBarrier.c 31
Wl main i Barrier 2 main MyBarrier.c 31
WA Barrier -9 Barrier 3(2)  main MyBarrier.c 4

U4l Barrier 1 Barrier MyBarrier.c 8

O Barrier 3 main MyBarrier.c 41

Wi Barrier 4(0)  main MyBarrier.c 57 I
@ YA Barrier 5 (1) main MyBarrier.c 62 -
< R [ > >
s @0 HE%

~

/ N\
MPI Barriers view Barrier Matches view Barrier Errors view
Simply lists the Sﬁ?tléﬂstssg?r?; it:aat If there are errors, a
barriers barrier set - all counter-example
Like MPI Artifacts view, processes must go Sh'OWS paths with
double-click to through a barrier in mismatched number
navigate to source the set to prevent a of barriers

code line (all 3 views)  deadlock
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MPI Barrier Analysis - example

5. Comment out one of the
barriers and rerun
1. Create a sample program in an analysis. Note barrier

MPI project that uses mismatch and thus error.
barrier 1. c on the TutorialCD

in ‘samples’ folder

To run MPI Barrier Analysis:

6. Now put a barrierin a
function call, to test

2. Select the file (or Project) in interprocedural analysis
the Projects view features. The function

call can even be in

3. Run Barrier Analysis via the .
another source file.

menu .
e 7. Rerun analysis and view

#» Show OpenMP Artifacts errors.

W21 MPT Barrier Anclysis  <emm—t——

4. See the output views. No
errors! Examine matching sets.
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OpenMP Managed Build Project

Create a new OpenMP project — [rom —

+ File»New > C Project E—

+ Name the project e.g. = Mopertipriec ‘
‘MyOpenMPproject’ i ErrrrTT—— .

+ Select OpenMP Hello

+ Select Next, then fill in\ ]
other info like MPI project o |

SR

+ If you haven't set up \ R
OpenMP preferences e.g.

include file location, you'll be
reminded

Project types

< Back Next> |[ Fmish ][ Cancal
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Setting OpenMP Special
Build Options

= Properties for MyOpenMPproject @

+ OpenMP typically requires [peswe: e

special compiler options. ST
+ Open the project
) Tool settings Buld steps Buid artifact | [ Binary parsers | @

properties //v

+ Select C/C++ Buily el R
+ Select Settings T g =1
+ Select C Compiler Eb

+In Miscellaneous, i k
add option(s). o

(5 shared Library 5¢ [

Other flags | - -fimessage-ength =0 -fopenmp
[Jverbose ()
[15upport ANST programs (-ansi)

»

+ This isn’t necessary for PLDT OpenMP analysis, only for
building real executable OpenMP programs ©
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+ Select source file,
folder, or project

+ Run analysis

O

3 show MPI Artifacts

B Show OpenP Artifacts <t

T#Fi MPL Barrier Analysis

+ See artifacts
OpenMP view

Module 5

Show OpenMP Artifacts

= C/C++ - MyOpenMPproject/src/MyOpenMPpraject.c - Eclipse SDK - Criews\runtime-temp [B=X]
File Edit Refactor Navigate Search Project Run Window Help
i@ & ETETEr FrO- QO [ %5 pebug |G cjc++ |8 Java
» S wn NG
(2 project Explrer = B[ 12 MyopenPpraject.c 1 S Blfou B 2 =8
A= RS (it o (R
= &5 MyMPIproject DR (e oriaAn u sdoh
-5 Incudes - . 3 sting.n
s » i (omp_in parallel())( 4 sdbh
W, G & Debuo rinte ("cTuer) ; retnh
=555 MyOpenMPproject ) & ; 2 openmph
- Incudes L emery o ohe _— ©  man(nt, char
TR B s x = (double +) malloo( (size t) ( arraySize * sizeof(dor
VopEnHprolect.c ¥ = (double *) malloc( (size_t) ( arraySize * sizeof(dot
(= Debug -
CE + Hers's the e for-lof (=
: a P #pragua omp parallel for
for (1= 0: 1< arraySize; i+ )
y[i] = sin( exp( cos( - exp( sin(x[i]) } ) ) ):
return 0:
1
v
< E3 < >
in e Probene e o oo cimemiiimiospeetrel 3. Oper!P xtifact View =5
iR
OpenMP Artifact Flename LineNo. Col
(" omp_in_paralll MyOpeniPproject.c % Fur
W zpragma omp paralel for MyOpenhPproject.c 34 Opy
< >
=

SC 2007

analysis

pragma in

artifact view

Module 5

Right click on :

Select Show
#pragma region

Show Pragma Region

Run OpenMP

E jpenMP pragma th
’ #pragma omp parallel for
for ( i = 0:; i < arraySize: i++ )

¥[i]l = sin({ exp( cos( — exp( sin(x[il) ) ) ) ):
H
return 07
H

<]

[34 Problems ~Z, Tasks | &l Console

OpenMP Artifact Filename

MyOpenMPproject.c

Debug | & OpenMP Problems * OpenMP Artifact View &2

LineNa
26

arallel
B ect.c

Show pragma region

See highlighted region in C editor

SC 2007

34

10



Show Concurrency

+

Insert the following
#pragma...

Save the file

+ 4+ 4+ +

on the highlighted
statement, and click
Show concurrency

Re-run OpenMP analysis
Select this statement
Select the context menu

[c] testregione 23 . [€] cfg.c | [g] IncludeExample.c | [£] MacroExample.c i

#include <ztdio.h>

{

)

(5]

+ Other statements will be

highlighted in yeIIow

statements can execute

concurrently to the
selected statement

Module 5

int findme (int a)

int £, c,d;

#pragma omp parallel
«

At
for(int i=0; i<a; it++) {

eb;
#pragma owp herriey
iy

if la==f)
{if la==c] a=f:}

SC 2007 5-20

Show OpenMP Problems

+ After “"Show OpenMP
artifacts” analysis:

+ Select OpenMP
problems view

+ Sample file
openMPpr obl ens. ¢
is on TutorialCD in
‘samples’ folder

Module 5

= C/C++ - MyD|

P penMPp c- [cllpvse SDK - C:\ews\runtime-temp Lo

File Edit Refactor

B4

[ project Explorer

- Includes
2-E8 sre

@
(> Debug

= w
& BN e R | B crct+ | & sava

NgtESEhP]tR Windon el

E-& -6 i/-B- i H-0-Q O 5 %5 Debug

82 7 B[lg *Myopenmporoject.c €] opentPproblems.c i =8

=R #pragma omp parallel for $==..OpepME. problem U
= &5 MyMPIproject for(3=1; 3<10: 3++) {
-5 Includes S+es
B2 src 3
4l (= Debug ¥
S5 MyOpenMPproject }

void barriercheckd ()

MyOpenMPproject.c int i, 3:
roblems

#pragma omp parallel for
for(i=0: i<3; i++) {
#pragma omp bsrrier {{ <== OpenME problem =

[ Problems [ %) Tasks | & Console | @ OpeniP problems 51§ OpenVp Artifactview| — O
i v
Re

Description
@ For directive embedded within anather parallel for or parzlel sections o
@ Barrier drective not permitted in region extent of for, ordered, sections, single, master, and ritcal  op

Writable SmartInsert | 26:5

SC 2007 5-21

11



Running a Parallel Application

+ The PTP Runtime perspective is provided for
monitoring and controlling applications

+ Some terminology

+ Resource manager - Corresponds to an instance of
a resource management system (e.g. a job
scheduler). You can have multiple resource mangers
connected to different machines.

+ Queue - A queue of pending jobs

+ Job - A parallel application

+ Machine - A parallel computer system

+ Node - Some form of computational resource

+ Process - An execution unit (may be multiple
threads of execution)

Module 5 SC 2007 5-22

PTP Runtime

€ PTP Runtime - mpitest/mpitest.c - Eclipse SDK.
Fle Edit Refactor Nevigate Search Project Run Window Help
Reso urce i~ @ | B Ov Q- | = & [§EPTP Runti..] EC/C++
. ) Resource Managers &3 =03 mpitest.c = S
managers View=—» 1 #include <npi i
#include <stdio.h>
int
| .| main(int argc, char *argv(])
i Machines % =8 int rank;
Please select amachine . ,
: : WPI_Init(Sargc, Sargy);
Machines view —» B oo et e o, sran
printf(*ni from w\n*, rank);
WPI_Finalize();
exit(0);
d d i | Node Attributes Process Info
NO e details Attribute  Value
view
& Jobs %3 =B & Console 53 [£ Problems| = Properties| & Tasks| € Ermor Log 5
. Please select ajob ~ No consoles to display at this time. 9v
Jobs vieW ——
Module 5 SC 2007 5-23
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Fle Edit Refactor Navigate Search Project Run Window Help
+ Right-click in Resource e m | %~ 0- Q=
Managers view and select OTE DT

p.

Add Resource Manager v e |

£ Machines

+ Choose the ORTE

Resou rce Manager Choose Resource Manager Type
Type Select the type of resource manager to use

=

@
X

Resource Manager Types:
LSF

+ Select Next> MPICH2

@ Next > Cancel

Module 5 SC 2007

Setting Remote System Address

ORTE Proxy Configuration
+ FS{ZLigEc:?:r\?Iiethpet‘OVIder S~—_Enterinformation to connect to an ORTE proxy server

+ Click New... to create a
new location

Remote service provider: [ RSE

:]

Proxy server location: | NN %} [ New... }
/
Enter IP address or hOSt Path to proxy executable: [,‘usrﬂu[al,’bin]ptp_urte_pmxyﬂ[ Browse }
name of the remote
machine Multiplexing Options
. £ New Connection
Select Finish 3 B Remote SSH Only System Connection
Select the proxy server Local| Pefine connection information :E]
location you just created Parent profle: um‘hm’/ ¢
if it is not visible in the O Louncl] voscrome: (i =
drOdeWI’l Connection name: [N.N.N.N ]
Description: [ ]
@ ] Verify host name :] [m
Module 5 scad ? next> |[ gnish || cancel 5-25
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+ 4+

+ 4+

@ The authenticity of host 'LOCNCHOST can't be established.

Setting

Click Browse to select the
proxy server executable

Open Root twisty

Enter your User ID and

Password when asked

Check Save user ID and

Save password

Click OK

Now navigate to and select
+ /usr/local/bin/ptp_orte_proxy

Click Yes if you see this
warning

RSA key fingerprint is

=
ORTE Proxy Configuration

Proxy Server

er information to connect to an ORTE proxy server
Remote service provider:

”

= ! ro arver exacutal

Seiect a fie

~ B Rool

Host name:  N.R.MN.N

Fassword:

‘tt:*

Proxy server location: N.N.N.N < b}
B < proxy

New...
Browse

—

1

9b:04:33:92:31:9d:4:6f:b3:F3:b

ml Cancel I

Are you sure you want to cunmuewnecmgv

5-26

Setting Local System Address

e 1

This is the address that the

proxy uses to connect to

Eclipse

ISF?Ieg(t:I yourflocal r|_1]1achine’s
address from the

dropdown ~—

Enter it manually if it's not

visible

Click Finish

Module 5

ORTE Proxy Configuration
Enter information to connect to an ORTE proxy server
Remote service provider: [ RSE s }
Proxy server location: [N.N.N‘N ¢ } [ New... }
ath to proxy executable: [,‘usrﬂu[al,’hin,ﬂptp_urte_pmxy } [ Browse }
Multiplexing O
@ None
Local address for proxy connection: IM.M.M‘M\ | ~ ]
[ Launch server manually
@ Next = } [ Finish I I Cancel I
SC 2007 5-27
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Starting the Resource Manager

+ Right click on new
resource manager and
select Start resource

manager \

+ If everything is ok, you
should see the resource
manager change to green

+ If something goes wrong,
it will change to red

'+ ResoMrce Managers
(@ ORTE@N.N.N.N (ORTE)

Module 5

(+) Resource Managers £
@ ORTE@N.N.N. N2
Add Resource Manager...
Remove Resource Manager

\ Edit Resource Manager
888 Machines 2

a8 e Start Resource Manager
Please select a mac

Resource Managers &2

I» (3) ORTE@N.N.N.N {ORTE)

SC 2007 5-28

System Monitoring

+ Machine status shown in
Machines view

+ Node status also shown
Machines view

+ Hover over node to see
node name

+ Double-click on node to __|

show attributes

Module 5

(¥) Resource Managers 53 =8

» (3 ORTE@N.N.N.N (ORTE)

888 Machines 2 &, v G =8

ORTE@N.N.N.N: localhost.localdomain - Root [64]

EE localhost localdomain o [ [ o o
O [ ) )
20 [ [ [
30 () )
40 [ [ I ) ) O
50 [ I S S
60 [ I I I
Node Attributes Process Info
Attribute Value
Node Number 0
Node State up D
SC 2007 5-29
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Getting Program Source

Switch to the CVS Repository Exploring perspective
Open the repository you created in module 4
Open HEAD

Right click on MyMPIProject and select Check Out
(not Check Out As...)

+ Click Yes to confirm overwrite (if you already have a
project with this name)

+ Switch to the C/C++ perspective to check the project is
in your workspace

+ Switch back to the PTP Runtime perspective

+ 4+ + 4+

Module 5 SC 2007 5-30

Create a Launch Configuration

& Run
Create, manage, and run configurations —

Create a configuration to launch a parallel application in Parallel Perspective &

Open the run configuration =
. M S Configure launch settings from this dialo
dial og Run»O pen Run ( == 9- srsss the New nugmm to create agmnﬁgurat\on of the selected type

H - - Press the 'Duplicate’ button to copy the selected configuration.
D 1a I Og s :ES;; f;:h‘c:i:?:m % - Press the 'Delete’ button to remove the selected configuration.
Se | ect Pa ra I I el 1 java Applet % - Press the 'Filter' button to configure filtering options
- . 31 Java Application - Edit or view an existing configuration by selecting it.
Application o e
J Junit Plug-in Test Configure launch perspective settings from the Perspectives preference page.
Select the New button & 050l ramenork

[ P

Filter matched 8 of 8 items

| cose |

Module 5 SC 2007 5-31
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Complete the Main Tab

+ In Main tab, select the
resource manager you

& Run

Want tO use tO |aunCh ~ @ Application program is not specified

this job
+ Then click the Browse
button to select the
Parallel Project
+ Next, click the Browse
button to find the
Application program
(executable) on the
remote machine
+ Open My Home
+ Open MyMPIProject
+ Select MPIProgram
+ Click OK

Module 5

Create, manage, and run configurations P
v
N 8 3~ Name: [MyMPIProject ]
[type filter teX ! ) Main &5 Resources| % Debugger| ®= Arguments| & Source| 7§ Environment| ™,
[E] C/C++ Local Applica’
© Eclipse Application Resource Manager: | ORTE@N.N.N.N < |
EINErCE:
71 Java Application Parallel Project
Ju Junit [MyMPIProject || prowse |
i Junit Plug-in Test Application program:
Easoy S
> [ — || Browse |
< £ Parallel Application
: MyMPIProject
€2 T |
Filter matched 9 of 10 items
| close |

Complete the Resources Tab

+ Select Resources tab
+ Enter the number of

processes for this job ~<

+ 4 is a good number for
this tutorial
+ Other resource managers
may provide additional
resources to select (e.g.
network interface, run
duration, etc.)

Module 5

£ Run

Create, manage, and run configurations

ugger]: No debugger available

[type filt

[E]C/C++ Local Applicatio
® Eclipse Application

3 Java Applet

[ Java Application

Ju JUnit

Ji7 Junit Plug-in Test

4 0SGi Framework

Launch Attributes’

Number of Processes:

< & Parallel Application

i MyMPIProject

( B [
Filter matched 9 of 10 items

Apply || Revert |

| close |

SC 2007
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Complete the Debugger Tab

Select Debugger tab
Choose SDM from the
Debugger dropdown
Click on Browse and
select the debugger
executable

For the tutorial:

+ Open Root

+ Navigate to

/usr/local/bin/sdm
+ Click OK

Click on the Run button

—

& Run
Create, manage, and run configurations

Create a configuration to launch a parallel application in Parallel Perspective

0 v

Name: [ MyMPIProject

type filter text —

| Main i Resources %3 Debugger  ®- Arguments % Source Mg Environment 1

C/C++ Local Applicatio
=i c/ PP Debugger: [ SDM

i Java Applet
1 Java Application
Ju Junit

Debugger Options
Debugger Path:

3 Junit Plug-in Test [rusrocalbingsdm]

][ Browse

% 0SGi Framework
< §5 Parallel Application

i MyMPIProject

B
Filter matched 9 of 10 items

Apply Revert

Close

to launch the job

Module 5

SC 2007

5-34

Viewi 'he Run
£ PTP Runtime - MyMPIProject/testMPI.c - Eclipse SDK. =13 <
Fle Edit Refactor Navigate Search Run Project Window Help
+ D bl | k [ERNRE S A SR v Gy e ey : P Runti...| EC/C++
ou e-clic a ( Resource Managers 52 = B[4 testMPlc 1 ac
node in machines fhhelude i f> -
view to see which~ " haint o, avr i
Processes ran on e = s B
.
ORTE@sc07tutorial: localhost.] in - Root [64] MPI_Init(& , &a )
the node ﬂgﬂanlwu._l._luu\_. | MPI:C'(;VJnm_r:;ETMPI_Crg;M_WDRLD. &rank);
| printf(*hi from %d\n*, rank);
20 [ .
B TR | B R
Y T RN B
+H =
50 | Trrrrrirrlpd
overovera i o
process for tooltip
Node Attributes Process Info
opu Attribute Value ¥ job02:1
popup
Node Number 1
ode State up
D =
B Jobs %2 aQ o v =g L
+ Job and procCesSses| ouremomioio Ditions- soat i1 @ Consol [ robem [ ropert @ Tasks @ mor Lo |€ progress 5= O
H : > = job02 LR % <
Shown In JObs uis Building workspace (Finished) x [
H oK
view 1
[~
Writable Smar..sert 14:2
Module 5 SC 2007 5-35
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Viewing Program Output

€ PTP Runti

job02:1 - Eclipse SDK- ) %)
Fle Edit Navigate Search Run Project Window Help
(il B Ov Qv | |4 ey .| EC/CH++
() Resource Managers 53 =0 [gtestMPl.c B job02:1 R =n
Process details
Index: 1 Node: nodel Total: 4
PID: 21935 Job: job02
Status: EXITED
£ Machines 52 Q o o @~ =0 - Program output
ORTE@sc07tutorial: localhost Jocaldomain - Root [64] || hifrom2 Fl
-cli o 1 1 1
+ Double-click a et Teeiettar
20 [0 [ e
process to see i
process detail and EEEEEEEEEE
commm
standard output
from the process | moe s Process Info n
Attribute Value ¥ job02:1
Name nodel
Node Number 1
up
£8 Jobs R @ =0
ORTE@scO7tutorial: de Nyio! [ Consol | [2. Problem | Properti V2 Tasks @) Error Lo ¢ Progress 12 = O
X A %
s Building workspace (Finished) x
oK
O 5
o Index: 1 EXITED PID: 21935
Module 5 SC 2007 5-36

About PTP Icons

+ Open using legend icon in

Resource Manager Icons
toolbar @ STARTING
@ STARTED
@ STOPPING
s STOPPED
£~ PTP Runtime - mpitest/mpitest. - Eclipse SDK 4 SUSPENDED
. B - @ ERROR
File Edit Refactor Navigate Seagh Run Project
Machine Icons Node Icons
rﬁv S @ q‘@;v Ov %v Q“ A uP L oup & USER SHARED
DOWN 1 oown @ OTHER EXCLUSIVE
ALERT ERROR # OTHER SHARED
B ERROR 2 UNKNOWN [#/ PROCESS RUNNING
2 UNKNOWN % USER EXCLUSIVE & PROCESS TERMINATED
Jﬂb Icons: Process Icons
© PENDING + STARTING
© STARTED + RUNNING
@ RUNNING + EXITED NORMALLY
© TERMINATED | < EXITED WITH SIGNAL
@ SUSPENDED » SUSPENDED
© ERROR + ERROR
@ UNKNOWN % UNKNOWN
Module 5 SC 2007 5-37
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Module 6: Parallel Debugging

+ Objective

+ Learn the basics of debugging parallel programs with

PTP
+ Contents

+ Launching a parallel debug session
+ The PTP Debug Perspective

+ Controlling sets of processes

+ Controlling individual processes

+ Parallel Breakpoints

+ Terminating processes

Module 6

SC 2007 6-0

Launching A Debug Session

+ Use the drop-down next to

the debug button (bug | file Edit Refacfor MNavigate Search Run Project Window Help

icon) instead of run button

+ Select the MyMPIProject to
launch

+ The debug launch will use
the same number of
processes that the normal
launch used (edit the
Debug Launch
Configuration to change)

Module 6

£ PTP Runtime - job05:0 - Eclipse SDK

el O MR S @
(2) Resource Manaqe_ =g |

%5 Open Debug Dialog...
Organize Favorites...

8 Machines &2 &, o~ @ =8
ORTE@sc07tutorial: localhost.localdomain - Root [64]

E= localhost localdomain 0 [ 3 N S e

Node Attributes Process Info

Attribute  value |

SC 2007 6-1




+ Parallel Debug

view shows job
and processes

being debugged —

Debug view shows

threads and call —»

stack for individual
processes

Source view
shows a current
line marker for all
processes

£ PTP Debug - MyMP) BER
Fle Edit Refactor Navigate Search Run Project Window Help
£ o v O Qv (O = | & v 4 |#PTP Debug| B PTP Runti.. EC/CH++
#% Parallel Debug 52 = B 9 Breakpoints - Variables &3 47 Expressions = B
ORTE@scO7tutorial d 1y (g = o © 0 a o @ s <
£) job02 0@y Name Value
¥ job06 % my_rank 4545765
% num_procs 134515657
s = cog
35 Debug % e 5 & % source -1076822980
~ &} MyMPIProject [Parallel Application] o dest 1076823128
~ & Process 0 al I EWE
~ 4 Thread [1] (Suspended)
main() testMPLc:50 80489b0
al L)
le] testMPLC 52 job05:0 =8 g outline 2 =8
< o] o 5o o
int my_rank; /¥ rank of process * B RN
int num_procs; /* number of proce: 1 mpih
int source /* rank of sender */ .
int dest 7% rank of receiver %/ ¥ stdoh
int tag = 0; /* ta 0 stringh
cha message[100];  /* */
WPI_Status status ; /* retum status o calc_pilint, int) : void
© main(int, chart{]) : int
/¥ start up WPT +/
WPI_Init(sargc, Sargv);
/* find out process rank */
MPI_Comm_rank (MPI_COMM_WORLD, &my_rank) ; ol
(T B}
& console 33 [ Memory| &7 Error Log| [£: Problems % 0 ot By 78
0 a0 E W

Module 6

SC 2007

+ Breakpoints view

The PTP Debug Perspective (2)

shows breakpoints
that have been set
(more on this later)

Variables view —
shows the current
values of variabley
for the currently
selected process in
the Debug view

Outline view (from
CDT) of source

£ PTP Debug - MyMP) Eclipse SDK BER
Fle Edit Refactor Navigate Search Run Project Window Help
civ W |3 O Qv O | = | 4 Gv [ |#PTP Debug; P Runti... [@C/C++
% parallel Debug 23 sl °o Breakpoints 9= Variables §3 &1 Expressions = B
- > ENE CIRES o @ & B M
ol v+ ¥ Name Value
% my_rank 4545765
% num_procs 134515657
% Debug 2 > % source -1076822980
= &4 MyMPIProject [P % dest -1076823128 S
=50 al D)
~ 4 Thread [1] (Suspended)
main() testMPLc:50 80489b0
al L)
le] testMPLC 52 job05:0 =8 g outline 2 =8
( o] o 5o o
int my_rank; /% rank of proce B RN
int num_procs; 2 mpih
int sourc: .
int dest H stdoh
int tag = 0; 0 stringh
message[100] ; storage fo
WPI_Status status ; /* return sta o calc_pilint, int) : void

start up MPI ¥/

MPI_Init(sargc, &argy);

int

H

© main(int, char+(])

code

MPI_Comm_rank (MPT_COMM_WORLD, &my_rank) ;

@l

Bl Console 22 [0 Memory € Error Log [2 Problems

o

Module 6

SC 2007




Process Sets (1)

+ Traditional debuggers apply operations to a single
process

+ Parallel debugging operations apply to a single process
or to arbitrary collections of processes

+ A process set is a means of simultaneously referring to
one or more processes

Module 6 SC 2007 6-4

Process Sets (2)

+ When a parallel debug session is first started, all
processes are placed in a set, called the Root set

+ Sets are always associated with a single job
+ A job can have any number of process sets

+ A set can contain from 1 to the number of processes in
a job

Module 6 SC 2007 6-5




Operations On Process Sets

+ Debug operations on the
Parallel Debug view

toolbar aIways apply tO the £ Parallel Debug 12 [ 3 I w0 & o @y =0

ORTE@scO7tutorial: default:job0ge Root [4]

current set: e
+ Resume, suspend, stop,
step into, step over, step
return %5 Doy 2 i3 3D
~ &+ MyMPIProject [Par#El Application]

+ The current process set is < 58 Process 0
listed next to job name < 15 Thregf1] (suspended)

along Wlth number Of = 1main() testMPI|.c:50 80489b0
processes in the set
+ The processes in process
set are visible in right hand
part of the view

Root set = all
processes

Module 6 SC 2007 6-6

Stepping All Processes

+ Click on the Step Over w—[? = i w0’ A @ =

ORTE@sc07tutorial: default:job06 - Roat [4

button 0 job02 109 o
+ Observe that all process
icons change to green,

then back to yellow # Debig 3\ o ® =@ -
+ Notice that the current T et Fasie oplcatin

line marker has moved to < 4 Thread [1] (Suspended)

the next source line

+ Step Over twice more,
until your source window
|OOkS ||ke thIS [¢) testMPl.c 2 . E job05:0

/% start up WPL */
MPI_Init(&argc, &argw);

/% find out process rank */
MPI_Comm_rank(MPI_COMM WORLD, &my_rank);

/* Find out number of processes */
MPI_Comm_size (MPL_COMM_WORLD, &num_procs);

Module 6 SC 2007 6-7




Managing Process Sets

+ The remaining icons in the toolbar of the Parallel
Debug view allow you to create, modify, and delete
process sets, and to change the current process set

Create set Remove
\ P‘om set
¥4 parallel Debug &2 O I > w0 S o~ By~ 0
ORTE@sc07tutorial: default:job06 - Root [4] \ Cha nge
£ oboz oy s current set
3 Debug 2 s S - -z Delete
~ £ MyMPIProject [Parallel Application] set
~ &2 Process 0
v o Thread [1] (Suspended)
= 1 main() testMPI.c:50 80483b0
Module 6 SC 2007 6-8

Creating A New Process Set

Select the processes = 2 > =3 om0 & g e =0
you want in the set by ORTE@sc07tutorial: default:job0s - Root [4]
clicking and dragging, ™ foe > E s

in this case, the last
three

Click on the Create
Set button

Enter a name for the
set, in this case
workers, and click OK
You will see the view
change to display only

< Create a new set name

Please enter the new set name

= &4 MyMPIProject [H
~ & Process 0 (S
= o® Thread [1]

workers

OK Cancel

the selected processes lel Debug 52 > e 0@ 0 & o
ORTE@scO7tu ault:job06 - workers [3]
£) jobo2 1%+ >

Module 6 SC 2007 6-9




Stepping Using New Process Set

With the workers set
active, click the Step

£ PTP Debug - MyMPIProject/testMPI.c - Eclipse SDK

Over button

You will now see two
current line markers,
the first shows the
position of process 0,
the second shows the
positions of processes

1-3 (the workers) \

Module 6

Fle Edit Refactor Navigate Search Run Project Window Help
9~ a0y Qe OV = | @ v =1 _@PTP Debug| #
— » w0 & v F & &> = O|[% Breakp |©- var
ORTE@sc07tutorial: default;job06 - workers 3]
job02 1
m vy Name
¥ job06
%5 Debug % ® v =8
& MyMPIProject [Parallel Application]
[ —
[ —
(¢ testMPLc 58§ job05:0 =05
/% start up WP #/
) " WPI_Init(Gargc, Gargy);
/% find out process rank */
MPI_Comm_rank(MPI_COMM_WORLD, &my_rank) ; D
/% find out number of processes ¥/
MPT_Comm_size (MPI_COMM_WORLD, &num_procs);
$€ (me rank 1= @) £ o]
&I D]
E Console % [ Memory €] Error Log 2. Problems

Stepping

Switch back to the
Root set by clicking
on the Change Set
button

The buttons in the

Debug view are used-

to control and
individual process, in
this case process 0

Click the Step Over =

button

Notice that the first
current line marker
disappears (it has
merged with the
second current line
marker

Module 6

J— 4 :

An Individual Process

£ PTP Debug - MyMPIProject/testMPI.c - Eclipse SDK.

File Edit Refactor Navigate Search Run Project Window Help

w2 V| O Qv | O~ ~ v 7 |#2PTP Debug| §
1 Parallel Debug 2 [ 3 B - My 21> = O1|[% Breakp |00V
T E@sc0/tutonal: default:job06 - Root [4] -
bo2 0
2 Bess Nare
¥ job06
& my_rank
| & num_procs
B R T = ¥ 0 ¢ source
< §3 MyMPIProject [Parallel Application] @ dest
= &2 Process 0 (Suspended) & tag
v 4 Thread [1 e € —
— 1« main() testMPI.c:63 804890
(A P—
[© testMPl.c 2 . & job05:0 -8|:
5]

J* start up MPT #/

MPI_Init(&argc, &argv);

/* find out process rank */
MPI_Comm_rank (MPT_COMM_WORLD, &my_rank);

/* find out number of processes */
MPI_Comm_size(MPI_COMM WORLD, &num_ procs);

(&

AF (mu rank 1=y S

SC 2007 6-11




Process Registration

+ Process set commands apply to groups of
processes

+ For finer control and more detailed
information, a process can be registered and
isolated in the Debug view

+ Registered processes, including their stack
traces and threads, appear in the Debug
view

+ Any number of processes can be registered,
and processes can be registered or
un-registered at any time

Module 6 SC 2007 6-12

Registering A Process

-
+ TO reg|5t?r a.process, Hle Edit Refactor Navigate Search Run Project Window Help
double-click its process B % 0v @ |Or | m | g o = Br
icon in the Parallel £ Parallel Debug 2 IS B 0 & o' @ = 0%

Debug view or select a | stasconuons) defal oo
number of processes and

click on the register —
button

=
o
Ll

Groups (sets)
of processes

¢ ¢ e ¢ ¢ e

%5 Debug 2 S ¥ =0
* The process icon W||| be ~ &= MyMPIProject [Parallel Applicaiyfn] .
+ &8 Process 0 (Suspended) Ind|V|dUa| >
surrounded by a box.and o Thread (1] (suspephba) (registered) b e
the process appears in V@Prz;j;g) im"d‘)“““““e“ processes

the Debug view ——»

+ To un-register a process,
double-click on the & testyffic 51 i job05:0
process icon or select a
number of processes and
click on the unregister
button

Suspended)

Module 6 SC 2007 6-13




Current Line Marker

+ The current line marker is used to show the
current location of suspended processes

+ In traditional programs, there is a single
current line marker (the exception to this is
multi-threaded programs)

+ In parallel programs, there is a current line
marker for every process

+ The PTP debugger shows one current line
marker for every group of processes at the
same location

SC 2007

Module 6

Colors And Markers

+ The highlight color depends on
the processes suspended at
that line:

+ Blue: All registered process(es)

+ Orange: All unregistered
process(es)

+ Green: Registered or unregistered
process with no source line (e.g.
suspended in a library routine)

+ The marker depends on the
type of process stopped at that
location

+ Hover over marker for more
details about the processes
suspend at that location

Module 6

SC 2007

(€ testMPILc 52 i job05:0
* start up MPL *

MPI_Init(&argc, &argv);

« find out process rank *
> MPI_Comm_rank(MPL_COMM_WORLD, &my_rank);

¥ find out number of processes *
- MPI_Comm_size (MPL_COMM_WORLD, &num_procs);

iF (me rank 1= @) f

E Console 2 00 Memory €] Error Log [ Problems.

% Multiple processes marker
» Registered process marker

® Un-registered process marker

W Multiple markers at this line
-Suspended on unregistered process: 2
-Suspended on registered process: 1
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Breakpoints

+ Apply only to processes in the particular set that is
active in the Parallel Debug view when the breakpoint
is created

+ Breakpoints are colored depending on the active
process set and the set the breakpoint applies to:
+ Green indicates the breakpoint set is the same
as the active set.
+ Blue indicates some processes in the breakpoint set are
also in the active set (i.e. the process sets overlap)
+ Yellow indicates the breakpoint set is different from the
active set (i.e. the process sets are disjoint)
+ When the job completes, the breakpoints are
automatically removed .
& else
] ) print:
J MPI_Final

Module 6 SC 2007

Creating A Breakpoint

SeleCt the process Set that %ﬁ:i;iﬂ:ii:;: uafau\tjinarwzﬂrksr;s]w 2o go 0 [ 7O b
the breakpoint should apply | e T —
to, in this case, the workers o
set ] en
Double-click on the left edge  *%2 o= e
of an editor window, at the - 48 rovess 3 (upended —
line on which you want to set =P Thvead (31 {Suspended) por s
the breakpoint, or right click
and use the Parallel
Breakpoint»Toggle a—
Breakpoint context menu St i >0
Set the brea kpoint on the prins rj:ilqef‘fﬂ process wi*, my_rank);
call to MPI _Send() —— oo - (s, el . 1o

! el:ﬁi.ngtf(wum processes: %d\n",num_procs);

o ot e omssage. 300, WBT ChA source. ko,

Module 6
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Hitting the Breakpoint

Switch back to the Root
process set

Notice that the breakpoint
color changes to indicate that
the active set and the
breakpoint set are different
Click on the Resume button
in the Parallel Debug view
The three worker processes
have hit the breakpoint, as
indicated by the yellow
process icons and the current

line marker /
Process 0 is still running as its |-

icon is green

Module 6

£ PTP Debug - MyMPIProject/testMPI.c - Eclipse SDK
Fle Edit Refactor Navigate Search Run Project Window Help

£y B % 0 |o i |4 v = @
{2 Parallel Debug & o 00 ® 0 & o &~ =80
ORTE@sc07tutorial: defp#ME:job06 - Root [4]

£ joboz 0@ v + @ &
:jobos
o> @ v =8
< &4 MyMPIProject [Pargflel Application]
< & Process 3 (Syffended) D
~ i Thread [f] (suspended: Breakpoint hit.) b
(@n

= 1r ain() testMPI.c:70 8048a14.
= &2 Proggfs 0
sffhread [1] (Running)

[iffestMPl.c 32 - E job0S:0

if (my_rank 1= 0) {
/¥ create message */
sprintf(message, "Greetings from process %d!*, my_rank);
/* use strlen+l so that '\@' get transmitted */
MPI_Send(message, strlen(message)+l, MPI_CHAR,
dest, tag, MPI_COMM_VWORLD):
} else {
printf("Num processes: Sd\n*,num procs);

SC 2007 6-18

More On Stepping

The Step buttons are only
enabled when all processes
in the active set are
suspended (yellow icon)
In this case, process 0 is still=—
running

Switch to the workers set
You will now see the Step

“_PTP Debug - MyMPIProject/testMPI.c - Eclipse SDK

¥ Parallel Debug £ [/} w0 8 (404 @~ =0 %1

utorial: default:job0s - Root [4]
£ jobo2 o[F -+ +[E -

£ PTP Debug - MyMPIProject/testMPl.c - Eclipse SDK.

Fle Edit Refactor Navigate Search Run Project Window Help

e & %0 Qv O || o g

buttons become enabled

Step a couple of times to see
what happens

§1 Parallel Debug 53 r— i ® 0 & v ¢ = @ =0 e
ORTE@sc07tutorial: default:job06 - workers [3]

£ job02 14+ N

Module 6

SC 2007 6-19
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Breakpoint Information

+ Hover over breakpoint icon

+ Will show the sets this breakpoint applies to
+ Select Breakpoints view

+ Will show all breakpoints in all projects

% Breakpoints ¥ - ™= Variables & Expressions =08
% | lmE E 5 1Y
testMPl.c [line: 70] {job03:workers}
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Breakpoints View

+ Use the menu in the breakpoints view to
group breakpoints by type

+ Breakpoints sorted by bregkpoint set (process
set)

©5 Breakpoints 52 - - Variables €7 Expressions =0
*® & W mEEe N
< ¥l workers show Full Paths
# testMPl.c [line: 70] {job03:workers}

(1 Breakpoints

oo Select Default Working Set... | (2 Breakpoint Types
(3 Breakpoint Working Sets
Working Sets... (4 Files
= =
R — (L2 5 Paraliel Breakpoint et |
[ show Qualified Names 06 Projects
I (7 Resource Working Sets
(8 Advanced...
Module 6 SC 2007 6-21
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Module 6

Global Breakpoints

+ Apply to all processes and all jobs
+ Used for gaining control at debugger startup
+ To create a global breakpoint

+ First make sure that no jobs are selected (click in white
part of jobs view if necessary)

+ Double-click on the left edge of an editor window

+ Note that if a job is selected, the breakpoint will apply to
the current set

if (my_rank '= @) {
/¥ create message */
sprintf(message, "Greetin

SC 2007 6-22

Terminating A Debug Session

+ Click on the Terminate
icon in the Parallel —Tr————uy

Debug view to
terminate all processes
in the active set

+ Make sure the Root set
is active if you want to
terminate all processes

+ You can also use the
terminate icon in the

£ PTP Debug - MyMPIProject/testMPI.c - Eclipse SDK.
Fle Edit Refactor Navigate Search Run Project Window Help

v w0y Q@ (O A (ol =g} -]
ORTE@sc07tutorial: default:job06 - Root [4]

£ joboz XXrr £
o

% Debug R

& MyMPIProject [Parallel Application]

#3 Parallel Debug 2 /'3 W 2 w0 &
ORTE@sc07tutorial: default:job0o6 - Root [4]

jobo2 o
l° s Narr

%5 Debug &2 — 3k B

Debug view to
terminate the currently
selected process

Module 6

~ &+ MyMPIProject [Parallel Application]
= & Process 0 (Suspended)
w o Thread [1] (Suspended)

= 1 main() testMPI.c:63 80489e0

SC 2007 6-23
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Module 7: Where To Go Next

+ Objective
+ How to find more information on PTP
+ Learn about other tools related to PTP
+ See PTP upcoming features

+ Contents
+ Links to other tools, including performance tools
+ Planned features for new versions of PTP
+ Additional documentation
+ How to get involved

Module 7 SC 2007 7-0

Information About PTP

+ Main web site for downloads, documentation, etc.
+ http://eclipse.org/ptp
+ Developers’ wiki for designs, planning, meetings, etc.
+ http://wiki.eclipse.org/PTP
+ Mailing lists
+ Major announcements (new releases, etc.) - low volume
+ http://dev.eclipse.org/mailman/listinfo/ptp-announce
+ User discussion and queries - medium volume
+ http://dev.eclipse.org/mailman/listinfo/ptp-user
+ Developer discussions - high volume
+ http://dev.eclipse.org/mailman/listinfo/ptp-dev
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PTP-Related Tools

+ Tuning and Analysis Utilities (TAU)

+ TuningFork - Performance Visualization
+ Remote System Explorer

+ Photran - Fortran Development Tools

Module 7 SC 2007 7-2

Tuning and Analysis Utilities

Demo presented by Wyatt Spear, wspear@cs.uoregon.edu
http://www.cs.uoregon.edu/research/tau/

+ TAU Features

+ Highly scalable and portable: works on numerous
operating systems and architectures

+ Supports many data collection and analysis options,
including hardware counters, callpath profiling and
memory profiling

+ Allows output and conversion of performance data to
several trace and profile formats

+ TAU Eclipse Plug-ins

+ Simple configuration of TAU instrumentation and data
collection options

+ Automatic 'one-click' instrumentation, compilation,
execution and data-collection

+ Profile database and analysis tools integrated with Eclipse,
including source callback
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TuningFork

+ http://www.alphaworks.ibm.com/tech/tuningfork

+ Performance visualization Eclipse plug-ins
from IBM Research

+ Rich Client Platform or IDE versions available

+ Designed for real-time visualization of large
data sets

+ Will be available open source on Source Forge

+ Enhancements for parallel computing
underway

Module 7 SC 2007 7-4

Remote System Explorer

+ http://eclipse.org/dsdp/tm

+ Now part of the Eclipse releases (available in
Europa)

+ Allows project explorer to be used to view and
manipulate remote files

+ Supports connections using ssh, ftp, telnet,
and its own protocol (dstore)

+ Remote shell access

+ List of remote processes

+ Remote debugging (gdbserver)

+ Not quite full remote project support
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Useful Eclipse Tools

+ Python
+ http://pydev.sourceforge.net
+ Subversion (CVS replacement)
+ http://subclipse.tigris.org
+ Now an Eclipse Technology project
+ Photran - Fortran Development Tools
+ http://eclipse.org/photran
+ Still under development

+ ... and many more!
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PTP Upcoming Features

+ Additional resource manager support for
MPICH2, SLURM, LoadLeveler, and Parallel
Environment (PE)

+ PLDT enhancements

+ Improved error checking for MPI and OpenMP
+ New static analysis, including parallelization
assistance

+ Full remote project support (combined with
CDT)

+ Remote build and indexing
+ Remote launch/debug
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PTP Upcoming Features (2)

+ Debugger improvements
+ Support for new architectures
+ Scalability improvements
+ New user interface functionality

+ Performance Analysis Framework

+ Provide integration for instrumentation,
measurement, and analysis for a variety of
performance tools

+ http://wiki.eclipse.org/index.php/PTP/designs/perf
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PTP Publications

+ “Developing Scientific Applications Using Eclipse,” Computing
in Science & Engineering, vol. 8, no. 4, July/August 2006, pp.
50-61

+ Link on http://eclipse.org/ptp web page

+ “A Model-Based Framework for the Integration of Parallel
Tools”, Proceedings of the IEEE International Conference on
Cluster Computing, Barcelona, September 2006

+ Link on http://eclipse.org/ptp web page

+ IBM developerWorks article:

+ http://www-128.ibm.com/developerworks/edu/os-dw-os-ecl-ptp.html

+ “An Integrated Tools Platform for Multi-Core Enablement,”
Beth Tibbitts & Evelyn Duesterwald, STMCS: Second
Workshop on Software Tools for Multi-Core Systems, March
2007

+ http://www.isi.edu/~mbhall/stmcs07/program.html
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Getting Involved

+ See http://eclipse.org/ptp

+ Read the developer documentation on the wiki
+ Join the mailing lists

+ Attend the monthly developer teleconference
+ Attend the annual workshop

+ PTP will only succeed with your participation!
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PTP Tutorial Feedback

+ Please complete feedback form
+ Your feedback is valuable!

Thanks for attending
We hope you found it useful
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