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Time (Tentative) | Module Topics
8:30-9:00 1. Eclipse & PTP + Installation of Eclipse and PTP
Installation (can start early as people arrive)
9:00-9:30 2. Introduction & + Eclipse architecture & organization
Overview overview
9:30-10:30 3. Developing with + Eclipse basics; Creating a new project
Eclipse from CVS; Local, remote, and
synchronized projects
+ Editing C files; MPI Features; Building w/
Makefile
10:30-10:45 BREAK
10:45-11:45 3. Developing with Continue from before the break...
Ecllpse_ + Resource Managers and launching a
(continued) parallel app
+ Fortran, Refactoring, other Advanced
Features
11:45-12:00 4. Wrap-up + NCSA HPC Workbench, Other Tools,
website, mailing lists, future features

Module 1: Installation

+ Objective
+ To learn how to install Eclipse and PTP

+ Contents
+ System Prerequisites

+ Eclipse Download and Installation of “Eclipse IDE for
Parallel Application Developers” - parallel package

+ Installation Confirmation

+ Updating the PTP within your Eclipse to the latest
release
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About the Tutorial Installation

+ This tutorial assumes you have Eclipse and PTP pre-
installed on your laptop

+ If you already have Eclipse installed, go directly to
“Starting Eclipse”, slide 5

+ If you don’t have Eclipse installed, you will need to
follow the handouts so that you can catch up with the
rest of the class

+ Note: up-to-date info on installing PTP and its pre-regs
is available from the release notes:
+ http://wiki.eclipse.org/PTP/release_notes/5.0
+ This information may supersede these slides
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System Prerequisites

+ Local system (running Eclipse)
+ Linux (just about any version)
+ Mac OS X (10.5/Leopard or later)
+ Windows (XP or later)
+ Java: Eclipse requires Sun or IBM Java
+ Only need Java runtime environment (JRE)
+ Java 1.6 or higher
+Java 1.6 is the same as Java SE 6.0

+ The GNU Java Compiler (GCJ), which comes
standard on Linux, will not work!
+ OpenlDK, distributed with some Linux distributions,
has not been tested by us but should work.
+ See http://wiki.eclipse.org/PTP/installjava
1-2
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Eclipse Installation

+ Download the Eclipse IDE for Parallel
Application Developers package
+ http://download.eclipse.org
+ Make sure you match the architecture with

that of your laptop
+ If your machine is Linux or Mac OS X, untar

the file
+ On Mac OS X you can just double-click in the Finder

+ If your machine is Windows, unzip the file
+ This creates an folder containing the
executable as well as other support files and

folders

1-4
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Eclipse Packages

+ The current version of Eclipse (3.7) is also

known as Indigo
+ Eclipse is available in a number of different

packages for different kinds of development

+ http://eclipse.org/downloads
+ With Indigo, there is a new package directly

relevant for HPC:
+ Eclipse IDE for Parallel Application Developers

+ This is recommended for all new installs

Developers (includes |

9

A4%% Eclipse IDE for Parallel Applicati
Package”

&7 components), 184 MB

Downloaded 39,008 Times  Details

+ Can also add PTP to an existing Eclipse
installation
1-3
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Starting Eclipse

+ Linux
+ From a terminal window, enter
“<eclipse_installation_path>/eclipse/eclipse &”

+ MacOS X
+ From finder, open the folder where you installed

+ Double-click on the

application
+ Or launch from a terminal window instead (like Linux)

+ Windows
+ Open the
+ Double-click on the

folder
executable

1-5
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Specifying A Workspace

+ Eclipse prompts for a workspace location at
startup time

+ The workspace contains all user-defined data
+ Projects and resources such as folders and files
+ The default workspace location is fine for this tutorial

‘= Workspace Launcher x|
The prompt can be Sel.e((awurkspace o
tu rned Off Ez,\:'zz:a?c\:.tfonn stores your projects in a folder called a
Workspace: [~][ growse..
[] Use this as the default and do not ask again
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Check Installation Details I
+ To confirm you have installed OK
4+ Mac:
+ Others:
+ Choose Differs
+ Confirm you have the following installed dep:nding
on base
software download
18.0.06 Eclipse Installation Details
~ [installed Software | History | Features = Plug-ins  Configuration |
Name Version Id
» [ Eclipse IDE for Parallel Application Developers 1.4.2.20120213-... epp.package.parallel
+ Close the dialog:
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Eclipse Welcome Page

+ Displayed when Eclipse is run for the first time
Select “Go to the workbench'y
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Checking for PTP Updates

+ From time-to-time there may be newer PTP
releases than the Indigo release

+ Indigo and “Parallel package” updates are released
only in Sept and February
+ PTP maintains its own update site with the
most recent release
+ Bug fix releases can be more frequent than Indigo’s
and what is within the parallel package
+ You must enable the PTP-specific update site
before the updates will be found
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Updating PTP

+ Enable PTP-specific update site ana

+ Help>Install New Software... it

+ Click Available Software
Sites link

+ Ensure this checkbox is selected for the PTP site:
http://download.eclipse.org/tools/ptp/updates/indigo
+ Choose OK
+ Choose Cancel (to return to Eclipse workbench)
+ Now select Help>Check for updates
+ If you see “No updates were found”...

+ It's only because there are no updates in the
“Eclipse IDE for Parallel Application Developers”

+ We will update the PTP within it

re by working with (€
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Updating PTP (3)

+ Quick and dirty:

+ Check everything - which updates existing features and adds a few more

Name
™ » 000 Fortran Development Tools (Photran)
™ » 000 Parallel Tools Platform

@ » (00 Remote Development Tools

+ Detailed:
+ Open each feature and check the ones you want to update
+ Icons indicate: Grey plug: already installed

and up to date ST
Double arrow: can be updated ) <) PTP Paralle|
Color plug: Not installed yet o @ PTP Parallel
. . . (=] <= PTP Parallel
Note: For this tutorial, install GEM and TAU
[ZI -i[LPTP External Tools Framework TAU Extension
EI ([‘ PTP External Tools Framework TAU Extension for Fortran
@ -if.‘: PTP Graphical Explorer of MPI Programs (GEM)

Note: if conference network is slow, consider unchecking:

@] Contact all update sites during install to find required software
Module 1 1-12

Updating PTP (2)

+ We will get the PTP release that is more recent than what
is currently (Nov. 2011) within the parallel package
+ Now select Help>Install New Software...
+ In the Work With: dropdown box, select the PTP update

site you confirmed already:
1800 Install

Available Software

Check the items that you wish to install,|

w
0

Find more software by working with the "Available Software Sites" preferences.

l Work with:  PTP - http://download.eclipse.org/tools/ptp/updates/indigo 3 Add...

type filter text

Name
() » 000 Fortran Development Tools (Photran)

() » 000 Parallel Tools Platform
» 000 Remote Development Tools

Module 1

Version

Updating PTP (4)

+ Select Next to continue updating PTP
+ Select Next to confirm features to install
+ Accept the License agreement and select Finish

000, Installing Software

|| Installing Software

Installing org.eclipse.ptp.pldt.upc

() Aiways run in background
Run lor

Grcel ) (el >> ) (RaminSackgroumany |

+ Select Restart Now when prompted

8.0.0 Software Updates

|| Youwill need to restart Eclipse for the installation changes to take effect. You may
try to apply the changes without restarting, but this may cause errors.

Nor Now oy Cranges Now)  (mResmamtiowsns)
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Wait for installation to
finish

If conference network is
too slow, we have this
cached on USB




Restart after Install

ann

If any top-level
features are installed...
Welcome page informs
you of new features
installed

We only updated PTP,
so we land back at C/C++
Perspective

... Ready to go!

Help>About or Eclipse > About Eclipse ...
will indicate the release of PTP installed

Further Help>Check for Updates will find future updates
on the PTP Update site
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New and Improved Features

+ More flexible projects

+ Synchronized projects overcome many problems of
remote projects

+ Allows development when “off-line”
+ Works with non-C/C++ projects
+ More customizable resource managers
+ Resource managers can now be added by users
+ Able to have site-specific configurations

+ Interactive launch using job schedulers now
supported

Module 2 2-1

Module 2: Introduction

+ Objective

+ To introduce the Eclipse platform and PTP
+ Contents

+ New and Improved Features

+ What is Eclipse?

+ What is PTP?

Module 2 2-0

New and Improved Features (2)

+ Scalable system/job monitoring

+ New perspective allows monitoring of systems of
virtually any size

+ View shows location of jobs on cluster
+ Active and inactive jobs views

+ Remote support for performance tools

+ External Tools Framework has been extended to
support remote systems

+ Performance tools such as TAU can now launch and
collect data from remote systems
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What is Eclipse?

+ A vendor-neutral open-source workbench for
multi-language development

+ A extensible platform for tool integration

+ Plug-in based framework to create, integrate
and utilize software tools

Java C/C++/Fortran Test and
Development Development Performance Parallel Tools
Tools Tools Tools
Planorm
Equinox |
Module 2 2-3

Parallel Tools Platform (PTP)

+ The Parallel Tools Platform aims to provide a highly
integrated environment specifically designed for parallel
application development

+ Features include:

+ An integrated development environment (IDE) that
supports a wide range of parallel architectures and runtime
systems

+ A scalable parallel debugger

+ Parallel programming tools
(MPI, OpenMP, UPC, etc.)

+ Support for the integration
of parallel tools o

+ An environment that simplifies the
end-user interaction with parallel systems

+ http://www.eclipse.org/ptp
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Eclipse Features

+ Full development lifecycle support

+ Revision control integration (CVS, SVN, Git)
+ Project dependency management

+ Incremental building

+ Content assistance

+ Context sensitive help

+ Language sensitive searching

+ Multi-language support

+ Debugging

Module 2 2-4

Eclipse PTP Famlly of Tools

Coding & Analysis

Launching &
(C, C++, Fortran)

Momtormg

[ HHHI\IIIIHIII\HII\ |
0
IHHII\I MR T O AR
ROV NTAE A R
JJ UALE (WEA N0 |}
IﬂﬁJJJUJJUJUUJ | I

Performance Tuning Parallel Debugging
Module 2 (TAU, PPW, ...) 2.6



How Eclipse is Used
Editing/Compiling

IFEE]

Module 2

How Eclipse is Used
Debugging

Source Code
Executable
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How Eclipse is Used
Launching/Monitoring

I \ HH |l
|\ \M,\HM

LI I
MMMIIHW[MM

Source Code
Executable

Module 2 2-8
How Eclipse is Used
Performance Tuning
n.u,—-.-f(;z_- SEL %]

Module 2

Source Code
Executable
Perf. Data



Module 3: Developing with Eclipse Contents

+ Objective
+ Learn basic Eclipse concepts: Perspectives, Views, ...
+ Learn about local, remote, and synchronized projects
+ Learn how to create and manage a C project
+ Learn about Eclipse editing features
+ Learn about Eclipse Team features
+ Learn about MPI features

+ Learn how to build and launch an MPI program on a
remote system

+ Learn about Fortran projects
+ Learn about searching, refactoring, etc.

+ Basic Eclipse Features (3-2)
+ Projects In Eclipse (3-13)
+ Editor Features (3-24)

+ Team Features (3-34)

+ MPI Features (3-40)

+ Synchronizing the Project (3-56)
+ Building the Project (3-62)
+
+
+
+
+
+

Running: Resource Manager Configuration (3-69)
Running: Launching a Job(3-82)

Advanced Features: Searching (3-90)

Fortran Specifics (3-99)

Advanced editing: Code Templates (3-108)
Refactoring and Transformation (3-113)

Module 3 3-0 Module 3 3-1

Eclipse Basics

+ A workbench contains the menus, toolbars, editors and
views that make up the main Eclipse window
. . + The workbench represents
Basic Ecli pse Features the desktop development
environment
+ Contains a set of tools
for resource mgmt
+ Provides a common way
of navigating through view
the resources
+ Multiple workbenches
can be opened at the
same time

+ Only one workbench can view

be open on a workspace
at a time

Module 3 3-2 Module 3
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Perspectives

+ Perspectives define the layout of views and
editors in the workbench

+ They are task oriented, i.e. they contain
specific views for doing certain tasks:

+ Thereis a for manipulating
resources

+ C/C++ Perspective for manipulating compiled code
+ Debug Perspective for debugging applications

+ You can easily switch between perspectives

+ If you are on the Welcome screen now, select
“Go to Workbench” now &

Module 3 Workbench 3-4

Which Perspective?

+Which Perspective am in in?
See Title Bar

C/C++ - MyHelloProject/src/MyHelloProject.c - Eclipse SDK -
File Edit Sourte—TRefactor Navigate Search Project Run PAPI Window

Civ B @ | & | gv & [dv Gv | Qv B | Fv Ov Qv Qv | O~
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Switching Perspectives

wch_projectRun [N Heln

ClC=%  New Window Eclipse SO

+ Three ways of changing
perspectives

1. Choose the
Perspective menu option
Then choose Other...

Open Perspective
G C/C++
[ CVS Repository Exploring
%5 Debug

£ PTP Debug
£ PTP Runtime

2. Click on the Open Perspective button in the
upper right corner of
screen (hover over it to

see names T =
) \m 888 parallel Runt... @ C/C++

3. Click on a perspective
shortcut button

+ Switch to the C/C++ Perspective

[t Resource
£° Team Synchronizing

oK | cancel
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Views

+ The workbench window is
divided up into Views

+ The main purpose of a view is:
+ To provide alternative ways of presenting information
+ For navigation
+ For editing and modifying information

+ Views can have their own menus and toolbars

+ Items available in menus and toolbars are
available only in that view

+ Menu actions only
apply to the view 2 Outline 2 B N % o ¥ =0

+ Views can be resized e main() : int
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Stacked Views Expand a View

+ Stacked views appear as tabs

+ Selecting a tab brings that view to the
foreground

+ Double-click on a view/editor’ s tab to fill the
workbench with its content;

800 Remote C/C++ = hello/hello.c - Eclipse - R t t t t P I H
C 0 @@ @ @ G & B |50 % |O- 5 Sraatt .. e ] » + Repeat to return to original size
B & |8 ] - 5le % Gr e
o v § o . 5 |Bl@ e 6 elar o = e T B8 & 8 64 o o
(2 Projec 324 Remo o m»gmu O[22 outine 52 =) $-0-8-Q OB ¥ o-la $:0°%- Q| &5 77 Ot
el n AR o R Elow v e Bl o e
| o en oot E Froblee B3 Tasks| G Console T =
| U sl 8% T |
\ © maintoid) : int TS heiio cription AlResource [pamn ™ (|
| > incud
; -
v | E|
#include <stdlib.h> |
int main(uoid) { |
puts(*!11Hello Worldl11%); /* prints 111Hello World
return EXIT_SUCCESS;
)
2 Console 52 _[2 Problems | * Remote Call Hiera | 5 Remote Type Hier | B Remote Environm | = B
C-Build hello & & [B]B B B[t B 13- e
gcc -5 -o hello hello.c
4
4

+ Window > Reset Per'spective
returns everything to original positions

Module 3 3-9

Writable Smartinsert | 1: | Remote Tools DStore ..c.edu): (100%) @

NFEL

Zl
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Help Eclipse Preferences

800 Preferences

Eclipse Preferences allow
customization of almost

rrext Typing Gv v v +

To access help — tyoe
Shelp - ecipe == === “

Automatically close

+ Help Help Contents\‘ P o sunge
ol = oS Nl w » Autotools L i
+ Help Search Ij:?;bkbe o —(‘; . alEh ) -) 2 252 il ks {D o0 »B # (Parentheses) and [square] brackets eVeryth|ng
@ Workbench User Guide [~ Code Analysis
i Rivennio N YV o o s + To open use
+ Help>Dynamic Help e e e e »Debug @ forces) P
H = @ ¢/C++ Library Documentation i v Editor H
Help Contents provides o e o Dot Using the help system i + Mac:
i i @ Elipse Marketplace User Guide Browse topics in the Contents frame (&) on the left. Ciick on a overs & Tab key adjusts indentation of the current line + Others:

detalled help on dlfferent @ GCov User Guide Aopmlohavls it displayed. Use the Back and Forward buttons to :Z:Erém,,mm The tab display value (currently 4) and whether spaces are

Window>Preferences...

used to indent lines are configured on the code style

navigate within the history of viewed topics. e
preference page. The current indentation mode uses tabs.

Save Actions
Scalability

Eclipse features

@ GProf User Guide

browser 99 Lbhover Deveopers Gide Searching S G P
& @ Mylyn Documentation To quickly locate topics on a particular subject in the documentation % & Adjust indencation
Search allows you to & @ Parallel Tools Platform (PTP) User Guide  enter a query in the Search field. Use the Search frame () to + The C/C+ + p references

% © Photran User's Guide display the Search view. You can narow the scope of your search Indexer In string literals
@ Remote Development Tools User Guide by Selecting only the sections you are interested in
% RSE User Guide

% Usage Data Collector

allow many options to be
altered

Language Mappings.  Wrap automatically
» New CDT Project Wizard
- » Property Pages Settings

Task Tags

search for help locally, or
using Google or the Eclipse

. =)
Synchronizing (] Escape text when pasting into a string literal

Automatically indent

web site

Dynamic Help shows help
related to the current

context (perspective, view,
etc.)

Module 3

Clicking the Show in Table of Contents button (=) will select that
topic i the navigation tree. The Link with Contents bution (%)
keeps the navigation tree synchronized to the current topic

Capabilities

Template Default Values
XLC/C++ Compiler
XLC/C++ Language Option

™ New lines and braces

Changelog
> Fortran

v (Restore Defaults ) (_Apsly )
'Hfl.{ Restore Defaults Apply
o= D
@ Canel ) oD

Module 3

In this example you can
adjust what happens in
the editor as you type.



Preferences Example

[ XeYe) Preferences

Tpeferon O Codesyle Grirw More C/C++ preferences:
+1In this example the
Sy e i) B) o ) (romoe Code Style preferences
EEEy— = pors \ are shown
o e + These allow code to be
— automatically

Select a profile:

§ formatted in different
Taskags ways

®@ “Anoly (canesi ) (I),r/
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Project Types

+ Local

+ Source is located on local machine, builds happen
locally

+ Synchronized

+ Source is local, then synchronized with remote
machine(s)

+ Building and launching happens remotely
(can also happen locally)

+ Remote

+ Source is located on remote machine(s), build and
launch takes place on remote machine(s)

Module 3 3-14

Projects In Eclipse

Module 3 3-13

Debud

Compute

Debug Service
7\
Build Service

Executable

[ File Service } [ Index Service }

Search/Index
Navigation

Edit

Synchronize
Source code

copy

Local source
code

—>

Local Remote

Module 3 3-15



Remote Projects C, C++, and Fortran Projects

; Build types
- . + Makeflle—base'd ' . '
+ Project contains its own makefile (or makefiles) for
- Compute building the application
el
+ Managed
+ Eclipse manages the build process, no makefile
required
== Executable

[ File Service }

Parallel programs can be run on local machine or
on a remote system
+ MPI (or other runtime) needs to be installed

+ An application built locally probably can’t be run on a
Local Remote remote machine unless their architectures are the same

Source code

A

Module 3 3-16 Module 3 3-17

Importing a Project from CVS

+ Switch to
. . Exploring perspective
CheCkl ng OUt the pI"O_]eCt + Window > Open Perspective > Other...
+ Select CVS Repository Exploring
+ Select OK

Using a Source Code Repository
Introduction to Team Features

+ Right click in CVS Repositories
view and select New>Repository
Location... .,

CVS Repository Exploring - Eclips

Module 3 3-18 Module 3 3-19



Add CVS Repository

8no Add CVS Repository

+ Enter Host: dev.eclipse.org

+ Repository path:
/cvsroot/tools

Add a new CVS Repository

Add a new CVS Repository to the CVS Repositories view

Host: dev.eclipse.org

£l

Repository path: | /cvsroot/tools

(EIN0

|:>+ For anonymous access:

=

User: anonymoug|
+ User Password
+ No password is required ——_.

+ Connection type: pserver (default)

Connection type: |_pserver

ko)

® Use default port

+ For authorized access: O use pot.
+ User: your userid ™ validate connection on finish
+ Password: your password
+ Connection type: change to extssh

+ Select Finish

-
@

Module 3

New Project Wizard

() save password (could trigger secure storage login)
To manage your password, please see 'Secure Storage'
Configure connection preferences

 Cancel )

3-20

New Project

Checking out the Project

enn CVS Repository Exploring -

Qe
L) CVs Repositories &3
+ Expand the repository location —— g
Expand HEAD L

» org.ecipse.att

+

+ Expand org.eclipse.ptp, doc, e

+ Right click on shallow-mixed e
and select Check Out As... S
Finish

and samples e
+ On Check Out As dialog, select vomm
‘igi W project log.csv 1.3

i Tag as Version..
Tag with Existing...

The default of  — commoomeoene
Check out as a ) Gt e e rdwioeas

project configured

using the New

Paste Connection
Compare With...
Compare
Expand All

Add to Branch List.

Project Nam

O check ou

 Checkout subfolders.

Project Wizard” is e

» (> org.cclipse.ve-feature $ Refresh View
(01 Add project to working sets » G org.eclipse.ve.cde
what we want rking sets I e » G org.eclipse.ve.doc

> G org.eclipse.ve.examples
> G org.eclipse.ve.examples-feature

Module 3

As project is checked out from CVS, the F—

Wizard helps you configure the Eclipse information to
be added to the project

+Expand
+Select and click on

+Enter shallow as
+ Under

expand 8nNo C Project

- scroll to the bottom C Project
Create C project of selected type

+ Select

Project name: shallow

+ Select a toolchain that
matches your system from
Toolchains L

i " N . Choose file system: default
+ Since we will build/run this on
the remote system, choose

 Use default location

Toolchains:

Browse

an appropriate toolchain MacOsx Gec
¥ (= Makefile project MinGW GCC
+ You may need to uncheck © Empty Project 0
M N © Empty Project - Fortran Remote XL C/C++ Tool Chain &
Show project types and © Demo - Hello World - Fortr ¥ || Remote XL UPC Tool Chain

toolchains only if they are -

Solaris.GEC.

supported on the platform”
+ Click on Finish

Module 3 @ C<mk ) (e ) (el )

| ) Show project types and toolchains only If they are supported on the platform

( Finish )
7

For SC tutorial
Choose
Remote Linux
GCC Tool
Chain

3-22

C/C++ Perspective

(.Ne] Open Associated Perspective?

“This kind of project is associated with the C/C+-+ perspective. Do you want to

+ Switch to the C/C++ Perspective ‘ L apen s perspecive row?
when Prompted

() Remember my decision

+ You should now see the shallow project in your
workspace
800 ( C/C&Q—I;APEDevclcbﬂidnmn'/Usﬂs/b =]
| @ e @ @ R B 508 |®E #- 7 Bocvs Repose.
O] el ey
. Project Explorer £ =g g @mBET™ =8
Expand the
project root
to see the
project’ s
s contents
(2] provlems 53 & Tasks | [ Console = =8
e [alo=E® <)

Module 3 ' ) - 3-23

% Configure Branches and Versions...




Editor Features

Module 3 3-24

Saving File in Editor

+ When you change a file in the editor,
an asterisk on the editor’s title bar
indicates unsaved changes

\€] *hello.c 23

+ Save the changes by using
Command/Ctrl-S or

+ Undo last change using Command/Ctrl Z

Module 3 3-26

Editors

+ An editor for a resource (e.g. a file) opens when you
double-click on a resource
+ The type of editor depends on the type of the resource

+ .c files are opened with the (e Hrmcsmes =0
C/C++ editor by default . O

£ shallow_[cvs.ncsa.uiuc.edu

+ You can use to M N >
use another editor

+ In this case the default
editor is fine (double-click)

Open
[& C/C++ Editor

v 8 Remote C/C++ Editor
[2) Text Editor

’2 = Copy %C
4 Paste

12 % Delete ® System Editor

Default Editor
Other...

+ Some editors do not just edit raw text

+ When an editor opens on a resource, it stays open across
different perspectives

+ An active editor contains menus and toolbars specific to that
editor

Module 3 3-25

Editor and Outline View

Double-click on
source file

Editor will open in
main view ———————

Outline view is
shown for file in —7
editor

Console shows
results of build,
local runs, etc.

2 sshatlow/mainc e [algme

Module 3 3-27



Source Code Editors & Markers

+ A source code editor is a
special type of editor for | V' .
manipulating source

¢ linear_function.c &2

+
double evaluate(double x)

COde 2 add semicolon to end of next line
+ Language features are T TR
highlighted = '

+ Marker bars for showing
+ Breakpoints
+ Errors/warnings
+ Task Tags, Bookmarks

+ Location bar for
navigating to interesting

features in the entire file el Task tag
Icons: & Warning
(x] ) Error
Module 3 3-28

Line Numbers

[c| hello.c &3
+ Text editors can show line numbers in the Lp
left column 3 Name
4 Author
5 Version
6 Copyrigl|
+ To turn on line (¢ hello.c & g oscrie
numbering: ' )| */
) . . __—3 Name : helloLocal.c 10
+ Right-mouse click in Author 11 #include
the editor marker bar Toggle Breakpoint It notici }f#‘"du‘ie
. Enable Breakpoint n C, Ansi-style
+ Click on Breakpoint Types >
Numbers Add Bookmark...
Add Task...
v Show Quick Diff ~0Q
Folding >
Preferences...
Module 3 3-30

Code Analysis (Codan)

+ If you see bug icons in the editor marker bar,
they are likely suggestions from Codan

+ Code checkers can flag possible errors, even if

code is technically correct

<) main.c &3

+ To turn them off, use Preferences @ W

}
Window > Preferences or Mac: Eclipse > Preferences @ =

C/C++ > Code Analysis

B

and uncheck oo rterences

1 error, 2 warnings, 0 others

all problems
+ Select OK to

close

Preferences
+To remove icons:
Rightmouse on
Project > Run C/C++
Code Analysis

Description
» @ Errors (1 item)
¥ & Warnings (2 items)

Navigating to Other Files

+ On demand hyperlink
4+ In main.c line 135:
+ Hold down Command/Ctrl key
e.g.on call to initialise
+ Click on initialise to navigate
to its definition in the header file
(Exact key combination
depends on your OS)
+ E.g. Command/Ctrl and click on
initialise
+ Open declaration
+ Right-click and select Open
Declaration will also open the
file in which the element is
declared
+ E.g. in main.c line 29 right-click
on decs.h and select Open
Declaration

Module 3

[c) mainc 23 0 (] decs.h [€) init.c
8 ¥

s

initialise data structures and construct packets to be

*/

initialise(p, u, v, psi, pold, uold, vold, di, dj, 2);

diag(1, @\ p, u, v, h, 2);

for (i = 1;\i < proc_ent; i+4) {
<nj 34 {

[8) main.c decs.h |[c)initie &3
G#include <
#include "

29void initialise(p, u, v,
) float p[n]([m];

1 float un)[m];
float vn][n];

3 float psi[n][ml;

v
#include <st  Open Type Hierarchy F4
#include <st  Open Call Hierarchy ~AXH
. _ Quick Outline #0
int "“i:g"“’: Quick Type Hierarchy ®T

t:tu,n e Explore Macro Expansion ="
} Toggle Source/Header  ~Tab

Note: may need to left-click
before right-click works

psi, pold, uold, vold, di, dj, z

£L Problems 52 V2 Tasks| &l Console | [ Pro,

s Possible assignment in condition 'x=1'
s Possible assignment in condition 'x=1'

sent to workers
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Content Assist & Templates Inactive code

+ Type an incomplete function name e.g. get into the editor,
and hit ctrl-space

+ Select desired completion value with cursor or mouse + InaCtive. code will appear grayed out in the
CDT editor

13

14 int main(void) {
15 puts("!!!Hello World!!!"
16 get

/* prints !!1Hello World!!! */

260 #def{ne VAL

17 v yewnan_umucrgefoiu) i 1
18 ret @ getdelim( ** __lineptr,* _n,int __delimit 61 #ifdef VAL
19} o getenvfonst char * __name) : char * 2 acopy_one_to_two(VAL, ds, res.indx);
20 @ getline(char * * __lineptr,* __n,FILE * _ strear 63 #else )
@ _netlnadavatdauhle *__loadava int  nelem) T 264 acopy_one_to_two(res.row, ds, res.indx);
> 265 #endif
Press '~Space’ to show Template Propos N
Hit ctrl-space again T
+ (‘Zod’e Templates: type for code templates 260 //#define VAL
for’ and Ctrl-space 261 #ifdef VAL
. = 262 acopy_one_to_two(VAL, ds, res.indx);
7 F |
iA "j for - for loop for (int var = @; var < max; ++var) { 263 #else .
19 ret [ for - for loop with temporary variable | 264 acopy_one_to_two(res.row, ds, res.indx);
i i 265 #endif
More info on code templates later
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“Team” Features

+ Eclipse supports integration with multiple
Team Features version contrgl systems (VCS)
+ CVS, SVN, Git, and others
+ Collectively known as “Team” services
+ Many features are common across VCS
+ Compare/merge
+ History
+ Check-in/check-out
+ Some differences
+ Version numbers
+ Branching

Module 3 3-34 Module 3 3-35



CVS Features File Modification

&void calcuvzh(jstart,jend,p,u,v,cu,cv,h,z, Fsdx, Fsdy)
291int jstart,jend;

0 float plnl[n];

1 float u[n][m];

32 float v[n][m];

33 float culn][nd;

4 float cv[n][n];

5 float h[n][m];

36 float z[n][m];

37 float fsdx, fsdy;

+ Shows version numbers next to——‘—'fsri‘»‘v + Open “calc.c”

each resource . + Add comment at line 40
+ Marks resources that have 'L,I:‘:::;;i + Save file
changed ‘
+ Can also change color (preference & & ...
option) / S —
+ Context menu for Team | B

Operatlon S ' r‘smnm ) "

{
) int 1,5,1p,5p5

+ File will be marked to

For() jstart;j< )e nd;jee) {
)

indicate that is has been = & &% s
6 ip = +1) % m;

el 47 tu[]][\p] 0.5*Cp[3][ipd+p[31[iD)*u(31LipP];

mod |f| ed evlip][i] = 0.5*Cp[3p][id+p[3I[11)*v[jpI[i];
z[jpl[ip] = (Fsdx*(v[ip][ip]-v[jp][i])-Fsdy*(u [Jp][\p]

50 -u[3101p1))/Cp[31[11+pLi1ipI+p[ip] [ip]+p[ip][11)
51 h[]][\] p[31[11+0.25*Cu[31[ip]*ul3] [ipI+ulI[i]* u[]][l]
5 +v[ipI[11*v P [13+v[3I0i*v[3I0iD)5

}
+ Compare to latest, another _—su s = o e [+
branch, or history P - | e -
+ Synchronize whole project (or any
selected resources)
Module 3 3-36 Module 3 3-37

View Changes Revert To The Latest Version

Right-click on calc.c and

+ Right-click on the “shallow” project and select
select Compare
With>Latest from HEAD

Replace With>Latest from HEAD
Compare editor will open o ccoen

+ Review the resources that will be replaced,
showing differences e

then click OK
between local (changed) TS © o8l @ @snk

file and the original

Buttons allow changes to
be merged from right to

4 float cv[nllml;
5 float hn][n];

6 float z[n][m];
float fsdx, Fsdy;

32 float v[n][ml; 8NO
33 float culn][m];
34 float cv[n][m];

float h[n][m];

Overwrite itted Changes

The selected elements contain uncommitted changes that will be overwritten.

Module 3
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i{ float z[n1[n]: Should the replace proceed?
) _int_ i,3,ip,dp; 37 float fsdx, Fedy;
left 2 ~
. 1 * Added a comment here 29_int  1,3.1p,je; @ Cancel <<Details ) ok )
o o 9
Can also navigate between i s ——
Changes using buttons 4 ;:r’(?ljlz <m; ] s ?gr‘(fjin The following elements contain uncommitted changes that will be overwritten.
6 ip - (D) % my » ip - (LD) % m; s 5%
cul31Lipd = 0.5%CoLi1LipdepCiIIULIC culi1Cip] - 0 $pJep[51D)% ang
DpIli] - 0.5*CLpILiIp LD IRl wliplli] a[ss) &5 shallow
2[ip)lip] - (P CVipITipd-vIpIiD)-F ¢ =0pITip] - (Fade GLpITiod VEIRILE 29 cale.c
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MPI Features

+ In Project Explorer, select a project, fol

single source file
+ The analysis will be run on the selected resources

+ Select
Artifacts

+ Run the analysis by

clicking on drop-

down menu next to
the analysis button

+ Works on local and

remote files

Module 3
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r, ora

clces

MPI-Specific Features

+ PTP’s Parallel Language Development Tools (PLDT) has
several features specifically for developing MPI code

+ Show MPI Artifacts

+ Code completion

+ Context Sensitive Help for MPI
+ Hover Help

+ MPI Templates in the editor

+ MPI Barrier Analysis

Module 3 3-41

i Ctig o)

£ CCn % Corocent -

s Show OpenMP Artifacts

4 MPI Barrier Analysis
# Show UPC Artifacts

% # Show LAPI Artifacts

“nust hove ot least 2 processes,

D) 1-0)

5 B meposi. >

ouEn-o
BN o %
i

n
n

YYVYVYVYVY |

MPI Artifact View

Markers indicate the

location of artifacts in =
ed|t0r (! 1 B 6 @ @ | & B |45 0 Q- Qur [O |4+ | B | @S 4+
The MPI Artifact View
lists the type and
location of each artifact
Navigate to source code
line by double-clicking
on the artifact

Run the analysis on
another file (or entire
project!) and its
markers will be added
to the view

Click on column
headings to sort

Remove markers via x
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MPI Editor Features Context Sensitive Help

e =8(=on ewg + Code completion will show all + Click mouse, then press help < Fi
float  vela_start(o; T 5w the possible MPI keyword key when the cursor is within a MPI Comm rénk (MPI_COMM WORLD, &my_rank
it v B math completions function name om_ark
MPI_Datatype * res_type; o mpih i ;re';:?"yp;oﬂ 1t MPL_Comm_rank(MP1_Comm, int *)
MPI_Init(&argc, &argv); ; ;:d:: * Enter the Start Of a keyWord + WlndOWS F1 key ‘Remrnsnthe r;nkofkhelo:d task in the group associated with a com!
Mot Comn UL COAL AL, oroc_cnt; o then press <ctrl-space> + Linux: ctrl-F1 key ! =l
MPI_Comn_rank(MPI_COMM_WORLD, &tid); T setup_res0 : MPI ) =
= (I ©  main(int, char*(J + MacOSs X: HeI ke or D Help &2 &
MPLBIOMPI_BimerlMPI_Cumm}lm 4 [Blocks each task until all tasks have called it. Help» Dyn mIi) Hyl Related Topics
S7.C] @ MPLscstia, i, L0y, i, . elp»bDynamic Help P
{ oo e + Ahelp view appears (Related 7=
W L p— = Topics) which shows See also: i Some special
17 (| MoLBeastold >t ot countat Dt floatold-starclnl; : additional information B edor v < clickhere | info has been
{ © MPI_Bsend(void * buf,int count,MP_Datatype.| int :\'d;- ' (You may need to C|IC|( on MPI B int MPI_Comm_rank{MPI_Comm, int *) added for MPI
< i 9 MPLBsend inigivoid * buf it count.MPL lﬂu' MPL Datatype * res_type; API |n edltor agaln tO APIs
—— Press "~ 1o show Template Propos /| MPI_Init(8arge, Bargv); ) ’
oot coachon, sy ™ P populate) Dbn i 56 dlc i
4+ Hover over MPI G T + Click on the function name to ® contents %7 search 8 Related Topics O Bookmars B8 ndex
API Re!ums(her:mkol(heInta\(.:skmmggveup.nso(m(edwnlha:::r:\zu::rc;a:lrs”, see more information I Comm rank
return 1; I H — —
; } + Move the help view within your
+ Displ th . . . . )
Sp aYS e £ €00 % Groc.ent - ) 1-0) Eclipse workbench, if you like, NAME
fu nction prototype it atdere, *Caumber of processes - 1 must be o s by dragging its title tab MPI_Comm_rank — Determines the rank of the
calling process in the communicator.

and a description € 3 :
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Local
files only

MPI Templates

MPI Barrier Analysis

- Eclipse SDK - C: M=%
o T BErR B e T ) )
B cee- 5 ipeo-ar e o mEw Verify barrier
B o ([ Resource.

et & 0 G [ mremete [Enmeee i 7w “0(meme omemee -0 SYNCchronization in C/

+Allows quick entry of common patterns in MPI programming

o 1 (ny_rank ! [aln BRW e ¥
MPT_Comm_rank(UPT_COMM_WORLD, &rank; B e ~ MPI programs
+E le: i %3 il
xXample: MPI_Comm_size(MPI_COMM_WORLD, &p); OB g o
_ f if (rank == @){ //master task T e i e o faria0:vod
MPI send receive printf("Hello From process @: Num processes: %d\n",p); n;gthsl o :“‘"“"!vmﬂ"ﬂﬁ"‘!

Interprocedural static

+ Enter: for (source = 1; source < p; source++) { 5 MyCoroject I}

mpisr <ctrl-space> MPI_Recv(fiessagd, 100, MPI_CHAR, source, tad, BB oot
+ Expands to a send-receive

MPI_COMM_WORLD, &status);
printf("%s\n",message);

analysis outputs:

pattern —> et ) vorker ok +For verified programs,
+ Highlighted variable names 7+ create message */ — lists barrier statements
can all be changed at once ;printfémessnge, "Hello from process %d!", my_rank); s s L ; = - that synchronize
t - : R & /i Barrier Matches 57 i 7
+ Type mpi <ctrl-space> <ctrl- 7% use sirlensi so that "\8' get transmitted */ ) e dims Fer: .| together (match)
MPI_Send(message, strlen(message)+1, MPI_CHAR, W e B e — e - . i
space> to see all templates , dest, tag, MPL_COMM_HORLD); " Sl e w3 S Unran 1) + For synchronization
- " e Loy momme {1} 8 on bty errors, reports counter
y ?"‘"F"";‘::I-'S"":": Elnalize S| "] example that illustrates
=] mpisr - MPI Send Receive : ) e e :
or = Add more templates using Eclipse preferences! Bt e b and explains the error
C/C++>Editor>Templates L e meewe @ Ml ‘ .
Extend to other common patterns B om®

Module 3 3-46 Module 3 3-47



MPI Barrier Analysis — Try it MPI Barrier Analysis — Try It (2)

Run the Analysis: , :
: TR — + No Barrier Errors are found (no pop-up
+ In the Project 5]

Explorer, select the =& indicating error); Two barriers are found

+ & shallow [cvs.ncsa.uiuc.edu]
. H > [fcalcc 1.1 ® Eclipse File Edit Source Refactor Navigate Search Project Run Window Help
p ro.] eCt (0 r d I reCtO rYI > [ copy.c 1.1 : 800 lc| C/C++ - shallow/main.c - Eclipse - /Users/beth/ews/

or file) to analyze > Bdecsh 1.3 0 86 E@ e @ e R B 508 &S S B WO

» [ di = = :
delag.c 1.1 [ Project Explorer 52 O [¢] mainc &3

I

2% e~ MPI_FinalizeQ);
= return 1;

¥ G shallow [cvs.ncsa.uiuc.edu] 85 }

> [ealcc 1.1
/ » [} copy.c 1 8 i id 1=
+ SeleCt the MPI l e Lﬁaezn !i f (:o':ker(g? ¢
i i " ——— » [ diagc 1.1 w & MPT_ Barri r(MPI_COMM_WORLD);
Barrier Analysis  Show MPI Artifacts N F b S
1 H » &) Includes
action in the pull- > Show OpenMP Artifacts gL 5/ master process
down menu Lskieiibamiitinns ikt > Bames 12 -

Show UPC Artifacts » [ftstep.c 1.1 -
b » ¢l worker.c 1.2 "#7) MPI Barrier Matches | /i MPI Barriers &3
g aclocal.m4 1.1 Function Filename LineNo IndexNo
[ZYAUTHORS 1.1 WA main main.c 89 1
i Changelog 1.1 ¥/ main main.c 206 2
 compile 1.1
“j config.guess 1.1
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MPI Barrier Analysis - views Barrier Errors

011 Bariers £ = 57[[2. problems ] Tasks | B Console ¥4 Barrer Matches 52 = 0| Barrer Errrs 53 iv=0
i~ i ||| Barrier Matching Set Function
Function Barrieratching Set_| Functon Fiename e _[a]l| STAEE ey man + Let ’ S cause a b a rri erm i smatc h error

A i = WA Barrier 1(2)  Barrier MyBarrier.c 8 Wl Path 2 (0 barrier(®))
at arrier(s)

W4 main WA Barrier 1 Barrier MyBarrier.c 8 wn
8 [ Wh B3 man wygarerc 41 B =2 +0 k i th dt b d bl I k
"4 main S Whisarier2()  man MyBarrier.c EN 0p (dynamic number of bariers) .
© Wl oo & ber o barirs) en worker.c in e ediltor oubple-ClicKIn
YA main Wi Barrier 2 main MyBarrier.c 31 - . .
Wi Barvier S Uhsster3(2)  man a4 t P t E I
B pRe S = on it in Project Explorer

41

© MPI_Buffer_attach( void®, int) int
© MPI_Buffer_detach( void®, int *) int

WhBamer3  man Mygarir.c
W Barrier mai rrier. H
D e e e 1 + At about line 125, 120 pry - vorkertAE);
<] |2 u 3] | 1 > . 220 Setart < warker ISTARTI;
5 \ OFEL enter a barrier: D !
124
2! MPLB|
I ' \ + Type M PI B 51;5 /% lo MPI_Barrier(MPI_Comm ) int + Blocks each task until
i i . : . . - 12 recei o MP|_Bcast(void®, int, MPI_D: , int, MPL_|
MPI Barriers view Barrier Matches view Barrier Errors view + Hit Ctl 128 %/ | o MpLasemdtvalde, m WP Daraype, m
[ -space i" for ¢ © MPLBsend_initivoid®, int, MPL_Datatype, it
13 L
13 Ll

Groups barriers that
match together in a

1

Simply lists the barriers + Select MPI_Barrier

+ Add communicator

If there are errors, a
counter-example

Like MPI Artifacts view,
double-click to navigate
to source code line (all

3 views)

Module 3

barrier set — all
processes must go
through a barrier in the
set to prevent a
deadlock

shows paths with
mismatched number
of barriers

arg MPI_COMM_WORLD and closing semicolon

Module 3

S ot e Ly

1
125 MPI_Barrier(MPI_COMM_WORLD);
126



Barrier Errors (2)

+ Save the file
+ Ctl-S (Mac Command-S) or File > Save
+ Tab should lose asterisk indicating file saved

L) *worker.c 83 ) | worker.c 53
“_-"5777 ‘l -3

+ Run barrier analysis on shallow project again

+ Select shallow rd

project in Project > she M'Pl*i i
; I ow rtifacts

Explorer first # Show OpenMP Artifacts

/// MPI Barrier Analysis

# Show UPC Artifacts

v
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Fix Barrier Error

[€ worker.c &[] main.c

+ Fix the Barrier Error .

before continuing " TR
+ DO u b I e _Cl iCk O n th e "#7i MP| Barrier Matches |/ MPI Barriersxm Barrier Errors m

Barrier Matching Set Function Filypame  LineNo  IndexNo
¥ UhiError

V#iPath 1 (2 barrier(s))
#/iBarrier 1

main

barrier in worker.
to quickly navigate
to it

+ Remove the line and save the file
_or_
Right mouse on worker.c in Project Explorer
and do Replace With > Latest from HEAD

VW#iPath 2 (1 barrier(s))
#/iBarrier 2 main main.c 206 2

Team >
Compare With >
Replace With » Latest from HEAD
49 Run C/C++ Code Analysis Another Branch or Version...
f History...
Module 3 Properties 281 Previous from Local History 3-54

Barrier Errors (3)

8.0.0 MPI Barrier Analysis
|

+ Ba rr|er Err'OF |S found ‘ ! Found barrier synchronization error(s)!
+ Hit OK to dismiss dialog ‘ T

+ Code diverges on line 87
+ One path has 2 barriers, other has 1

#7) MPI Barrier Matches -'IIA MPI Barriers "IIA MPI Barrier Errors 23 !EL Pr DOUble'CliCk
on a row in
Barrier Matching Set Function Filename ineNo IndexNo .
VUEro main main.c @ 0 B_arrler E_rrors
= o view to find
#/iBarrier main main.c 89 1 H H
flLRariie worker  worker.c 125 3 the Ilne It .
o o references in
fiBarrier main main.c 206 2 the Code
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Remove Barrier Markers

+ Run Barrier Analysis again to remove the error
- and/or -

+ Remove the Barrier Markers via the “X” in one
of the MPI Barrier views

/11 MPI Barrier Errors 83 i(x } =0
Barrier Matching Set Function Filename LineNo
» Wi Error main main.c 87
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Synchronizing the Project

Module 3 3-56

Converting To Synchronized

+ Select File>New>Other...
+ Open the Remote folder eno New

+ Select Convert C/C+H+ OF 00w snvenie e sosces =
Fortran Project to a

Synchronized Project »
+ Click Next> Caiens

chronized Fortran Project
(> Remote System Explorer

(= Tasks

(=XLUPC

@ — S Cancelme)
@ < Back ( Next> \) Cancel
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Synchronizing the Project

+ Because we will be running on a remote
system, we must also build on that system

+ Source files must be available to build
+ We will use a synchronized project to do this

+ Only needs to be done once for each project
+ A synchronized project could have been created
initially
+ Files are synchronized automatically when
they are saved

+ A full synchronize is also performed prior to a
build

Module 3 3-57

+

Convert Projects Wizard

Convert Projects

Convert to a synchronized project

Select checkbox next to shallow o
For Connection:, click on New... o Goatow

Enter as directed:
+ Target name
+ Host name of remote system

Synchronization Provider: (Git 1%
Remote Provider: | Remote Tools 1%

+ Userid and Password commect = P
ocaton: [ ursruamOsRaon =

Click Finish to close it
Back in the Convert Projects
Enter a directory name in the

Location field; select Browse...
+ Sample: /u/ac/trainXX/shallow

+ Project files will be copied under this
directory

Click Finish

N
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Synchronized Project

+ Back in the Project

Explorer, decorator on

project con indicates - L(1 Project Explorer &
synchronized project

+ Double-+ icon

> =5 project

+ Before sync b [ calc.c 1.2

|vk§ir|allow [dev.eclipse.org] - [‘B COpY.C 1.2
+ After sync —

Vh%shallow [dev.eclipse.org]

Module 3

Building the Project

Module 3

.hallow [dev.eclip
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Set Active Build Configuration

+ The Active build configuration determines which system will
be used for both synchronizing and building

+ Right-click on the project and select Build
Configurations>Set Active>Remote (Build on remote

machine)

Close Unrelated Projects

Livip,es

Build Configurations > Set Active [ v 1 Default
Make Targets > Manage... 2 Remote (Build on cemote machine)

Index
Synchronization

Validate

Chwas in Damata Cucrame viaw

>
»  Build All

Clean Al

Build Selected...

+ The project should synchronize immediately

| Remote Synchronization: (46%) ol 3}

Module 3

Building the Project

+ Select the project in Project Explorer, click on the «.

hammer button to run the build

[ Projec

(&5 project Explorer =2

—> & shallow [dev.eclipse.org]
> [ calec 1.2
> [l copy.c 1.2

S propertes| b Remote en

& istory|

3-61

C/C++ - shallow/calc.c - Eclipse - /Users/

+ By default, the Build Configuration assumes there is a
Makefile (or makefile) for the project

+ In this case, there is no Makefile,

so the build will fail.
See Console:

s ‘v |35+ 0+ 8 A | B & 4~ | o-
=0 alce 2
. Problems | ] Task 3). T Properties | B Remote Environ

CDT Build Console [shallo

+ We Il see how to change it if the build
command is different from
‘make -f Makefile’

Module 3

**** Build of configuration Remote for project shallow ****

make all

make: *** No rule to make target ‘all'.

**** Build Finished ****

Stop.
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Fixing the Build Eommang:

Editing Project Properties

+ The build command is specified in the project properties
+ Open the properties by right-clicking on shallow and selecting
Properties (bottom of the context menu list)
+ Click on C/C++ Build
+ Uncheck Use default build command
+ Enter make -f Makefile.mk in the Build Command field
+ CIICk OK to ClO?e 8.0N0 Properties for shallow
p!’OJeCt properties type flter text C/C++ Build G
dialog » Resource i
vi%?fsun a Confi [Remote [ Active )
Build Variables
Disfovery Options
tosgng (Elawia
Syncheanize Builder
Tool Chain Editor Builder type: External builder
XL C/C++ Compiler
»C/C++ General [ Use default build command
gfmvery Options Build command: | make -f Makefile.mk
Environment
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+ Build problems will be

+ Double-click on line in

Build Problems

[[1CIC#+ - shall Edlipse -

800

LR

2 roject Exporer 50

shown in a variety of
ways

]
s aclocalma 1

Line is highlighted
Marker on overview ruler
Listed in the Problems
view

+ 4+ 4+ +

Problems view to go
to location of error in
the editor

Module 3

+ Marker on file j/
Marker on editor line e

cGr G508 A | @S 5

chunk_size - 1

111 naster_packet[PREV] = pr;

2 4F @ == proc_ent - 1)

115 else
1 xt - s

5 FC/CH+ Roesource £0Team Synchr... 4 paraiel Debug -

— >
) s S=o
ST ocaion—Tryoe
ETTT—
e ralow ines7 Cices prosem
mane valow Ineziz  Cloos posen
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Re-Building the Project

+ Click on the «- button again to run the build
+ Build output will be shown in the Console view

[ Problems | ] Tasks | &l Console 83 [ Properties | & Remote Environments | 5 History

CDT Build Console [shallow]
error: syntax error before ':' token
: error: syntax error before ')' token
t top level:
n.c:212: error: syntax error before "return”
make: *** [main.o] Error 1

***% Build Finished ****

+ Exact output depends on your compiler
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Fix Build Problems

Fix errors by changing ‘:’ to ‘;’ on line 97
Save the file Bach  [Beome  [Bdmc  [B manc X Bworkere |71 =B

Rebuild by pressing build
button |g.

Error markers have been | ..
01 if (1 == proc_ent - 1)

removed ) master_packet[JEND] = n - 1;

103 else
master_packet[JEND] = i * chunk_size - 1; i

Check console for correct e . 5
build output . problems | ] Tasks | E] Console &3

|CDT Build Console [shallow]

chunk_size = n / (proc_cnt - 1);

for (i = 1; i < proc_cnt; i+4) { 0
/* calculate each worker's boundary */
master_packet[JSTART] = (i - 1) * chunk_size;

**** Build of configuration Remote for project shallow ***%

make -f Makefile.mk all

mpicc -g  -c -o main.o main.|
mpicc -g  -c -o time.o time.c
mpifdd -g -c -o tstep.o tstep.f90
mpicc -9 -c -o worker.o worker.c
mpicc -g  -c -o dump.o dump.c

mpicc -g -o shallow calc.o copy.o diag.o init.o main.o time.o tstep.o worker.o dun

***x Build Finished ****
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Forcing a Rebuild

+ If no changes have been made, Himies %T:shksuﬂlamso'e &
make doesn’t think a build is needed

\make -f Mnlfefile.mk all . ,
+ In Project Explorer, Rightmouse on rakes Nothing to be done for el
project, select

3 Build Project
Clean Project Clean Froect o
&) Refresh F5
Close Project
Close Unrelated Projects

+ See console —__ | o G Do s

CDT Build Console [shallow]
*** Clean-only build of configurat

+ Then rebulld ‘ Q make -f Makefile.mk clean
rm -F shallow c

alc.o copy.o diag.o
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Running the Program

+ Creating a resource manager

+ Starting the resource manager

+ Creating a run configuration

+ Running (launching) the application
+ Viewing the application run

configuration that you only need to

@ Much of the following setup is
do once: This icon will remind you.

Do this
once
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Running the Program

Resource Managers

Module 3 3-69

Resource Managers

+ PTP uses the term “resource manager” to refer to
any subsystem that controls the resources required
for launching a parallel job.

+ Examples:
+Batch scheduler (e.g. LoadLeveler, PBS, SLURM)

+ Interactive execution (e.g. Open MPI, MPICHZ2,
etc.)

+ Each resource manager controls one target system
+ Resource Managers can be local or remote
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Monitoring/Runtime Perspectives

+ Parallel Runtime Perspective
+ Used for legacy PTP Resource Managers
+ System Monitoring Perspective

+ Used for newer Configurable Resource Managers (since
PTP 5.0)

+ Which one is used?

Resource Manager System Monitoring Parallel Runtime

1BM LoadLeveler v

1BM Parallel Env

MPICH2

AN

Open MPI

PBS-Batch-Generic v

PBS-Batch-Interactive v

Remote Launch

AN AN

SLURM
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System Monitoring Perspective

| ’”’“\Ii[’lii“iii“i||uﬂu
i

\HH
]

+ System view

+ Jobs running
on system

+ Active jobs

+ Inactive jobs \.

Module 3
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Preparing to Launch

+ Setting up a resource manager is done in the System Monitoring
perspective

+ (For PTP 5.0, this applies to PBS)
+ Select Window>Open Perspective>Other.,.
+ Choose System Monitoring and click OK

o

fgcice+ defauly

New Window

Open Perspective
Show View

\| 35 Debug
>N&” Team Synchronizing

Customize Perspective... Other...
Save Perspective As...
Reset Perspective
Close Perspective
Close All Perspectives
Navigation
= Working Sets
Preferences...
3-73
Module 3
+ Open using legend icon in @ Legend,
Resource Mas
toolbar 5 o
@ sTAR
" (@ STOPPING
80O Parallel Runtime ~Sqallow/m ofpu—
A
= 3 | = e | | (@ suspE
L ‘u|w v Qv Qv Qur 2l @ mo
nnnnnnnnnnnn lode
e (] 12] NOWN
# powN 1 oow © CESS R
ALERT
B ERROR B« = cess
2 UNKNOWN
Job Icons Process
© STARTING >
(O RUNNING # RUNNING
(O SUSPENDED »  SUSPENDED
© COMPLETED ¥ PLETED
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+ Right-click in Resource DrERe $ro-a-iz osr @
Managers view and (oY m—
SeleCt Add Reso“rce ~— 4) Open_MPI@lincoln (Open MP])
Manager

Do this
once

+ Choose Resource
Manager Type:
edu.illinois.ncsa.forge
.pbs.batch.openmpi

T~
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+ Select Next>

Configure Monitor Connection

+ Keep default Monitor Connection (same as Control Connection),

click Next
eNO Do this
Monitor Connection configuration once

Enter connection information

# same as control connection
Remote service provider: | Local
Connection name Local 2] (New.

Advanced Options

®

(_<Back Next > Cancel € Finish )
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Configure Control Connection

+ Choose Remote Tools for Remote service provider @
+ Choose the remote connection you made previously Do this

H once
+ Click Next>
800
Control Connection configurati
Enter connection information
Remote service provider: | Remote Tools ]
N

Connection name: (forge ) (New.)
» Advanced Options
‘:’:’:’ < Back (" Next> ;) Cancel Finish
Module 3 3-77

Common Configuration

+ Keep default name

+ Can automatically start Resource Manager (leave unselected
today)

4+ Click Finish @
f.N.O,

Common Resource Manager Configuration Do this
once

Change any settings for the resource manager

Name and description
™ Use default name and description

Name: PBS-G

Description: XML C:

Startup

() Automatically start resource manager when Eclipse starts

C \ | ——— =
@ <Back ) ( Next> Cancel (Crnish )
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+ Right click on new
resource manager and
select Start resource

() PBS-Generic-Batcl

Start Resource Manager

manager

+ If everything is ok,
you should see the
resource manager change

| Sl@p Resource Manager

Add Resource Manager...
Remove Resource Manager
Edit Resource Manager

52 Active Jobs Zgj =a
to green = Set Default Resource Manager =
+ If something goes™ong,
it will change
to red
) Resource Managers 53
@I PBS-Generic-Batch (LML_JAXB)
Module 3 3-80
Running the Program
(Launching a Job)
Module 3 3-82

Syste

m Monitoring

forge.ncsa.illinois.edu

+ System view, with ——
abstraction of nodes
for selected Resource
Manager

Grsygeneric

| System Monitoring - - Edlipse - 1 tutorial o

oni...|Racs Reposit.. TEic/Crs

=15

. system: forge.ncsalinos edu 8

A

+ Active and inactive jobs

+ Hover over node in

System view to see job

3L cnea 43200 201 2011,

43200200 201
3200 200 2011,

running on node in
Active Jobs view

B conso

+ Hold mouse button
down on a job in Active
Jobs view to see where
it is running in System
view

Module 3

e 51 properties| . Problems | 2 Tasks,
=

One node with
16 cores

Create a Run Configuration =

once
2 Run Configuration: - - - - ==
Ov Qv Qv | O~ Create, manage. and run configurations -
.\ Create a configuration to launch a parallel application in Parallel Perspective @

i Run As )I 5] ) EEX Configure launch settings from this dialog:
T

Run Configurations...

Organize Fagon'tes..k

+ Open the run configuration x

dialog Run

Configurations... /
+ Select Parallel Application
+ Select the New button

Or, just double-click on
Parallel Application
to create a new one

pe filter text |4 - Press the 'New' button to create a configuration of the selected type.

[€] C/C++ Application || (2] - Press the ‘Duplicate’ button to copy the selected configuration.
%] Fortran Local Applicat
- Launch Group

£ Parallel Application

% - Press the Delete’ button to remove the selected configuration.

it

- Press the ilter’ button to configure filtering options.

- Edit or view an existing configuration by selecting it.

[¢ perspective the Perspectiy

« il »

Filter matched 4 of 4 items

Depending on which flavor of Eclipse you
installed, you might have more choices in

Application types
Module 3

Note: we sometimes
interchange the terms
“Run Configuration” and
“Launch Configuration”
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Complete the Resources Tab )

Enter a name for this run
configuration, e.g.
“shallow-pbs-batch”

In Resources tab, select
the PBS resource manager
you just created
(edu.illinois.ncsa.forge....)

Select the destination

Do this
once

®no Run Configurati

Create, manage, and run configurations
Create a configuration to launch a parallel application ;}

M e M e e B oo
! ReroTeE Marager: [ eduil .
[¥]Fortran Local Application j
b ‘

Name Value

Basic PES Settings | Advanced S Settings _Import A5 Script

Job Name: “mpdos | The name assigned to the job by the asub or qalter comm
Account T Accounttowhich to charge this job.
S

queue - debug

gl (Gebg 1) Desigrationof job.
ook L g tam

The MPI Command field R g ——
allows this job to be run R

Maximum amount of memory used by all concurrent proce:

Maximum amount of rea time during which the job can be

as an MPI JOb / WP Command: F wpirun T2)  Which mpi command to use.
+ Choose mpirun __— e g [ v

Export Envronment: Al variables in the asub command's environment are tbe.

Enter the resources

needed tO run thIS ]Ob View Script ‘View Configuration ) (_Restore Defauits
_— 5
+ Use 1 nodes, 4 cores (MPI
tasks) (- Cra D o)

@ Cam D) @ |
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Job Monitoring

|| System Monitoring -
w3 |G |35 0@ |22 e 9~
() Resource Managers &3
(3) PBS-Generic-Batch (LML_JAXB)

k - Eclipse -

P
@

[ i System Mo

Job initially appears in

“Inactive Jobs”, then in
“Active Jobs”, then returns to . . =N ==l
Inactive on completion B T B e J

system: forge.ncsa.illinois.edu 33

[ 3627.fsched gopal _debug 600 2011.. 7

This short-running program =
may not run long enough to
appear in “Active Jobs”

Status refreshes

automatically every 60 sec

Or force refresh with menu
After status = COMPLETED,
Can view output or error by
right clicking on job, selecting
appropriate output

2 SUBMITTED

22 Active Jobs |2 Inactive Jobs 88 =8
step owner queue | wall queuedz dispal totalcore: status
[ 3626.fsched gopal debug 600 2011 2 SUBMITTED
[0 3627.fsched gopal debug 600 2011... ? ? SUBMITTED

O 3736.fsched tibbitts debug 72 ? —
R © Resume Job

O Cancel Job
Hold Job
Release Job
Suspend Job

=

=

—————

&1 Get Job Error
&) Get Job Output

O Refresh Job Status

% Remove Job Entry
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Complete the Application Tab @

Do this
once

+ Select the Application 00 e

tab | Create, manage, and run configurations ;—5

+ Choose the Application
program by clicking the
Browse button and
locating the executable on
the remote machine

+ Use the same “shallow”
executable

+ Select Display output
from all processes in a
console view

+ Click Run to submit the
application to the job
scheduler

Module 3

Create a configuration to launch a parallel application
[E]c/C++ Application

Name: [snation-2gact
B Reseuv( e W B | o
arael P

[]Fortran Local Applicati

" Browse
Java Applet snallo =
Java Application
# Launch Group

Application program:

G
§shallow _
() Copy executable from local filesystem
i s IS Y
C— ARG e

Filter matched 7 of 7 items.
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Job Output

+ After status = COMPLETED,

Can view output or error by

right clicking on job, selecti
appropriate output

+ Output/Error info shows in
Console View

Module 3

= o=
 Inactive Jobs &% a
step owner queue | wall queuedate dispat totalc status
[ 3626.fsched  gopal debug 600 2011-1. ? SUBMITTED
[ 3627.fsched  gopal debug 600 2011-1.. 7 7 SUBMITTED
[ 3769.fsched alberto  normal 43..2011-1.. ? 18 SUBMITTED
[ 3774fsched  dsouth  normal 14..2011-1.. 7 12 SUBMITTED
ng O 3772fsched  tibbitts 22 2 7 COMPLETED
O 3773.fsched _tibbitts debug kit 2 ? COMPLETED
T e I
[0 3783.fsched tibbitts  debug 22 Resume Job
oL O Cancel Job
— - — Hold Job
& console 32 Lbh:::v;ies {£1{ Problems | ¥ Tasks| Release Job
j0b.0:
— 1 Suspend Job

Potential energy 6.505 Kinetic Enery
Total Energy 48032.016 Pot. Enstropl &) Get Job Error

Cycle number 950 Model time in days 0.oMMMEAACAB AT ITS
Potential energy 760.460 Kinetic Enery
Total Energy 48385.996 Pot. Enstropl & Refresh Job Status

Cycle number 1000  Model time in days 1.8 3 Remove Job Entry

Potential energy  21561.033 Kinetic Energ .
Total Energy 48000.496 Pot. Enstrophy 1.805456e-27 o) E
- IC
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Building before Run )

Do this
once
. . . To bring up Preferences dialog,
+If projects build prior use Window>Preferences or
tO Iaunch you can Mac: Eclipse>Preferences
! .
. 8eno Preferen

tu rn It off- W Launching — G -

+ Go into }ﬁfg‘_’f’ Save required dirty editors before launching

Changelog

Preferences>Run/

» Help
»Install/Update

O Always O Never @ Prompt

Wait for ongoing build to complete before launching

H @ Aways O Never () Prompt
Debug and click on | »==
- , :;'JI“"V Hover Launch in debug mode when workspace contains breakpoints
yiyn
Launching. > Paranel Tools O Ahays @ Never O prome

+ Uncheck "Build (if oy
required) before -

Continue launch if project contains errors

O Aways @ Prompt

- ”
launching e
View Maragement
View Performance ing a configuration from th
Service Cq 1 N e 5
+ Should be set by @ J—
default now
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Advanced Features

Searching
Fortran
Refactoring

Module 3 3-90

Exercise

+ Start with your ‘shallow’ project
+ Create and start Resource Manager
+ Build; Run shallow
+ See results
+ Change something
+ Change m and n in decs.h
+ Rebuild and re-run

Module 3

Searching

Module 3
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Switching Perspectives

+ Switch to C/C++ Perspective -

one of three ways:

1. Choose the Window>Open

Perspective menu option
Then choose Other...

2. Click on the Open Perspective button in the

upper right corner of
screen (hover over it to
see names)

3. Click on a perspective
shortcut button

ot KT vy
CICes  New Window Ecipse SO

4 New Editor nE

Show View G mSnchranzing

Customize Perspective... | Other.
Save Perspective As..

Reset Perspective.

Close Perspective

Close Al Perspectives

Open Perspective

5 C/C++

& CVS Repository Exploring
45 Debug

&8 PTP Debug

25 PTP Runtime

[ Resource

50 Team Synchronizing

\E 888 parallel Runt... @ C/C++

>

ok |[ cancel

Find/Replace within Editor

+ Simple Find within editor buffer
+ Ctrl-F (Mac: Command-F)

. ® 7 O Find/Replace '@76\391 2

/

39
Find: | pmean| - 1
Replace with: - 41

43
Direction Scope W
@ Forward ® Al 45
46
O Backward O Selected lines 3
Options :°
() Case sensitive ¥ Wrap search 50

() Whole word () Incremental

() Regular expressions 53

(@ Find ) (Replace/Find 56
Replace ) (_ReplaceAll ) | 58

5
—— | 60
Close Fe

Y, %

float ptot,ketot,etot,enstot,ptime,pmean;
int  1,3,ip,ip;

ptot-0.; ketot-!
for (G - 0; 1 <
for (i - 0;

; etot=0.; enstot = 0.; pmean = 0.;

<m; i) {
pmean - pmeamp[)] [id;
}
}
pmean - pmean/(m*n);
for (3 = @; J < n; j+d{
jp = (3+1) % n;
for (i = @0; 1 <m; 14){
ip = (i41) % m;
ketot +- p[j][i]*@. ZS‘(“E]J[\P]‘u[J][\DJWEJJE\]‘H[J][\J
+vl3p][i1*v[3p] [i]+v[3I0I*vITI[i)
ptot += (p[j][i]-pmean)*(p[j1[i]-pmean);
etot += h[j1[i];
enstot += z[jp][ip]*z[jpl[ip] * @.25%
(p[3][3+p[310ipI+p[ip] [ipd+p3pI[11);
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Mark Occurrences

(C/C++ Only)

+ Double-click on a variable in the CDT editor

+ All occurrences in the source file are
highlighted to make locating the variable
easier

+ Alt-shift-O to turn off (Mac: Alt-Cmd-0)

float ptot ketot,etot,enstot,ptime,pmean;
int  1,j,ip,3p;

44 ptot=0.; ketot}d.; etot-d.; enstot - @.; pmean - @.
4 for(J-B.J<n, ) {
for (i = @; 1 <m; i) {

pmean = pmean+p[j1[i];

pmean = pmean/(m*n);
for (3 = 0; j < n; j+d{

52 jp = (3+1) % n;
53 for (i = @; i <m; i+4){
54 ip = (i+1) % m;
55 ketot +- p[j]1[1]*@.25*(ulj][ipI*u[3][ip]+ul3]iI*u3I[1]
Module 3 56 +v[3pI[i1*v Pl [i14v I vITIi)5 3-94
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Language-Based Searching

(C/C++ and Fortran)

+ “Knows” what things can m + E.g., search for every call

be declared in each
language (functions,
variables, classes,

modules, etc.)

= Search

Search..  Ctrl+H
.,” File...
Text »

to a function whose name
starts with “get”

g C/Cr+.

+ Search can be project- or
workspace-wide

' Fortran...

7 File Search | %’ C/C++ Search | K7 Fortran Search | %’ Java Search | %7 Plug-in Search

Search string (* = any string, ? = any character):
getr < [ Case sensitive 17 File Search | %7 C/C++ Search | & Fortran Search |B7 Java Search | 7 Plug-in Search
Search pattern:
Search For LimitTo -
[ Class / Struct. [Z]Function (] Variable [ Declarations [] Definitions 9t - [ Regular expression
[ Union [@IMethod  [Field [@IReferences 7] All Occurrences (*= any string, ? = any character)
[7]Enumeration [ Enumerator [7] Namespace Search for Limit to
[T Typedef [FIMacro [7) Any Element. [Z] Common block [¥] Function All occurrences
[@ISubroutine [ Module Declarations
Scope [[]Variable [C]Program © References
® Workspace ) Selected resources ) Enclosing projects
Working set: Scope
© Workspace () Selected resources  ©) Enclosing projects
Working set:

Module 3
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Find References

(C/C++ and Fortran)

+ Finds all of the places where a variable,
function, etc., is used
+ Right-click on an identifier in the editor

+ Click References»
or References»

References > Workspace (%G
Search Text > Project

Working Set...
Make Targets

+ Search view
shows matches

Module 3
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Search - Try It!

1. Find every call to in Shallow.

2. In worker.c, on line 42, there is a declaration
float pln] [m].

a) What is m (local? global? function parameter?)
b) Where is m defined?

c) How many times is m used in the project?

3. Find every function whose name contains the
word time

Module 3 3-98

Open Declaration

(C/C++ and Fortran)

+ Jumps to the declaration of  (imane

a variable, function, etc., B ) o
P . . 135 initialise(p, u, v, psi, pold, uold, vold, di, dj, z);
even if it’s in a different e dieaCl, 0.,p, b v,
file 138 for (i = 1; i < proc_cnt Undo
139 for Camds i Revert File
141 PT STTICET—<Tar
+ Left-click to select identifier | B Open Declaration
. . . . 144 _two_to_i Open Type Hierarchy F4
+ Right-click on identifier 145 T Senichu_stefl  Open Call ierarchy AXH

+ Click Open Declaration Goes to its declaration

in copy.c
+ C/C++ only:

. [¢] main. ] copys
Can also Ctrl-click il

59  bcopy(src[column], dest[column], sizeof(src[column]));

(Mac: Cmd-click) on an 60}

i H “ . ” 61

Identlﬂer to hyperllnk to ‘P»aCOﬂy_tW_tO_onektwodim,onedim,column)
its declaration 63 float  twodim[n][n];

64 float  onedim[m];
651int column;
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Fortran Specifics
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Project Properties

+ Right-click Project
+ Select Properties...

[ Project Exp?r 83 . 4 Remote Systems p roj ect

VS >shalloF [dev.eclipse.org)
> g calec 1.2
> [ copy.c 1.2 \
800 Properties for shallow.
type filter text Resource Gvvw
[ Resource ]
Path Jshallow .
»C/C+ Build Type Project
»C/C++ General Location: JUsers/bethjews/test1027-sc11-tutorial/shallow
ovs Last modified: October 31, 2011 3:49:23 PM
Discovery Options
Environment Text file encoding
Paths and Symbols @ Inherited from container (MacRoman)
Project References
Run/Debug Settings O oOther: Mackoman +
Service Configurations .
i () store the encoding of derived resources separately
P Task Repasitory New text il line delimiter
sk Tags
Tool Chain Editor © Inherited from container
» validation -
Variables SClim
WikiText |
<
@) e
®@ Ceancet )
Module 3

+ Project properties are settings
that can be changed for each

+ Contrast with
workspace preferences,
which are the same
regardless of what
project is being edited

+ e.g., editor colors

+ Set in Window»
Preferences
(on Mac, Eclipse»
Preferences)

+ Careful! Dialog is
very similar
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Project Location

+ How to tell where a project

resides?
800

Properties for shallow

Converting to a Fortran Project

+ Are there categories labeled Fortran General
and Fortran Build in the project properties?

800 Propt

type fiter text Resource
Builders. Path:

»C/Ce+ Build Type

No Fortran categories ————»  »¢/Ce+ Ceneral Location:

Project References e n

¥Remote Development Do this

Remote Paths and Symbc Text file e once

Run/Debug Settings @© Inherit
Service Configurations ~

+ If not, the project is not a Fortran Project
+ Switch to the Fortran Perspective
+ In the Project Explorer view, right-click on the
project, and click Convert to Fortran Project
+ Don’t worry; it s still a C/C++ project, too ¥ 5 >shallow

+ Every Fortran project is also a C/C++ Project
Module 3
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type filter text
 —

+ In the project properties | @
dialog, select the / »CIC++ Build
Resource category Tl e

cvs
Discovery Options
Environment
Paths and Symbols
Project References
Run/Debug Settings
Service Configurations
Settings

» Task Repository
Task Tags
Tool Chain Editor

> Validation
Variables
WikiText

@
@

Module 3

Resource =27
Path: /shallow

Type;

Location: /Users/beth/ews/test1027-scll-tutoria)sha
Last - =

Text file encoding
@ Inherited from container (MacRoman)

(O Other: Mac

(] Store the encoding of derived resources separately
New text file line delimiter
@ Inherited from container

O Other:

Error Parsers

+ Are compiler errors not appearing in the @
Problems view?
+ Make sure the correct error parser is enabled

+ In the project properties, navigate to
C++ Build»>Settings or Fortran Build »Settings
+ Switch to the Error Parsers tab

+ Check the error parser(s) for your compiler(s)

Do this
once

|oip Binary Parsers _.. Error Parsers |

v :/CDT GNU Make Error Parser 6.0 (Deprecated)
¥ =Photran Error Parser for GNU Fortran (gfortran)
v/ <=CDT GNU C/C++ Error Parser
V| =CDT GNU Linker Error Parser
V| =CDT GNU Assembler Error Parser
V= Photran Error Parser for Absoft Fortran
¥ =Photran Error Parser for Intel Fortran 8.1
V| = Photran Error Parser for Lahey/Fujitsu Fortran 7.1
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Fortran Source Form Settings Fortran Source Form Settings by

. . . Do this
+ Fortran files are either free form or fixed form;
some Fortran files are preprocessed (#define, #ifdef, etc.) + In the project Al e S -
properties, select e '
+ Source form determined by filename extension Fortran General» ol File Name/Extension Source Form
+ Defaults are similar to most Fortran compilers: Source Form o5 “F Fixed Form - INCLUDE lines Ignored __
‘ortran Buil *.FO3 Free Form - C Preprocessed v
Fixed form: .f fix for  fpp .ftn  .f77 o e actoring |08 Free Form - C Preprocessed -
+ Select source form Pa nd Symbels
aths and Symbols .| ixed Form - ines ignorex v
Free form:  .f08 .f03  .f95  .f90 < unpreprocessed f h fil T T :;7) :m:r:WC':ij::m oreres =
.FO8 .FO3 .F95 .F90 < preprocessed or €ach Tiiename Run/Debug Settings s et For € Freproceceed :
eXte nsion ;\T,‘;i:;?:: *.FIX Fixed Form - INCLUDE lines ignored v
- - - - *.FOR Fixed Form - INCLUDE lines ignored v
+ Many features will not work if filename extensions + Click OK T -
are associated with the wrong source form b T
(outline view, content assist, search, refactorings, etc.) 03 Free form 0
*.fos Free Form v
~f77 Fixed Form - INCLUDE lines ignored v
(’?/ [ cancel | [ ok |
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Enabling Fortran Advanced Features Project Properties — Try It!

-

+ Some Fortran features are by default @ . Convert shallow to a Fortran project

11 0 this
+ Must be epr|C|tIy engble.d once 2. Make sure errors from the GNU Fortran
+ In the project properties dialog, compiler will be recognized
select Fortran General » Analysis/Refactoring
+ Click Enable — E— 3. Make sure *.f90 files are treated as
Analysis/ Analysis/Refactoring “Free Form” which is unpreprocessed
Refactoring > Resource e

+ Close and re-open b Clce s nuld e 4. Make sure search and refactoring will work in

»C/Ct+ General following box. A program database (index) wil

. a Fortran file § ated or saved.
any Fortran editors  ,%_ ... Fortran

v
Fortran General # Enable Fortran Declaration view

‘ i Analysis/Refactoring
Th IS tu rns on th € Patd ybs @ Enable Fortran content assist (Ctrl+Space)
“ »” s F
Photran Indexer e O e §f Enable Forran Hover s

+ Turn it off if it's slow @

o
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Advanced Editing

Code Templates

Module 3 3-108

Code Templates (2)

(C/C++ and Fortran)

+ After pressing enter to insert the code
template, completion fields are highlighted

[h] decs.h [€) init.c [F] *tstep.fo0 53
1 ! 2 ! 3

)~ subroutine pameparameters)

90
)1 | end subroutine name

+ Press Tab to move between completion fields

+ Changing one instance of a field changes all
occurrences
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Code Templates

(C/C++ and Fortran)

+ Auto-complete common code patterns
+ For loops/do loops, if constructs, etc.
+ Also MPI code templates

+ Included with content assist proposals
(when Ctrl-Space is pressed)

+ E.g., after the last line in tstep.f90, type “sub” and
press Ctrl-Space

+ Press Enter to insert the template

[n) decs.h [¢] init.c [A) *tstep.foo 2
| 1 | 2 | 3 ' 4 ! 5
end do
7| end subroutine

)| sub
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a1

Advanced Editing — Try It!

+ Open tstep.f90 and retype the last loop nest
+ Use the code template to complete the do-loops

+ Use content assist to complete variable names
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Custom Code Templates

(Fortran)

+ Customize code templates in Window »
Preferences » Fortran » Templates

e 00 Preferences
type filter text Templates =14 v
» General
» Ant Create, edit or remove templates:
»C/CH+ Name Context  Description New.
» Dynamic Languages ™ allocate (...) Fortran  Allocate statement (lower case)
¥Fortran @ ALLOCATE(...) Fortran  Allocate statement (upper case) =
CDT Integration ™ call ... Fortran  Call statement (lower case)
Editor ™ CcALL ... Fortran  Call statement (upper case)
( deallocate (..) Fortran  Deallocate statement (lower case) Remove
> Help (¥ DEALLOCAT... Fortran  Deallocate statement (upper case)
P Install/Update @ do while...e... Fortran  Do-while construct (lower case) Restore Removed
»Java (¥ DO WHILE...... Fortran  Do-while construct (upper case) cotore Remoes
» JavaScript ™ do..enddo  Fortran  Do-loop construct (lower case)
» Parallel Tools @ DO..END DO Fortran  Do-loop construct (upper case) Revectito,Default
» PHP @ forall...end... Fortran  Forall construct (lower case)
» Plug-in Development (M FORALL..E... Fortran  Forall construct (upper case) |
» Remote Systems @ function...e... Fortran  Function (lower case) mport:
» Remote Tools ¥ FUNCTION..... Fortran  Function (upper case)
» Run/Debug W if than Fortean If-than canctrict (Inwar cace) Export

Service Configurations

+ Can import/export templates to XML files

Module 3

Refactoring

3-112

(making changes to source code that don’t affect the behavior of the program)

Refactoring and Transformation

Module 3 3-113

+ Refactoring is the research

Refactor YoR i .
Rename... motivation for Photran @ Illinois
Extract '°‘ oL + lllinois is a leader in refactoring research
Extract Lo ol “ R : ;

PLICIT NONE..- M + “Refactoring” was coined in our group
ntroduce IM (Opdyke & Johnson, 1990)
Variable.- ) ) .
gncapsulate : + We had the first dissertation...
Make Privaté Entity Plaztcsﬂ;a(emgn(... (Opdyke, 1992)
se 0 ) ) .
AddAo:dthOCr:i: List. o= + ...and built the first refactoring tool...
inim! of
Mini . ONVariab“ '(‘;,TJON e (Roberts, Brant, & Johnson, 1997)
Make Covevariablefwc + ..and first supported the C preprocessor
Move SA = (Unchecked Yo (Garrido, 2005)
e Lo ’ :
Intercha"? B + Photran’s agenda: refactorings for HPC,
14 . .
nify K:g:f:alue oper® language evolution, refactoring framework
Repla®
ing)
(0ebu9%" . ;
+ Photran 7.0: 31 refactorings
Module 3
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Refactoring Caveats

+ Photran can only refactor free form code that
is preprocessed

+ Determined by Source Form settings

(recall from earlier that these are configured in
Project Properties: Fortran General»Source Form)

v Free Form, Unpreprocessed: .f08 .f03 .f95 .f90
8 Free Form, Preprocessed: .FO8 .F0O3 .F95 .F90
# Fixed Form: f fix  for .fpp .ftn .f77

+ Refactor menu will be empty if
+ Refactoring not enabled in project properties

(recall from earlier that it is enabled in
Project Properties: Fortran General»Analysis/Refactoring)

+ The file in the active editor is fixed form
+ The file in the active editor is preprocessed
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Rename Refactoring Rename in File

(also available in Fortran) (C/C++ Only)
+ Changes the name of a variable, function, etc., + Position th ; .
A . osition e care c| worker.c &3
/nC/Udlng eVQI‘y use ) over an identifier. 306 time_unload(prv,nxt, tu_my_id,
(change is semantic, not textual, and can be workspace-wide) int prv;
] ) + Press Ctrl-1 o N ':zfr;ny_ld'
+ Only proceeds if the new name will be legal (Command-1 on Mac). 310 int jstart;
aware of scoping rules, namespaces, etc. 311 int jend;
( ping P ) + Enter a new name. 312 float  dvdt[n][m];
Changes are 134
Fili di f; i h i i i . 314 Felghboﬁr_senq(nxt, tu_my.
de g& suree Mavlgate desiuei + Switch to C/C++ Perspective propagated within s atore, T
LS EE g + Open a source file the file as you type. 163
¢ v §lv %= ¢ov| Extract Local Variable  Shift+Alt+L . . 317
Extract Constant... Alt+C + In the ed|t0r, C||Ck on a 318 /¥
L5 Project Explorer . . . . 319 this is a general purpose fun
Extract Function...  Shift+Alt+M va rlable or functlon name 320 *
' . 321 heighbour_send(ns_neighbour,n:
In Java (Murphy-Hill et al., ICSE 2008 4+ Select menu item e  gnbour,
Refactoring Uses Percentage Refactor» Rename int ns_my_id;
Rename 179,871 74.8% 324 int ns_rec_\d;
pactLocl Varidble 0 29 +0Or use context menu
Extract Method 10,581 4.4%
fl;;mgcMclhodSlgn;\lurc 3733 T;);/: + Enter new name
Module 3 Extract Constant 3363 14% 3-116 Module 3 3-117
(16 Other Refactorings) 10,924 4.5%

Extract Function Refactoring Introduce ImpLiciT NoNE Refactoring

(also available in Fortran - “Extract Procedure”)

+ Fortran does not require variable declarations
(by default, names starting with I-N are integer variables; others are reals)

+ This adds an IMPLICIT NONE statement and adds explicit

+ Moves statements into a new function, replacing the
statements with a call to that function

+ Local variables are passed as arguments variable declarations for all implicitly declared variables
Changes to be performed 4§ ‘iﬁl" ® 00 Introduce Implicit None + Introduce in a Single file by
_Y - - Changes to be performed & ¢[%-  opening the file and selecting
1, initc cufia 4 Select a sequence of v & ntroduce Implicit None H
Original Source Refactored Source | Statementsq RefactorPCodlng Style»

Introduce IMPLICIT NONE...

1 for (G = 0; 3 <n; 34 { 3 for (§ =03 § <n; gee) {

i ey G CEREEEE + Select menu item B tepf00
i} X 2Ll = 0.3 Original S Ref: d S
R . Refactor> rorasin sl i el | 4+ Introduce in multiple files by
i s Extract Function... use, intrinsic :: ISQ use, intrinsic.::| g | " ) 3
R, H— ! — TopHcte mons selecting them in the Project
| Drinetcchumber. of potnts tn the X direl / 13 ® + Enter new name realCkind=C_FLOAT), v | integer :: jt Explorer view, right-clicking on
e G B L 2 integerCkind=C_INT), i ! X
the selection, and choosing
Refactor» Coding

Style»Introduce IMPLICIT

@ [ <Back J [ Next [ cancel
[ <Back Cancel o) NONE...
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Loop Transformations

(Fortran only)

+ Interchange LOOpS CAUTION: No check for behavior preservation
+ Swaps the loop headers in a two-loop nest
+ Select the loop nest, click menu item >
Interchange Loops (Unchecked)...

(- NeNs) Interchange Loops (Unchecked)

Module 3

Changes to be performed
™ v & Interchange Loops (Unchecked)

M 2 tstep.f90 - shallow

[F) tstep.fo0

Original Source
60

3

ED
v U [SPT

HABR

Refactored Source

60

61" doi1=1, m
do j = jstart+l, jendsl

61

do j - jstartsl, jendil
doi=1,m

pren(i,3) = pold(i,3) + taf
unew(i,j) = uold(i,3) + tdt
vnen(i,3) = vold(i,j) + tdt
66 end do
’ end do

Old version traverses
matrices in row-major order

/ end do

pren(t,3) = pold(i,3) 4
unew(i,j) = uold(i,3) +
vnen(i,3) = vold(i,j) +

end do

New version traverses
in column-major order
(better cache performance)

>
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Refactoring & Transformation - Try It!

In tstep.f90...

1. Ininit.c, extract the printf statements at

the bottom of the file into a new function
called print banner

2. In worker.c, change the spellings of

neighbour send and neighbour receive

to American English

3. In tstep.f90, make the (Fortran) tstep
subroutine IMPLICIT NONE

Module 3
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Loop Transformations

+ Unroll Loop

(Fortran only)

+ Select a loop, click Refactor»Do Loop»Unroll Loop...

doi=1, 12

print *, 10*i

end do

@ Unroll 4x

[F) tstep.fo0

Original Source

)1 Don't apply time filter on first
0 if ( firststep == 0 ) then
1 do j = jstartsl, jendsl
doi=1,m
pold(i,j) = p(i,j)+alpha*(pne|
4 uold(i,3) = u(i,j)+alpha*(Cune|

5 vold(i,j) = v(i,j)+alpha*(vne
i 6 end do
do i =1, 12, o enair
, . . ‘
print *, 10*i o do j - jstartel, jendel
. % * . 81 do 1 = m
print *, 10* (i+1) . pCi,3) = prenci, i)
print *, 10%(i+2) % 4B Iued)
) . 85 end do
print *, 10*(i+3) 86 end do
d d 27-end subroutine
en o Bs
Module 3
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Refactored Source
end do
) end if

do j = jstarts1, jendsl
ToopUpperBound = m
do i = 1, loopUpperBound,4
p(i,3) = pnew(i,j)
u(i,j) = unew(i,j)
v(i,3) = vnew(i,j)
p((i+1),3) = pnew((i+1)
u((i+1),3) = unew((i+1)
v((i+1),3) = vnew((i+1)
P((i+42),3) = pnew((i+2)
u((i42),3) = unew((i+2)
v((i42),3) = vnew((i+2)
P((143),3) = pnew((i+3)
u((i+43),3) = unew((i+3)
v((i+3),3) = vnew((i+3)
end do
end do
)8 end subroutine

3-121

Module 4: Other Tools and

+ Objective

Wrap-up

+ How to find more information on PTP

+ Learn about other tools related to PTP

+ See PTP upcoming features

+ Contents

+ Links to other tools, including performance tools
+ Planned features for new versions of PTP

+ Additional documentation
+ How to get involved

Module 4
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NCSA Blue Waters
RNNESA Hpc Workbench

+ Tools for NCSA Blue Waters
+ http://www.ncsa.illinois.edu/BlueWaters/
+ Sustained Petaflop system
+ Based on Eclipse and PTP
+ Includes some related tools
+ Performance tOOlS SUSTAINED PETASCALE COMPUTING E
+ Workflow tools (https://wiki.ncsa.uiuc.edu/

display/MRDPUB/MRD+Public+Space+Home
+Page)
+ Part of the enhanced computational environment
described at:
http://www.ncsa.illinois.edu/BlueWaters/ece.html

BLUE WATERS

Module 4 4-1

Analysis ;
,,,,, . Launching &
(C/C+ +le9rtr§ p) " Monitoring

Coding & NCSA HPC WOFkbenCh PTP

Workflow

Performance
Tuning

= 111

Module 4

- Parallel Debugw('_:}er‘tr3

NSF SI2 Workbench for High
Performance Computing

4+ “
for HPC Applications”, which is supported by the National
Science Foundation under award number OCI 1047956

+ Produce a productive and accessible development
workbench using Eclipse PTP
+ Key Components
+ Determining Requirements, Ensuring Impact
4+ Make improvements to Eclipse PTP
+ Engineering Process
+ Metrics
+ Outreach/Training/Education
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Planned PTP Future Work

+ Scalability improvements
+ UI to support 1M processes
+ Very large application support
+ Usability improvements
+ New wizard to improve setup experience
+ Ability to share configuration information
+ Resource Managers

+ More implementations of configurable resource
managers

+ Synchronized project improvements
+ Conversion wizard
+ Resolving merge conflicts

Module 4 4-4



Useful Eclipse Tools

+ Linux Tools (autotools, valgrind, Oprofile, Gprof)
+ http://eclipse.org/linuxtools
+ Python
+ http://pydev.org
+ Ruby
+ http://www.aptana.com/products/radrails
+ Perl
+ http://www.epic-ide.org
+ Git
+ http://www.eclipse.org/egit
+ VI bindings
+ Vrapper (open source) - http://vrapper.sourceforge.net
+ viPlugin (commercial) - http://www.viplugin.com
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Mailing Lists

+ PTP Mailing lists
+ Major announcements (new releases, etc.) - low volume
+ http://dev.eclipse.org/mailman/listinfo/ptp-announce
+ User discussion and queries - medium volume
+ http://dev.eclipse.org/mailman/listinfo/ptp-user
+ Developer discussions - high volume
+ http://dev.eclipse.org/mailman/listinfo/ptp-dev
+ Photran Mailing lists
+ User discussion and queries
+ http://dev.eclipse.org/mailman/listinfo/photran
+ Developer discussions -
+ Also on ptp-dev list (see above)
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Online Information

+ Information about PTP
4+ Main web site for downloads, documentation, etc.
+http://eclipse.org/ptp
+ Wiki for designs, planning, meetings, etc.
+http://wiki.eclipse.org/PTP
+ Articles and other documents
+http://wiki.eclipse.org/PTP/articles

+ Information about Photran
+ Main web site for downloads, documentation, etc.
+http://eclipse.org/photran
+ User’s manuals

+http://wiki.eclipse.org/PTP/photran/

documentation
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Getting Involved

+ See http://eclipse.org/ptp

+ Read the developer documentation on the wiki
+ http://wiki.eclipse.org/PTP

+ Join the mailing lists

+ Attend the monthly developer meetings
+ Conf Call Monthly: Second Tuesday, 1:00 pm ET
+ Details on the PTP wiki

+ Attend the monthly user meetings
+ Teleconf Monthly: 4t Wednesday, 1:00 pm ET
+ Details on the PTP wiki

PTP will only succeed with your participation!
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