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Tutorial Outline

Time (Tentative) | Module Topics
8:30-9:00 1. Eclipse & PTP + Installation of Eclipse and PTP
Installation (can start early as people arrive)
9:00-9:30 2. Introduction & + Eclipse architecture & organization
Overview overview
9:30-10:30 3. Developing with + Eclipse basics; Creating a new project
Eclipse from CVS; Local, remote, and
synchronized projects
+ Editing C files; MPI Features; Building w/
ELGHIE
10:30-10:45 BREAK
10:45-11:45 3. Developing with Continue from before the break...
EC“DSG_ + Resource Managers and launching a
(continued) parallel app
+ Fortran, Refactoring, other Advanced
Features
11:45-12:00 4. Wrap-up + NCSA HPC Workbench, Other Tools,

website, mailing lists, future features
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About the Tutorial Installation

+ This tutorial assumes you have Eclipse and PTP pre-
installed on your laptop

+ If you already have Eclipse installed, go directly to
“Starting Eclipse”, slide 5

+ If you don’t have Eclipse installed, you will need to
follow the handouts so that you can catch up with the
rest of the class

+ Note: up-to-date info on installing PTP and its pre-reqgs
is available from the release notes:

+ http://wiki.eclipse.org/PTP/release_notes/5.0

+ This information may supersede these slides

Module 1 1-1
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System Prerequisites

+ Local system (running Eclipse)
+ Linux (just about any version)
+ Mac OS X (10.5/Leopard or later)
+ Windows (XP or later)

+ Java: Eclipse requires Sun or IBM Java
+ Only need Java runtime environment (JRE)
+ Java 1.6 or higher
+Java 1.6 is the same as Java SE 6.0

+ The GNU Java Compiler (GCJ), which comes
standard on Linux, will not work!

+ Open]DK, distributed with some Linux distributions,
has not been tested by us but should work.

+ See http://wiki.eclipse.org/PTP/installjava

Module 1 1-2
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Eclipse Packages

+ The current version of Eclipse (3.7) is also
known as “Indigo”

+ Eclipse is available in a number of different
packages for different kinds of development
+ http://eclipse.org/downloads

+ With Indigo, there is a new package directly
relevant for HPC:
+ Eclipse IDE for Parallel Application Developers
+ This is recommended for all new installs

% Eclipse IDE for Parallel Application Developers (includes Incubating “Parallel

’ components), 184 MB ”
Downloaded 39,008 Times  Details Package

+ Can also add PTP to an existing Eclipse
installation

Module 1 1-3
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Eclipse Installation

+ Download the “Eclipse IDE for Parallel
Application Developers” package

+ http://download.eclipse.org

+ Make sure you match the architecture with
that of your laptop

+ If your machine is Linux or Mac OS X, untar
the file

+ On Mac OS X you can just double-click in the Finder
+ If your machine is Windows, unzip the file

+ This creates an eclipse folder containing the
executable as well as other support files and
folders

Module 1 1-4
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Starting Eclipse

+ Linux

+ From a terminal window, enter
“<eclipse_installation_path>/eclipse/eclipse &”

+ Mac OS X
+ From finder, open the eclipse folder where you installed
+ Double-click on the Eclipse application
+ Or launch from a terminal window instead (like Linux)

+ Windows
+ Open the eclipse folder
+ Double-click on the eclipse executable

Module 1
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Specifying A Workspace

+ Eclipse prompts for a workspace location at
startup time
+ The workspace contains all user-defined data

+ Projects and resources such as folders and files
+ The default workspace location is fine for this tutorial

ré Workspace Launcher B=
The prom pt can be Select a workspace
Ecli Platf t jectsin a fold lled
tu I‘n6d Off wf)lrﬁ:Sac:. orm stores your projects in a folder called a

[ ————————— /1 |
Workspace: | rEal S v || Browse... |

2palc

[] Use this as the default and do not ask again

| cancel |

Module 1
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Eclipse Welcome Page =

+ Displayed when Eclipse is run for the first time

7

Select “Go to the workbench
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Check Installation Details

+ To confirm you have installed OK
+ Mac: Eclipse>About Eclipse
+ Others: Help>About

4+ Choose Installation Details

+ Confirm you have the following installed
software

e OO0 Eclipse Installation Details

Installed Software | Installation History = Features = Plug-ins = Configuration |

Name Version Id
b - Eclipse IDE for Parallel Application Developers 1.4.2.20120213-... epp.package.parallel

+ Close the dialog: Close, OK

Module 1
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Differs
depending
on base
download
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Checking for PTP Updates

+ From time-to-time there may be newer PTP
releases than the Indigo release
+ Indigo and “Parallel package” updates are released
only in Sept and February

+ PTP maintains its own update site with the
most recent release

+ Bug fix releases can be more frequent than Indigo’s
and what is within the parallel package

+ You must enable the PTP-specific update site
before the updates will be found

Module 1 1-9
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Updating PTP -

+ Enable PTP-specific update site
+ Help>Install New Software...

+ Click Available Software
Sites link

+ Ensure this checkbox is selected for the PTP site:
http://download.eclipse.org/tools/ptp/updates/indigo

+ Choose OK
+ Choose Cancel (to return to Eclipse workbench)

+ Now select Help>Check for updates
+ If you see “No updates were found”...

+ It’s only because there are no updates in the
“Eclipse IDE for Parallel Application Developers”

+ We will update the PTP within it

Module 1 1-10
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Updating PTP (2)

e \2\\
e

+ We will get the PTP release that is more recent than what
is currently (Nov. 2011) within the parallel package

+ Now select Help>Install New Software...

+ In the Work With: dropdown box, select the PTP update
site you confirmed already:

Install

| Available Software

I

Check the items that you wish to install/

Work with:  PTP - http://download.eclipse.org/tools/ptp/updates/indigo 3 [ Add...

Find more software by working with the "Available Software Sites" preferences.

)e niter text

Version
U Fortran Development Tools (Photran)
U0 Parallel Tools Platform
UJ Remote Development Tools

Module 1 1-11
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Updating PTP (3)

+ Quick and dirty:

+ Check everything - which updates existing features and adds a few more

Ul Fortran Development Tools (Photran)

Ul Parallel Tools Platform
UJ Remote Development Tools

+ Detailed:

+ Open each feature and check the ones you want to update

+ Icons indicate: Grey plug: already installed
and up to date — j
Double arrow: can be updated - =)= PTP Parallel

Color plug: Not installed yet v :Tri ::afa::e:
aralle
Note: For this tutorial, install GEM and TAU 4

«J== PTP External Tools Framework TAU Extension

,L PTP External Tools Framework TAU Extension for Fortran
Ly PTP Graphical Explorer of MPI Programs (GEM)

Note: if conference network is slow, consider unchecking:

12‘ Contact all update sites during install to find required software
Module 1 1-12
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Updating PTP (4)

+ Select Next to continue updating PTP
+ Select Next to confirm features to install
+ Accept the License agreement and select Finish

Installing Software

1 Installing Software

Installing org.eclipse.ptp.pldt.upc

Wait for installation to
finish

_ Always run in background

_Cancel _ Details >> (_Run in Background

If conference network is
too slow, we have this
Software Updates CaChEd on USB

You will need to restart Eclipse for the installation changes to take effect. You may
try to apply the changes without restarting, but this may cause errors.

+ Select Restart Now when prompted

. Not Now Apply Changes Now Restart Now

Module 1 1-13
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Restart after Install

If any top-level
features are installed...
Welcome page informs
you of new features
installed

We only updated PTP,
so we land back at C/C++
Perspective

... Ready to go!

Help>About or Eclipse > About Eclipse ...
will indicate the release of PTP installed

Further Help>Check for Updates will find future updates
on the PTP Update site

Module 1 1-14
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New and Improved Features

+ More flexible projects

+ Synchronized projects overcome many problems of
remote projects

+ Allows development when “off-line”
+ Works with non-C/C++ projects

+ More customizable resource managers
+ Resource managers can now be added by users
+ Able to have site-specific configurations

+ Interactive launch using job schedulers now
supported

Module 2 2-1
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New and Improved Features (2)

+ Scalable system/job monitoring

+ New perspective allows monitoring of systems of
virtually any size

+ View shows location of jobs on cluster
+ Active and inactive jobs views

+ Remote support for performance tools

4+ External Tools Framework has been extended to
support remote systems

+ Performance tools such as TAU can now launch and
collect data from remote systems

Module 2 2-2
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What is Eclipse?

+ A vendor-neutral open-source workbench for
multi-language development

+ A extensible platform for tool integration

+ Plug-in based framework to create, integrate
and utilize software tools

Java C/C++/Fortran Test and
Development Development Performance Parallel Tools
Tools Tools Tools

Platform

User

Module 2 2-3
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Eclipse Features

+ Full development lifecycle support

+ Revision control integration (CVS, SVN, Git)
+ Project dependency management

+ Incremental building

+ Content assistance

+ Context sensitive help

+ Language sensitive searching

+ Multi-language support

+ Debugging

Module 2 2-4
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Parallel Tools Platform (PTP)

+ The Parallel Tools Platform aims to provide a highly
integrated environment specifically designed for parallel
application development

4+ Features include:

+ An integrated development environment (IDE) that

supports a wide range of parallel archltectures and runtlme
systems =

+ A scalable parallel debugger

+ Parallel programming tools
(MPI, OpenMP, UPC, etc.)

+ Support for the integration
of parallel tools

+ An environment that simplifies the E
end-user interaction with parallel systems [

+ http://www.eclipse.org/ptp

hhhhh

Module 2 2-5



paratiel-tools—platform

el === —
=5 =
)
B MM : = 53339 Iﬂ.w
@) | a)
@) [
- ©
" &
@
o °
LL o
c
(=
w =
L=
al e &
c2
0 5
QO © &
)]
N E— Y\/
O ¢
b
Tt
B + ﬂa/_.v
20 S
TY S
@ =



paratiel-tools—platform

How Eclipse is Used
Editing/Compiling

File Edit Navigate Search Project Run

_module Mdataset
D EEMMFP = implicit none TEI v ) Mdataset

- D%>org.ec|ipse.photran-samp v ) Tdataset

ire a Tdat e to hold data points

D < Binaries .. Tdataset ¥ datapt

D (4 src-fixed-form . datapt(4,1000) ¢ npts
integer npts

P (4 src-fortran-and-c € real valsum(4) ¢ valsum

D (£} src-gaussian-elimination & real valsum(4) @ valsum

real 1t xysum(3) .

1 logical has_np(2) Xxysum

D (3 src-language-features end type Tdataset ® has_np

P (f src-includes

v i3 >src-line-fitting end module Mdataset v (P BstFitProj

Dot ¥ LoadDataSet

program BstFitProj

j.cvsignore 1.1 (ASCI “ ShowDataPoints

fi src-modules J|e use Mdataset ® squareDistances |~/
<« | (] ]

@ Make Targets 52 = B |/[Zl Problems 2 " Console Properties

» X 26 errors, 0 warnings, 0 infos -
c y Description Resource  |=!
D =S org.eclipse.photran-samples - -

whatever2 @ Derived type definition has no components bug138221.f—

@ FILE tag must be of type CHARACTER bugl18974.f
llegal preprocessor directive bugl118961.1[5]
>

(@]
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How Eclipse is Used
Launching/Monitoring

Module 2 2-8
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How Eclipse is Used
Debugging

Parallel Debug - shallow/m:

[ B Parallel Debug 338 Parallel Runt... FZiRemote C/C...
£ parallel Debug ® 0 2} Expressi |09 Variables 53 5% Signals | {{} Arrays ¢

Open_MPI@abe.ncsa.uiuc.edu: default;job0 - Root [4]
£jobo @ Value

1
7Hffifdes8
5.957805E-39

% Detug 2 - [0-18)

8} shallow [Parallel Application] [0 - 18]
&2 Process 0 (- 18]
Thread (1] (Suspended) (0 - 18]

main() main.c:38 4032ca

1€ main.c & Outline 23
2MPI_Datatype * setup_res(); 13 R \ ° %
main (argc, argv) b math.h
. int argc; ) mpi.h

char * argv([]; 2 swdio.h

decs.h

float pi=4.*(float)atan((double)1.); worker() : void

float p[nl[ml; *p rf )

float  u[n][m];

float  v[n][m]; o )

float  psi[nl[r < func setup_res() : MPI_Datatype:

float  pold[n][m]; update_global_ds(MPI_Datatype

float uold[n][m];

float  vold[n][m];

float  h[n][m];

float  z[n][m];

float  dummyl[m];

float  dummy2[n][:

float  tpi-pispi;

float  di-tpi/(fFloatdm;

float  dj=tpi/(float)n;

setup_res() : MPI_Datatype* [
main(int, char*(})

B console R @ Memory| £ Problems
Open_MPI@abe.ncsa.uiuc.edu:default:job0

Open Mpi Job

Module 2 2-9
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How Eclipse is Used

Performance Tuning

2-10
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Contents

Basic Eclipse Features (3-2)

Projects In Eclipse (3-13)

Editor Features (3-24)

Team Features (3-34)

MPI Features (3-40)

Synchronizing the Project (3-56)

Building the Project (3-62)

Running: Resource Manager Configuration (3-69)
Running: Launching a Job(3-82)

Advanced Features: Searching (3-90)
Fortran Specifics (3-99)

Advanced editing: Code Templates (3-108)
Refactoring and Transformation (3-113)

TR I I
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Basic Eclipse Features

Module 3 3-2
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Eclipse Basics

+ A workbench contains the menus, toolbars, editors and
views that make up the main Eclipse window

+ The workbench represents
the desktop development
environment

4+ Contains a set of tools
for resource mgmt

+ Provides a common way
of navigating through i
the resources
+ Multiple workbenches
can be opened at the
same time

+ Only one workbench can
be open on a workspace
at a time

Module 3

Writable S I

perspective
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Perspectives

+ Perspectives define the layout of views and
editors in the workbench

+ They are task oriented, i.e. they contain
specific views for doing certain tasks:

+ There is a Resource Perspective for manipulating
resources

+ C/C++ Perspective for manipulating compiled code
+ Debug Perspective for debugging applications

+ You can easily switch between perspectives

+ If you are on the Welcome screen now, select
“Go to Workbench™ now &

Module 3 3-4
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Switching Perspectives

hrch  Project Run RULGGIVM Help
New Window Eclipse SDK

. New Editor
35

+ Three ways of changing AT
perspectives
1. Choose the Window>Open o -
Perspective menu option T

Then choose Other...

CVS Repository Exploring

%5 Debug
#% PTP Debug
g8 PTP Runtime

L5 Resource

2. Click on the Open Perspective button in the
upper right corner of

screen (hover overitto [

see names)

&Y Team Synchronizing

£ 0Ooo
goo Parallel Runt...

oK | cancel |

3. Click on a perspective
shortcut button

+ Switch to the C/C++ Perspective

Module 3 3-5
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Which Perspective?

+Which Perspective am in in?
See Title Bar

& C/C++ - MyHelloProject/src/MyHelloProject.c - Eclipse SDK -
File Edit Sour - Refactor Navigate Search Project Run PAPI Window

= 1=} = Pt i ~ o ) S 3
v E & W | &y av by Gy | ][ By | v Ov @v @v | OV

Module 3 3-6
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Sou MyCproject/src/MyCproject.c - Eclipse SDK
File Edit Refactor Navigate Search Project Run elp

Views

+ The workbench window is
divided up into Views

+ The main purpose of a view is:
+ To provide alternative ways of presenting information
+ For navigation
+ For editing and modifying information

+ Views can have their own menus and toolbars

+ Items available in menus and toolbars are
available only in that view

+ Menu actions only
apply to the view 5= Outline 53

+ Views can be resized

e main() : int

Module 3



paratiel-tools platform

Stacked Views

+ Stacked views appear as tabs
+ Selecting a tab brings that view to the

foreground

Module 3

e no Remote C/C++ - hello/hello.c - Eclipse - /Users/beth/ews/test0917c

G & v @G | K~ YR [y 888 Parallel Runt... FiclRemote C/C... »

ql | &« & v s &
1l LYY N Y

L5 Projec &3 48 remo = 8| [c] hello.c £3 = B[ 5= outline & =0
5o || / : AR o %~
§ . he 1 ¢ 2l stdio.h
=l stdlib.h
@ main(void) : int

=5 hello
\.c| hello.c
nt Includes

#include <
#include <

int main(void) {
puts("!11Hello World!!1");
return EXIT_SUCCESS;

ETTTTTTTTIZSSNN

& console 52 |2 Problems | .3
C-Build [hello]

Remote Call Hiera | 72 Remote Type Hier | (&5 Remote Environm =0

JL

T |5 LB BE Ex |t B[Sy

gcc -g -0 hello hello.c

Writable Smart Insert - | Remote Tools DStore S...c.edu): (100%)
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Expand a View

+ Double-click on a view/editor’ s tab to fill the
workbench with its content;

+ Window > Reset Perspective
returns everything to original positions

Module 3 3-9



To access help
+ Help>Help Contents
+ Help>Search
+ Help>Dynamic Help

Help Contents provides
detailed help on different
Eclipse features in a
browser

Search allows you to
search for help locally, or
using Google or the Eclipse
web site

Dynamic Help shows help
related to the current
context (perspective, view,
etc.)

Module 3
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Help

- Help - Eclipse

Search:

5l o

¥ Workbench User Guide

Autotools Plug-in User Guide

& C/C++ Development User Guide
& C/C++ Library Documentation

Changelog Editor User Guide

Eclipse Marketplace User Guide

GCov User Guide

GNU Tools

GProf User Guide

Libhover Developer's Guide

Mylyn Documentation

Parallel Tools Platform (PTP) User Guide
Photran User's Guide

Remote Development Tools User Guide
RSE User Guide

& Usage Data Collector

Scope: All topics

[?)7 P

Using the help system

Browse topics in the Contents frame {@) on the left. Click on a
topic to have it displayed. Use the Back and Forward buttons to
navigate within the history of viewed topics.

Searching

To quickly locate topics on a particular subject in the documentation

enter a query in the Search field. Use the Search frame () to
display the Search view. You can narrow the scope of your search
by selecting only the sections you are interested in

Synchronizing
Clicking the Show in Table of Contents button (&%) will select that

topic in the navigation tree. The Link with Contents button (<)
keeps the navigation tree synchronized to the current topic

Capabilities

3-10
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Eclipse Preferences

Preferences

Typing N + Eclipse Preferences allow
Automatically close Customization Of almost
= sunas everything

Build @ (Parentheses) and [square] brackets
Code Analysis

Code Style & <Angle> brackets + TO O pe n u Se

Debug [2' {Braces}

Editor + Mac: Eclipse>Preferences...

Content Assist Tabulators

Folding [~ j i i i .
Hovers ¥ Tab key adjusts indentation of the current line + Others :
Mark Occurrences The tab display value (currently 4) and whether spaces are

used to indent lines are configured on the code style Wi ndow> Prefe rences. L]

Save Actions & =
preference page. The current indentation mode uses tabs.

[) Escape text when pasting into a string literal

Automatically indent

Scalability
Syntax Coloring When pasting
Indexer In string literals )
o Wrap automatically allow many options to be
Property Pages Settings
Task Tags
XL C/C++ Compiler ™ New lines and braces I h 1 I
XL C/C++ Language Option + n t IS exa m p e you Ca n
adjust what happens in
ngIp " Restore Defaults

# M Adjust indentation * The C/C++ preferences
New CDT Project Wizard
altered
Template Default Values
(Jestor Dufus ) (_toeh the editor as you type.

Cancel

Module 3 3-11
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Preferences Example

&) O Preferences

| Cpefieron —— © | Codesle  Geoev] More C/C++ preferences:

S P +In this example the

C/C++ Select a profile:

CoTE— T T Code Style preferences
—_— e are shown

Editor Preview:

Enironment —— e _ - + These allow code to be

File Types

e T m———————— 1 ae— 2 UtoMatically

Language Ma

New CDT Pro . .
property Pag| Poteme: (A oo formatted in different
Scripti

T‘;Zstjl'r;zs : [ Indentation | Braces  White Space  Control Statements  Line Wrapping W a y S

Template Def

XL C/C++ Cq
XLC/C++ La Tab policy: Tabs only _ﬂ * A
! * Inde n
Fortran ] Use tabs only for leading indentations *
Help , oy . #include <math.h>
Install/Update .
Java Tab size: class Point {
. public:
JavaScript Point(double xc, double yc) :
Parallel Tools Indent x(xc), y(yed {
}

General settings Preview: () Show invisible char.

Plug-in Develop) [ 'public', 'protected', 'private’ within class body

Remote Systems ¥ Declarations relative to 'public’, 'protected’, 'private’ double distance(const Point& other) cons|

Remote Tools o int compareX(const Point& other) const;
i f ithi i .

Run/Debug ¥ Statements within function body double x;

double y;
Server ¥ Statements within blocks . ouble y;
;

Service Conﬁg“’ ) Statements within 'switch' body
TAU Configurati - double Point::distance(const Point& other) c
Teamn !Z‘, Statements within 'case’ body double dx = x - other.x;

Validation M 'break' statements double dy = y - other.y;

Web Declarations within 'namespace’ definition return sqrt(dx * dx + dy * dy);

J i }
Web Page Editor, ] Empty lines

XML int_Point::comoareX(const Point& other) cons”
e

Cancel

Module 3 3-12
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Projects In Eclipse

Module 3 3-13
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Project Types

+ Local

+ Source is located on local machine, builds happen
locally

+ Synchronized

+ Source is local, then synchronized with remote
machine(s)

+ Building and launching happens remotely
(can also happen locally)

+ Remote

+ Source is located on remote machine(s), build and
launch takes place on remote machine(s)

Module 3 3-14
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Synchronized Projects

S C/C++ - testOpenMP.c - C:\ews\runtime-workspace-scO5local - Eclipse SDK

I» I
[¢) Edmiston_Soluton... 3 = O|[5E outine

Al

openmp.h
main

; 1 < arraySize; i++ )

¥[i] = sin( exp( cos( - exp( sin(x[il)

OpenMP Pragma

pragma region

: Executable

Search/Index
Navigation

Synchronize
Local source Source code

code copy

Local Remote

Module 3 3-15



Edit Search Project Run LAPI Artifac

- AMCRNCRNE R R NEb 22 TN )

[:) 3\ Navigator| = O |[ [¢] Edmiston_Solution...

1% ¥
stdo.h
string.h

dib.h
math.h
openmp.h
main

parallel for
i < arraySize; i++ )

O
yOpenMPproject [lexcs L lexingtol v[i] = sin( exp( cos( - exp( sin(x[i])
Includes

>
Problems | Console | Properties | MPI Artifact View | () OpenMP Artifact View 2 i

Opente Arti Filename LineNo uct

G omp_in_parallel testOpenMP.c Function Call

€ #pragma omp paraliel for[ testOpeniP. OpenMP Pragma

pragma region

kmarks

SmartInsert | 26:6

paratiel-tools—platform

Executable

Source code

Local Remote

Module 3

3-16



paratiel-tools platform

C, C++, and Fortran Projects
Build types

+ Makefile-based

+ Project contains its own makefile (or makefiles) for
building the application

+ Managed

+ Eclipse manages the build process, no makefile
required

Parallel programs can be run on local machine or
on a remote system
+ MPI (or other runtime) needs to be installed

+ An application built locally probably can t be run on a
remote machine unless their architectures are the same

Module 3 3-17
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Checking out the project

Using a Source Code Repository
Introduction to Team Features

Module 3 3-18
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Importing a Project from CVS

+ Switch to CVS Repository
Exploring perspective
+ Window > Open Perspective > Other...

HgC/C++ (default)

+ Select CVS Repository Exploring
+ Select OK

unti

{ielRemote C/C++

;E Remote System Explorer
[y Resource

Liis System Monitoring
E0Team Synchronizing

+ Right click in CVS Repositories .
view and select New>Repository
Location...

CVS Repository Exploring - Eclips,

New > & Repository Location...
Paste Connection 3V s I

5* Refresh View

Module 3 3-19
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_—— _'\B

. 53

Add CVS RepOS|tory >

®NO Add CVS Repository

+ Enter Host: dev.eclipse.org Add 2 new CVS Repository

+ RepOSitO ry path - anew €pository to the epositories view
/cvsroot/tools

Host: dev.eclipse.org

|[CV5

Repository path:  /cvsroot/tools

+ For anonymous access.:

User: anonymous|

+ User: anonymous
+ No password is required ,

Connection
+ Connection type: pserver (default) | —

Password:

(® Use default port

+ For authorized access:

lz‘ Validate connection on finish

+ User: your userid
* Password : your password To manage your password, please see 'Secure Storage'
+ Connection type: Change to extssh Configure connection preferences...

[) Save password (could trigger secure storage login)

+ Select Finish

_ Cancel ) € Finish
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Checking out the Project '

+ Expand the repository location
Expand HEAD

+ Expand org.eclipse.ptp, doc,
and samples

+ Right click on shallow-mixed
and select Check Out As...

+ On Check Out As dialog, select

e

Finish

The default of
“Check out as a
project configured
using the New
Project Wizard” is
what we want

Module 3

Select the method of check out

Choose how to check out folder 'shallow'
(® Check out as a project configured using the New Project Wizard

.': Check out as a project in the workspace

(O Check out into an existing project

™ Checkout subfolders

(] Add project to working sets

Q@ 4
||| CVS Repositories £3

| :pserver:anonymous@dev.ecli
‘K HEAD
(= CVSROOT
(= org.aspectj
(= org.eclipse.ajdt
(= org.eclipse.atf
(= org.eclipse.edt
(=>org.eclipse.gef
(= org.eclipse.orbit
(=>org.eclipse.pdt

paratiel-tools platform

_——

. 53

-

CVS Repository Exploring

v

pse.org:/cvsroot/tools

(= org.eclipse.pdtincubator

(= org.eclipse.ptp
(= core
(= debug
(=doc
(= articles

(= org.eclipse.ptp.doc.isv

(= org.eclipse.ptp.doc.user

(= presentations
(= samples
(= shallow-c

I B shallow-mixed

(= tutorials
(= whitepapers
X| .project 1.1
3 project_log.csv 1.
(=old
(= photran
(= rdt
(= releng
(=rms
(= tools
X| pom.xml 1.4
(= org.eclipse.tm.core
(= org.eclipse.tm.rse
(= org.eclipse.uml|2.releng
(= org.eclipse.ve
(= org.eclipse.ve-feature
(= org.eclipse.ve.cde
(= org.eclipse.ve.doc

New

Check Out
3 ;

iz Tag as Version...
Tag with Existing...

Paste Connection
Compare With...
Cc are
Expand All
Add to Branch List...
&’ Configure Branches and Versions...

5 Refresh View

(= org.eclipse.ve.examples
(~>org.eclipse.ve.examples-feature
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o L

New Project Wizard :

As project is checked out from CVS, the New Project &=
Wizard helps you configure the Eclipse information to
be added to the project

+Expand C/C++
+Select C Project and click on Next>

+Enter ‘shallow’ as Project Name
+ Under Project type,

i

il

expand Makefile project 800 GBsolect
- scroll to the bottom C Project
- Create C project of selected type
+ Select Empty Project
+ Select a toolchain that Project name: | shallow
matches your system from SR
Toolchains Location: sers/beth/ews/test1027-sc tutorial /shallow
Choose file system:
+ Since we will build/run this on ’
Project type: Toolchains: .
bl 21l CTCIESE S e [ s e For SC tutorial
N $n approprlatje toolc I?In . (7 Makefile project MinGW GCC Choose
© Empty Project :
“Ou may nee to unc eC @ Emz:: Pro}e(t—fortran O me L C/' I RemOte Llnux
ShOW prOJeCt typeS and @ Demo - Hello World - Fortr ¥ Remote XL UPC Tool Chain
toolchains only if they are E—— - Solaris. GCC ] GCC Tool

("] Show project types and toolchains only if they are supported on the platform Ch a | n

supported on the platform”

4+ Click on Finish
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NG

C/C++ Perspective 2.

Open Associated Perspective?

This kind of project is associated with the C/C++ perspective. Do you want to

+ Switch to the C/C++ Perspective 1) apen'his perspective now?
When Prompted ") Remember my decision

+ You should now see the “shallow” project in your
workspace

C/C++ - IBM PE Developer Edition - /Users/beth/ews/test0930ppedev
S - ) —
o |G G [ R B [0 Qr [BEB Y [@3CVS Reposit...  »
O- |12 v D
L[ Project Explorer &3 =0 =a|(@m BT™ =5

-4 -

E( shallow [dev.eclipse.org] An outline is not available.

Expand the
) project root
to see the

project’s
contents

=0a

-

[2( Problems 23 ¥ Tasks | B Console| & Properties ;b Remote Enviro
0 items

Description A |Resource Path

=5 shallow
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Editor Features
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Editors

+ An editor for a resource (e.g. a file) opens when you
double-click on a resource

+ The type of editor depends on the type of the resource

+ .c files are opened with the T r————
C/C++ editor by default :

4+ You can use to
use another editor T

+ In this case the default ¢ & Remot I+ o
editor is fine (double-click) g D Paste

System Editor
Default Editor

Other...

+ Some editors do not just edit raw text

+ When an editor opens on a resource, it stays open across
different perspectives

+ An active editor contains menus and toolbars specific to that
editor
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Saving File in Editor

+ When you change a file in the editor,
an asterisk on the editor’ s title bar

indicates unsaved changes

+ Save the changes by using
Command/Ctrl-S or File>Save

+ Undo last change using Command/Ctrl Z
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Editor and Outline View

Double-click on
source file

3 CVS Reposit... | Hg)C/C++

Editor will open in |EE=2 ; e
main view :

worker()

setup_res() D
main(int, char*(])
setup_res() : MPI_Datatype
update_global_ds(MPI_Dat:

o
o
o

H decs.h
=+
L dump.c 1.1 #include - H
[ Includes #include < e
L.} init.c #include (]
#include ®

extern void worker();

t:::;t:c(rcl 7 . MPI_Datatype * setup_res();
A':‘ aclocal.m4 1.1
= ] - J AUTHORS 1.1 Tht argc;
Outl I ne VIeW IS j Changelog 1.1 char * argv[];
. . Tconfig.guess 1.1 float pi=4.*(float)atan((double)l.);
shown for file in oo
. float ;

float
float

- ;conﬂgure 1.1 ]
ed Ito r Af] configure.ac 1.1 float  pold[n][m];
3 COPYING 1.1 float  uwold[n][m];
, depcomp 1.1 float  vold[n][m];

J INSTALL 1.1 float  h[n][m];

Console shows St

A Makefile.am 1.1

Makefile.in 1.1 [21 Problems | ] Tasks | B Console £ . Properties | [ Remote Environments

results of build, e
local runs, etc.

L€] /shallow/main.c
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Source Code Editors & Markers

A source code editor is a
special type of editor for
manipulating source
code

Language features are
highlighted

Marker bars for showing

+ Breakpoints

+ Errors/warnings

+ Task Tags, Bookmarks
Location bar for
navigating to interesting
features in the entire file

Module 3

2 }

¢ linear_function.c &3

I.H
k Returns f(x) = 3.0*%x + 2.C
¥ /

double evaluate(double X)

A

, add semicolon to end of next line
double y = 3.0*%x + 2.0
return y;

Task tag
Warning

CRPAS
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Code Analysis (Codan)

+ If you see bug icons in the editor marker bar,
they are likely suggestions from Codan

+ Code checkers can flag possible errors, even if

code is technically correct
+ To turn them off, use Preferences ol
Window > Preferences or Mac: Eclipse > Preferences ’ tro a0

C/C++ > Code Analy5|s

and uncheck
all problems
+ Select OK to
close
Preferences

+To remove icons:
Rightmouse on
Project > Run C/C++
Code Analysis

g Problems 83 . v Tasks | El Console | C
1 error, 2 warnings, O others

Description
€ Errors (1 item)
5 Warnings (2 items)
.1 Possible assignment in condition 'x=1'
.1, Possible assignment in condition 'x=1'

CRPAS
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Line Numbers

.c| hello.c 23
+ Text editors can show line numbers in the Ly

left column 2 Nome
} Author
6 C;ﬁ;;:g
. ' Descrip
+ To turn on line L hello X B
numbering: | — S |
+ Right-mouse click in (I . | #include
the editor marker bar Toggle Breakpoint oticlil 2 Finclude
. - Enable Breakpoint C ' le
+ Click on Show Line -
Numbers

Add Bookmark...
Add Task...

v Show Quick Diff ~Q
); /* prints !!!Hello World

Folding >

Preferences...
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Navigating to Other Files

+ On demand hyperlink
4+ In main.c line 135:

+ Hold down Command/Ctrl key
e.g. on call to initialise

+ Click on initialise to navigate
to its definition in the header file
(Exact key combination
depends on your OS)

+ E.g. Command/Ctrl and click on
initialise

+ Open declaration

+ Right-click and select Open
Declaration will also open the
file in which the element is
declared

+ E.g. in main.c line 29 right-click
on decs.h and select Open
Declaration

Module 3

|.c| main.c 23

|h] decs.h L.€] init.c

5

initialise data structures

initialise(p, u, v, psi, pold, uold, vold, di, dj, z);
p, u, v, h, z);

for (1 = 1;\1 < proc_cnt; i++) {

1
1

1

1

132

133 */
134

1

1

1

1

1 9; J < n; jed {

] main.c [N decs.h |.c) init.c &3
26 #include <math.h>

27 #include "dkgs.h"

29void initialise(p, u, v, psi, pold, uold, vold, di, dj, z)
30 float p[n][m];

31 float ul[n][m];

32 float v[n][m];

33 float psi[n][m];

*/ Open Declaration F3
Open Type Hierarchy F4

#include <st
#include <st

Open Call Hierarchy ~XH
Quick Outline #®0
Quick Type Hierarchy ®T
Explore Macro Expansion ¥=
~Tab

int main(voi
puts("!!
return E

} Toggle Source/Header

irld!!

Note: may need to left-click

before right-click works 3-31

w53

_—— \\\

and construct packets to be sent to workers
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Content Assist & Templates

+ Type an incomplete function name e.g. “get” into the editor,
and hit ctrl-space

+ Select desired completion value with cursor or mouse

lint main(void) {
. puts("!!!Hello World!!!" /* prints !!1Hello World!!! */
get

W oyTLuian_uriiucn vUIUj) LI
i

ret @ getdelim(chdr * * __lineptr,* __n,int __delimit

@ getenvitonst char * __name) : char * O
@ getline(char * * __lineptr,* __n,FILE * __strear

o netlnadavaldnuhles * lnadawva int nelam)
«———— >

Press '~Space’ to show Template Propos

Hit ctrl-space again

+ Code Templates: type for code templates

‘for’ and Ctrl-space

1 for
18 -| for - for loop for (int var = @; var < max; ++var) {
19 ret = for - for loop with temporary variable

‘,‘} }

More info on code templates later
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Inactive code

+ Inactive code will appear grayed out in the
CDT editor

260 #define VAL

261 #ifdef VAL

262 acopy_one_to_two(VAL, . .indx);

263 #else

264 acopy_one_to_two(res. r , res.indx);
265 #endif

260 //#define VAL

261 #ifdef VAL
acopy_one_to_two(VAL, - .1ndx);
263 #else
24 acopy_one_to_two(res.row, , res.indx);
265 #endif
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Team Features
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“Team” Features

+ Eclipse supports integration with multiple
version control systems (VCS)
+ CVS, SVN, Git, and others
+ Collectively known as “Team” services

+ Many features are common across VCS
+ Compare/merge
+ History
+ Check-in/check-out

+ Some differences
+ Version numbers
+ Branching

Module 3 3-35



paratiel-tools platform
CVS Features

+ Shows version numbers next to
each resource

+ Marks resources that have
changed
+ Can also change color (preference E
option) £ 6ui sected ity
+ Context menu for Team
operations

+ Compare to latest, another :
branch, or history

Properties

+ Synchronize whole project (or any
selected resources)
Module 3 3-36
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File Modification

28 void calcuvzh(jstart,jend,p,u,v,cu,cv,h,z, fsdx, fsdy)

té 77 291int jstart,jend;
+ Open “calc.c
31 float u[n][m];
32 float v[n][m];

1 33 float culn][ml;

+ Add comment at line 40 [QjEtheeais:
35 float h[n][m];
36 float z[n][m];

* Save fi Ie ;1out fsdx, fsdy;

int  1,3,1ip,Jp;

10 /*

+ File will be marked to | —

for(j=jstart;j<=jend;j++) {

= = = 14 ip = (3+1) % n;

indicate that is has been ISR
X ip = (i+41) % m;

. g 4 culj1Cip] = 0.5*(p[31Cipl+p[3ILi1D*ul3I[ip];

mOd |f|ed ev[pl[il = 0.5*(p[ip][11+p[3I[i1D*vlipI[i];
19 z[jpllip] = (Fsdx*(v[ipl[ip]l-vlipl[i1)-Ffsdy*Culip]lip]
50 -ul31Cip1))/CpL31[11+p[31ipI+p [P [ipd+pipI[11);
' h[3I0i] = p[310i1+0.25*Cul3ICip]*uli]Cipl+ul3I[1]*ul3IL1]

+v[ip][1I*v[ipI[11+v[I[1I*v3IDD;

L—%:'shal A cvs.ncsa.uiuc.edu
L6} >calcc 1.1

| copy.c 1.1
[K) decs.h 1.3
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View Changes

Right-click on “calc.c” and
select Compare
With>Latest from HEAD

Compare editor will open
showing differences
between local (changed)
file and the original

Buttons allow changes to
be merged from right to
left

Can also navigate between
changes using buttons

Module 3

=
L] calc.c &Y calc.c

IEl, € Compare

|c® Translation Unit
+® calcuvzh
etd calcuvzh
2 cu
o o
@0 fsdx
€0 fsdy

IE C Compare Viewer ¥

Local Flle 1l 1

32 float v[n][m]
33 float cul[n][m];
34 float cv[n][m];
5 float h[n][m];
36 float z[n][m];
float fsdx, fsdy;
38 {
)__int  1,3,ip,Jp;
10 /*
11 * Added a comment here
- ‘/’
for(j=jstart;j<=jend;j++) {
ip = (3+1) % n;
for (i = @; 1 < m; 144){
ip = (1+41) % m;

cul310ip] = @.5*(p[31[ipJ+p[3I010D*ul3]L

cvlipl[i] = @.5*(p[ipI[iJ+p[3ILLID*v ip]

2[jp]Lip] = (Fsdx*(vLip]Lip]-vip][i)-F

_— ‘\\

w53

» Remote Flle 1 1
float pln] [m]

31 float u[n][m];

1

2 float v[n][m];

33 float cul[n][m];
34 float cv[n][m];

5 float h[n][m];

36 float z[n][m];

37 float fsdx, fsdy;
)__int  1,3,1ip,Jp;

\{]

for(j=jstart;j<=jend;j++) {
ip = (G+1) % n;
for (1 = @; 1 < m; 144){
ip = (i41) % m;
cu[j1[ip] = 0.5*Cp[31[ipl+p[3I1[i1D*u
cv[ipl[i] = 0.5*Cp[ipI [1]+p[3I[1ID*v
Z[JP][lp] = (fsdx*(v[jpllip]- V[JP][\

Pt N B T W N o B e BPRN ot B e |
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Revert To The Latest Version

+ Right-click on the “shallow” project and select
Replace With>Latest from HEAD

+ Review the resources that will be replaced,
then click OK

Overwrite Uncommitted Changes

The selected elements contain uncommitted changes that will be overwritten.
Should the replace proceed?

@

The following elements contain uncommitted changes that will be overwritten.

Changes
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MPI Features
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MPI-Specific Features

+ PTP s Parallel Language Development Tools (PLDT) has
several features specifically for developing MPI code

+ Show MPI Artifacts

+ Code completion

+ Context Sensitive Help for MPI
+ Hover Help

+ MPI Templates in the editor

+ MPI Barrier Analysis
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Show MPI Artifacts
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.

+ In Project Explorer, select a project, folder, or a

single source file

+ The analysis will be run on the selected resources

+ Select Show MPI
Artifacts

+ Run the analysis by

clicking on drop-
down menu next to
the analysis button

+ Works on local and
remote files

Module 3

J AUTHORS 1.1
3 Changelog 1.1

j configure.ac 1.1
| COPYING 1.1

j depcomp 1.1

5 INSTALL 1.1
jinstall-sh 1.1

} Makefile.am 1.1

C/C++ - shallow/main s="ECiipse - [Users/beth/ews/testptp

¢ main.c 2
float vold_sta
int proc_cnt;
int tid;
MPI_Datatype *

MPI_Init(&argc,
MPI_Comm _size(MP
MPI_Comm_rank(MP

if ( proc_ent < 2 )

fprintf(stderr, "mus

MPI_Finalize(Q);
return 1;
}

» Sh

t have at leas

if ( (n % (proc_ent - 1)) 1=0 )

{
if ((tid == 0 )

|21 Problems | 2 Tasks | E] Console

Artifact

B MPLInit

’ MPI_Comm_size

[ Properties | i MPI Artifact View 53

2| CVS Reposit... »

ow OpenMP Artifa'gts 12‘:‘,'\M\; e
#7; MP| Barrier Analysis
#» Show UPC Artifacts
# Show LAPI Artifacts

p_res() : MPI_Datatype
& Tham(int, char*(])
@ setup_res() : MPI_Datatype
@ update_global_ds(MPI_Dat:



MPI Artifact View =9

Markers indicate the
location of artifacts in
editor

The MPI Artifact View

lists the type and
location of each artifact

Navigate to source code
line by double-clicking
on the artifact

Run the analysis on
another file (or entire
project!) and its
markers will be added
to the view

Click on column
headings to sort

Remove markers via

paratiel-tools platform

C/C++ - shallow/main.c - Eclipse - /Users/beth/ews/testptp

Y [@aCVS Reposit... >

=0 R\ @m|ET| =8
BN o %Y

2l math.h
= mpi.h
Bl stdio.h
MPI_Init(&argc, &argv); H decs.h
MPI,_Comm.size(MPI_COMM_WORLD, &proc_cnt); void
MPI_Comm._rank(MPI_COMM_WORLD, &tid); 0 : MPI_Datatype
. char*(])
f <2
if ( proc_cnt D] 0 : MPI_Datatype
fprintf(stderr, "must have at leas
MPI_Finalize(Q);
return 1;
}

if ( (n % (proc_ent - 1)) =0 )

if (tid == 0 )

|2 Problems | | Tasks | E] Console | = Properties ’ MPI Artifact View $3

(] 1
JINSTALL 1.1
jinstall-sh 1.1

} Makefile.am 1.1
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MPI Editor Features '

—— SeEeraEenl + Code completion will show all
float  vold_start[m]; - [ N the pOSS|bIe MPI keyword

int proc_cnt;

int tid; B math.h completions

MPI_Datatype * res_type; = mpi.h

| M stdioh + Enter the start of a keyword
MPI_Init(&argc, &argv); = decs.h
- then press <ctrl-space>

MPI_Comm_size(MPI_COMM_WORLD, &proc_cnt);

MPI_Comm_rank(MPI_COMM_WORLD, &tid); Tt setup, res0 : MP
L]

main(int, char*[]

MPI_Barrier(MPI_Comm ) int + |Blocks each task until all tasks have called it.
MPI_Bcast(void*, int, MPI_Datatype, int, MPI_

MPI_Bsend(void*, int, MPI_Datatype, int, int,

MPI_Bsend_init(void*, int, MPI_Datatype, int,

MPI_Buffer_attach( void*, int) int

MPI_Buffer_detach( void*, int *) int [c] main.c £3
MPI_Barrier(MPI_Comm comm) : int float vold_start[m];
MPI_Bcast(void * buffer,int count,MPI_Dataty int proc_cnt;
MPI_Bsend(void * buf,int count,MPI_Datatype | int tid;

_MPI_Bsend _init{void * buf.int count.MPI Datz * MPI_Datatype * res_type;

- W L.

-
-
~

-
‘@ oo 0o o0 @0 @ o0

Press '~ ' to show Template Propos /4 MPI_Init(&argc, &argv);
MPI_Comm_size(MPI_COMM_WORLD, &proc_cnt);
MPI_Comm_rardk(MPI_COMM_WORLD, &tid);

+ Hover over MPI
Prototype: int MPI_Comm_rank(MPI_Comm, int *)

Description:

Returns the rank of the local task in the group associated with a communicator.!" |
Press 'F2' for focus

b

return 1;

}

+ Displays the
function prototype e dre, *Cumbar of pracesses - 3 mt be 2

and a description — :
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Context Sensitive Help

+ Click mouse, then press help
key when the cursor is within a
function name

+ Windows: F1 key

+ Linux: ctrl-F1 key

+ MacOS X: Help key or
Help» Dynamic Help

+ A help view appears (Related
Topics) which shows
additional information
(You may need to click on MPI
API in editor again, to
populate)

+ Click on the function name to
see more information

+ Move the help view within your
Eclipse workbench, if you like,
by dragging its title tab

Module 3

Related Topics

+ About

Click below to see help. .
See also: Some SpeCIal

info has been
added for MPI
APIs

= Edltor view (0
El int MPI_Comm_ran\MPI_Comm, int *)

e — yParallel D
@ S N & —

Related Topics :.H] Bookmarks [ Index

MPI_Comm_rank

@ Help 53

Contents %" Search

NAME

MPI_Comm_rank — Determines the rank of the
calling process in the communicator.
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MPI Templates

+Allows quick entry of common patterns in MPI programming

MPI_Comm_rank(MPI_COMM_WORLD, &rank);

+ Example: MPI_Comm_size(MPI_COMM_WORLD, &p);
- i if (rank == @8){ //master task
MPI Send recelve brintf("Hcllo From process @: Num processes: %d\n",p);
+ Enter: for (source = 1; source < p; source++) {
. MPI_Recv( 100, MPI_CHAR, source, tag,
mpisr <ctrl-space> ~ MPI_COMM_WORLD, &status);
+ Expands to a send-receive printf("%s\n", SESSEER) ;
pattern
. . . // worker tasks
+ Highlighted variable names /% create message */
can a” be Changed at once sprintf(message, "Hello from process %d!", my_rank);
dest = 9;
+ Type mpi <Ctr|-SpaCG> <Ctr|' /* use strlen+l so that "\@' get transmitted */
MPI_Send(message, strlen(message)+1l, MPI_CHAR,
space> to see all templates dest. tag, MPI_COMM_WORLD);

- mpiif - MPI_Init and Finalize

- mpisr - MPI Send Receive

Add more templates using Eclipse preferences!
C/C++>Editor>Templates
Extend to other common patterns
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Local
files only

MPI Barrier AnaIyS|s

< C/C++ - MyBarrier/src/MyBarrier.c - Eclipse SDK - C:\ews\runtime-cdt40

File Edit Refactor Source Statistics Navigate Search Project Run Window Help

L MM R -0 a O  BlEw Verify barrier

- L5 Resource

5 ) - - -
L Project Explorer &2 = B[ [ matrixio.c l.€| zzzzTemplateTest.c EE: MyBarrier.c &2 gE Outline &3 (@) Make Targets| = O Sy n c h ro n Iza t I o n I n C /

=) {35 MyBarrier : g | i == . o stdio.h e M PI prog ra ms

#- [ Includes _:’ ! EE a0 Bhasisshtd s = string.h
=53 src . = mpi.h
& < - '\0' ge ec _D ~
+-pst] MyBarrier.c y @ Barrier() : void
+- (= Debug - i y . @ main(int, char*[]) : int

s x Interprocedural static
analysis outputs:

+For verified programs,
lists barrier statements
that synchronize
c {2 Problems | | Tasks | &l Console |/ Barrier Matches 53 = O || Barrier Errors 52 i ¥ =0
{""main i || Barrier Matching Set Function tog eth er (m atCh)

main

/7, MP1 Barriers %

=
main Barrier Matching Set Function Filename LineNo | "1, Error L=

main =W Barrier 1(2) Barrier MyBarrier.c : i S PathiL(1 barrler(szrzr * FO r Sy n C h ro n I Z a tl O n

wh 2 er(s
main /) Barrier 1 Barrier MyBarrier.c 8 Eathi2(Qbamier)

T 'IIIA Ban::er? n{j\ﬁ MyBarrier.c il i "f‘;"[:c‘[oop (dynamic number of barriers) e r ro rs 7 re p O rts CO u n te r

MyBarrier.c 31

S tuiriobe — example that illustrates

i Barrier 1 Barrier Barrier.c 8

/i Barrier 3 main Barrier.c 4 a n d eX p I a i n S th e e rro r

"4 Barrier 4 (0) main MyBarrier.c 57
+- W Barrier 5 (1) main MyBarrier.c 62
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=

MPI Barrier Analysis — Try it

Run the Analysis:
+ In the Project

L[ Project Explorer &3

EXplOI‘eI‘, SElECt the 7 & shallow [cvs.ncsa.uiuc.edu)
project (or directory, S copmc 11
or file) to analyze (7 decs.h 1.3

|} diag.c 1.1

+ Select the MPI OHM et G
Barrier Ana|ySIS ¥ Show MPI Artifacts
action in the pu”- ' »Show OpenMPArtlfacts
down menu

# Show UPC Amfacts
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MPI Barrier Analysis — Try It (2) =

+ No Barrier Errors are found (no pop-up
indicating error); Two barriers are found

® Eclipse File Edit

L{*5 Project Explorer 23

=5 shallow [cvs.ncsa.uiuc.edu]

| calc.c 1.1

. copy.c 1.1

|k decs.h 1.3

|} diag.c 1.1

|7 dump.c 1.1

i Includes

|7 init.c 1.2

|7} main.c 1.4

|7 time.c 1.2

|7} tstep.c 1.1

|y worker.c 1.2
Afjaclocal.m4 1.1
JAUTHORS 1.1
4y Changelog 1.1
j compile 1.1
) config.guess 1.1

Module 3

e
=

Refactor Navigate Search Project Run Window Help
'c| C/C++ - shallow/main.c - Eclipse - /[Users/beth/ews/

l.c| main.c &3

MPI_Finalize();
return 1;

}

if (tid !'= @) {
worker();
MPI _Barrier(MPI_COMM_WORLD);
MPI_Finalize();

} else {

/* master process */

1 - - - VAR R |

/i MPI Barrier Matches |#7 MPI Barriers 23

Function Filename LineNo IndexNo
7 main main.c 89 1
/i main main.c 206 2
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MPI Barrier Analysis - views

/) MP1 Barriers &2 = B |/[2. Problems | | Tasks | &l Console | % Barrier Matches &2 = O || %4 Barrier Errors 52 i ¥ =08

i - i v Barrier Matching Set Function
=W Error main

Function Barrier Matching Set Function Filename LineNo |#
T ———————————————— +- Path 1 (1 barrier(s))

W7 main =W Barrier 1(2)  Barrier MyBarrier.c
i main i Barrier 1 Barrier MyBarrier.c
#h  main /i Barrier 3 main MyBarrier.c
¥ main =W Barrier 2 (1) main MyBarrier.c
W main /i Barrier 2 main MyBarrier.c

Barrier = Barrier 3 (2) main MyBarrier.c

7 Path 2 (0 barrier(s))
=W Error main
+-W Loop (dynamic number of barriers)

4 Barrier 1 Barrie MyBarrier.c
/i Barrier 3 main MyBarrier.c
" Barrier 4 (0) main MyBarrier.c

+- U Barrier 5 (1) main MyBarrier.c

MPI Barriers view Barrier Matches view Barrier Errors view
Groups barriers that

match together in a If there are errors, a
Like MPI Artifacts view, pgrrier set — all counter-example

double-click to navigate processes must go shows paths with
to source code line (all  through a barrier in the ~ MiSMatched number
3 views) set to prevent a of barriers

deadlock
Module 3 3-50
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Barrier Errors

+ Let’ s cause a barrier mismatch error

+ Open worker.c in the editor by double-clicking
on it in Project Explorer

+ At about line 125, 20 pry = worker (PREV)

t = worker[NEXT];
= - -~ :star‘t = worker[JSTART];
enter a arrler. 23 end = worker[JEND];
+ Type M PI_B 126 /¥ ; © MPI_Barrier(MPI_Comm ) int Blocks each task until
< "»C'»l @ MPI_Bcast(void*, int, MPI_Datatype, int, MPI_
1 <c @ MPI_Bsend(void*, int, MPI_Datatype, int, int,
+ H It Ctl _Space B for ( ® MPI_Bsend_init{void*, int, MPI_Datatype, int, w
. N M © MPIBuffer_attach( void®, int) int
+ Select M PI Ba rrier 3; ® MPI_Buffer_detach( void*, int *) int

+ Add communicator
arg MPI_COMM_WORLD and closing semicolon

MPI_Barrier(MPI_COMM_WORLD);

Module 3 3-51



paratiel-tools—platform

Barrier Errors (2)

+ Save the file
+ Ctl-S (Mac Command-S) or File > Save
+ Tab should lose asterisk indicating file saved

.c| *worker.c &3 .c| worker.c &3

+ Run barrier analysis on shallow project again

+ Select shallow
project in Project O 81 §lvo O

. Show MPI Artifacts
Explorer fir »
BOS st b Show OpenMP Amfacts

# Show UPC Amfacts
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Barrier Errors (3)

MPI Barrier Analysis

* Ba rrier‘ Error iS found ' Found barrier synchronization error(s)!
+ Hit OK to dismiss dialog O

+ Code diverges on line 87
+ One path has 2 barriers, other has 1

#7) MPI Barrier Matches |7 MPI Barriers |//) MPI Barrier Errors 23 . .0 P Double-click
on a row in
Barrier Matching Set Function Filename ineNo IndexNo .
#iErro main main.c @ 0 B_arrler E_rrors
U/iPath 1 (2 barrier(s)) 0 0 view to find
#/iBarrier 1 main main.c 89 1 - .
f/iRarric worker worker.c 3 the Ilne It .
0 0 references in
//iBarrier 2 main main.c 2 the Code
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Fix Barrier Error

l.c] worker.c 23 €| main.c

+ Fix the Barrier Error jg
before continuing

D I _ I H k h #7) MP1 Barrier Matches |/ MPI Barriers |#ZA\MPI Barrier Errors £3
* O u b e C I C O n t e Function Filgname LineNo
i

Barrier Matching Set
#/iError main

ba rrier in Worker.c f7iPath 1 (2 barrier(s))

f/iBarrier 1 main

tO qUICkly naVIQate /// Barrier 3 worker

#/iPath 2 (1 barrier(s))

to it #/iBarrier 2

+ Remove the line and save the file
_Or‘_
Right mouse on worker.c in Project Explorer
and do Replace With > Latest from HEAD

Team

Compare With
" ReplaceWith  p» _ latestfromHEAD

% Run C/C++ Code Analysis Another Branch or Version...

History...
Module 3 Properties Previous from Local History 3-54
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Remove Barrier Markers

+ Run Barrier Analysis again to remove the error
- and/or -

4+ Remove the Barrier Markers via the “X” in one
of the MPI Barrier views

//; MPI Barrier Errors &3 @ = O

Barrier Matching Set Function Filename LineNo
#/iError main main.c 87
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Synchronizing the Project
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Synchronizing the Project

+ Because we will be running on a remote
system, we must also build on that system

4+ Source files must be available to build

+ We will use a synchronized project to do this
+ Only needs to be done once for each project
+ A synchronized project could have been created
initially
+ Files are synchronized automatically when
they are saved

+ A full synchronize is also performed prior to a
build

Module 3 3-57



paratiel-tools platform

- \2\\

Converting To Synchronized

+ Select File>New>O0ther...

+ Open the Remote folder 60

+ Select Convert C/C++ Or |u
Fortran Project to a
Synchronized Project

+ Click Next> Ecrces

(= CVsS
(= Fortran
(= Java
(=~ Remote

Wizards:

& Convert C/C++ or Fortran Project to a Synchronized Project

[t Convert to a Remote Project

=) Remote C/C++ Project

[c]] Synchronized C/C++ Project

[ Synchronized Fortran Project
[~ Remote System Explorer

(=~ Tasks
(= XL UPC
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Convert Projects Wizard

Select checkbox next to “shallow”

For Connection:, click on New...
Enter as directed:

+ Target name

+ Host name of remote system

+ Userid and Password

Click Finish to close it
Back in the Convert Projects dialog,

Enter a directory name in the
Location field; select Browse...
+ Sample: /u/ac/trainXX/shallow

+ Project files will be copied under this
directory

Click Finish

Module 3

paratiel-tools—platform

Convert Projects

Convert to a synchronized project

Converts a managed or unmanaged project to a synchronized
project by adding a sync nature

Candidates for conversion:

™ (= shallow

Synchronization Provider: | Git ﬁ

Remote Provider: | Remote Tools _3]

Connection: forge

Location: fujac/trainXX/shallow

(  Cancel ) ( Finish \

LS

ication
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Synchronized Project

+ Back in the Project
Explorer, decorator on
project icon indicates ./ Project Explorer 23
synchronized project

+ Double-+ icon

== project

hallow

+ Before sync . calc.c 1.2

o5 shallow [dev.eclipse.org]

. copy.c 1.2
+ After sync .

'@shallow dev.eclipse.org)
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Set Active Build Configuration -

+ The “Active” build configuration determines which system will
be used for both synchronizing and building
+ Right-click on the project and select Build

Configurations>Set Active>Remote (Build on remote
machine)

Index

’ .
Synchronization Build All
Clean All

Validate Build Selected... 0

=

+ The project should synchronize immediately

Remote Synchronization: (46%)
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Building the Project
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Building the Project

+ Select the project in Project Explorer, click on the
hammer button to run the build 1

L[| Project Explorer &3 = | @ 65+ [&+ & 45 O Qe Qv | (B 7 -
v v * | v

N

lorer = (T
& shallow [dev.eclipse.org] - €] cale.c 52

+ By default, the Build Configuration assumes there is a
Makefile (or makefile) for the project

+ In this case, there is no Makefile,
SO the bUiId WI” faiI- * | Problems | v Task =1 Properties | [Z» Remote Environ

See CO N SO | e . CDT Build Console [shalloW

+ We’ || see hOW to Change it |f the bU||d ***% Build of configuration Remote for project shallow ****
command is different from make all
‘ TP, ke: *** No rule to make target “all'. Stop.
make —-f Makefile "

** Build Finished *¥**
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Fixing the Build Command: =9

Editing Project Properties

The build command is specified in the project properties

Open the properties by right-clicking on “shallow” and selecting
Properties (bottom of the context menu list)

Click on C/C++ Build
Uncheck Use default build command

Enter “make -f Makefile.mk” in the Build Command field
Click OK to close

+ +

+ 4+ 4+ +

Properties for shallow

project properties ———
dlalog Resource
zjgie'frsBuild Configuration: Remote [ Active ]

C/C++ Build

Build Variables
Discovery Options
Environment
Logging
Settings
Synchronize
Tool Chain Editor Builder type:
XL C/C++ Compiler -
C/C++ General |} Use default build command
Cvs
Discovery Options
Environment

Builder

Build command: make -f Makefile.mk
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Re-Building the Project =

+ Click on the B¥ button again to run the build
+ Build output will be shown in the Console view

‘['j'ﬁ Problems | v Tasks El Console 23 =) Properties Eb Remote Environments @I History
CDT Build Console [shallow]

main.c:97: error: syntax error before ':' token
main.c:97: error: syntax error before ')' token
main.c: At top level:

main.c:212: error: syntax error before "return"
make: *** [main.o] Error 1

¥¥¥¥% Build Finished *¥**

+ Exact output depends on your compiler
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+ Build problems will be
shown in a variety of
ways

+ Marker on file

Marker on editor line

Line is highlighted

Marker on overview ruler

Listed in the Problems
view

+ 4+ 4+ +

+ Double-click on line in
Problems view to go
to location of error in
the editor

Module 3
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Build Problems

| | C/C++ - shallow/m Eclipse - /Users/greg/Documents/workspace
55 Egc/c++ [yResource E0Team Synchr... £ Parallel Debug
O~
L5 Project Explorer &2 = 0|4 cale.c g€l main.c &
if (tid 1= 0) {
s - worker();
g shallow [cvs.ncsa.uiuc.edu ) MPI_Barrier(MPI_COMM_WORLD);
Lj cale.c 1.1 )0 MPI_Finalize();
g copy.c 1.1 )1 } else { stdio.h
|h) decs.h 1.3 decs.h
|.f} diag.c 1.1 worker() : vo
i dump.c 1.1 setup_res()
nil Includes main(int, char*(])
L init.c 1.2 setup_res() : MPI_Datatype
) main.c 1.4 ) calculate ) boundary */ update_global_ds(MPI_Dat:
iz "z y master_packet[JSTART] = (i - 1) * chunk_size;
L) tstep.c 1.1 1
PWOTRer.C

= 0|8z our R

math.h
mpi.h

if (i == proc_cnt -
afj aclocal.mé 1.1 . - ma =pUCKet [JEND] = n - 1;
AUTHORS 1.1 etse . .
o ) master_packet[JEND] = i * chunk_size - 1;
| Changglas
1 compile 1.1 10¢ if (i == 1)
j config.guess 1.1 1 prv = proc_cnt-1;
j config.h.in 1.1 1 else
3 config.sub 1.1 109 prv = i-1;
j configure 1.1 110
Af configure.ac 1
COPYING 1.1 : -
! o 11 if (i == proc_cnt - 1)
J¥gpcomp 1.1 11 nxt = 1;
§INSRQLL 1.1 11 else
Jinstall~ag 1.1 nxt = i41;
A Makefile.al
A Makefile.in 1
Makefile.mk 1.1
i) m;s;ng L1 1. Problems &3 | Tasks | £ Console | = Properties | @ Remote Environments | (5 History
A NEWS 1.1
) README 1

master_packet[PREV] = prv;

master_packet[NEXT] = nxt;

3 errors, 0 warning
A |Resource Path Location

& Errors (3 items)

(®) syntax error before "' token N m /shallow m C/C++ Problem _

@ syntax error before )' token main.c /shallow line 97 C/C++ Problem
@ syntax error before "return” main.c /shallow line 212 C/C++ Problem

syntax error before "' token
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Fix Build Problems =

Fix errors by changing “:’
Save the file

Rebuild by pressing build

button
Error markers have been

removed

Check console for correct
build output

Module 3

paratiel-tools platform

i)
v
1
ez

to ;7 on line 97

|h| decs.h l.€] copy.c l.c|] diag.c L] main.c 22 |.c] worker.c

/* master process */

chunk_size = n / (proc_cnt - 1);
for (1 = 1; 1 < proc_cnt; i+4) {

/* calculate each worker's boundary */

master_packet[JSTART] = (1 - 1) * chunk_size;

if (i == proc_cnt - 1)
master_packet[JEND] = n - 1;
else
master_packet[JEND] = i * chunk_size - 1;

—————————————————y

'* Problems | ¥ Tasks | &l Console £3
CDT Build Console [shallow]

**¥¥ Build of configuration Remote for project shallow ****

make -f Makefile.mk all

mpicc -g -c -o main.o main.c|

mpicc -g -c -0 time.o time.c

mpif99 -g -c -o tstep.o tstep.f90

mpicc -g -c -o worker.o worker.c

mpicc -g -c -0 dump.o dump.c

mpicc -g -0 shallow calc.o copy.o diag.o init.o main.o time.o tstep.o worker.o du

*¥¥¥x Build Finished ****
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Forcing a Rebuild =1

+ If no changes have been made,
make doesn t think a build is needed

+ In Project Explorer, Rightmouse on
project, select

Clean Project

- Clean Project 5
2 Refresh

Close Project
Close Unrelated Projects

+ See ConSOIe {2 Problems | ¥ Tasks | Bl Console £2

CDT Build Console [shallow]

*¥¥* (lean-only build of configura

+ Then rebUild make -f Makefile.mk clean

rm -f shallow calc.o copy.o diag.o

Module 3

'* | Problems | v:| Tasks | & Console £3
CDT Build Console [shallow]

make -f Makefile.mk all
make: Nothing to be done for “all'.
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Running the Program

Resource Managers
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Running the Program

+ Creating a resource manager

+ Starting the resource manager

+ Creating a run configuration

+ Running (launching) the application
+ Viewing the application run

Much of the following setup is
@ configuration that you only need to
do once: This icon will remind you.

Do this
once
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Resource Managers

+ PTP uses the term “resource manager” to refer to
any subsystem that controls the resources required
for launching a parallel job.

+ Examples:
+ Batch scheduler (e.g. LoadLeveler, PBS, SLURM)

+ Interactive execution (e.g. Open MPI, MPICH?Z2,
etc.)

+ Each resource manager controls one target system
+ Resource Managers can be local or remote
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Monitoring/Runtime Perspectives

+ Parallel Runtime Perspective
+ Used for legacy PTP Resource Managers
+ System Monitoring Perspective

+ Used for newer Configurable Resource Managers (since
PTP 5.0)

+ Which one is used?

Resource Manager System Monitoring Parallel Runtime
IBM LoadLeveler v

IBM Parallel Env (4
MPICH2 4

Open MPI 4
PBS-Batch-Generic (4

PBS-Batch-Interactive

Remote Launch (4

SLURM 4
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Preparing to Launch

+ Setting up a resource manager is done in the System Monitoring
perspective
+ (For PTP 5.0, this applies to PBS)

+ Select Window>0pen Perspective>Other...
+ Choose System Monitoring and click OK

Help

Hg C/C++ (defau New Window

CVS Repository Exploring
%5 Debug
@ Fortran
‘@JJava
JJava Browsing
?gjjava Type Hierar
ﬁParallel Debug
888 Parallel Runtime
) Planning

M %5 Debug
Show View 5U Team Synchronizing

Customize Perspective...
Save Perspective As...
Reset Perspective

Close Perspective

@Remote C/C++

[? Resource Close All Perspectives

s12: System Monitoring
EYTeam Synchronizing
X XML

Navigation

Working Sets

Preferences...
Cancel

3-73
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About PTP Icons

+ Open using legend icon in  SESSEEE—.

t00| bar (@) STARTING
(3) STARTED
(@ STOPPING
4, STOPPED
SUSPENDED

(@ ERROR

Machine Icons Node Icons

up up ? UNKNOWN
DOWN
ALERT
ERROR
UNKNOWN

PROCESS RUNNING

=
x| |f] PROCESS TERMINATED

==
.

Job Icons Process Icons
O STARTING « STARTING
RUNNING y RUNNING
SUSPENDED y SUSPENDED
COMPLETED « COMPLETED

 Close )
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Configuring Job Scheduler ‘

+ Right-click in Resource
Managers view and
select Add Resource
Manager

+ Choose Resource
Manager Type:
edu.illinois.ncsa.forge
.pbs.batch.openmpi

4+ Select Next>

Module 3
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File Edit Navigate Search Project Run Window Help

() Resource Managers 52 = O |[§88 System Monitor &2

+, Open_MPI@lincoln (Open MPI)

oo .
goa Active Jobs 23

Hr Qv Q

Do this

once
P Start Resource Manager
Stop Resource Manager
ooa I g
288 [nactivese
Add Resource Manager...
Remove Resource Manager

Edit Resource Manager

Set Default Resource Manage

Choose Resource Manager Type

Select the type of resource manager to use

Resource Manager Types:

IBM LoadLeveler

IBM Parallel Environment

MPICH2

Open MPI

Open MPI-Generic-Interactive
PBS-Generic-Batch
PBS-Generic-Interactive

Remote Launch

SLURM
edu.illinois.ncsa.forge.pbs.batch.mvapich2
edu.utk.nics.keeneland.pbs.batch
edu.utk.nics.kraken.pbs.batch

3-76



paratiel-tools—platform

-u u?}

Configure Control Connection

+ Choose Remote Tools for Remote service provider
+ Choose the remote connection you made previously Do this
+ Click Next> onee

Control Connection configuratioy

Enter connection information

Remote service provider: | Remote Tools
Connection name:

» Advanced Options
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Configure Monitor Connection

+ Keep default Monitor Connection (same as Control Connection),

click Next

Do this
once

Monitor Connection configuration

Enter connection information
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Common Configuration

+ Keep default name
+ Can automatically start Resource Manager (leave unselected

today)
+ Click Finish Lﬁ
<,
Do this

Common Resource Manager Configuration
once

Change any settings for the resource manager

Name and description

IZT Use default name and description:
Name:
Description: XML C

Startup
(") Automatically start resource manager when Eclipse starts

(  Cancel ) ( Finish *\
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Starting the Resource Manager

+ Right click on new
resource manager and

@ Resource Managers &3 = O[5

1:-: = - _
select Start resource T St Resource Manager —
mManager B S®p Resource Manager

+ If everything IS Ok, Add Resource Manager...
you should see the Remove Resource Manager
resource manager change o

a=« Active Jobs -
to green *  Set Default Resource Ma

+ If something goes wrong,
it will change
to

@ Resource Managers 23 @ Resource Managers &3

‘e, PBS-Generic-Batch (LML_JAXB) ¥ PBS-Generic-Batch (LML_JAXB)
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=

System Monitoring

forge.ncsa.illinois.edu

| System Monitoring - shallow/Makefile.mk - Eclipse - /Users/beth/ews/test1027-sc11-tutorial

System view, with
abstraction of nodes
for selected Resource
Manager

ic-Batch (LML_JAXB)

\ Select Resource Manag

=0

Active and inactive jobs

Hover over node in i

System view to see job [P o i “5 DDDD DDDDDD DDDDDDDD
runr_1ing on noc_Ie in : e ’ | DHHH HHHHHHQQQQQQQD
Active JobsgiEd 1 ot s o e _ T

make -f Makefile.mk all
icc -g -c -0 calc.o calc.c

Hold mouse button
down on a job in Active One node with
Jobs view to see where 16 cores
it is running in System
view
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Running the Program

(Launching a Job)
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Create a Run Configuration :..

once

= Run Configurations . » -®

ov ‘;(,'v ‘}Qv Ov

Create, manage. and run configurations
Create a configuration to launch a parallel application in Parallel Perspective

‘ = 3o v Configure launch settings from this dialog:

| Run As >

Run Configurations...

Organize Favorites..)

I

type filter text | - Press the 'New' button to create a configuration of the selected type.

[c] C/C++ Application =| - Press the 'Duplicate’ button to copy the selected configuration.
[F] Fortran Local Applical

- Press the 'Delete’ button to remove the selected configuration.
@ Launch Group

5=} Parallel Application

5 - Press the 'Filter' button to configure filtering options.

+ Open the run configuration
dialog Run>Run
Co nfig u rations - Configure launch perspective settings from the Perspectives preference page.

+ Select Parallel Application
+ Select the New button .

- Edit or view an existing configuration by selecting it.

Or, just double-click on oL

Parallel Application :

to create a new one @
Depending on which flavor of Eclipse you I_chte:hwe SOTheti?')es
: . . . interchange tne terms
msta_lled_, you might have more choices in “Run Configuration” and
Application types “Launch Configuration”
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Complete the Resources Tab

Enter a name for this run
configuration, e.g.
“shallow-pbs-batch”

In Resources tab, select
the PBS resource manager
you just created
(edu.illinois.ncsa.forge....)
Select the destination
queue - debug

The MPI Command field
allows this job to be run
as an MPI job

+ Choose mpirun
Enter the resources
needed to run this job

+ Use 1 nodes, 4 cores (MPI
tasks)

Module 3
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Do this
once

Run Configurations

Create, manage, and run configurations

Create a configuration to launch a parallel application

Name: _ shallow-pbs-batch

E 3’ Resources Application | (9= Arguments ?’;'-, Environment | Synchronize | -] Common
[C]c/C++ Application
Zl’oman Local Application

Java Applet
vTRPD

Resource Manager: | edu.illinois.ncsa.forge.pbs.batch.openmpi

. { Basic PBS Settings Advanced PBS Settings | Import PBS Script

@ Launch Group

E ;{Para[lel Application
§=% shallow

Name Value Description

Job Name: ptp_job The name assigned to the job by the gsub or galter commg

Account: Account to which to charge this job.
Queue: S Designation of the queue to which to submit the job.

Number of nodes: Number and/or type of nodes to be reserved for exclusive

Total Memory Needed: Maximum amount of memory used by all concurrent proce

Wallclock Time: 00:05:00 ' Maximum amount of real time during which the job can be

MPI Command: mpirun Which mpi command to use.

MPI Number of Cores: 4 )

<

the '-np' value

Export Environment: @ All variables in the gsub command's environment are to be

) ( View Configuration ) Restore Defaults

View Script )

’0,b- ]

. Revert
Filter matched 7 of 7 items

@ .' ) R
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Complete the Application Tab

Select the Application
tab

Choose the Application
program by clicking the
Browse button and
locating the executable on
the remote machine

+ Use the same “shallow”
executable

Select Display output
from all processes in a
console view

Click Run to submit the
application to the job
scheduler

Module 3
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Run Configurations

Create, manage, and run configurations

Create a configuration to launch a parallel application

X |5 3p- Name: ' shallow-pbs=h

5=} Resourcffs | [£] Application ) ()= Arguments | g Environment | Synchronize
[C]C/C++ Application Parallel Project:
[F|Fortran Local Applicatit
Java Applet
Java Application Application program:
= Launch Group
53} Parallel Application

5} shallow

shallow

Juf/ac/tibbitts /shallow/shallow

(] Copy executable from local filesystem

Path to the local file:

play output from all processes in a console view

> -

Filter matched 7 of 7 items

&

Do this
once

l\l/// )

] Common

( Browse )
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Job Monitoring

| | System Monitoring - shallow/Makefile.mk - Eclipse - /Users/beth/ews/test10

Job initially appears in A
“Inactlve JObS”, then II’] | (¥) PBS-Generic-Batch (LML_JAXB)
“Active Jobs”, then returns tofSs

Inactive on completion

This short-running program
may not run long enough to
appear in “Active Jobs”

ste T wete re: status
[0 3626.fsched ebu 600 2011... ? ? SUBMITTED
[ 3627.fsched ebu 600 2011... ? ? SUBMITTED

Status refreSheS [ ;:26.fschcd gopa ebu 630 2;('1‘;" ;7“ e m“; ;'L:II;:ASITT[D
: [0 3627.fsched gopal  debu 600 2011... ? ? SUBMITTED
automatlcally every 60 =le O 3736.fsched tibbite 27 2

Or force refresh with menu

After status = COMPLETED,
Can view output or error by

> Get Job Error

right clicking on job, selecting ) Get Job Output
appropriate output :

Module 3
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Job Output ‘*

¢ Inactive Jobs £3 =08
* After Status — CO M PLETE D, step owner queue wall queuedate dispatc¢ total¢ status
3626.fsched gopal debug 600 2011-1... ? ? SUBMITTED
1 3627.fsched  gopal debug 600 2011-1... ? ? SUBMITTED
Ca n VIeW OUtpUt Or error by 3769.fsched alberto normal 43... 2011-1... ? 18 SUBMITTED

right clicking on job, selecting 0 353 o3 counee
appropriate output

[0 3783.fsched tibbitts debug

. . Console £ Properties | ;.. Problems | v Tasks
+ Output/Error info shows in

ptp_job.03777

CO”SOIG VieW Potential energy 6.505 Kinetic [ner‘!

Total Energy 48032.916 Pot. Enstropl

Cycle number 950 Model time in days 9.9
Potential energy 760.460 Kinetic Enery
Total Energy 48385.996 Pot. Enstropl 75‘1 Refresh Job Status

Cycle number 1000 Model time in days 1.2« ¥ Remove Job Entry
Potential energy 21561.933 Kinetic Energy Z09359.9035
Total Energy 48000.496 Pot. Enstrophy 1.805456e-27 O
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Building before Run

Do this
once

To bring up Preferences dialog,

+ If projects build prior use Window>Preferences or
to launch, you can Mac: Eclipse>Preferences
’

tu rn It Off. Launching
+ O I n O Seneral Save required dirty editors before launching
G I t C/C++ ve reguired dirty editors before launching

Changelog () Always () Never ® Prompt
Fortran
P refe re n Ces > Ru n / Help Wait for ongoing build to complete before launching

Install/Update

Debug d nd Cl ICk on Java @® Aways (O Never (O Prompt

Library Hover Launch in debug mode when workspace contains breakpoints

- Mylyn _ -
La UNC h in g . P|ayr:11el Tools O Always @ Never (O Prompt

Remote Systems

U n Ch eC k n B u i Id if Remote Tools Continue launch if project contains errors
‘ Run/Debug () Always ® Prompt
Console

req u i red ) befo re GCeneral Options

- = Build (if required) before launching
Ia u n Ch I n g String Substitution @ Remove terminated launches when a new launch is created

View Management
) 9 'z[ Prompt for confirmation when removing a configuration from th
View Performance

Service Configurations + TR >

Preferences

+ Should be set by
default now

';7 Cancel | ( OK
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-u ‘3\\

Exercise

+ Start with your ‘shallow’ project

+ Create and start Resource Manager
+ Build; Run shallow

+ See results

+ Change something
+ Change m and n in decs.h

+ Rebuild and re-run
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Advanced Features

Searching
Fortran
Refactoring

Module 3 3-90



paratiel-tools platform

Searching
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o L

_——

Switching Perspectives =2

_—— _'\B

hrch  Project Run RULGGIVM Help
C/C++ New Window Eclipse SDK
35 New Editor

. . — Y=  (Open P i Deb .
+ Switch to C/C++ Perspective e ata s

Name Customize Perspective... Other...
O n e Of t h ree Wa ys = Author  Save Perspective As...
= ersiol - Reset Perspective...
escri] Close Perspective
Close All Perspectives

1. Choose the Window>Open Finclude <statih.ho (€ ~OpenFerspective ]
Perspective menu option ————
Then choose Other... ' ‘

CVS Repository Exploring

%5 Debug
#% PTP Debug
88 PTP Runtime

2. Click on the Open Perspective button in the
upper right corner of

screen (hover overitto [

see names)

(5 Resource
&Y Team Synchronizing

£ 0Ooo
goo Parallel Runt...

Cancel

3. Click on a perspective
shortcut button
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Find/Replace within Editor

+ Simple Find within editor buffer
+ Ctrl-F (Mac: Command-F)

™ O Find/Replace

Find: pmean|

Replace with: float ptqtf ket.ot ,etot,enstot,ptime,pmean;
int 1,],1P,]P;

Sl P ptot=0.; ketot-0.; etot-0.; enstot - @.; pmean = 9.;

® Forward ® Al 15 for (3 = 0; J < n; jes) {

16 for (1 = 0; 1 < m; 144) {
pmean = pmean+p[jJ][i];
}

-~ 9}

|_] Case sensitive @Wrap search 5¢ pmean = pmean/(m*n);

for (3 = @; 7 < n; j+d{

- ip = (3+1) % n;

(] Regular expressions 53 for (1 = @; 1 < m; 1+4){
54 ip = (1+41) % m;

() Backward () selected lines

Options

(] Whole word [} Incremental

P 55 ketot += p[jI[1]*0.25*CuljIipI*ul3I0ip]+ul3I01]*u[3101]
(___Find ) ( Replace/Find ) S +vipl(AI*vlipd (1J+v[3I0I*v[3I010);
57 ptot += (p[jI[i]-pmean)*(p[jI[i]-pmean);

" Replace ) ( Replace All ) 58 etot += h[31[i];
59 enstot += z[jp][ipJl*z[jpl[ip] * 0.25*%
Cp(310J+p (3] 0pd+p[Gp][ip]+p [Gp1[11D;

Close
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Mark Occurrences

(C/C++ Only)

+ Double-click on a variable in the CDT editor

+ All occurrences in the source file are
highlighted to make locating the variable
easier

+ Alt-shift-O to turn off (Mac: Alt-Cmd-0O)

l.c| diag.c 23
AR 3
11 float ptot,ketot,etot,enstot,ptime,pmean;

12 int  1,3,1ip,Jp;

14 ptot=0.; ketot}@.; etot=0.; enstot = @.; pmean = 0.;
15 for (3 = 0; J < n; J++) {
{ for (1 = @; 1 < m; 144) {
pmean = pmean+p[Jj][1];
}

)}
50 pmean = pmean/(m*n);
for (3 = @; j < n; J++d{
ip = (3+1) % n;
for (i = @; 1 < m; i44){

ip = (1+41) % m;
: ketot +=- p[jI[11*@.25*(uljIlip]*ulj][ipJ+ul3]1[i]*u[3][1]
Module 3 WGPITINVGPI T WGIEI VD, 3-94




paratiel-tools platform

Language-Based Searching

(C/C++ and Fortran)

+ “Knows” what things can ProjectWirclow + E.g., search for every call
be declared in each A to a function whose name
language (functions, " T; starts with “get”
variables, classes,

modules, etc.)

EC + Search can be project- or
ortran... 1
workspace-wide

— Ty oo — = - . )
) File Search | C/C++ Search | ) Fortran Search I 7 Java Search I 5 Plug-in Search T . E

Search string (* = any string, ? = any character): . i )
get* - Case sensitive 7 File Search | 5" C/C++ Search | By Fortran Search |17 Java Search I %" Plug-in Search

Search pattern:
Search For Limit To

. . . - get” Regular expression
Class / Struct V| Function Variable Declarations Definitions

. . (* = anv string. ? = any
Union V| Method Field /| References All Occurrences (* = any string, ? = any character)

Search for Limit to

Common block |[¥|Function All occurrences

Enumeration Enumerator Namespace

Typedef Macro Any Element
V| Subroutine Module Declarations

Scope Variable Program @ References

@ Workspace Selected resources Enclosing projects

Working set: Scope
@ Workspace Selected resources Enclosing projects

Working set: Choose...

Customize... I

Customize... ‘
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Find References

(C/C++ and Fortran)

+ Finds all of the places where a variable,
function, etc., is used

+ Right-click on an identifier in the editor

+ Click References»Workspace
or References» Project

References > Workspace
Search Text Project
Working Set...

038G

Make Targets

+ Search view

MPI_Init(&argc, &argv);
I_Comm_size(MPI_COMM_WORLD, &proc_cnt);
&tid); K

shows matches [l

if ( proc_cnt < 2 )|

_size(MPI_COMM_WORLD, &proc_cnt);
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Open Declaration

(C/C++ and Fortran)

Jumps to the declaration of [EETEEx
a variable, function, etc., 134
even if it’s in a different
file

initialise(p, u, v, psi, pold, uold, vold, di, dj, z);
diag(l, 0., p, u, v, h, 2);

for (i = 1; 1 < proc_cnt Undo

MP ar'

MPI_COMM_WOR
Open Declaration (]
acopy_two_to_one/ Open Type Hierarchy
MPI_Send(&u_staf"  Open Call Hierarchy

Left-click to select identifier
Right-click on identifier
Click Open Declaration

1
1
1
1 .
148
> acopy_two_to_onel Save
141 d
14¢
143
1
1

Goes to its declaration

in copy.c
C/C++ only: :
] L¢] main.c ¢ copy.c &3

Can also Ctrl-click - . _

. copy(src[column], dest[column], sizeof(src[column]));
(Mac: Cmd-click) on an 60}
. . g ‘“ . 11 bl
Identlﬂer to hyperllnk to 62 acopy_two_to_onef twodim,onedim, column)

its declaration 63 float  twodim[n][m];

64 float onedim[m];

51int column;
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Search - Try It!

- ‘2\\

1. Find every call to MPI Recwv in Shallow.

2. In worker.c, on line 42, there is a declaration
float pln] [m].

a) Whatism (local? global? function parameter?)
b) Where is m defined?

c) How many times is m used in the project?

3. Find every function whose name contains the
word time
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Fortran Specifics
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Project Properties

+ Right-click Project
+ Select Properties...

L™ Project Engr &3 45 remote Systems
_c >shallo dev.eclipse.org]

| calc.c 1.2
|7} copy.c 1.2

Properties for shallow
Resource

Path:
Type:

Builders /shallow

C/C++ Build
C/C++ General

Ccvs

Discovery Options
Environment

Paths and Symbols
Project References
Run/Debug Settings
Service Configurations
Settings

Task Repository
Task Tags

Tool Chain Editor
Validation

Project
Location:
Last modified: October 31, 2011 3:49:23 PM

Text file encoding

® Inherited from container (MacRoman)

O other: MacRoman v

New text file line delimiter

@ Inherited from container

Variables () Other:

WikiText

/Users/beth/ews/test1027-scl1l-tutorial/shallow

+ Project properties are settings
that can be changed for each
project

+ Contrast with
workspace preferences,
which are the same
regardless of what
project is being edited

+ e.g., editor colors

+ Set in Window »
Preferences
(on Mac, Eclipse»
Preferences)
+ Careful! Dialog is
very similar
3-100
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Converting to a Fortran Project

+ Are there categories labeled Fortran General
and Fortran Build in the project properties?

Do this
once

+ Switch to the Fortran Perspective

+ In the Project Explorer view, right-click on the
project, and click Convert to Fortran Project

+ Don’ t worry; it’ s still a C/C++ project, too [RESTEEUEULT

+ Every Fortran project is also a C/C++ Project
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Project Location

+ How to tell where a project

resides?

+ In the project properties

dialog, select the
Resource category

Module 3

I Resource

C/C++ Build
C/C++ GCeneral

CVS

Discovery Options
Environment

Paths and Symbols
Project References
Run/Debug Settings
Service Configurations
Settings

Task Repository
Task Tags

Tool Chain Editor
Validation

Variables

WikiText

Properties for shallow

Resource

Path: /shallow
Type: ;
Location:

Last mod

Text file encoding

O Inherited from container (MacRoman)

() Other: MacRoman ~

(] Store the encoding of derived resources separately

New text file line delimiter
® Inherited from container

() Other:

-

Cancel
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Error Parsers

+ Are compiler errors not appearing in the
Problems view? Do this
+ Make sure the correct error parser is enabled

+ In the project properties, navigate to
C++ Build »Settings or Fortran Build »Settings

+ Switch to the Error Parsers tab
+ Check the error parser(s) for your compiler(s)

¢ Binary Parsers  [I§ S Ervor Parsers

% CDT GNU Make Error Parser 6.0 (Deprecated)
{+=Photran Error Parser for GNU Fortran (gfortran)
£=CDT CGNU C/C++ Error Parser

£=CDT GNU Linker Error Parser

£=CDT GNU Assembler Error Parser

= Photran Error Parser for Absoft Fortran

= Photran Error Parser for Intel Fortran 8.1

v
v
v
v
v
v
v
v

(= Photran Error Parser for Lahey/Fujitsu Fortran 7.1
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Fortran Source Form Settings

+ Fortran files are either free form or fixed form;
some Fortran files are preprocessed (#define, #ifdef, etc.)

+ Source form determined by filename extension
+ Defaults are similar to most Fortran compilers:

Fixed form: .f fix for fpp ftn £77
Free form: .fO8 .fO3 .fo95 .f90 < unpreprocessed
.FO8 .FO3 .F95 .F90 < preprocessed

+ Many features will not work if filename extensions

are associated with the wrong source form
(outline view, content assist, search, refactorings, etc.)
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Fortran Source Form Settings .

Do this
once

Properties for shallow

+ In the project
properties, select

Builders Source form/filename associations:

FO rt ra n Gene ra I > >C/C++ Build File Name/Extension Source Form

»C/C++ General

Sou rce Fo rm cvs *F Fixed Form - INCLUDE lines ignored
> Fortran Build * FO3 Free Form - C Preprocessed
¥ Fortran General

Analysis /Refactoring *.Fo8 Free Form - C Preprocessed

+ Se | eCt source fO m % *F77 Fixed Form - INCLUDE lines ignored
fo r ea C h fl Ie n a m e Project References *FS0 Free Form - C Preprocessed

Source Form

- Run/Debug Settings *.F95 Free Form - C Preprocessed
extension
p Validation * FIX Fixed Form - INCLUDE lines ignored
*.FOR Fixed Form - INCLUDE lines ignored
+ Cl ICk o K *.FPP Fixed Form - INCLUDE lines ignored

*FTN Fixed Form - INCLUDE lines ignored
*f Fixed Form - INCLUDE lines ignored
Free Form
Free Form

Fixed Form - INCLUDE lines ignored

Cancel

Module 3 3-105



paratiel-tools—platform

Enabling Fortran Advanced Features

+ Some Fortran features are disabled by default @
+ Must be explicitly enabled Do this

+ In the project properties dialog,
select Fortran General » Analysis/Refactoring

+ Click Enable

. e OO0 Properties for shallow
Ana IySIS/ type filter text Analysis/Refactoring
>R
Refa Ctorl ng 83332:26 To enable Open Declaration, Find All Reference
» C/C++ Build view, content assist, and refactoring in Fortran
+ C|OS€ a n d re-O pen [3"C:/C+* General following box. A program database (index) wil
. o a Fortran file is created or saved.
any Fortran editors S i =
- VFortran General @1 Enable Fortran Declaration view
4+ This turns on the
Paths and Symbols sz Enable Fortran content assist (Ctrl+Space)
é ” Source Form ,
P h Ot ra n I n d exe r Project Refarances # Enable Fortran Hover tips

+ Turn it off if it’ s slow &
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aw ‘3\\

Project Properties — Try It!

1. Convert shallow to a Fortran project

2. Make sure errors from the GNU Fortran
compiler will be recognized

3. Make sure *.f90 files are treated as
“Free Form” which is unpreprocessed

4. Make sure search and refactoring will work in
Fortran
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Advanced Editing

Code Templates
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Code Templates

(C/C++ and Fortran)

+ Auto-complete common code patterns
+ For loops/do loops, if constructs, etc.
+ Also MPI code templates

+ Included with content assist proposals
(when Ctrl-Space is pressed)

+ E.g., after the last line in tstep.f90, type “sub” and
press Ctrl-Space

+ Press Enter to insert the template

Lm decs.h L€ init.c [] *tstep.foC

end do ‘
" end subroutine

) sub
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Code Templates (2)

(C/C++ and Fortran)

+ After pressing enter to insert the code
template, completion fields are highlighted

\h| decs.h L] init.c *tstep.f90 &3

)— subroutine amepar‘ameters)

)1 | end subroutine name

+ Press Tab to move between completion fields

+ Changing one instance of a field changes all
occurrences
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Advanced Editing — Try It!

aw ‘2\\

+ Open tstep.f90 and retype the last loop nest
+ Use the code template to complete the do-loops

+ Use content assist to complete variable names
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Custom Code Templates

(Fortran)

+ Customize code templates in Window »
Preferences » Fortran » Templates

Preferences

Templates

» Ceneral
» Ant Create, edit or remove templates:
PC/C++ Name Context | Description
P Dynamic Languages QT allocate (...) Fortran Allocate statement (lower case)
¥ Fortran (V¥ ALLOCATE (...) Fortran Allocate statement (upper case)
CDT Integration ™ call ... Fortran Call statement (lower case)
Editor ™ CALL ... Fortran Call statement (upper case)
 deallocate (...) Fortran  Deallocate statement (lower case)
» Help (¥ DEALLOCAT... Fortran Deallocate statement (upper case)
»Install/Update ™ do while...e... Fortran Do-while construct (lower case)
P Java ¥ DO WHILE...... Fortran Do-while construct (upper case)
P JavaScript QT do...end do Fortran Do-loop construct (lower case)
> Parallel Tools # DO...END DO Fortran Do-loop construct (upper case)
» PHP Qf forall...end... Fortran Forall construct (lower case)
P Plug-in Development QT FORALL...E... Fortran Forall construct (upper case)
> Remote Systems ™ function...e... Fortran Function (lower case)
> Remote Tools W FUNCTION..... Fortran Function (upper case)
[ Run/oebug M if then Fartran If-then ranctriirt (lower Face)

Service Configurations

+ Can import/export templates to XML files
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Refactoring and Transformation
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Refactoring

(making changes to source code that don’t affect the behavior of the program)

Roractor _ Refactoring is the research
Rename... : motivation for Photran @ Illinois

e Procedur' — Illinois is a leader in refactoring research
Extract Local Variable...

T NONE... “Refactoring” was coined in our group
(Opdyke & Johnson, 1990)

We had the first dissertation...
(Opdyke, 1992)

Introduce (MPLICI

Encapsu|ate variable...

...and built the first refactoring tool...
(Roberts, Brant, & Johnson, 1997)

...and first supported the C preprocessor
(Garrido, 2005)

Photran’ s agenda: refactorings for HPC,
language evolution, refactoring framework

Photran 7.0: 31 refactorings
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Refactoring Caveats

+ Photran can only refactor free form code that
is not preprocessed

+ Determined by Source Form settings

(recall from earlier that these are configured in
Project Properties: Fortran General»Source Form)

v Free Form, Unpreprocessed: .f08 .f03 .f95 .f90
Free Form, Preprocessed: .FO8 .FO3 .F95 .F90
Fixed Form: f fix  .for .fpp .ftn .f77

+ Refactor menu will be empty if
+ Refactoring not enabled in project properties

(recall from earlier that it is enabled in
Project Properties: Fortran General»Analysis/Refactoring)

+ The file in the active editor is fixed form

+ The file in the active editor is preprocessed
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Rename Refactoring

(also available in Fortran)

+ Changes the name of a variable, function, etc.,

including every use
(change is semantic, not textual, and can be workspace-wide)

+ Only proceeds if the new name will be legal
(aware of scoping rules, namespaces, etc.)

RN refsctor IRITIISNESTIIIDE 4+ Switch to C/C++ Perspective
Rename... Shift+Alt+R

S o ~ + Open a source file

d|v v %o (ov Extract Local Variable Shift+Alt+L

Extract Constant... Alt+C + In the editor, CliCk on a
Extract Function... Shift+Alt+M Variable or function name

.5 Project Explorer

In Java (Murphy-Hill et al., ICSE 2008): 4 Select menu item
“Refactoring _ Uses _Percentage Refactor» Rename

Rename 179,871 74.8%
Extract Local Variable 13,523 5.6%
Move 3208 o +Or use context menu
Extract Method 10,581 4.4%

Change Method Signature 4,764 2.0% + E n te r n eW n a m e

Inline 4,102 1.7%

Modu/e 3 Extract Constant 3,363 1.4% 3-116

(16 Other Refactorings) 10,924 4.5%
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Rename in File

(C/C++ Only)

+ Position the caret .| worker.c 53
over an identifier. 206 time_unload(prv,nxt, tu_my_1id,
307 int prv;
308 int nxt;
+ Press Ctri-1 100 int tumy_id:
(Command-1 on Mac). int jstart;
: int jend;
+ Enter a new name. 312 float  dvdt[n][m];
Changes are N 314 eighbor‘_send_(nxt, tu_my
propagated within 315 neighbour_receive(prv, tu

the file as you type.

a generaL purpose run

121 neighbour_send(ns_neighbour,n
: int ns_neighbour;
323 int ns_my_1id;

int ns_rec_1id;
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Extract Function Refactoring

(also available in Fortran - “Extract Procedure”)

+ Moves statements into a new function, replacing the
statements with a call to that function

+ Local variables are passed as arguments

Changes to be performed

I + Select a sequence of
Original Source Refactored Source
o i statements
Y for O =8 3 <n; Jan) 1 83 for (G = 0; 3 < n; j4) { )
it i i R B for (= 0) 1 <m; in) { + Select menu item
} e 3 Refactor»

8 Extract Function...

+ Enter new name

= 0 printhamer0y ]
9 printf("Shallow water weather model - [ "1_} i L0 1]
) printf("Number of points in the X direc

AL\ w Al nmAatnbkes Te kA VAl A "

ek £ LAPREA N
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Introduce ImpLIiCcIT NONE Refactoring

+ Fortran does not require variable declarations
(by default, names starting with I-N are integer variables; others are reals)

+ This adds an IMPLICIT NONE statement and adds explicit
variable declarations for all implicitly declared variables

+ Introduce in a single file by
Changes to be performed. R opening the file and selecting

Refactor»Coding Style»
Introduce IMPLICIT NONE...

F] tstep.fo0

Original Source Refactored Source

e ISR RC ATl + [ntroduce in multiple files by
T _ Tmplicit none selecting them in the Project
integer(kind=C_INT), integer :: i . . c -
real(iind-C_FLOATY; - integer :: ] Explorer view, right-clicking on
) the selection, and choosing
Refactor» Coding

Style» Introduce IMPLICIT
NONE...
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Loop Transformations

(Fortran only)

+ Interchange LOOPS CAUTION: No check for behavior preservation
+ Swaps the loop headers in a two-loop nest

+ Select the loop nest, click menu item > >
Interchange Loops (Unchecked)...

e OO0 Interchange Loops (Unchecked)

Changes to be performed

IET ¥ @3 Interchange Loops {(Unchecked)

V] 22 tstep.f90 - shallow

F] tstep.f90

Original Source Refactored Source

61 doi=1, m 61 do j = jstart+l, jend+l
do j = jstart+l, jend+l b doi=1,m
pnew(1,]j) = pold(i,j) + tdt 63 pnew(1,j) = pold(1,]
unew(i,j) = uold(i,j) + tdt 64 unew(1i,j) = uold(i,]
vhew(i,3j) = vold(i,j) + tdt 65 vhew(i,3j) = vold(i,j
end do 66 end do
end do 67  end do
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Loop Transformations

+ Unroll Loop
+ Select a loop, click Refactor»Do Loop»Unroll Loop...

do i =1, 12

print *, 10*1
end do
Unroll 4x
do 1 =1, 12, 4
print *, 10*1
print *, 10* (1i+1)
print *, 10*(1+2)
print *, 10*(1+3)
end do

Module 3

(Fortran only)

[F tstep.f90

Original Source

! Don't apply time filter on first
if ( firststep == @ ) then
do j = jstart+l, jend+l
doi=1, m
pold(i,j)
uold(i,3)
vold(i,j)
end do
end do
end if

p(i,jd)+alpha*(pne
u(i,jd)+alpha*Cune
v(1i,j)+alpha*(vne

do j = jstart+l, jend+l
doi1=1, m
p(i,3)
u(i, 3
v(i,])
end do
end do
i7-end subroutine

pnew(i,j)
unew(i,j)
vnew(i,j)

Refactored Source

end do
end if

do j = jstart+l, jend+l
loopUpperBound = m
do 1 = 1, loopUpperBound,4
p(i,3) = pnew(i,j)
u(i,j) = unew(i,j)
v(i,j) = vnew(i,j)
p((i+1),3) = pnew((i+1)
u((i+1),3) unew((1+1)
v((i+1),3) vhew((i+1)
p((i+2),]3) = pnew((i+2)
u((i+2),3) unew((1+2)
v((i+2),3) vhew((142)
p((i+3),3) = pnew((i+3)
u((i+3),3) unew((1+3)
v((1+3),3) vhew((1i+3)
end do
end do
)2 end subroutine
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Refactoring & Transformation — Try It!

In tstep.f90...

1. In init.c, extract the printf statements at
the bottom of the file into a new function
called print banner

2. In worker.c, change the spellings of
neighbour send and neighbour receive
to American English

3. In tstep.f90, make the (Fortran) tstep
subroutine IMPLICIT NONE
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‘ NCSA Blue Waters
HPC Workbench

+ Tools for NCSA Blue Waters
+

+ Sustained Petaflop system
+ Based on Eclipse and PTP
+ Includes some related tools
+ Performance tools

+ Workflow tools (https://wiki.ncsa.uiuc.edu/
display/MRDPUB/MRD+Public+Space+Home
+Page)

+ Part of the enhanced computational environment
described at:
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NSF SI12 Workbench for High
Performance Computing

+ “SI2-SSI Productive and Accessible Development Workbench
for HPC Applications”, which is supported by the National
Science Foundation under award number OCI 1047956

+ Produce a productive and accessible development
workbench using Eclipse PTP

+ Key Components
+ Determining Requirements, Ensuring Impact
+ Make improvements to Eclipse PTP
+ Engineering Process
+ Metrics
+ Outreach/Training/Education
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Coding & NCSA HPC Workbench .
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Planned PTP Future Work

+ Scalability improvements
+ UI to support 1M processes
+ Very large application support
+ Usability improvements
+ New wizard to improve setup experience
+ Ability to share configuration information

+ Resource Managers

+ More implementations of configurable resource
managers

+ Synchronized project improvements
+ Conversion wizard
+ Resolving merge conflicts
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Useful Eclipse Tools

+ Linux Tools (autotools, valgrind, Oprofile, Gprof)
+ http://eclipse.org/linuxtools
+ Python
+ http://pydev.org
+ Ruby
+ http://www.aptana.com/products/radrails
+ Perl
+ http://www.epic-ide.org
+ Git
+ http://www.eclipse.org/egit

+ VI bindings
+ Vrapper (open source) - http://vrapper.sourceforge.net
+ vVviPlugin (commercial) - http://www.viplugin.com
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Online Information

+ Information about PTP
+ Main web site for downloads, documentation, etc.
+http://eclipse.org/ptp
+ Wiki for designs, planning, meetings, etc.
+http://wiki.eclipse.org/PTP
+ Articles and other documents
+http://wiki.eclipse.org/PTP/articles

+ Information about Photran
+ Main web site for downloads, documentation, etc.
+http://eclipse.org/photran
+ User’' s manuals

+http://wiki.eclipse.org/PTP/photran/

documentation
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Mailing Lists

+ PTP Mailing lists

+ Major announcements (new releases, etc.) - low volume
+ http://dev.eclipse.org/mailman/listinfo/ptp-announce

+ User discussion and queries - medium volume
+ http://dev.eclipse.org/mailman/listinfo/ptp-user

+ Developer discussions - high volume
+ http://dev.eclipse.org/mailman/listinfo/ptp-dev

+ Photran Mailing lists

+ User discussion and queries

+ http://dev.eclipse.org/mailman/listinfo/photran
+ Developer discussions -

+ Also on ptp-dev list (see above)
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Getting Involved

+ See http://eclipse.org/ptp

+ Read the developer documentation on the wiki
+ http://wiki.eclipse.org/PTP

+ Join the mailing lists

+ Attend the monthly developer meetings
+ Conf Call Monthly: Second Tuesday, 1:00 pm ET
+ Details on the PTP wiki

+ Attend the monthly user meetings
+ Teleconf Monthly: 4t Wednesday, 1:00 pm ET
+ Details on the PTP wiki

PTP will only succeed with your participation!
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