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Tutorial Outline

Time Module Outcomes Presenter
1:30 - 2:30 | 1. Overview of Eclipse + Introduction to PTP Greg
and PTP + Eclipse basics
+ Configuring Resource
Managers & setup
2:30-3:00 2. Creating and Running +PTP project creation Beth
MPI Programs +New project wizards
+PTP Runtime Perspective
3:00 - 3:30 | Break
3:30 - 4:00 | 3. Parallel Language + MPI, OpenMP analysis Beth
Development Tools (PLDT) features
4:00 - 4:30 | 4. Parallel Debugger + Debug Perspective, Greg
breakpoints, variables,
stepping, etc.
4:30 - 5:00 5. Advanced Eclipse and + CVS, Makefiles, autoconf, Greg
PTP features Search, Refactoring, UPC,
Remote debugging, MPICH2,
IBM PE & LoadLeveler
5:00 - 5:30 6. Other, Summary, + Perf. Tools? Website, mailing Beth
Wrapup lists, more info, participation "




Module 1: Overview of Eclipse
and PTP

+ Objective
+ To introduce the Eclipse platform and PTP
+ To learn the basics of Eclipse
+ Contents
+ What is Eclipse? Who is using Eclipse?
+ What is PTP?
+ Eclipse basics
+ Configuring a Resource Manager
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History

+ Originally developed by Object Technology
International (OTI) and purchased by IBM for
use by internal developers

+ Released to open-source community in 2001,
managed by consortium
+ Eclipse Public License (EPL)

+ Based on IBM Common Public License (CPL)

+ Consortium reorganized into independent not-
for-profit corporation, the Eclipse Foundation,
in early 2004
+ Participants from over 100 companies
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Eclipse Foundation & Members

+ Board of Directors and full-time Eclipse
management organization

+ Councils guide the development done by Eclipse
Open Source projects

+ 180 members (March ‘08)
+ 21 strategic members

+ 942 committers, representing 50+ organizations

Strategic Members
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Eclipse Member companies

Eclipse Membership through March 2008

180

91

asdijap
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EC2004 EC2005 EC2006 EC2007 EC2008
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What is Eclipse?

+ A vendor-neutral open source development
platform

+ A universal platform for tool integration

+ Plug-in based framework to create, integrate
and utilize software tools

Java C/C++/Fortran Test and
Development Development Performance Parallel Tools
Tools Tools Tools
n___
Platform
| Equinox |
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Eclipse Platform

+ Core frameworks and services with which all

plug-in extensions are created

+ Represents the common facilities required by

most tool builders:

+ Workbench user interface

+ Project model for resource management

+ Portable user interface libraries (SWT and JFace)

+ Automatic resource delta management for
incremental compilers and builders

+ Language-independent debug infrastructure

+ Distributed multi-user versioned resource
management (CVS supported in base install)

+ Dynamic update/install service
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Plug-ins

Java Development Tools (JDT)

Plug-in Development Environment (PDE)
C/C++ Development Tools (CDT)

Parallel Tools Platform (PTP)

Fortran Development Tools (Photran)

Test and Performance Tools Platform (TPTP)
Business Intelligence and Reporting Tools (BIRT)
Web Tools Platform (WTP)

Data Tools Platform (DTP)

Device Software Development Platform (DSDP)
Many more...
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Parallel Tools Platform (PTP)

+ The Parallel Tools Platform aims to provide a highly
integrated environment specifically designed for parallel
application development

+ Features include:

+ An integrated development environment (IDE) that
supports a wide range of parallel architectures and runtime
systems s ‘

+ A scalable parallel debugger

+ Parallel programming tools
(MP1/0OpenMP)

+ Support for the integration
of parallel tools

+ An environment that simplifies the
end-user interaction with parallel systems

+ http://www.eclipse.org/ptp
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PTP
Software Prerequisites

+ Java (1.5 or later)
+ Cygwin or MinGW (for Windows)

+ make, gcc, and gdb (or other vendor
compilers)

+ OpenMPI or MPICH2 (only required for PTP
Runtime)

Note:
+ Linux & Mac have full PTP support

+ Windows can be used for Eclipse, targeting a
remote parallel machine
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Java Prerequisite

+ Eclipse requires Sun or IBM versions of Java
+ Only need Java runtime environment (JRE)
+Java 1.5 is the same as JRE 5.0

+ The GNU Java Compiler (GCJ), which comes standard

on Linux, will not work!

Module 1 PTP Tutorial
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Eclipse and PTP Installation

+ Eclipse is installed in two steps

+ First, the ‘base’ Eclipse is downloaded and installed

+ This provides a number of pre-configured ‘features’

+ Additional functionality is obtained by adding more

‘features’

+ This can be done via an ~update site’ that
automatically downloads and installs the features

+ Features can also be downloaded and manually
installed

+ PTP requires the following features
+ C/C++ Development Tools (CDT)
+ Parallel Tools Platform (PTP)
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Eclipse Installation

+ Two alternatives for installation:

+ The Eclipse Classic is the full software development kit
(SDK), including Java and Plug-in development tools

+ The Eclipse IDE for C/C++ developers is the base Eclipse
platform plus the CDT (C/C++ Development tools).
This is ideal for PTP use (included on the tutorial CD)
+ Eclipse is downloaded as a single zip or gzipped tar file
from http://eclipse.org/downloads
+ You must have the correct file for your operating system
and windowing system
+ Unzipping or untarring this file creates a directory
containing the main executable
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Platform Differences

+ Single button mouse (e.g. MacBook)

+ Use Control-click for right mouse / context menu
+ Context-sensitive help key differences

+ Windows: use F1 key

+ Linux: use Shift-F1 keys

+ MacOS X

+ Full keyboard, use Help key

+ MacBooks or aluminum keyboard, create a key binding
for Dynamic Help to any key you want

+ Accessing preferences
+ Windows & Linux: Window » Preferences...
+ MacOS X: Eclipse»Preferences...
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Starting Eclipse I

+ Linux
+ From a terminal window, enter
<eclipse_installation>/eclipse/eclipse &

+ MacOS X
+ From finder, open the Applications»eclipse folder
+ Double-click on the Eclipse application
+ Windows
+ Open the eclipse folder
+ Double-click on the eclipse executable

+ Accept default workspace when asked .
+ Select workbench icon from welcome page (LA
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Specifying A Workspace I

+ Eclipse prompts for a workspace location at
startup time

+ The workspace contains all user-defined data
+ Projects and resources such as folders and files

g Workspace Launcher =%
Select a workspace
Eclipse SDK stores your projects in a folder called a workspace.
The prompt can be Choose a workspace folder to use for this session.
tu rned Off Workspace: |/home/tutnn/workspace Il] ‘ Browse...

[[] Use this as the default and do not ask again
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Eclipse Welcome Page

+ Displayed when Eclipse is run for the first time

Java - Eclipse SDK
Eile Edit Refactor Navigate Search Project Run Window Help
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Adding Features

+ New functionality is added to Eclipse using features

+ Features are obtained and installed from an update site
(like a web site)

+ Features can also be installed manually by copying files
to the features and plugins directories in the main
eclipse directory
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Installing Eclipse Features
from an Update Site

+ Three types of update sites
+ Remote - download and install from remote server
+ Local - install from local directory
+ Archived - a local site packaged as a zip or jar file
+ Eclipse 3.3.2 comes preconfigured with a link to the
Europa Discovery Site

+ This is a remote site that contains a large number of official
features

+ Europa projects are guaranteed to work with Eclipse 3.3.2
+ Many other sites offer Eclipse features
+ Use at own risk
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+ 4+ +

Installing from a Local Update Site

. . £ Install [=]]
We have combined everything needed | qate sites to visit ;
for the tutorial onto a local update Site | seiect update sites to isit whik looking for new features =
on the CDROM

Sites to include in search
From the Help menu, choose A Europa Discovery Site New Remote site
Software Updates»Find and o1 The Eclpse Project Updates New Local site...
I nStaI I e New Archived Site.
Select Search for new features to
install
Click Next > /
Click New Local Site... mport sites...
Navigate to your CDROM, select the Exportsites.,
updatesite folder and click Choose
(OK on Linux or Windows) @ tnore fea DT
Enter Tutorial for the Name Tutorial |
(or use default: TutorialCD/updatesite) URL: _ [file:jmediajcdromupdatesite/
Click OK
OK Cancel
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Installing Tutorial Features

+ Make sure only Tutorial

is selected, other options Search Rosults
as defau Its Select features to install from the search result list.

+ CIICk FInISh Select the features to install:

+ From Search Results, BT | oeselect Al |
select Tutorial (open
the twisty to see the
contents)

o (%
) =

&)

| select Required

1 of 1 selected.
¥ Show the latest version of a feature only
] Filter features included in other features on the list
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Choose features oo —

Select features to install from the search result list

Select the features to install:

4+ Choose PTP features to Gy Aroracormsmine Comeeass )
install

+ Easy way to choose: —

0.0 21 welected.

+ S I I I Select the features to install:
e eCt a = [ ¥ ptp-updatesite-2.0.0.200803280847.zip
.
+ Unselect anything
- T3 » ) @ PTP Parallel Language Development Tools 2.0.0.200803280847
Wlth red X ¢ PTP Common External Components 2.0.0.200803280847

» Parallel Tools Platform End-User Runtime 2.0.0.200803280847

+ This omits features
for which you lack
the pre-requisites

&

PTP Remote Tools Enabler 2.0.0.200803280847

PTP RSE Enabler 2.0.0.200803280847

PTP Remote Tools 2.0.0.200803280847

PTP Support For IBM LoadLeveler 2.0.0.200803280847

PTP Support For IBM Parallel Environment 2.0.0.200803280847
PTP Support For Open MPI 2.0.0.200803280847

PTP Scalable Debug Manager 2.0.0.200803280847

PTP Support For MPICH2 2.0.0.200803280847

PTP Performance Analysis Framework 1.0.0.200803280847
PTP Remote Development Tools 1.0.0.200803280847

PP e Analysis for TAU 1.0.0. 7

PTP Performance Analysis Framework: TAU Fortran Enabler 1.0.0.200803280847
PTP Parallel Language Development Tools - LAPI support 2.0.0.200803280847

R R R R R R R R R R
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Finishing Installation I

Click Next >

Accept the license terms
Click Next >

Click Finish

For Feature Verification, click
Install All

Restart the Eclipse Platform when
asked

+ +++++

Install/Update

It is recommended you restart the Eclipse Platform for the

@ changes to take effect, but it may be possible to apply the
changes to the current configuration without restarting. Would
you like to restart now?

Ly )l Mo

| [apply Changes |

Module 1

£ updates o %

Search Results

Select features to install from the search result list. ,{)‘-
e

Select the features to install:

» @[ Tutorial | Dpeselect Al |

\§elect Required

@
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Restarting Eclipse

.

C/C++ - Eclipse Platform - /home/beth/ecl/cpp0402/eclipse/~/ews/temp0402a -ox
Fle Edit Refactor Navigate Search Project Run Window Help
+ Welcome page |
informs you of
new features
installed ‘
Overview Go @ orkbench
+ Select workbenc
workbench icon The Eclipse Platform is a kind of universal tool platform - an open extensible IDE for anything and nothing in particular
to go to = Parallel Tools Platform
Workbench Leam more about PTP, the Parallel Tools <+—
Platform Ye"OW
i indicates new
| Parallel Language Development Tools -
Leam more about PLDT, to help in developing Teatures JUSt
MPI and OpenMP programs. installed
= Workbench basics
_j Leam about basic Eclipse workbench concepts
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(Installing the PTP Proxy)

+ Normally installed on a parallel machine
+ e.g. a cluster
+ Can install on a non-parallel system
+ Not available for Windows
+ Requires OpenMPI to be built and installed
+ This process depends on the type of machine
+ Beyond the scope of this tutorial
+ To install the proxy, do the following steps from a terminal
+ Change to your Eclipse installation directory
+ Change to plugins/org.eclipse.ptp.os.arch_2.0", where
os is your operating system (macosx or linux), arch is your
architecture (ppc, x86, or x86_64)
+ Run the command: sh BUILD
* Directory may include a suffix of build date timestamp.
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Workbench

+ The Workbench T Resource - Ecllpse 50K ol
represents the deSktOp File Edit Navigate Seach Proect Run  Window Help ‘ -
. v w Qv | A vy © Qe Do £7 |LoResource «
development environment | == -
+ It contains a set of tools
for resource management
+ It provides a common et Ocmsl O X % °°0
way of navigating — —= ‘{"""*l. —
through the resources e i '

+ Multiple workbenches can
be opened at the same
time g ) :

Module 2 PTP Tutorial 2-25




Workbench Components

+ A Workbench contains perspectives
+ A Perspective contains views and editors

Edit Refactor Navigate Search Project Run  Window Help
. v SRR S Al vy O Ov Py 1|\ OResource|
pe rSpeCtIVe Project Explocer & 0 | (8 MyCproject.c & =]
) = &5 MyCproject ]
edltor TR ain(void) {
b & Includes puts(“1!1Hello World!!!"); ‘
/wu ) return EXIT_SUCCESS; |
b [ . -
/ b @ Debug o 2
“)Tasks £ . O Consale X ¥ <=0
i = Outline & —lp
VvViews BN e 7 I [no«nrmn ]Rueum ]F
\ u s:doh
o main(void) : int < ] )
.
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+ Perspectives define the layout of views in the
Workbench

+ They are task oriented, i.e. they contain
specific views for doing certain tasks:

+ There is a Resource Perspective for manipulating
resources

+ C/C++ Perspective for manipulating compiled code
+ Debug Perspective for debugging applications

+ You can easily switch between perspectives
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Switching Perspectives

* YOU Can SWltCh )] Resource - MyCprojectsrc/MyCproject.c - Eclipse SDK
H - Eile Edit Refactor Navigate Seach Project Run  Window Help

Perspec_tlves by: SR

+ Choosing the =o
Window»Open _ H
Perspective menu |° L
Option return EXIT_SUCCESS; i ‘

+ Clicking on the " ¢ ¢ & ] o
Open Perspective | OTasks & @ Consce 5% %~ °0
bUtton - |1 [Desciption [Resource ¢

+ Clicking on a i
perspective shortcut| - msve i [ [ o)
button >

Module 2 PTP Tutorial 2-28

Available Perspectives

) Window»

+ By default, certain Open Perspective
perspectives are available T
in the Workbench LS Open Perspective x

+ We’ “ use: {#a CVS Repository Exploring

%5 Debug
+ C/CH+ #% PTP Debug
+ PTP Runtime §8 PTP Runtime
{5 Resource
+PTP Debug £0 Team Synchronizing
OK | Cancel
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Views

4+ The workbench window is
divided up into Views

+ The main purpose of a view is:
+ To provide alternative ways of presenting information
+ For navigation
+ For editing and modifying information

+ Views can have their own menus and tQolbars

+ Items available in menus and toolbars are
available only in that view

+ Menu actions only

apply to the view o= Outline 22 % W ¥ o ¥ =0
+ Views can be resized e main() : int
Module 2 PTP Tutorial 2.30

Stacked Views

+ Stacked views appear as tabs

+ Selecting a tab brings that view to the
foreground

Project ExplodNG O/ (& MyCpeojecte i

#include <stdio.h>

= &5 MyCproject #include <stdlib.h>
b
WeBlnasies int main(void)
b eV Includes puts(“!!tHello World!!!");
> Bsn Teturn EXIT_SUCCESS;
b [ o
3]
@ Debug 2
“)Tasks £ O Consde 1 X B T°0
= Outline &2 0 isems
YN e T [v I! ]Do«nam [anm IF
U sidioh
U sidkb.h
o mainivoid) : int Ie y 0
)
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Access help

+ Help»Help Contents

+ Help»Search

+ Help»Dynamic Help
Help Contents provides
detailed help on different
Eclipse features
Search allows you to
search for help locally, or
using Google or the Eclipse
web site
Dynamic Help shows help
related to the current
context (perspective, view,
etc.)

Module 2

(v Help - Eclipse SDK [=)5])x]
Search: Search scope: All topics
Contents ¢ = g Cw|RelS b

" Workbench User Guide

> Java Development User Guide
“ Platform Plug-in Developer Guid
“* JDT Plug-in Developer Guide
" Plug-in Development Environme
" PTP: Parallel Tools Platform

‘" PTP Parallel Language Developr
" CDT Plug-in Developer Guide
" C/C++ Development User Guide

[

Using the Eclipse help system

Browse topics in the Contents frame (&) on
the left. Click on a topic to have it displayed.
Use the Back and Forward buttons to
navigate within the history of viewed topics.

Searching

To quickly locate topics on a particular
subject in the documentation, enter a query in
the Search field. Use the Search frame (7 ) to
display the Search view. You can narrow the
scope of your search by selecting only the
sections you are interested in. [zfﬂ

7]

PTP Tutorial
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Open PTP Runtime Perspective

Window > Open Perspective > Other...

I e

New Window b ‘
New Edit p .
: ‘ = Open Perspective =)
q Open Perspective | %5 Debug
| Show View > £0 Team Synchronizing | EICICR RESr
CVS Repository Exploring
Customize Perspective... Other... %5 Debug
Save Perspective As... K i PTP Debug

Reset Perspective
Close Perspective
Close All Perspectives

Navigation >
& Working Sets >
Preferences...
Module 1 PTP Tutorial

£82 PTP Runtime
[25 Resource
50 Team Synchronizing

e |




Terminology

+ The PTP Runtime perspective is provided for

monitoring and controlling applications
+ Some terminology

+ Resource manager - Corresponds to an instance of

a resource management system (e.g. a job

scheduler). You can have multiple resource mangers

connected to different machines.
+ Queue - A queue of pending jobs
+ Job - A parallel application
+ Machine - A parallel computer system

+ Node - Some form of computational resource
+ Process - An execution unit (may be multiple

threads of execution)

Module 1 PTP Tutorial 1-34
PTP Runtime Perspective I
[ £ PTP Runtime - mpitest/mpitest.c - Eclipse SDK_ BER

Resource B IR s B
managers view=—jp| s
Machines view—p
Node details
view >
Jobs View ——p|
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Resource Managers

+ PTP uses the term resource manager to refer to any
subsystem that controls the resources required for
launching a parallel job.

+ Examples:

+ Job scheduler (e.g. LoadLeveler)

+ Open MPI Runtime Environment (ORTE)
+ Each resource manager controls one target system
+ Resource Managers can be local or remote

Module 1 PTP Tutorial 1-36

Adding a Resource Manager

£ PTP Runtime - mpitest/mpitest.c - Eclipse SDK.
fle Edit Refactor Navigate Search Project Run Window Help

+ Right-click in Resource
Managers view and select
Add Resource Manager

w By Ov Q- =

- Resource Managers &2 =

& Machines 2

4+ Choose the ORTE P

8 )
Resou rce Manager Choose Resource Manager Type
Type Select the type of resource manager to use

Resource Manager Types:
LSF

4+ Select Next> MPICH2

Next > [ cancel

Module 1 PTP Tutorial




Configure the

ORTE Proxy Configuration

| Enter information to connect to an ORTE proxy server

Remote service provider: | Local

Resource Manager I

+ Can choose Remote
service provider

+ Can choose Proxy
server location

| Proxy server location: Local

i [ Launch server manually
|

| Path to proxy executable: |8~57/h‘rnfplp_urlcymxy{: Browse

ORTED Configuration

Enter information to configure ORTED |

¥ Use default settings

Options...
Muitiplexing Options
® None | Choose Resource ger Name and ipti
Local address for proxy connection: [localhost Jocaldomain v l Enter a name and description for the resource manager

] Use default name and description:
Name:

ORTE@Local

Description: |ORTE Resource Manager

® Nexq Path to ORTED:
Extra ORTED arguments:
i p

. 7) k | i e |
For details on remote o [e] Soeh cance
resource managers, see
Module 5 % <pack || Next> Finish Cancel
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Starting the Resource Manager

+ Right click on new
resource manager and
select Start resource
manager

If everything is ok, you
should see the resource
manager change to green
If something goes wrong,
it will change to red

(+) ResoMPce Managers &3

@ ORTE@N.N.N.N (ORTE)

Module 1

\

PTP Tutorial

(+) Resource Managers £

@ ORTE@N.N.N.N2E
Add Resource Manager...
Remove Resource Manager
Edit Resource Manager

Please select a mac

P> Start Resource Manager

| Resource Managers &2

b (3 ORTE@N.N.N.N (ORTE)

1-39




+ 0+ o+ 0+

System Monitoring

Machine status shown in
Machines view

Node status also shown
Machines view

Hover over node to see
node name

Double-click on node to
show attributes

Module 2

(%) Resource Managers £

» &) ORTE@N.N.N.N (ORTE)

282 Machines 3 e, o
ORTE@N.N.N.N: localhost.localdomain - Root [64]

60 I I B

Node Attributes Process Info

=}y

T, 0N e
_

O [ ) I
20 [ I I I B
30 [ I I I O
40 [ () [
50 I

=8

=a

Attribute Value

Name

» Node Number 0
Node State up
(T w1 [>)

(¢
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Module 2: Creating and
Running MPI Programs

+ Objective
+ Learn how to use Eclipse to develop parallel programs
+ Learn how to run and monitor a parallel program

+ Contents

+ Brief introduction to the C/C++ Development Tools
+ Create a simple application

+ Learn to launch a parallel job and view it via the PTP
Runtime Perspective

Module 2 PTP Tutorial 2-0

Switch to C/C++ Perspective

; Help
+ Only needed |f New Window =
you’re not
already in the Open Perspective i) (&5 CVS Repository Exploring
R Show View > {5 Resource
perspective A ‘
Customize Perspective... Other...

Save Perspective As...

Reset Perspective
X Open Perspective
Close Perspective

Close All Perspectives

Navigation > it CVS Repository Exploring
- %5 Debug

Working Sets > £8 PTP Debug

Preferences... £ PTP Runtime

Resource

£9 Team Synchronizing

pr—

OK Cancel
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Project Explorer View

+ Represents user’s data
4+ It is a set of user defined

resources [ Project Explorer &2 Sm
+ Files a5
+ FOIderS b % Binaries
+ Projects P 5 Includes
. . v Esrc
4+ Collections of files and

b [€ MyCproject.c
folders b GDebug

4+ Plus meta-data

+ Resources are visible in
the Project Explorer View

Module 2 PTP Tutorial 2-2

Editors

+ An editor for a resource (e.g. a file) - TR
opens when you double-click on v
a resource
+ The type of editor depends on the type of the resource
+ .c files are opened with the C/C++ editor
+ Some editors do not just edit text
+ When an editor opens on a resource, it stays open across
different perspectives
+ An active editor contains menus and toolbars specific to that
editor

+ When you change a resource, an asterisk on the editor’s
title bar indicates unsi}ed changes

[¢] *MyCproject.c &3
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Source Code Editors

A source code editor is a
special type of editor for b
manipulating source
code
Language features are
highlighted
Marker bars for showing
+ Breakpoints —
+ Errors/warnings
+ Tasks
Location bar for
navigating to interesting
features

R

}

Module 2

| linear_function.c &2

PTP Tutorial

double evaluate(double x)

double y = 3.0%x + 2.0
return y;

2-4

Set up for MPI d

Preferences

+ To use the PTP Parallel Language Development Tools feature for

MPI development, you need to
+ Specify the MPI include path
+ Specify the MPI build command
+ Open Window »
Preferences...
+ Open the PTP item

+ Open the Parallel Language
Development Tools item

4+ Select MPI

4+ Select New... to add MPI
include path

+ If running OpenMP, add its

include file location here too
(we will cover that later)

Module 2 PTP Tutorial

b

b

b CiCes
b Help
b

b

5

evelopment
7] Preferences x)
e o —

InstalyUpdate
Java

Plug in Development
PP MPI buld command: | mpce
~ Paraiel Language Deve

OperdMP
Resource Managers

Viewer

b RunDebug

b Team ’ 1

a I o lRo\lmDohunH Apply J
o e |
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Creating a Parallel Application

Steps:

+ Create a new C project
+ Edit source code

+ Save and build

Module 2 PTP Tutorial 2-6
Creating a simple
MPI Project (1)
Create a new MPI project = =

| € Project

+ File»New»C Project Create € project o seected type

+ Name the project S
‘MyHelloProject’ ] s (
+ Under Project types, under roect
Executable, select MPI I
Hello World C Project
and hit Next

+ On Basic Settings page,
fill in information for your
new project (Author
name etc.) and hit Next

golkchains caly If they are supported on the platform

Module 2 PTP Tutorial 2-7




Creating

a simple

MPI Project (2)

. . )
+ On the MPI Project Settings MPI Project Setings —
wizard page, make sure Add Select the MPI include path, lib name, library search path, and build |
MPI project Settings to thiS command information to be automatically be added to the new project.
prOj ect |S CheCked P[] Add MPI project settings to this project
) LW Use defauit information
+ Change default paths, etc. if—"]" s ustocalinclude |[Browse
necessary (they are probably Library name mp \
OK) (ry S ssiocaliib |[Browse
+ Hit Finish*. MP! compile command; | mpicc }
MPI link command: mpicc
+ *If you instead hit Next, then
on the Select Configurations
page, you can alter Project
settings. Hit Finish. o) <Back | New- || Ensh || Cance
Module 2 PTP Tutorial 2-8
Changing the C/C++ Build 2
Settings Manually
+ Open the project properties
by right-mouse clicking on [ i s for el i o
project and select — _ =
Properties > _
+ Open C/C++ Build ' e
+ Select Settings ' =
+ Select GCC C Compiler to vt s
change compiler settings
+ Select GCC C Linker to
change linker settings
+ It’'s also possible to change Reen et
compiler/linker arguments : .
Module 2 PTP Tutorial 2-9




Editor and Outline View

[ crce~~Tprojectientz.c - Eclipse SOK ‘[gﬁ_b
+ Double-click on L i > Rceer e

source file in the
Project Explorer
to open C editor

4+ Outline view is
shown for file in
editor

Prodlers | ] Tasks | (2 Cormoie [ Propertes Bk 26
IC2uid [Zorcject]
5-10 Module 5 PTP Tutorial

Content Assist

+ Type an incomplete MPI function name e.g. "MPI_Ini" into the
editor, and hit ctrl-space

+ Select desired completion value with cursor or mouse

MPI_Ini|
© MPI_Init(int *, char ***) int
"~ £ind e MpI_nit_thread(int , char ===, int, int %) int
MPI_Com o MpI_Initialized(int =) int

4+ Hover over the MPI Artifact
identified in the source file to
see additional information
about that function call, for
example

Module 2

PTP Tutorial

[Initializes MPI.

* find out process rank *

MP17Co!nm7£ank (MPI_COMM WORLD, &my_rank);

[Name: MPT_Comm_rank

Prototype: int MPI_Comm_rank(MPI_Comm, int *)

Description:

[Returns the rank of the local task in the group assodiated with a communicator.

Press 'F2’ for foous.

2-11




Module 2

Context Sensitive Help

Click mouse, then press help
key when the cursor is within a
function name

+ Windows: F1 key

+ Linux: ctrl-F1 key

+ MacOS X: Help key or Help»

Dynamic Help

A help view appears (Related
Topics) which shows
additional information
Click on the function name to
see more information

Move the help view within your
Eclipse workbench, if you like,
by dragging its title tab

:4Pl__;em__;§::k(!f{EI_CQ;{R{_WQ&LD, &my_rank ‘
[Name: MPT_Comm_rank

[Protoype: int MPI_Comm_rank(MPI_Comm, int *)

Description:
Returns the rank of the local task in the group associated with a comi
(1<

{1 Help 2 & v =0

Related Topics
~ About

Click below to see help.
See also:

B Editor view click here
B int MPI_Comm_ranﬁ\ IPI_Comm, int *)

{2 Help X

MPI_Comm_rank

int MPI_Comm_vark (MPI_Comm, int *)

Retums the rank of the local
task in the group associated
with a communicator.

PTP Tutorial
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Module 2

Running a Parallel Application

Steps:

+ Create a launch configuration

+ Run the application
+ Monitor its progress in the PTP Runtime

Perspective

PTP Tutorial




P - Press the 'New' button to create a configuration of the selected type.
[E1CIC++ Local Application =« Press the "Duplicate” button to copy the selected configuration,
+ Open the run Parallel Application X - Press the "Delete’ button to remove the selected configuration.

Create a Launch Configuration

©0Y e QO | &

F

Organize Fayorites... .

configuration
dialog Run»
Open Run Dialog...

Create, manage, and run configurations

Create a configuration to launch a parallel application in Parallel Perspective @

Run )

S B

Configure launch settings from this dialog:

# - Press the *Ater* button to configure filtering options.
- Edit or view an existing configuration by selecting It.

Configure launch perspective settings from the Perspectives preference
page.

+ Local program: executable
is under Debug folder in the
project

Module 2

+ Select Parallel
Ap pl |Cat| on Fiiter matched 2 of 2 items
+ Select the New
button ! Qose
Module 2 PTP Tutorial 2-14
+ In Main tab, select the
resource manager yOU want Create, manage, and run :onn:uunom @
to use to launch this job © roptcationpregram s ot speciies
+ If Parallel Project isn’t LIR)e & Name: Mymeloproject
filled in then click the SN Fesources | % Debupger| - Arguments| i Source| ™2
Browse button to select < Hrsrton [
+ Find the Application
program (executable) by oS
clicking the Browse button e

Display combined output in a conscle view

D
Fiter matched 3 of 3 items

Close

PTP Tutorial 2-15




Complete the Resources Tab

+ Select Resources tab  creste manage. and run contgurations
4+ Enter the number of

= L Parabel Appkcation Launch Attrbutes

may provide additional TSN | | e ot rocesses @
resources to select (e.g.

network interface, run

duration, etc.)

B s S

[Debugger): No debugger avalatie \U

processes for this job Spamta e T —
+ Other resource managers e oo | | Quene:

Fiter matched 3 of 3items tovly et
Module 2 PTP Tutorial 2-16
Complete the Debugger Tab I
+ Select Debugger tab o 0
+ Choose SDM from the e et s il P ()
Debugger dropdown I home. yretoronct
. e ) Main |5 Reggurc: -ouwrwu Y Seurce 1§ Environment =y
+ Confirm the debugger @ :
executable e | idseriniing
<+ C“Ck on the Run :};,;m:‘i::»pwmum;:o:o:aox:b:uuk-\wn Browse
button to launch the st csomin
job
fiter matched 3 of Jitems Jork. el

-

Module 2 PTP Tutorial 2-17




PTF Rustime - MyHetlo o
D L0t Refactar Navigete Search Broject B Window e

+ DOUb|e-C|iCk a X = 0 0-9-Q- O |7 + < o (e e

2 Ressurce Managens 11 =0 i MynesoProect € 3

node in machines iat st . chrs arn
view to see whic L

processes ran On Dl':l"u(l h(.m Mu?lln] - =2 -‘LA‘EE'?‘-:?:‘"’.“;:]
the node ,Bmma.u_s__n.u s

+ Hover over a o \ - ...,,m !
process for tooltip etie [k -

Name  neded &Y (my_ramk 1900

O u Node Numi 0 sprintt(message, “wells W1 werld from process
Node Stats L2 dest = &

| o G1r LHT0 eomoie 1 & frodlems = Properties 3 task
ORTIgLoca 2 - Aot (4] C-Buld [y e rafect | 2

rvoking. GCC ¢ Linker
3ce N

+ Job and processes —»
shown in jobs e o st tprnoct
view

Module 2 PTP Tutorial

15 o'mmelloPraject” /are/

2-18

Viewing Program Output

Be (St Nevgete Sewch Broject fun Window bl

» 902~ Q- O 15| ¥4 o o = (BT Rt 2
2 Resource Managers 11 =0 (2 MyMeloProject ¢ [l job02:0 13
»0: 23513
Status: EXITED
—— e e - Mo et
ORTE@Le< ok locaihast Jocaldsman - Rsot [10] ik s ekl ok pracens ¢ s precesees: &
. [Buceorthcasoman [0 "TT Tl Mol b e from precess 21
+ Double-click a EEEESEEEEE L e fran e
process to see
process detail and
standard output e e e
from the process Name  noser
Node hurrd 1
~ (217 0] O comele = 2, tvoblems) 03 Proparties| & ks
C-Bud [MyHeloProject|

Tavoking &C € Lisker
spice -L/usr/local/lid -o*Wyelledroject . /5rc/
melloProject. o -1

Finished buildisg target: MydelloProject

EXITED PID; 21513

Module 2 PTP Tutorial




+ Open using legend icon in

toolbar

| 8~

About PTP Icons

@ STARTING
@ STARTED
@

PTP Runtime - jo,"02:0 - Eclip
File Edit Navigate Search Project Run WNgdow Hi

STOPPING
STOPPED
+ SUSPENDED

J Hv Ov Qv Qv JO" J J @ ERROR

Module 2

Machine Icons:

= up
DOWN
ALERT
B ERROR
# UNKNOWN

Job Icons

PENDING
STARTED
RUNNING
TERMINATED
SUSPENDED
ERROR
UNKNOWN

e00000COC

Resource Manager Icons

Node Icons

fEEE

Process Icons

ey e

e~

upP

DOWN

ERROR
UNKNOWN

USER EXCLUSIVE

USER SHARED

OTHER EXCLUSIVE
OTHER SHARED
PROCESS RUNNING
PROCESS TERMINATED

ERR K

STARTING

RUNNING

EXITED NORMALLY
EXITED WITH SIGNAL
SUSPENDED

ERROR

UNKNOWN

'close;

PTP Tutorial
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Module 3: PTP and Parallel
Language Development Tools

+ Objective
+ Learn to develop a parallel program
+ Learn to analyse with PLDT

+ Contents

+ Learn to use PTP’s Parallel Language Development
Tools

+ Learn to find MPI & OpenMP artifacts
+ Learn how to do MPI and OpenMP Specific analysis

Module 3 PTP Tutorial 3-0

Parallel Language Development
Tools (1)

+ Features

+ Analysis of C and C++ code to determine the location
of MPI and OpenMP Artifacts (Fortran planned)

+ "Artifact View" indicates locations of Artifacts found in
source code

+ Navigation to source code location of artifacts
+ Content assist via ctrl+space (“completion”)
+ Hover help

+ Reference information about the MPI and OpenMP calls
via Dynamic Help

Module 3 PTP Tutorial 3-1




Parallel Language Development
Tools (2)

+ More PLDT features:

+ New project wizard automatically configures
managed build projects for MPI & OpenMP

+ OpenMP problems view of common errors

+ OpenMP “show #pragma region” action

+ OpenMP “show concurrency” action

+ MPI Barrier analysis - detects potential deadlocks

Module 3 PTP Tutorial 3-2

Show MPI Artifacts . ..

Select source file; Run
analysis by clicking on
drop-down menu next
to the analysis button
and selecting Show
MPI Artifacts =
Markers indicate the < I :
location of artifacts in kst o e
editor i -
; n rl;/ItI;’I Artlfalct View \A o D
y any column b cone  daysank);
(click on col. headingy™~~

WL _Comm_size(NPI_COMM_NORLD, Snum_procs)
Navigate to source code : " J -
line by dOUble—CliCking Tasks | Consale 2 Problems > MP1 Asitact View £1 I X3 °°0
Amtact Flesame LineNo |CMI

W Show MPI Artifacts
¥ Show OpenMP Artifacts
/7, MPI Barrier Analysis

C/Co s - MyMPIpIOjecy s My MPIger scic - Eclipse SOK

on the artifact * e rv— FinctonCt
Run the analysis on e v . (g
another file and its (g e . —
markers will be added to s omsins . i
the view e et . —
Remove markers via * |~ iy Py Dog

Module 3 PTP Tutorial 3-3




MPI1 Barrier Analysis

RG]

Verify barrier

synchronization in

C/MPI programs

Interprocedural static
analysis outputs:

ae0

- Eclipee SOK - C:

-

€G- B-0-Q- &4 O- 0| Rcxcee

Tomd i Vrdow el

+For verified programs,
lists barrier statements
that synchronize
together (match)

+ For synchronization
errors, reports counter
example that illustrates
and explains the error.

Module 3 PTP Tutorial 3-4

MPI1 Barrier Analysis - view

1/ [2. Problems | <) Tasks ) Conscle 2 barrier Matches O | (92 porries Ervors i
i | b
Flerome

MySarrier.C
MySarrier .
MyRarrier.c

5 vl garners 1

Barrier Matching Set Function

Furction Borrier Matching Set | Funcion
i - 7y

v
n
wh
wh
73

man
man
man

Barrer

= WA Erree

MySarrier ¢
MyBarier.c
MyBarrier.c
Myarrier.c

& VB pacres 5 (1)

MPI Barriers view

Simply lists the
barriers

Like MPI Artifacts view,
double-click to
navigate to source
code line (all 3 views)

Module 3

Barrier Matches view
Groups barriers that
match together in a
barrier set — all
processes must go
through a barrier in
the set to prevent a
deadlock

PTP Tutorial

Barrier Errors view

If there are errors, a
counter-example
shows paths with
mismatched number
of barriers

3-5




OpenMP Managed Build Project

+ If you haven’t set up
OpenMP preferences e.g.
include file location, do it
now

+ Create a new OpenMP
project
+ File»New»C Project

+ Name the project e.qg!
‘MyOpenMPproject’

+ Select OpenMP Hello World C

Project

+ Select Next, then fill in other
info like MPI project

Module 3

PTP Tutorial

€ Project

Create € project of selected fype
Project name: | MyOpenMPproject

¥] Use defaudt location

Toolchain:

Project types:

® Hello Word Co+ Project
© Hallo Word ANSI C Project
© Empry Project
@ MPI Melo Wadd € Project
® MPI Emgey € Project
LW ® OpenMP Hetlo Wodd C Prsy
® OpenMP Emgsy C Project

& Shared Library

@ Static Libeary &
o 0]
7] Show pecject types and took hains only # they are supported on the platform

xl Mew> | Besh ][ Cancel

3-6

Setting OpenMP Special

Build Options

+ OpenMP typically requires
special compiler options.

+ Open the project
properties

+ Select C/C++ Build
+ Select Settings
+ Select C Compiler

+In Miscellaneous,
add option(s).

Module 3

PTP Tutorial

| "2 Properties for MyOpenmPproject =%
type fiter text Sottings
Resource a
Dulders
= ¥ | | Menoge
Buld arnfact | i) Bnary parsers | )
s | < -fmessegedengthed
ot ANSI programs (-ans)
[~y
v
< >
? o |

3-7




+ Select source file,
folder, or project

+ Run analysis

O IN : -
#» Show MPI Artifacts

" ¥ show OpenMP Artifacts

* W4 MP1 Barrier Analysis

4+ See artifacts in

R mopactiopiorse 71— 01§ yoparspropct.c S0 BN =0)
: SRE S oniy e wersaoan: il
* & mpmipropact I i o et U asn
) ke U wrgh
. / sample cpen AFI Blaiy
oo > AL (omp_im_parailel (1) ( o S
= printf(“crue”): I
= 55 Mot oot 3 U oowoh

Fle Edt Refoctr Nagste Sewch Froject R Wndow Meb
[l O SER Cr~ R P R - 23 - ©

} $-0-%- O~
> &9 i) PP

£ % 0ebg (TRcrcee (§ma

S e e R ®  manint, char|
5 o 11o0ate memory f oy

. x = (domble *) malloe( (size ] | arraySize * sizeof (4ot
¥ = (dosble *) malloc( (size_t) [ ArraySize * sizeof (dor

OpenMP Artifact
view

Module 3

yii] = sin( expl con{ -~ exp( sin(x{t]) ) ) ) »:
ratorn 0;
L
<l . =
- B Operew st vew
OpenP Artéact Flerame
W suragm oo parold fix HyOperMroct.c " O
3
<| >
PTP Tutorial 3-8

Show Pragma Region

+ Run OpenMP
analysis

+ Right click on
pragma in
artifact view

+ Select Show
pragma region

Module 3

/* Here's the OpenMP pragma that parallelizes the for-1lof
#pragma omp parallel for

P return 0;
L

See highlighted region in C editor

&l il ]
(2. Problems ] Tasks | ] Console | 3 Debug [ @ OpenP Problems # Openp Artfac
N\, | OpenP Artifact / Filename | LineNo
omp_in_parallel MyOpenMPproject.c 26

Show pragma region

PTP Tutorial 3-9




Show OpenMP Problems

+ Select OpenMP

(BT~ ToopeiPprofectsreiopemiPorobions.c - Ecipse SOK - Clemsiruntime tomp os
[Fie €3t Refoctr Navgate Search Propct Run Window Meb =
Gl @réivd-G K-8 i $-0°Q° O~ ] % oty

& 4 1 $i=gl-v G- Mo |§wm
1) Progect Exglorer 31 L6 MyOpertPpropect.c L6 operMPprotions.c |
= ~lp -

problems view

+ Wil identify standara~__ - .-

OpenMP restrictions

fpragua_omp parailel for
15 mywPioroject for (=17 3<10; 3ee) (

)

void barriercheckd ()

B Coert® Artfact View
P =
Descripton ne
® For drective embedded mitin snother peraliel for or paralel sections oo
© Darmier drective not permitted In region extent of for, srdeced, sections, sngle, master, snd ontcal  0p

+. Problems | < Tosks | © Console| @ Operd# prodiems (1

Writable Smartinsert | 26:5

Module 3 PTP Tutorial 3-10
Show Concurrency
+ Highlight a statement int ;;’:z;;f’)gmp parallel
+ Select the context menu -
on the highlighted b=2;
statement, and click A S
Show concurrency : H
+ Other statements will be
highlighted in yellow
+ The yellow highlighted int simple2(O{
. #pragma_omp parallel
statements might execute {
concurrently to the oy
selected statement #pragma_omp_barrier
b=3;
a=4;
}
}
Module 3 PTP Tutorial 3-11




Module 4: Parallel Debugging

+ Objective
+ Learn the basics of debugging parallel programs with
PTP
+ Contents
+ Launching a parallel debug session
+ The PTP Debug Perspective
+ Controlling sets of processes
+ Controlling individual processes
+ Parallel Breakpoints
+ Terminating processes

Module 4 PTP Tutorial 4-0

Launching A Debug Session

Use the drop-down next to

the debug button (bug =~ file Edit Refactor Navigate Search Run Project Window Help
icon) instead of run button riv P % 0 Q- O = | 4 o
Select the project to launch | @ Resource manage |11 MyMPIProject | =0
The debug launch will use Debug As '

% Open Debug Dialog...

the same number of SRR R
processes that the normal
launch used (edit the £ Machines %2 Qad v =0
Debug LaUnCh ORTE@sc07tutorial: localhost.localdomain - Root [64] B
e TTTTII T
Configuration to change) 10 1 1 I
20 (B0 I [ [ o oy
30 [0 [ [ ) o oy
v O Qv | O | & et
50 [ I I
. i1MymPiProject | 60l 1y
E Debug As > Node Attributes Process Info
%> Open Debug Dialog... Attribute  Value !

Organize Fayorites...

Module 4 PTP Tutorial 4-1




The PTP Debug Perspective (1)

+ Parallel Debug

view shows job
and processes

being debugged =P s

Debug view shows
threads and call
stack for individual
processes

Source view
shows a curre
line marker for all
processes

Module 4

nt

£ PTP Debug - MyMPIProject/testMPl.c - Eclipse SDK BBX
Fle Edit Refactor Navigate Search Run Project Window Help
| B 0¥ Qv | O~ i |RBPTP Debug| HIPTP Runti... TLC/C4++
8 parallel Debug &2 = O % Breakpoints b Variables £2 . 4f Expressions = O
ORTE@scO7tutorialid 1, g = = ® 0 K o .
o Name Vaiue
> job06 @ my_rank 4545765
= cag| Mmoo 134515657
AL = L < source -1076822980
= £ MyMPIProject [Parallel Application] & dest -1076823128
v § Process 0
v 4® Thread (1] (Suspended)
= 1 main() testMP1.c:50 8048950
< testMPlc 2 11 jobos:0 * 0 & Outline 11 "0
{ A N e v
int my_rank %R
int num_procs; M mpih
int source; ‘ er * .
int dest = 0; /% rank of receiver */ U stdioh
int tag = 0; . . u stringh
message [ 160 ; . ’
MWPI_Status status ; calc_pi(int, int) : void
o main(int, char¥(]) : int
WI_Init(sarge, &argv);
+ find out proce ks
WPI_Comm_rank (MPI_COMM_WORLD, &my_rank) ;
@ Console 3 () Memory €) Error Log| (2. Problems . B> =g
.
PTP Tutorial 4-2

+ Breakpoints view

shows breakpoints
that have been set
(more on this later)

Variables view —
shows the current
values of variabl
for the currently
selected process in
the Debug view

Outline view (from
CDT) of source

code

Fle Edit Refactor Navigate Search Run Project Window Help
r v | BY Ov Qr (O~ = v =7 |REPTP Debug| ! PTP Runti... TLC/IC++
22 parallel Debug it ﬂ % o0 Variables £ &7 Expressions = O
» @ 27 ® 0 K o> (= J -
0 job02 0@ Name Value
> job06 @ my_rank 4545765
= a'  num_procs 134515657
AU 2 @ source -1076822980
' & MymPIProject [P @ dest -1076823128
55 0
< 4® Thread 1] (Suspended)
= 1 main() testMP1.c:50 80489b0
es 4 testMPl.c = 0| & Outline 32 =
{ a e v
int my_rank; B R
int num_procs; 2 mpih
int source; . k of er + N
% [int dest = 0; /* rank of receiver +/ o stdeh
int tag = 6; + tag f 0 o stringh
char message[160]; o calc_pi
WI_Status status ; calc_pilint. int) : void
© main(int, char¥{]) : int
MPI_Init(Sargc, &argv);
MPI_Comm_rank (MPI_COMM_WORLD, &my_rank) ; - I
© Console 33 0 Memory| ©) Error Log [£. Problems - < 8- =n

Module 4
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Stepping All Processes

. £k Parallel D 3 ™ ® 0 K o~ v <0
+ The buttons in the_’mﬁﬁj&mmw 5
Parallel Debug View 0 jobo2 o+ v
control groups of
processes
+ Click on the Step Over % Debug 32 2> (4 O Toe
button = i MyMPIProject [Parallel Application]
< & Process 0
+ Observe that a“ proceSS v ® Thread [1] (Suspended)
iCOﬂS Change to green' = 1 main() testMP1.c:50 80489b0
then back to yellow
4+ Notice that the current
line marker has moved t0 . cowric = mjooso =
the next source line -
\ MPI_Init(&argc, &argv);
o ﬁl_co-_rauk(ml_com_mﬁl.n, &my_rank) ;
M»"I_(onm_s;zew‘!‘l_(om_quLD,v&m;m_pru(s),

Module 4

PTP Tutorial
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Stepping An Individual Process

4+ The buttons in the
Debug view are used
to control an
individual process, in

PTP Di

) [ BY 0 9 Q- |O- |2

2 Parallel Debug 11
ORTE@Local: default:}ob02 - Root (4]
> o » 9 ® 0 (a4 (=33
0 jobo2 o#e v
 Debug &

this case process 0
+ Click the Step Over
button
+ You will now see two

current line markers,
the first shows the

position of process O,
the second shows the

positions of processe;/ [
1-3

Module 4

i MyMPIProject [Parallel Appiication]
= @ Process 0 (Suspended)
= 4 Thread (1] (Suspended)

[2) MyMPIProject.c &3

WI_Init(sargc, Sargy)
D’l;(__rlﬂ(ﬂl_mﬁb. Gay_rank);

| ix;c__six-qwx_:c;u_mn, U!I;IJMH:
if (my_rank 1= 0) {

© Conscle 12
0

0 Memory 2. Problems.

PTP Tutorial

G- MyMPIPrO) Ect/rc/MyMPIPTOj ECt-C - EClipse PIALTOrm - JHOME/DEth/ecl/ cppOR02/~ ews, = B X |
Ple Edt Refactor Navigate Search Project Bun Yndow Help

=0 %Br%E v 2 @S BaFe 0

Name Vale
@ my_rank 0
g ¢ mumprocs 134515657
@ source -1081228708
-0 Outine i3 =
AR e~

u meih
u stdioh
u stingh

o cak_piint, int) : void
o main(int, chart{]) : int

4-5




Process Sets (1)

+ Traditional debuggers apply operations to a single
process

+ Parallel debugging operations apply to a single process
or to arbitrary collections of processes

+ A process set is a means of simultaneously referring to
one or more processes

Module 4 PTP Tutorial 4-6

Process Sets (2)

+ When a parallel debug session is first started, all
processes are placed in a set, called the Root set

+ Sets are always associated with a single job
+ A job can have any number of process sets

+ A set can contain from 1 to the number of processes in
a job

Module 4 PTP Tutorial 4-7




Operations On Process Sets

+ Debug operations on the
Parallel Debug view

toolbar always apply to the e e & S IE Y SV [ RO SN 1

ORTE@scO07tutorial: default:job0s - Root [4]

current set:

+ Resume, suspend, stop,
step into, step over, step
return

+ The current process set is < & Process 0
listed next to job name < i ThrepfT1] (suspended)
along with number of s
processes in the set

+ The processes in process
set are visible in right hand
part of the view

L]

Root set = all
processes

Module 4 PTP Tutorial 4-8
Managing Process Sets
+ The remaining icons in the toolbar of the Parallel
Debug view allow you to create, modify, and delete
process sets, and to change the current process set
Create set Remove
\ }rom set
# Parallel Debug £2 0> 2 & 0 S o @y =8
ORTE@scO07tutorial: default:job06 - Root [4] \ Change
£ jobo2 oFdr++ | current set
%5 Debug &2 o - 3. D ven Delete
— &% MyMPIProject [Parallel Application] Set
~ &2 Process 0
v @ Thread [1] (Suspended)
= 1 main() testMPI.c:50 80489b0
Module 4 PTP Tutorial 4-9




Creating A New Process Set

Select the processes 2 = I IR @~ =0
you Want in the Set by ORTE@sc07tutorial: default:job06 - Root [4]

s i : Lol P o[Fe ¢
clicking and dragging, o

in this case, the last
three

Click on the Create
Set button

Enter a name for the
set, in this case
workers, and click OK
You will see the view
change to display only

~ ~ Create a new set name

Please enter the new set name.
- &% MyMPIProject [# [workers |

¥ & Process 0 (St
= @ Thread [1]
= 1main()

the selected processes llel Debug 52 L I O R A A
ORTE@scO7tu ault:job06 - workers [3]
£ job02 1Ly vr

¥ job06

Module 4 PTP Tutorial 4-10

+ With the workers set

- ) | B~ 0~ 0 Q- |O- |12 | 4 v = »
active, click the Step _ gawou = T A O o
Over button TTOmemeaca s o 0664 - workers 3] - =

. o b RO K[ o @ @ ™ | == o

+ You will see only the R iobaz 1999
first current line :'“”‘ ) =
marker move s

+ If all ProCcesses are NOW | iiMymeierect (pael picatin]

Stepping Using New Process Set

£ PTP Debug - MyMPIProject/src/MyMPIProject.c - Eclipse Platform - fhome/beth/ecl/cpp0s02/-/ews, = B X
fle Edit Refoctor Navigote Search Project Bun Window Melp

11 MyMPIProject [Parallel Application)

at the same line, you
will only see one line
marker again W1 _Tnit(Garoc, bargv): =

B RV e
. . K u mpih
WPI_Comn_rank (MPI_COMM_WORLD, &ay_rank); u stdoh

. ¢ nesber of esses * U stringh
- WPI_Comm_size(MPI_COMM_WORLD, &num procs): ° calc_piling, int) : void
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& MyMPIProject.c I “ 0 outline 1t “0

v, * main(int, char*{]) : int
>
© Console & () Memory (2 Problems ® & 2 v =0
C-Bulld [MyMPIProject] -
make: Nothing to be done for “all’ c
2 2 <




Process Registration

+ Process set commands apply to groups of
processes

+ For finer control and more detailed
information, a process can be registered and
isolated in the Debug view

+ Registered processes, including their stack
traces and threads, appear in the Debug
view

+ Any number of processes can be registered,
and processes can be registered or
un-registered at any time

Module 4 PTP Tutorial 4-12

Registering A Process

o \EBP
=0 %Bi

Narr

To register a process, e e
double-click its process . =[5~ 0~ @~ |O~ | 3= .
icon in the Parallel 55 Parale) 2 > @ 3 ® 0 K o @~
Debug view or select a ;";:f’;“""“’"a' detoult:o i ;&'m
number of processes and |EETEEEE Groups (sets)
click on the register of processes
button % Debug 2 > = °
The process icon will be = £ MyMPIProject [Paralel ppiication] -

< & Process 0 (suspended) Individual
surrounded by a box and < # Thread [1] (Suspended) (registered)
the prOCGSS appears in . = 1 main() testMPI.c:63 80489e0 processes
the Debug view ——p| "IN
To un-register a process, st
double-click on the 4 testMPI.C 13 B job05:0

process icon or select a
number of processes and
click on the unregister
button
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Current Line Marker

+ The current line marker is used to show the
current location of suspended processes

+ In traditional programs, there is a single
current line marker (the exception to this is
multi-threaded programs)

+ In parallel programs, there is a current line
marker for every process

+ The PTP debugger shows one current line

marker for every group of processes at the
same location

Module 4 PTP Tutorial 4-14

Colors And Markers

testMPlc 2 jobos:0

The highlight color depends on
the processes suspended at W1_tnit (sarac, Gargy):
that line:

+ Blue: All registered process(es)

MPI_Comm_rank(MPI_COMM_WORLD, &my_rank);

) - MPI_Comm_size(MPI_COMM_WORLD, &n )i

+ Orange: All unregistered o e
process(es)

+ Green: Registered or unregistered | @cosoe 0 Memory @ eror Log . problems

process with no source line (e.g.
suspended in a library routine)

% Multiple processes marker
The marker depends on the
type of process stopped at that |» Registered process marker
location
® Un-registered process marker
Hover over marker for more _
details about the processes » Multiple markers at this line
suspend at that location ‘ -Suspended on unregistered process: 2
| -Suspended on registered process: 1
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Breakpoints

+ Apply only to processes in the particular set that is
active in the Parallel Debug view when the breakpoint
is created

+ Breakpoints are colored depending on the active
process set and the set the breakpoint applies to:
+ Green indicates the breakpoint set is the same
as the active set.
+ Blue indicates some processes in the breakpoint set are
also in the active set (i.e. the process sets overlap)
+ Yellow indicates the breakpoint set is different from the
active set (i.e. the process sets are disjoint)
+ When the job completes, the breakpoints are
automatically removed ]
9 else{
) ‘ print:
M MPI_Final
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Creating A Breakpoint

£8 Parallel Debug 2 B 2 C « K v~ & «
+ SeIeCt the p!’OCGSS Set that oRTE@swnutjna\ default:job06 - workers [3] :
the breakpoint should apply | aiee 1+
to, in this case, the workers

set
+ Double-click on the left edge | “™"" -

MyMPIProject [Parallel Application]

of an editor window, at the o @ process
line on which yOU want to set < @ Thread 1) (Suspended)

the breakpoint, or right click
and use the Parallel

Breakpoint» Toggle
Breakpoint context menu A

+ The breakpoint on the call to sprintf(essage, *Greetings from process wiI*, my_rank
MP1_Send() » . L Send(nessage, strien(ne WL_CHAR

dest, tag, MPI_COMM_WORLD)
} else {
printf(*Num processes: %d\n*,num_procs)
for (source = 1; source < num_procs; source++) {
MPI_Recv(message, 106, MPI_CHAR, source, tag
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Hitting t

4+ Click on the Resume button

he Breakpoint

£ PTP Debug - MyMPIProject/testMP.c - Eclipse SDK
file Edit Refactor Navigate Search Run Project Window Help

Module 4

in the Parallel Debug view=—+— R T = &
% parallel Debug > ™ &0 K| o~ @y =0 %I
+ In this example, the three O e
worker processes have hit the =
breakpoint, as indicated by
the yellow process icons and g > = =g
the current line marker P )
+ Process 0 is still running as its T2 Tt B Cuspenied breaeor G
. -
icon is green < &8 Process 0
@ Thread (1] (Running)
job05:0
if (m¥>rank.<: o) { X
s?rin‘ﬂ(r‘nes“nqe, 'menqus from process mv-L my_rank);
» wx_‘s‘end(ln‘ss;qe, strien(message)+l, MPI_CHAR,
dest, tag, MPI_COMM_WORLD);
" it own processes: W mumprecs);
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+ The Step buttons are only
enabled when all processes < “P17.Dabug MyMPIPrlactitastiplc Ecipse SDK
|n the aCtlve Set are File Ed &factor Nav|g?(e Search Run Project Window Help ‘7
. r v v 13} |
suspended (yellow icon) R - " “I
. . . ‘arallel Debug > ] o> v o
+ In this case, process O is stlll—w{mml B
H 0 jobo2 of# » »#
running L
;
+ Switch SOC}he set of ( h Hle Edit a(;or Navigate Search Run oject Window Help
suspended processes (the " % O~ Q- |O- | = . o[
Workers Set) E& parallel Debug &3 3 ® 0 K oy (f ) @y =0 9%
+ You Wl" I"IOW See the Step ORTE@sc07tutorial: default:job06 - workers [3]
0 jobo2 19 v
buttons become enabled y
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Breakpoint Information

+ Hover over breakpoint icon

+ Will show the sets this breakpoint applies to
+ Select Breakpoints view

+ Will show all breakpoints in all projects

9 Breakpoints £2 9= Variables & Expressions =8

% R N BmBE S %Y

V' @ testMPl.c [line: 70] {job03:workers}
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Breakpoints View

+ Use the menu in the breakpoints view to group
breakpoints by type

+ Breakpoints sorted by bregkpoint set (process
set)

9 Breakpoints 83 - Variables &4 Expressions =0
% N mBBEB %
~ ¥ & workers ¥| Show Full Paths
¥ @ testMPI.c [line: 70] {job03:workers}

1 Breakpoints

oo Select Default Working Set... -2 Breakpoint Types
3 Breakpoint Working Sets
Working Sets... 4 Files

Show Qualified Names = ' Sl

= 6 Projects
| 7 Resource Working Sets
8 Advanced...
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Global Breakpoints

+ Apply to all processes and all jobs

+ Used for gaining

control at debugger startup

+ To create a global breakpoint

+ First make sure that no jobs are selected (click in white
part of jobs view if necessary)

+ Double-click on the left edge of an editor window
+ Note that if a job is selected, the breakpoint will apply to

the current set

‘e

Module 4

if (my_rank '=0) {
/¥ create message *

sprintf(message, "Greetin

PTP Tutorial

Terminating A Debug Session

4+ Click on the Terminate

£ PTP Debug - MyMPIProject/testMPl.c - Eclipse SDK
File Edit Refactor Navigate Search Run Project Window Help

£3v W | O Qv |O | iE | 4 P & (B8

icon in the Parallel —mmmmmmr——» " v = 0|o1
Debug view to ORTE@sc07tutorial: default:job06 - Root [4] B
terminate all processes |2/ goeee
in the active set
Make sure the Root set
is active if you want to | #oeug = i
terminate a” processes £ MyMPIProject [Parallel Application]

2 Parallel Debug 2 > & 2 c ® 0 K o> v =0 %8

ORTE@scO07tutorial: default:job06 - Root [4]

0 jobo2 (R =
You can also use the L .
terminate icon in the = = =0 .
DebuQ VieW to < §3 MyMPIP t [Parallel Application] - ¢
terminate the currently | g soces e, °

selected process

Module 4

v & Process 0 (Suspended)
= 4@ Thread [1] (Suspended)

= 1 main() testMPI.c:63 80489e0
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Module 5: Advanced Development

+ Objective
+ Explore advanced features of Eclipse and PTP

+ Contents
+ Advanced Eclipse Features
+ Advanced PTP Features

Module 5 PTP Tutorial 5-0

Advanced Eclipse Concepts

+ Perspectives, views and preferences
+ Version control

+ Makefiles and autoconf

+ Task Tags

+ Searching

+ Refactoring
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Customizing Perspectives

+ Items such as shortcuts, menu items and views may be
customized

+ Window» Customize Perspective...
+ Save changes

+ Window» Save Perspective As...
+ Close Perspective

+ Right-click on perspective title and select Close
+ Reset Perspective

+ Window» Reset Perspective resets the current
perspective to its default layout

Module 5 PTP Tutorial 5-2

Opening New Views

+ To open a view: (- T
4+ Choose Window »Show View »Other...
< (=General 2
+ The Show View dialog comes up WBookmarks
. Classic Search
+ Select the view to be shown B Console
+ Select OK e e e
&% Outline
2 Problems
' Progress L
)Project Explorer
! Properties
Search
¥|Tasks
P =Ant
P =C/IC++ =
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Workbench Preferences

+ Preferences provide a way for you to
customize your Workbench

+ By selecting Window P Preferences... or Eclipse »
Preferences... (Mac)

+ Examples of preference settings

+ Use Emacs bindings for editor keys

+ Modify editor folding defaults
+E.g., fold all macro definitions

+ Associate file types with file extensions
+E.g., *.f03 with the Fortran editor

+ Toggle automatic builds

+ Change key sequence shortcuts
+E.g., Ctrl+/ for Comment
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Version Control (CVS)

+ Version control provided through the Project
Explorer View, in the Team context menu

4+ Provides familiar actions: @ ™ '
{  Open F3
1 { Open With »
+ Commit... | Qpenwih @
1
+ Update... {5 copy *e
. | Paste 8V Synchronize with Repository
+ Also less used tasks: | xoeee 2 S
C Patch...
+ Create/Apply Patch... BuldPath et b Apoly Patch.
H = T Vi
+ Tag as Version | Eimpor- Sonch
A Export. ;o
+ Branch... | & Refresh £51  Switch to Another Branch o Version...
Assign Working Sets... #, Show Annotation
<+ Merge.__ Validate Show History
. Run As »
Debug A:
+ Add to 'CVSIQnore"' Proﬁ“l‘EA: : Change ASClI/Binary Property.
Compare With »
Raplace Wi P Sowedens.
| properties e
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Specify Repository Locations

eNo Add CVS Repository

+ Select Window»Open Add a new CVS Repository

Perspective »Other... ety e aE e cvs
+ Select CVS Repository Exploring ==

then OK ———
+ Right-click in CVS Repositories Authenticaton

View, then select New » user:  [amomymoud =

Repository Location... Prssword
+ Set Host to the hostname of R — =

remote machine © Use default por
+ Set Repository path D e port
+ Fill in Username and Password i omectonn st
+ Set Connection type I aisie] oo 5T
+ Check Save password
+ Select Finish

(" cancel (" Fnish )
Module 5 PTP Tutorial 5-6
Checkout a non-Eclipse project as an
Eclipse C Project
+ Open Repository, open HEAD | New >
+ t(;]c:;e( pc)’rl:):eAc; .r.ight—click on Project» — RO fs...

R i Tag as Version...
+ Make sure Check out as a project Tag with Existing...
A0

configured using the New Project

Wizard is selected [t
+ Select Finish ‘ B

+ Select C»C project
+ Select Next>
+ Enter Project name

+ Under Project Types, select Makefile
project

+ Ensures that CDT will use existing
makefiles

+ Select Finish
+ Switch to the C/C++ Perspective

> (= Executable
(& Shared Library
(& Static Library
<> Executable (XL C/C++)
< static Library(XL C/C++)
<> Shared Library (XL C/C++)
» (= Makefile project
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About Makefiles and autoconf

+ Can create project Makefiles with the Makefile
Editor
+ Syntax highlighting and Outline view

+ autoconf often used to create Makefiles for
open source projects

+ Run configure manually, or from External
Tools Launch Configuration
+ Must refresh after running configure script

+ Refresh whenever file system is modified
outside of Eclipse

Module 5 PTP Tutorial 5-8

Building with Makefiles

&5 | BC/C++] EaCVS Repo...

+ Create a Make Target
named ‘a“’ = B Z=outline | =) Make Targets 2 =8
+ Right-click on the > &
project in Make =M ‘
Targets View P MYMPIPIOISC] . Add Make Target |

+ Select Add Make - e
Target

Target Name: ‘

Make Target

4+ Select Create Make Target: al /
4+ Double click on new CEL

Use default

make target to initiate Bulld commands:
the build Build Setting

Stop on first build error.

v Go Into

Run all project builders,

Create Cancel
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Task Tags

L MySamplefrogect.c i

Task tags are identifiers in
C/C++ comments

TODO is a built-in task tag

The build locates task tags ,
during compilation sinoiode <

View task tags in Tasks View | S

int maig(yoid) (

+ If it's not shown, Window =~ S
» Show View » Other... ‘

<

Open General and select i v Do S e G )

- e

Tasks Vmulﬂ\cd.Jolmw
T R e e
Configure your own task tag Tootasabkamky  Wiamir.. wimnee  bers
in Window » Preferences
+ Under C/C++, select Task
Tags
Module 5 PTP Tutorial 5-10
[ﬁ_‘__| Project Run Window
FCCH.
+ Language-based 4 search... ctri+H
searching | Hle..
+ Search for Language L ’
Elements
+ e_g_, C++ ClaSS, J File Search| ¥'C/IC++ Search
Function, Method, e e e ) 5 Case serchive
Variable, Field, e Uit ®
Namespace ;I:.:‘/Smx( :::;:ln :ml:ble :):'cpubom :;::;mc
e g o e
4+ Can Limit search to Erumention ©) Enumerstor () Namespace
Declarations, Definitions, s =
Sci
References e
+ Type navigation et oo
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UPC Support

Select the features to install:

- 1 v < TutorialCD/updatesite
+ TO see UPC Support N C () v 00 CDT 4.0.3.200802251018
1 1 i ] (§* Eclipse C/C++ Development Tools SDK 4.0.3.200802251
edltor' InSta” the Optlonal (] clipse C/C++ GDB Hardware Debugging 4.0.3.2008022¢
feature from CDT — ) bt &3-30420225 1018
8 3.200802251018
0 G e SUpport 4.0.3.200802251018
0 “* Eclipse CDT Testing Feature 4.0.3.200802251018
(] » 00 Parallel Tools Platform 2.0

MatrixMulti.upc &3

+ Filetypes of “upc” will

7

TS 1; // private variables

get UPC syntax high-

lighting, content assist, / f ieaiinzg_the matrix a[1[]

e?c 9 i—e; i<N; i+s; &a[i][0D)
’ BT 3-0; j<P; j++)

al[i][jJ=1*P+j+1;

// intialize the matrix b[][]
upc_forall(j=9; j<M; j++; &b[0J[j1)
for (i=9; i<P; i44)
b[11[j]-3%2;
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Refactoring

4+ Source-to-source transformation that
preserves behavior

+ Rename
+ Select C/C++ Perspective
+ Open a source file
+ Click in editor view on declaration of a variable
4+ Select menu item Refactor» Rename
+ Or use context menu
+ Change variable name
+ Notice that change is semantic not textual

l = C/C++ - MyCproject/src/MyCproject.
File Edit ‘ Refactor Navigate Search Projer

o - I

Module 5 PTP Tutorial 5-13




CDT 5.0 Refac

000 Refactoring

ct Constant

int main(void) {
double intvalue-0.0}
Source » ” H ' |
Rename... 4R

The following changes are necessary to perform the refactoring.

Changes to be performed
™ v & Changes

Declarations > Extract Constant... \XC

4 @5 MyCproject.c - MyCproject/src . H
T 5.0 will be available
in the Eclipse “Ganymede”
MyCproject.c 4 EE N
— release, June 2008
Original Source |Refa<mred Source
#include <stdio.h> #include <stdlib.h> a ] H
include <tdlibn netde = * || + Other refactorings that
__{static const float WYZERD = 0.0; ] B
Tht mainCvoid) T [int mainCvoid) { ] are planned :
double intvalu@ double intvalue-MYZERD; X
puts("111Hello N 1"y; /% prints | puts("111Hello World!!11"); /% prin + Extract Function
R return EXIT_SUCCESS; 8 return EXIT_SUCCESS; o + Hide Member Function
int foo(){ int foo(){ H :
foor mm T A E-WVIERD; + Move Field or Member Function
I} ’ |} + Extract Subclass
< 5 X + Extract Baseclass
+ Separate Class
+ Implement Function
+ Declare Function
O] < Back Next > Cancel + Move Function Definition
+ Generate Getters and Setters
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Advanced PTP Concepts

+ Remote resource managers
+ Debugging remotely
+ MPICH2, IBM PE and LoadLeveler
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Remote Resource Manager

(s JeNe)

ORTE Proxy Configuration
Select Remote Tools as the rory tengurat

. . nter information to connect to an ORTE proxy server
Remote service prowder \
Click New... to create a new

Iocat.on Remote service provider Remote Tools 5
|

Proxy server location T RemoTE FOTT—— =P New.. )
Enter a Target Name, IP
address or hOSt name Of the Path to proxy executable: x.x86/bin/ptp_orte_proxy (" Browse (' Options...
remote machine, and Multiplexing Options
credentials B0 Targes invionmens Conturation

(® None

Remote Host

Local addre "

(&

Select Finish

_Select the Target Name you T e

just created for Proxy — e

server location if it is not Launch serve o 5324587 Port: 22
visible in the dropdown

@ Password based authentication
Password: [seseed
Public ke based authentication
File with private key —_
@ Cancel ) Finish
Passphrase _— _

Advanced

Module 5 PTP T Goncel ) () 5-16

Select Proxy Agent

800

ORTE Proxy Configuration

Click Browvse to select
the proxy server
executable

Open Root twisty

Now navigate to and
SeleCt the prOXy Path to proxy executable: x.x86/bin/ptp_orte_proxy (" Browse Options...

executable Multiplexing Options /
i ® None [5) Browse File
Click OK .

1 Select file:

jnformation to connect to an ORTE proxy server

[ Tools [

Proxy server location: | VeryBigCluster “C] (" New.. )

Remote service provider:

(&

Local address
/Users/greg/Documents /workspaces/ptp_t
(O Use port forw:

» (= org.eclipse.ptp.macosx.pp
v (= org.eclipse.ptp.macosx.x8

Launch server m project

@ about.html
v & bin C
csignore
> oS
“ ptp_mpich2_proxy
- Ptp_orte_proxy  Finish )
? % piplib.py Cancel Finish
README 5
<dm
e———— <
Cancel ) (0K )
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Using Port Forwarding

8 No

ORTE Proxy Configuration

+ Port forwarding can be
enabled to tunnel all
communication over a

Enter information to connect to an ORTE proxy server

. A Remote service provider: Remote Tools ﬁ
single connection
+ If yOU don,t Want tO us Proxy server location: local —:] (" New.. )
port forwarding’ your Path to proxy executable: 'x.x86/bin/ptp_orte_proxy Browse ( Options...
local machine must be Multiplexing Options
accessible from the O None
remote machine Yo ¥ c 67 154,24
ocal address for proxy connection: 9.67.154.242
+ Select your local machine’s
IP address from the © Use port forwarding
dropdown
+ Enter it manually if it's not
visible
+ Click Finish
Z C Next > ) Cancel (" Finish )
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Debugging Remotely

(&) Debug
+ ChOOSe remote resource Create manage, and run configurations ‘ﬁﬁ
manager in Mal n tab Create a configuration to launch a parallel application in Parallel Debug Perspective _.\\) 1

4+ Click Browse and select
sdm executable on
remote machine (if path | _ "=~
is not correct) o urie

7% JUnit Plug-in Test

+ Set Debugger session | # osc rameworc | | Mstopatmaing on
address to the address N | | Sxesser oxen:
of the machine running i
the proxy agent
+ The address must be

Name: shallow2
[5) Main (£ Resources (3% Debugger ), 9= Arguments | 5 Source| 2

SOM ]

er:

Path to debugger executable A

/home/greg/ptp/plugins/org.eclipse.ptp.linux.x86_2 ( Browse )

Debugger session address
shallow

H shallow2 cluster_head
accessible from a cluster shaiow loal
node 7 Remote Java Aoolid
4+ Click Finish Filter matched 19 of 19
0 (" Close ( Debug )
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Alternate Resource Managers

+ An MPICH2 resource manager is provided

+ Use ptp _mpich2 proxy when selecting proxy executable
+ PE and LoadLeveler

+ See help documentation that comes with PTP for
information on configuring and using

+ Debugging support for alternate resource managers will
be available in next version of PTP
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Module 6: Where To Go Next

+ Objective
4+ How to find more information on PTP
4+ Learn about other tools related to PTP
+ See PTP upcoming features
+ Contents
+ Links to other tools, including performance tools
4+ Planned features for new versions of PTP
4+ Additional documentation
+ How to get involved

Module 6 PTP Tutorial

6-0

Information About PTP

+ Main web site for downloads, documentation, etc.
+ http://eclipse.org/ptp
+ Developers’ wiki for designs, planning, meetings, etc.
+ http://wiki.eclipse.org/PTP
+ Mailing lists
+ Major announcements (new releases, etc.) - low volume
+ http://dev.eclipse.org/mailman/listinfo/ptp-announce
+ User discussion and queries - medium volume
+ http://dev.eclipse.org/mailman/listinfo/ptp-user
+ Developer discussions - high volume
+ http://dev.eclipse.org/mailman/listinfo/ptp-dev
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PTP-Related Tools

+ Performance Tools Framework

+ Tuning and Analysis Utilities (TAU)

+ TuningFork - Performance Visualization
+ Photran — Fortran Development Tools

Module 6 PTP Tutorial 6-2

PTP / Performance Tools
Framework

Goal:

+ Reduce the “eclipse plumbing”
necessary to integrate tools = -

+ Provide integration for oo o e s i e ot O
instrumentation, measurement, and =
analysis for a variety of performance ==
tools

+ Dynamic Tool Definitions: = =
Workflows & Ul &

4+ Tools and tool workflows are
specified in an XML file

+ Tools are selected and configured in - o e
the launch configuration window =
+ Output is generated, managed and '
analyzed as specified in the
workflow
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PTP TAU plug-ins T-

http://www.cs.uoregon.edu/research/tau/home.php

+ TAU (Tuning and Analysis Utilities)
+ First implementation of Performance Tools Framework

+ Eclipse plug-ins wrap TAU functions, make them
available from Eclipse

+ Compatible with Photran and CDT projects and with
PTP parallel application launching

+ Other plug-ins launch Paraprof from Eclipse too

Module 6 PTP Tutorial 6-4

TuningFork

+ http://www.alphaworks.ibm.com/tech/tuningfork

+ Performance visualization Eclipse plug-ins
from IBM Research

4+ Rich Client Platform or IDE versions available

+ Designed for real-time visualization of large
data sets

+ Will be available open source on Source Forge

+ Enhancements for parallel computing
underway
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+

+

++++ 4

Photran http://eclipse.org/photran

ey - e e

Supports Fortran in B e -
the Eclipse workbench |aiccres: o mmms = 5|5 o
Supports Fortran 77, 90, p

and 95

It includes:

Syntax-highlighting editor

CVS support

GUIl interface to gdb

Makefile-based
compilation

Compiler error extraction
Outline view
Open declaration

Rename and Introduce
Implicit None refactorings

Module 6 PTP Tutorial

6-6

Useful Eclipse Tools

+ Python
+ http://pydev.sourceforge.net

+ Subversion (CVS replacement)
+ http://subclipse.tigris.org
+ Now an Eclipse Technology project

+ ... and many more!

Module 6 PTP Tutorial
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Future PTP Features

+ Resource manager support for SLURM, PBS,
LSF, BG/P

+ Simplified runtime system interface (plus
support for other MPI runtimes)

+ Debugging support for a broad range of
architectures

+ Full remote project support (combined with
CDT)
+ Remote build and indexing
+ Remote launch/debug

+ Performance analysis tools integration
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PTP Publications

+ “Developing Scientific Applications Using Eclipse,” Computing
in Science & Engineering, vol. 8, no. 4, July/August 2006, pp.
50-61

+ Link on http://eclipse.org/ptp web page

+ “A Model-Based Framework for the Integration of Parallel
Tools”, Proceedings of the IEEE International Conference on
Cluster Computing, Barcelona, September 2006

+ Link on http://eclipse.org/ptp web page

+ IBM developerWorks article:

+ http://www-128.ibm.com/developerworks/edu/os-dw-os-ecl-ptp.html

+ “An Integrated Tools Platform for Multi-Core Enablement,”
Beth Tibbitts & Evelyn Duesterwald, STMCS: Second
Workshop on Software Tools for Multi-Core Systems, March
2007

+ http://www.isi.edu/~mhall/stmcs07/program.html
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Getting Involved

+ See http://eclipse.org/ptp
+ Read the developer documentation on the wiki
+ Join the mailing lists

+ ptp-dev@eclipse.org; ptp-user@eclipse.org
+ Attend the monthly developer teleconference
+ Attend the annual workshop

+ PTP will only succeed with your participation!
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PTP Tutorial Feedback

+ Please complete feedback form
+ Your feedback is valuable!

Thanks for attending
We hope you found it useful
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