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Tutorial Outline

Time Module Outcomes Presenter
8:30-9:30 1. Overview of Eclipse + Introduction to PTP Greg
and PTP + Eclipse basics
+ Configuring Resource
Managers & setup
9:30-10:00 2. Creating and Running +PTP project creation Beth
MPI Programs +New project wizards
+PTP Runtime Perspective
10:00 - 10:30 | Break
10:30 - 10:55 | 3. Parallel Language + MPI, OpenMP analysis Beth
Development Tools features
(PLDT)
10:55- 11:25 | 4. Parallel Debugger + Debug Perspective, Greg
breakpoints, variables,
stepping, etc.
11:25 - 11:45 | 5. Advanced Eclipse and + CVS, Makefiles, autoconf, Greg
PTP features Search, Refactoring, UPC,
Remote debugging, MPICH2,
IBM PE & LoadLeveler
11:45- 12:00 | 6. Other, Summary, + Perf. Tools, website, mailing Beth
Wrapup lists, future features, etc.




Module 1: Overview of Eclipse
and PTP

+ Objective
+ To introduce the Eclipse platform and PTP
+ To learn the basics of Eclipse
+ Contents
+ What is Eclipse? Who is using Eclipse?
+ What is PTP?
+ Eclipse basics
+ Configuring a Resource Manager
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What is Eclipse?

+ A vendor-neutral open source development
platform

+ A universal platform for tool integration

+ Plug-in based framework to create, integrate
and utilize software tools

Java C/C++/Fortran Test and
Development Development Performance Parallel Tools
Tools Tools Tools
Platform
User
e Debug Update Help Team
Equinox
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Eclipse Platform

+ Core frameworks and services with which all

plug-in extensions are created

+ Represents the common facilities required by

most tool builders:

+ Workbench user interface

+ Project model for resource management

+ Portable user interface libraries (SWT and JFace)

+ Automatic resource delta management for
incremental compilers and builders

+ Language-independent debug infrastructure

+ Distributed multi-user versioned resource
management (CVS supported in base install)

+ Dynamic update/install service
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Plug-ins

Java Development Tools (JDT)

Plug-in Development Environment (PDE)
C/C++ Development Tools (CDT)

Parallel Tools Platform (PTP)

Fortran Development Tools (Photran)

Test and Performance Tools Platform (TPTP)
Business Intelligence and Reporting Tools (BIRT)
Web Tools Platform (WTP)

Data Tools Platform (DTP)

Device Software Development Platform (DSDP)
Many more...

Module 1 PTP Tutorial 1-3




Eclipse PTP: Parallel Tools Platform
http://eclipse.org/ptp
Coding & Analysis

Launching & Monitoring

it
Performance Tuning

Debugging
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Eclipse History

+ Originally developed by Object Technology
International (OTI) and purchased by IBM for
use by internal developers

+ Released to open-source community in 2001,
managed by consortium
+ Eclipse Public License (EPL)

+ Based on IBM Common Public License (CPL)

+ Consortium reorganized into independent not-
for-profit corporation, the Eclipse Foundation,
in early 2004

+ Participants from over 100 companies

Module 1 PTP Tutorial 1-5




Eclipse Foundation & Members

+ Board of Directors and full-time Eclipse
management organization

+ Councils guide the development done by Eclipse
Open Source projects

+ 180 members (March ‘08)
+ 21 strategic members

+ 942 committers, representing 50+ organizations

Strategic Members
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Eclipse Member companies

Eclipse Membership through March 2008

160 157 L
. 2 @
e 130 ®
S
12¢ E =z
91 3 n
100 =
®
o
=
w
o
o)
a0 o
= Mar. 17'5 . 20"
20 ;;:j Santa Clara
(=] California
EC2004 EC2005 EC2006 EC2007 EC2008
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Parallel Tools Platform (PTP)

+ The Parallel Tools Platform aims to provide a highly
integrated environment specifically designed for parallel
application development

+ Features include:

+ An integrated development environment (IDE) that
supports a wide range of parallel architectures and runtime

systems = =

+ A scalable parallel debugger — e

+ Parallel programming tools e eeeenlT T e
(MPI/OpenMP) I =L

+ Support for the integration e —
of parallel tools P,

+ An environment that simplifies the
end-user interaction with parallel systems

+ http://www.eclipse.org/ptp
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PTP
Software Prerequisites

+ Java (1.5 or later)
+ Cygwin or MinGW (for Windows)

+ make, gcc, and gdb (or other vendor
compilers)

+ OpenMPI or MPICH2 (only required for PTP
Runtime)

Note:
+ Linux & Mac have full PTP support

+ Windows can be used for Eclipse, targeting a
remote parallel machine

Module 1 PTP Tutorial 1-10

Java Prerequisite

+ Eclipse requires Sun or IBM versions of Java
+ Only need Java runtime environment (JRE)
+ Java 1.5 is the same as JRE 5.0

+ The GNU Java Compiler (GCJ), which comes standard
on Linux, will not work!
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Eclipse and PTP Installation

+ Eclipse is installed in two steps
+ First, the ‘base’ Eclipse is downloaded and installed
+ This provides a humber of pre-configured ‘features’

+ Additional functionality is obtained by adding more
‘features’

+ This can be done via an "update site’ that
automatically downloads and installs the features

+ Features can also be downloaded and manually
installed

+ PTP requires the following features
+ C/C++ Development Tools (CDT)
+ Parallel Tools Platform (PTP)

Module 1 PTP Tutorial 1-12

Eclipse Installation

+ Two alternatives for installation:
+ The Eclipse Classic is the full software development kit
(SDK), including Java and Plug-in development tools
+ The Eclipse IDE for C/C++ developers is the base Eclipse
platform plus the CDT (C/C++ Development tools).
This is ideal for PTP use (included on the tutorial CD)
+ Eclipse is downloaded as a single zip or gzipped tar file
from http://eclipse.org/downloads
+ Eclipse 3.4 (Ganymede) made available on June 25
+ This tutorial is based on Eclipse 3.3 (Europa)
+ PTP Tutorial CD contains all you need to install Eclipse, CDT & PTP
+ You must have the correct file for your operating system
and windowing system

+ Unzipping or untarring this file creates a directory
containing the main executable

Module 1 PTP Tutorial 1-13




Platform Differences

+ Single button mouse (e.g. MacBook)
+ Use Control-click for right mouse / context menu

+ Context-sensitive help key differences
+ Windows: use F1 key
+ Linux: use Shift-F1 keys

+ MacOS X
+ Full keyboard, use Help key

+ MacBooks or aluminum keyboard, create a key binding
for Dynamic Help to any key you want

+ Accessing preferences
+ Windows & Linux: Window » Preferences...
+ MacOS X: Eclipse»Preferences...

Module 1 PTP Tutorial 1-14

Starting Eclipse

+ Linux
+ From a terminal window, enter

| <eclipse installation>/eclipse/eclipse &

+ MacOS X
+ From finder, open the Applications»eclipse folder
+ Double-click on the Eclipse application
+ Windows
+ Open the eclipse folder
+ Double-click on the eclipse executable

+ Accept default workspace when asked ;
+ Select workbench icon from welcome page ! -

Module 1 PTP Tutorial 1-15




Specifying A Workspace

+ Eclipse prompts for a workspace location at
startup time

+ The workspace contains all user-defined data
+ Projects and resources such as folders and files

€ WWorkspace Launcher %
Select a workspace
Th e p ro m pt Ca n be Eclipse Platform stores your projects in a folder called a
workspace.
turned off
Workspace: || Browse..
(7] Use this as the default and do not ask again
oK | cancel
Module 1 PTP Tutorial 1-16

Eclipse Welcome Page

+ Displayed when Eclipse is run for the first time

=) Java - Eclipse SDK [-1=]x)
File Edt Refactor Navigate Search Project Run Window Help
@w e X

T

Module 1
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Adding Features

+ New functionality is added to Eclipse using features

+ Features are obtained and installed from an update site
(like a web site)

+ Features can also be installed manually by copying files
to the features and plugins directories in the main
eclipse directory

Module 1 PTP Tutorial 1-18

Installing Eclipse Features
from an Update Site

+ Three types of update sites
+ Remote - download and install from remote server
+ Local - install from local directory
+ Archived - a local site packaged as a zip or jar file
+ Eclipse 3.3.2 comes preconfigured with a link to the
Europa Discovery Site

+ This is a remote site that contains a large number of official
features

+ Europa projects are guaranteed to work with Eclipse 3.3.2
+ Many other sites offer Eclipse features
+ Use at own risk

Module 1 PTP Tutorial 1-19
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+4++ 0+

+

We have combined everything needed | ypqate sites to visit {—

for the tutorial onto a local update Site | seiectwpdate sites to st whie looking fornew features. )
on the CDROM

From the Help menu, choose
Software Updates»Find and " New Localite... |
Install... New Archived Site...

Select Search for new features to

install
Click Next > /
Click New Local Site... Import sites...

Navigate to your CDROM, select the ST
updatesite folder and click Choose

Sites to include in search
{1 4/l Europa Discovery Site [New Remote Site... |
01 4] The Eclipse Project Updates

(OK on Linux or Windows) R

Click OK on Edit Local Site automaticd Name: [flutorialCD/updatesite

to accept \\ URL: |file:/media/TutorialCD/updatesite/

@ | ok Cancel

Module 1 PTP Tutorial 1-20

Installing Tutorial Features

4+ Make sure On|y )

TutorialCD/updatesite
is selected

+ Click Finish to search
the update site for
features to install

+ From Search Results,
check TutorialCD
(open the twisty to see
the contents)

Search Results
Select features to install from the search result list. =

Select the features to install:

ialCD/updatesite Deselect All
/ 3 parallel Tools Platform 2.0

select Required

Parallel Tools Platform update site - Release 2.0

0 of 16 selected.
¥ Show the latest version of a feature only

Filter features included in other features on the list

Cancel

Module 1 PTP Tutorial 1-21
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Choose features

+ Choose PTP features to
install

+ Easy way to choose:
+ Select all

+ Unselect anything
with red "X” @

+ This omits features
for which you lack
the pre-requisites
(e.g., RSE, TAU,
Fortran)

Search Results

Select features to instal from the search result list =

Select the features to instal:
< & 9 TutorialcDpdatesite Deselect All
- 1 Parallel Tools Platform 2.0
@ Parallel Tools Platform End-User Runtime 2.0.1200804292220
@ PTP Parallel Language Development Tools 2.0.1.200804292220
@ PTP Common Extemal Components 2.0.1.200804292220
4 PTP Remote Tools Enabler 2.0.1.200804292220
@ PTP RSE Enabler 2.0.0.200804292220
& PTP Remote Tools 2.0.1.200804292220
& PTP Support For IBM LoadLeveler 2.0.1.200804292220
@ PTP Support For IBM Parallel Environment 2.0.1.200804292220
@ PTP Support For Open MP1 2.0.1.200804292220
& PTP Scalable Debug Manager 2.0.1.200804292220
& PTP Support For MPICH2 2.0.1.200804292220
4 PTP Performance Analysis Framework 1.0.1.200804292220

select Required

4 PTP Remote Development Tools 1.0.1.200804292220
@ PTP performance Analysis Framework for TAU 10,1 200804292220

% PTP performance Analysis Framework: TAU Fortran Enabler 1.0.0.200804292220
% @ PTP paraliel Language Development Tools - LAPI support 2.0.0.200804292220

13 of 16 selected
 Show the latest version of a feature only
Filter features included in other features on the list

® Next> | Cancel

Module 1 PTP Tutorial 1-22

+ +++++

Click Next >
Accept the license terms
Click Next >

Click Finish

For Feature Verification, click
Install All

Restart the Eclipse Platform when
asked

Install/Update

changes to take effect, but it may be possible to apply the
changes to the current configuration without restarting. Would
you like to restart now?

@ It is recommended you restart the Eclipse Platform for the

No Apply Changes |

Search Results

Select features to install from the search result list.

Select the features to install:

< @ 4 Tutorialc Djupdatesite | Deselect Al

@ 11 Parallel Tools Platform 2.0 L

¥ 4= Parallel Tools Platform End-User Ry
g4 PTP Parallel Language Developme,

¥ = PTP Common External Componen| m
T Dl

@ Next > | cancel

Module 1 PTP Tutorial 1-23
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File Edit Refactor Navigate Search Project Run Window Help
+ Welcome page | fvecmes i S
informs you of Q @+ &
new features
installed Overvi
verview
workbench
Select
Workbench icon The Eclipse Platform is a kind of universal tool platform - an open extensible IDE for anything and nothing in particular.
to go to T Parallel Tools Platform
workbench Leam more about PTP, the Parallel Tools -—
Platform. Yel IOW
. indicates new
= Parallel Language Development Tools : W
Learn more about PLDT, to help in developing featu res JUSt
MPI and OpenMP programs installed
>>  Workbench basics
‘ Learn about basic Eclipse workbench concepts
< B F
Module 1 PTP Tutorial 1-24

(Installing the PTP Proxy)

+ Normally installed on a parallel machine
+ e.g. a cluster
+ Can install on a non-parallel system

+ Not available for Windows

+ Requires OpenMPI to be built and installed
+ This process depends on the type of machine
+ Beyond the scope of this tutorial

+ To install the proxy, do the following steps from a terminal
+ Change to your Eclipse installation directory
+ Change to plugins/org.eclipse.ptp.os.arch 2.0", where

os is your operating system (macosx or 1inux), arch is your
architecture (ppc, x86, Oor x86_64)

+ Run the command: sh BUILD
* Directory may include a suffix of build date timestamp.
Module 1 PTP Tutorial 1-25
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Workbench

+ The Workbench
represents the desktOp gile Edit Navigate Search E'f,‘e(t Eun‘ Window Help - . :
development environment | | .. oo - e =

+ It contains a set of tools
for resource management

+ It provides a common ATaskale © Consde] @ X B ° =0
way of navigating through — — °/"em5|! [
the resources —

+ Multiple workbenches can
be opened at the same
time o O E—— 5l
Module 1 PTP Tutorial 1-26

Workbench Components

+ A Workbench contains perspectives
+ A Perspective contains views and editors

Resource - MyCproject/src/MyCproject.c - Eclipse SDK

Edit Refactor Navigate Search Project Run Window Help

perspectlve () Project Explorer 23 = 8| [g MyCproject.c & =8

= #include <stdio.h> =
¥ &5 MyCproject #include <stdlib.h>
editor o st |
P iincludes puts("!!!Hello World!!!"); i ‘]

/K return EXIT_SUCCESS;
}
b [

! |
b > Debug G I ]
7 Tasks 83 & Console X 3 v=0
£Z Outline 52 ey

VieWs 1 R W ~ ‘* |! |Des(nplion IResource |F
\ U stdioh
T

B

© main(void) : int al ol

]
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Perspectives

+ Perspectives define the layout of views in the
Workbench

+ They are task oriented, i.e. they contain
specific views for doing certain tasks:

+ There is a Resource Perspective for manipulating
resources

+ C/C++ Perspective for manipulating compiled code
+ Debug Perspective for debugging applications

+ You can easily switch between perspectives

Module 1 PTP Tutorial 1-28

Switching Perspectives

+ You can switch Eismiea i Eomincina iy Eomiacie S SR
Pers pectives by : File Edit Refactor Navigate Search Project Run Window Help
v w | Qv Resource b
+ ChOOSIng the Project Explorer &3 O [& MyCproject.c 3 =0
Window»Open N =
Perspective menu | = ‘e (
option s T ]
+ Clicking on the 7" © . =
- P & Debug
Open Perspective | OTasksE) O Console X % -0
7= Outline ¢ 0 items
bUtton . L N M % [r |De5:noﬂon |Resour<e |F
+ Clicking on a e
perspective shortcut| - mnvoio i = .
button @
Module 1 PTP Tutorial 1-29
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Available Perspectives

. Window »
+ By defaU|t, certain Open Perspective
perspectives are available -
. = Open Perspective x|
in the Workbench . _
+ We,” use. [#3 CVS Repository Exploring
%5 Debug
+ C/C++ %8 PTP Debug
+ PTP Runtime 8 PTP Runtime
5 Resource
+ PTP Debug £0 Team Synchronizing
oK ‘ Cancel |
Module 1 PTP Tutorial 1-30

Views

+ The workbench window is
divided up into Views

VIEW | view

+ The main purpose of a view is:
+ To provide alternative ways of presenting information
+ For navigation
+ For editing and modifying information

+ Views can have their own menus and tQolbars

+ Items available in menus and toolbars are
available only in that view

+ Menu actions only
apply to the view ¢ Outline 2 2 R & o ¥ =0

+ Views can be resized ® main):int

Module 1 PTP Tutorial 1-31
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Stac

ked Views

+ Stacked views appear as tabs
+ Selecting a tab brings that view to the

foreground

Resource - MyCproject/src/MyCproject.c - Eclipse SDK
File Ngdit Refactor Navigate Search Project Run Window Help
» 5 a | Qv > giv TovX =L =22
() Project Explol = B [ MyCproject.c & =8
< S
IR #include <stdio.h> ol
~ &5 MyCproject #include <stdlib.h>
¥ Bi
b ¥ Binaries int main(void) {
b @Includes puts("!!!Hello World!!!"); /* prints !1!
> B return EXIT_SUCCESS;
b L (=]
b (=Debug bl
v Tasks & [ Console 5 X P Y=0
£F Outline 22 = 8| iems
R o~ ‘V |! |Descrip(inn |Resomce |F
H stdioh
o sudib.h
© main(void) : int = 0]
o @
Module 1 PTP Tutorial 1-32

+ Access help
+ Help»Help Contents
+ Help»Search
+ Help»Dynamic Help

+ Help Contents provides
detailed help on different
Eclipse features

+ Search allows you to
search for help locally, or
using Google or the Eclipse
web site

+ Dynamic Help shows help
related to the current
context (perspective, view,
etc.)

Module 1

Search: |
Contents [} =]
# Workbench User Guide
+ " C/C++ Development User Guide
* Running IBM LoadLeveler Batch Jok
" PTP Parallel Language Developmer
 Running IBM Parallel Environment
 Parallel Tools Platform User Guide

p - Eclipse Platform
se

e latform = o x|

All topics

[ ) 2 I

Using the Eclipse help system

Browse topics in the Contents frame () on the left
Click on a topic to have it displayed. Use the Back
and Forward buttons to navigate within the history of
viewed topics

searching

To quickly locate topics on a particular subject in the
documentation, enter a query in the Search field
Use the Search frame (#) to display the Search
view. You can narrow the scope of your search by
selecting only the sections you are interested in

Synchronizing

After you run a search and find a topic you were
looking for. click either the Refresh / Show Current
Topic button () or Show in Table of Contents
bution (%) to match the navigation tree with the

< >]| curenttopic. You might also find it usetul to
@ synchronize after following in-topic links. "
PTP Tutorial 1-33
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Window > Open Perspective > Other...

Open PTP Runtime Perspective

f | Help
New Window

e | %> Debug -
Show View \> £Y Team Synchronizing e

[z CVS Repository Exploring
Customize Perspective... Other... %5 Debug
Save Perspective As... \ # PTP Debug
Reset Perspective 888 PTP Runtim
Close Perspective l¢5 Resource
Close All Perspectives £Y Team Synchronizing
Navigation >
Working Sets > oK Cancel
Preferences...
Module 1 PTP Tutorial 1-34

+ The PTP Runtime perspective is provided for

+ Some terminology

+ Resource manager - Corresponds to an instance of
a resource management system (e.g. a job
scheduler). You can have multiple resource mangers

connected to different machines.
+ Queue - A queue of pending jobs

monitoring and controlling applications

+ Job - A single run of a parallel application

+ Machine - A parallel computer system

+ Node - Some form of computational resource
+ Process - An execution unit (may be multiple

threads of execution)

Module 1 PTP Tutorial

18



Resource > Wy o-ar = & ([BEERRED R
managers view=—» .

Machines view —»

Node details Yode Rtes= process info
view ’

Jobs & = 0| @ Console &3 [2. Problems T Properties| & Tasks @) Eror Log =o
Please select a job No consoles to display at this time.

Jobs view —

Module 1 PTP Tutorial 1-36

Resource Managers

+ PTP uses the term resource manager to refer to any
subsystem that controls the resources required for
launching a parallel job.

+ Examples:
+ Job scheduler (e.g. LoadLeveler)
+ Open MPI Runtime Environment (ORTE)

+ Each resource manager controls one target system
+ Resource Managers can be local or remote

Module 1 PTP Tutorial 1-37
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File Edit Refactor Navigate Search Project Run Window Help

+ Right-click in Resource =5 Dl ererliEle
Managers view and select OLEE S0k -
Add Resource Manager [Add Resource Manager.. |
# Machines 83 <o
+ Choose the ORTE e 5 %
Resource Manager Choose Resource Manager Type
Type

Select the type of resource manager to use

Resource Manager Types:
LSF

+ Select Next> MPICH2

Module 1 PTP Tutorial

Configure the Resource Manager

oRTE P ourati + Can choose Remote
roxy Configuration - -
Enter information to connect to an ORTE proxy server [ service prOVIder
+ Can choose Proxy

Remote service provider: | Local ol server |ocati°n
Proxy server location: | Local < \
Path to proxy executable: [847/binjptp_orte_proxy] | Browse || oOptions... |

@ None Choose Resource Manager Name and Description

Local address for proxy connection: |localhost.localdomain ‘ v Enter a name and description for the resource manager
.
[[) Use default name and description:
[ Launch server manuall ORTED Configuration [
¥ Enter information to configure ORTED Name: ORTE@Local ‘

Description: |ORTE Resource Manager |
¥ Use default settings

~

Nex Path to ORTED:

Extra ORTED arguments:
For details on remote o LeEER] T
resource managers, see
Module 5 ? [ <pack Next> |[ finish Cancel
Module 1 PTP Tutorial 1-39
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Starting the Resource Manager

+ Right click on new
resource manager and
select Start resource

manager \

+ If everything is ok, you
should see the resource
manager change to green

+ If something goes wrong,
it will change to red

(.) ResoMrce Managers 2

@ ORTE@N.N.N.N (ORTE)

Module 1

(+) Resource Managers &3

& ORTE@N.N.N.NgL22

Add Resource Manager...
Remove Resource Manager

\ Edit Resource Manager
&2 Machines 2

g > Start Resource Manager
Please select a mac

\' Resource Managers 2
D (3 ORTE@N.N.N.N (ORTE)

PTP Tutorial 1-40

System Monitoring

+ Machine status shown in
Machines view

+ Node status also shown
Machines view

+ Hover over node to see
node name

+ Double-click on node to

(5) Resource Managers =0

» & ORTE@N.N.N.N (ORTE)

&8 Machines &3 a o o =8
ORTE@N.N.N.N: localhost.localdomain - Root [64]

B localhost localdomain o [CIEEEE T

show attributes

Module 1

LB ) SRR Y S R S

o HHEHEEEEEEE

30
40
50
60

A
HEEEEEEEEE
HEHEEEEEEE
gEEE

Node Attributes Process Info

Attribute Value

Node Number 0
Node State upP
| TR [>]
PTP Tutorial 1-41
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Module 2: Creating and
Running MPI Programs

+ Objective
+ Learn how to use Eclipse to develop parallel programs
+ Learn how to run and monitor a parallel program
+ Contents
+ Brief introduction to the C/C++ Development Tools
+ Create a simple application

+ Learn to launch a parallel job and view it via the PTP
Runtime Perspective

Module 2 PTP Tutorial 2-0

Switch to C/C++ Perspective

. Help
‘* Only needed |f New Window )
you're not
H CVS Repository Exploring
a I ready I_n the Show View >| [ty Resource
perspective , )
Customize Perspective... Other...

Save Perspective As...
Reset Perspective
Close Perspective
Close All Perspectives

[& CVS Repository Exploring

Navigation >
= %5 Debug
= Working Sets > % PTP Debug
Preferences... 838 PTP Runtime
[25 Resource

£0 Team Synchronizing

oK ‘ Cancel ‘

Module 2 PTP Tutorial 2-1




Project Explorer View

+ Represents user’s data
+ It is a set of user defined

resources ' Project Explorer &3 =0
+ Files =& Y
+ Folders b &2 Binaries
+ PrOjeCtS b [ Includes
¥ Esrc
+ Collections of files and

P e MyCproject.c
folders b (=Debug

+ Plus meta-data

+ Resources are visible in
the Project Explorer View

Module 2 PTP Tutorial 2-2

Editors

+ An editor for a resource (e.g. a file)
opens when you double-click on
a resource
+ The type of editor depends on the type of the resource
+ .c files are opened with the C/C++ editor
+ Some editors do not just edit text
+ When an editor opens on a resource, it stays open across
different perspectives
+ An active editor contains menus and toolbars specific to that
editor

+ When you change a resource, an asterisk on the editor’s
title bar indicates unszi}ed changes

L *MyCproject.c £3

Module 2 PTP Tutorial 2-3




Source Code Editors

A source code editor is @ i linear functionc =2 =0
special type of editor for V' -
manipulating source )

double evaluate(double x)

code i :
7z / add semicolon to end of next line
= X + 2.,
Lgngyage features are . gg:';t;; 3.92%.1.2.8 B
highlighted

Marker bars for showing
+ Breakpoints

+ Errors/warnings
+ Tasks

Location bar for
navigating to interesting

features
Module 2 PTP Tutorial 2-4
Preferences
Eclipse Preferences allow customization of almost everything
Open

Window » Preferences... ... o
C/C++ preferences R v Q| me

allow many options

Code formatting settings
(“Code Style”) shown here

Property Pages settings
Task Tags.
Template Default Values

Module 2 PTP Tutorial 2-5




Set up for MPI development 2

Preferen

ces

+ To use the PTP Parallel Language Development Tools feature for

MPI development, you need to
+ Specify the MPI include path
+ Specify the MPI build command
+ Open
Window » Preferences...
+ Open the PTP item

+ Open the Parallel Language
Development Tools item

+ Select MPI /

+ Select New... to add MPI
include path

+ If running OpenMP, add its

b General

x

Preferences (%]

MPI

MPI include paths:

include file location here too
(we will cover that later)

Module 2 PTP Tutorial

b An Justfocalfinclude
b C/C4+
b Install/Update S
b Java
b Plagin Development [ _oow_]
v PP MP! build command: | mpicc
< Parallel Language Devi
OpenMP

Resource Managers

Viewer
b Run/Debug
b Team

Restore Defaults Apply

=1 B

Creating a Parallel Application

Steps:

+ Create a new C project
+ Edit source code

+ Save and build

Module 2 PTP Tutorial
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MPI Project (1)

Create a new MPI project

[ x|
+ File» New»C Project | ‘create  rofct ot sectea ype =
\ MyH el IOPrOJeCt, | @ Use default location
+ Under Project types, under profect ypes
Executable, select MPI © Helo vord 4+ project
Hello World C Project < ey e
and hit Next T r—
+ On Basic Settings page, © oty € e
fill in information for your < orenis ey oot
new project (Author
name etc.) and hit NeXt ¥ Show project types oolchains only if they are supported on the platform
Next > Finish Cancel
Module 2 PTP Tutorial 2-8

Creating

a simple

MPI Project (2)

- . (] [x]
O_n the MPI Project Settings MPI Project Stings -
wizard page, ma ke sure Add Select the MPI include path, lib name, library search path, and build
MPI project Settings tO this command information to be automatically be added to the new project.
= H P[] Add MPI project settings to this project
proJeCt IS CheCked- i L] Use default information
Change default paths, etc. if—="] . stacalinclu
necessary (they are probably Litary nam =
OK) Library search path ustflocalflib
Hit Finish* ] MPI compile command: | mpicc
MPI link command: mpicc
*If you instead hit Next, then
on the Select Configurations
page, you can alter Project
settings. Hit Finish. @ <Back |[[ Emsh ][ cance
Module 2 PTP Tutorial 2-9




Changing the C/C++ Build
Settings Manually

+ Open the project properties
by right-mouse clicking on . raperdesforynlaprajce =
project and select — — i

Properties © s

+ Open C/C++ Build —

Configuration: | Debug 2| [Manage configurations

$Tool settings |+ Build steps  Buld artifact «.)Binary parsers  Error parsers

- 3% GCC C Compller Command: @

= 3 Preprocessor All options: -Iisflocalfinclude -00 -g3 -
+ Select Settings ¢ ssage
- length=0

H Project References 2 Optimization
+ Select GCC C Compiler to

3 Warmings Command

Cha nge com pller Sett| ngs Run/Debug Settings o o erern: |${COMMAND) §{FLAGS) $¢

1 GCC C Linker

+ Select GCC C Linker to _—

Ubraries.
Miscellaneous

change linker settings

+ It's also possible to change ' S
compiler/linker arguments : Or L caeet

Module 2 PTP Tutorial 2-10

Editor and Outline View

file Edit Refactor Navigate Search Project Run Window Help

+ Double-click on e P T - e
source file in the &7 |me|e
PI‘Oject Explorer , Project Explorer 2 "'S < MyHelloProject.c &3 =0 ZEout 8 9 Mak| = O
to open C editor \

S #include <stdio.h> o B R e T
#include <string.h>

< & MyHelloProject #include "mpi.h* u stdioh
b 4 Binaries ) L u stringh
int main(int argc, char+ argv[]){
R &) Includes int my_rank; /+ rank o mpih
R int p; * number o main(int, char#(]) : in

+ Outline view is B yrelorrojectc int source;
shown for file in G et 101 e
editor —— 5

> >
* Problems 52 i Tasks [ Console [ Properties b Remote Environm = 8
0 errors, 0 wamings, 0 infos _—

Description Resource Path Location

Writable sm..rt

Module 2 PTP Tutorial 2-11




Content Assist

+ Type an incomplete MPI function name e.g. "MPI_Ini" into the
editor, and hit ctrl-space

+ Select desired completion value with cursor or mouse

Initializes MPI.

find out process rank

MPI_ Inij
© MPI_Init(int *, char ***) int
T _find e MPL_Init_thread(int *, char **%, int, int ) int
MPI_Com o MpI_initialized(int =) int

+ Hover over the MPI Artifact

identified in the source file to I-IPI_Co!nm;Iénk (MPI_COMM_WORLD, &my_rank) ;

see additional information Brotatype: it T Conm_rark(VP1_Conm,

a bO th th at fLI n Ct' on Ca | I 7 fO r RDeet\st;Isp;':rr‘:ank of the local task in the group assodated with a tomnTunlcator.
example e
Module 2 PTP Tutorial 2-12

Context Sensitive Help

+ Click mouse, then press help

key when the cursor is within a MPI Co _COMM WORLD, &my_rank
function name i
+ Windows: F1 key 2izDeensfr:r:.sp::':'::anks.‘melocakaskm:he roup associated with a com
+ Linux: ctrl-F1 key ; =l
+ MacOS X: Help key or Dl ¢ —
Help»Dynamic Help Related Topics

+ A help view appears (Related | ="

Click below to see help.

Topics) which shows See also:
additional information B Edior view lick here
. . [ int MPI_Comm_rank(MPI_Comm, int %)
4+ Click on the function name to
see more information D Hep £2 =g
+ Move the help view within your diowedle

Eclipse workbench, if you like, MPI Comm rank
by dragging its title tab - -

int MPI_Comm_rark (MPI_Comm, int *)

Retums the rank of the local
task in the group associated
with a communicator.

Module 2 PTP Tutorial 2-13




Running a Parallel Application

Steps:

+ Create a launch configuration
+ Run the application
+ Monitor its progress in the PTP Runtime

Perspective

Module 2

PTP Tutorial 2-14

Organize Fayorites...

+ Open the run
configuration
dialog Run»
Open Run Dialog...
+ Select Parallel
Application
+ Select the New
button

Module 2

2 Run

Create, manage, and run configurations ¢
Create a configuration to launch a parallel application in Parallel Perspective W

B 3 Configure launch settings from this dialog:
™ : - Press the 'New' button to create a configuration of the selected type.
] C/c++ Local Appication - press the ‘Duplicate’ button to copy the selected configuration

: parallel Application X - Press the 'Delete’ button to remove the selected configuration.

¢ - Press the ‘Filter button to configure filtering options.

- Edit or view an existing configuration by selecting it.

Configure launch perspective settings from the Perspectives preference

Filter matched 2 of 2 items

@ Close

x|

PTP Tutorial 2-15




Complete

In Resources tab, select
the resource manager you
want to use to launch this
job

Enter a value in the
Number of Processes field

Module 2

the Resources Tab

Create, manage, and run configurations

Create a configuration to launch a parallel application in Parallel Perspective ~4
x - 24
Name: [MyHelloProject
type fiter text — = =
Application | > Debugger ¢4~ Arguments| . Source 1§ Environment | ”q
[E1C/C++ Local Application || | pecoireeTanager: | ORTE@Local
= § Parallel Application
Launch Attributes
; romty_ [ Rever
Filter matched 3 of 3 items
Run Close
PTP Tutorial 2-16

Complete the Application Tab

+ Ensure that the correct
Parallel Project is selected

+ Select the Application
program (executable) by
clicking the Browse button

+ Local program: executable
is under Debug folder in the
project

Remote program: must

copy to remote machine;

navigate to its location on
the remote machine here.

+ Select Display
combined output in a
console view if desired

+

Module 2

Run X
Create, manage, and run configurations
© [Debugger]: No debugger available J
&S Name: | MyHeloProject
type flter text 5 .
Yoo Ry o i Resource’]) Appication Y Debugger - Arguments & Source | ¥ Environment ™y
[€1C/C++ Local Application | parallel Proje!
< I Paraliel Application [yHeloproject) e
‘&pplication program
ject Browse
< [Display combined output in a console view
Apply Reyert
filter matched 3 of 3 items
Close.

PTP Tutorial




Complete the Debugger Tab

+ Select Debugger tab Create, manage, and run configurations

+ Choose SDM from the Create a configuration to launch a parallel appiication in Parallel Perspective

x

Debugger dropdown = ame: yetoprect

type flter text - =
ype fiter tex £ Resources Aoph(al e Arguments  t, Source 7% Environment ™

+ Confirm the debugger LG S e som

executable BT stop ot man
+ Set debugger session

address

+ In Arguments tab, enter
arguments and working
directory

+ Click on Run to launch the
program “alems

Del ptions
ath to debugger executable:
forg.eclipse ptp.inux x86_2.0.0.200804; pinysdm]|
Debugger session address
localhost Jocaldomain
Apply.

> i

Browse

Reyert

Close

Module 2 PTP Tutorial

e Edt Refactor Navigate Search Project Run Window Help

+ Double-click a o o8 |0 ar o =

2 Resource Managers & =a

node in machines
view to see which
processes ran on e Y I
the node

| localhost Jocaldomain

+ Hover Over a Node Attributes Process Info
process for tooltip e M
popup

Node Numi 0
Node State UP

i J Y [ 5 @~ |4j=0
e
+ Job and processes —> GEZN v v+ v

shown in jobs

view

& [EPTP Runti..| TCiCH+

2 MyHelloProject.c &

int main(int argc, ehart argv(]){
int my_rank; /¢

int tag=e;
char message(106);
WI_Status status

WPI_Init(6arge, Gargv);
WPI_Conn_rank (WPI_COMM_WORLD, Smy_rank)
WPI_Conm_size(MPI_COMY_WORLD, &p)

it (my_rank 1=0){

sprintf (nessage, *Hello WPI World from process *
st = 0;

© Console 32 [£. Problems| ) Properties £ Tasks
C-Buid [MyHeSoProject]
Tnvoking: GCC C Linker
mpicc -L/usr/local/Lib -o"MyHelloProject® /src/
MyHelloProject.o - lnpi

Finished building target: MyHelloProject

Module 2 PTP Tutorial
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PTP Runtime - job02:0 - Eclipse Platform - home/beth/ews/runtime=ptp20_0326/
Fle Edit Navigate Search Project Bun Window Help

3> W By 0v Q- Qv O |2 |4 © e £ | B PTP Runti..| RC/C++

@ Resource Managers 53
b () ORTE@Local (ORTE)

i Machines &3

ORTE@Local: localhost Jocaldomain - Root [10] Hello MP1 World from process 1t

|8 localhost Jocaldomain oHMEEummumE [ Helo MPI World from process 2!

+ Double-click a
process to see
process detail and
standard output e et

from the process e odel

Node Numt 1
Node State UP.

=0 [ MyHelloProject.c i job02:0 &3 =0

Process details

PID: 23513

Status: EXITED

~ Program output

o~ @y =8
Hello MPI World From process 0: Num processes: 4

Hello MP1 World from process 3!

Process Info
¥ job02:1

4= O '@ console 11 (2. Problems = Properties
. C-Build [MyHelloProject] - =

Invoking: 6CC € Linker e
mpicc -L/usr/local/lib -o*MyHelloProject” ./src/
MyHelloProject.o  -lmpi

Finished building target: Mynelloproject

? EXITED PID: 23513

Module 2

PTP Tutorial 2-20

About PTP Icons

+ Open using legend icon in
toolbar

Module 2

Resource Manager Icons
@ STARTING
@ STARTED
@ STOPPING
% STOPPED
+ SUSPENDED
@ ERROR
Machine Icons Node Icons
up o oue & USER SHARED
& DOwWN I Dpown © OTHER EXCLUSIVE
ALERT E ERROR @ OTHER SHARED
# ERROR 2 UNKNOWN @ PROCESS RUNNING
# UNKNOWN @ USER EXCLUSIVE [&) PROCESS TERMINATED
Job Icons Process Icons
© PENDING + STARTING
© STARTED » RUNNING
© RUNNING ¥ EXITED NORMALLY
O TERMINATED ¥ EXITED WITH SIGNAL
@ SUSPENDED » SUSPENDED
© ERROR ¥ ERROR
@ UNKNOWN % UNKNOWN
Close]
PTP Tutorial 2-21
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Module 3: PTP and Parallel
Language Development Tools

+ Objective
+ Learn to develop a parallel program
+ Learn to analyse with PLDT

+ Contents

+ Learn to use PTP’s Parallel Language Development
Tools

+ Learn to find MPI & OpenMP artifacts
+ Learn how to do MPI and OpenMP Specific analysis

Module 3 PTP Tutorial 3-0

Parallel Language Development
Tools (1)

+ Features

+ Analysis of C and C++ code to determine the location
of MPI and OpenMP Artifacts (Fortran planned)

+ "Artifact View" indicates locations of Artifacts found in
source code

+ Navigation to source code location of artifacts
+ Content assist via ctrl+space (“completion”)
+ Hover help

+ Reference information about the MPI and OpenMP calls
via Dynamic Help

Module 3 PTP Tutorial 3-1




Parallel Language Development
Tools (2)

+ More PLDT features:

+ New project wizard automatically configures
managed build projects for MPI & OpenMP

+ OpenMP problems view of common errors

+ OpenMP “show #pragma region” action
+ OpenMP “show concurrency” action
+ MPI Barrier analysis - detects potential deadlocks

Module 3

PTP Tutorial

3-2

Show MPI Artifacts

Select source file; Run
analysis by clicking on
drop-down menu next
to the analysis button
and selecting Show
MPI Artifacts

W Show MPI Artifacts
#» Show OpenMP Artifacts
/7, MP1 Barrier Analysis

o Navigute Seacch Project Run Window Help

@ &y Gy Gy Ry v |3

TR (P1_COMLWORLD, Say_rank);

. . () Project Explorer &3 =0
Markers indicate the ( o)
location of artifacts in " S
editor o reses ‘
In MPI Artifact View \ ek, Garen: Uk

sort by any column

(click on col. heading ™
Navigate to source code
line by double-clicking

il
2 Tasks & Console (2. Problems ¥ MP1 Artifact View £2

WPI_Comn_size (APT_COMM_WORLD, &num_procs);

on the artifact e e =
. P MPI_Reduce MyMPlproject.c 37
Run the analysis on > i MyMPIpectc 57
another ﬁle a nd ItS » MPI_Comm_size MyMPlproject.c 63
markers will be added to > e pivia .
the view [ grirrt — '

Remove markers via %

Wiitable Smart Insert | 60: 18

Module 3
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MPI Barrier Analysis

Sace.- - Eclipse SOK - C . Lo

O Gle e @-e 145 i5-0-ai07inGi0" Bger- Verify barrier

= s o T 5 om m“ 5| synchronization in C/
' s i . 2| MPI programs

s o Interprocedural static
- analysis outputs:
+For verified programs,
. ‘ e I lists barrier statements
— - | that synchronize
"""" T == | together (match)

+ For synchronization
errors, reports counter
example that illustrates
. i e — - .| and explains the error.

Module 3 PTP Tutorial 3-4

MPI Barrier Analysis - views

11 P Barriers £ = 03([2. Problems | ] Tasks | B Console Y/ Barrier Matches § = 01 (Ut Barrier Ervors £ i v=0o
g i 7 | Barrer Matching Set Function
50
Functon Barrier Matching Set | Function Filename LineNo [ VA Error jmai

@ WA Path 1 (1 barrier(s))

W “main = UhiBarer 1(2)  Barvier MyBarrier.c s bk
Wi man Vhigarier 1 Barier wgarierc 8 e e outh 2(3 o) —
VA man YhBaters  man MyBarrier.c 4 _— .
WA main = UhiBarrier 2(1)  main MyBarrier.c 31 DA G L)
W4 man /i Barrier 2 main MyBarrier.c 31
Wi Bariier S WhBarier3(2)  main MyBarrer.c 4
/i Barrier 1 Barrier MyBarrier.c 8
/i Barrier 3 main MyBarrier.c 41

Ul Barrier 4(0)  main MyBarrer.c 57
® WA Barrier S(1)  main MyBarier.c 62 =
< SR > < >
) alPQAL

MPI Barriers view Barrier Matches view Barrier Errors view

Simply lists the barriers Groups barriers that
match together in a

If there are errors, a

Like MPI Artifacts view, parrier set - all counter-example
double-click to processes must go shows paths with
navigate to source through a barrier in mismatched number
code line (all 3 views)  the set to prevent a of barriers

deadlock
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OpenMP Managed Build Project

+ If you haven't set up
OpenMP preferences e.g.
include file location, do it
now

+ Create a new OpenMP
project
+ File»New »C Project
+ Name the project e.g!
‘MyOpenMPproject’ A
+ Select OpenMP Hello World C
Project

+ Select Next, then fill in other
info like MPI project

(v
C Project
Create C project of selected type
Project name: | MyOpenMPproject

[¥] Use default location

Location: |/home/tibbitt runtime-pldt20/MyMPIg

Project types: Toolchain:

© Hello World C++ Project

@ Hello World ANSI C Project
® Empty Project

© MPI Hello World C Project
© MPI Empty C Project

LY @ OpenMP Hello World C Proj

© OpenMP Empty C Project
= Shared Library
> Static Library &
1 I—Z—

Show project types and toolchains only if they are supported on the platform

E [ Nex>

Module 3 PTP Tutorial 3-6
Setting OpenMP Special
Build Options
3 Properties for MyOpenMPproject =/X]
+ OpenMP typically requires |[imoee Settings
special compiler options. : —— o

+ Open the project

properties //v
+ Select C/C++ Buily 5
+ Select Settings

+ Select C Compiler

&) Tool settings | #* Buid steps

[Jsupport ANSI programs (-ansi)

+1In Miscellaneous,
add option(s).

Buid artifact | ¢ Binary parsers | @)

Other fiags | ¢ -fmessage-ength=|

Module 3 PTP Tutorial
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Show OpenMP Artifacts

S C/C++ - MyOpenMPproject/src/MyOpenMPproject.c - Eclipse SDK - C-\ews\runtime-temp = X]
File Edt Refactor Navigate Search Project Run Window Heb
i~ & S A~ AT A g $-0-Q- O B %5 Debug |Eiclc++ | 2ava
! > ms m
+ Select source file, |Cromome s =5/ momepomac =Bl 5% =E

o % double - - BV o

folder, or project e printe cpene o

U stdoh
® ) Indudes I U srigh
f @ (3 s o s
4+ Run ana|y5|s D B ir om_inparalien0)s g
\ < = printf( hE o .
= {5 MyOpenMPproject ) U openmp.h
% ) indudes R o manint, dhar
o D e x = (double *) malloe( ( ( 1ze * sizeof (dot
= oS3 y = (double *) malloc( (. ( i1ze * sizeof (dov
® (& Debup
o P e ) G T CY O e e o (e |
< P #pragna omp parallel for
W Show MPI Artifacts for (1= 0; i< arraysize; irs)
B> Show OpenMP Artifacts y[i] = sin( exp( cos( - exp( sin(x[i]) ) ) ) )z
}
/i MP1 Barrier Analysis return 0;
< > < >

i i B e e e of Artfact view 3 =0
+ See artifacts in i :

X%
OpenMP Artifact e I — o =
- W =pragma omp paralel for MyOpenMPproject.c 34
view - N
(3 >
Module 3 PTP Tutorial 3-8

Show Pragma Region

+ Run OpenMP
analysis * Here's the O MP pragma that parallelizes the for-loq |(m

’ #pragma omp parallel for

+ nght CIle On fo:‘ (1=0; i< arraySize; i++ ) =

H y[i] = sin( exp( cos( - exp( sin(x[i]) ) ) ) ):
pragma in ,

artlfact VleW , return 0;
(v
(<] m ‘ Bl <

[2. Problems | | Tasks | E] Console Debug | @ OpenMP Problems ’ OpenMP Artifact View &3

+ S € I € Ct s h ow OpenMP Artifact Filename LineNo
p ra g ma reg i on omp_in_parallel MyOpenMPproject.c 26
#>{ #pragma omp parallel for T pjecte 34

Show pragma region

+ See highlighted region in C editor

Module 3 PTP Tutorial 3-9




Show OpenMP Problems

S C/Ces- proj pe - Eclipse SDK - C:\ews\runtime-temp Lo
Fle Edt Refactor Navigate Search Project Run Window Help
[SHNEIEEC AN ANCANCAEE A RSHE “S a0 R0 S A » B [ %5 Debug
& & REREURRTIRACRER @ cic++ | & Java
+ SeIeCt open M P [25 Project Explorer 82 = O || [¢] =MyopenMPproject.c (<) openMPproblems.c 2 =0
problems view 2 7 » gprama omp paraiiel for S
= & MyMPIoroject for(3=1; 3<10: 3++)
+ Will identify standar
OpenMP restrictions
int 1, 3; i
® .c openMPproblems.c
# @ Debug » for
> g -

v

[2. Problems | Tasks 5 Console | @ OpenhP Problems 2 ¥ OpenlP ArtifactView| — [
i -

Description Re!

® For directive embedded within another paralel for or paralel sections o1

@ Barrier directive not permitted in region extent of for, ordered, sections, snle, master, and critical  op:

2(|(<] >
SmartInsert | 26:5

Writable

Module 3 PTP Tutorial 3-10
Show Concurrency
+ Highlight a statement int ;;'r“g;?gmp parallel
+ Select the context menu -
on the highlighted b-2:
statement, and click A
Show concurrency i H
+ Other statements will be
highlighted in yellow
+ The yellow highlighted int simle2O{ =~
statements might execute (o oana. SR RIS
concurrently to the -y
selected statement #pragna_omp_barrier
b=3;
a=4;
}
}
Module 3 PTP Tutorial 3-11




Module 4: Parallel Debugging

+ Objective

+ Learn the basics of debugging parallel programs with
PTP

+ Contents
+ Launching a parallel debug session
+ The PTP Debug Perspective
+ Controlling sets of processes
+ Controlling individual processes
+ Parallel Breakpoints
+ Terminating processes

Module 4

PTP Tutorial 4-0

Launching A Debug Session

+ Use the drop-down next to
the debug button (bug
icon) instead of run button

+ Select the project to launch

+ The debug launch will use
the same number of
processes that the normal
launch used (edit the
Debug Launch
Configuration to change)

By Ov Qv (O~ | i
Debug As >

% Open Debug Dialog...
Organize Fayorites...

Module 4

—

£ PTP Runtime - job05:0 - Eclipse SDK

File Edit Refactor Navigate Search Run Project Window Help
i a3 Ov Qv |Ov | E | & G~
(3) Resource Manage_ =8|

%5 Open Debug Dialog...
Organize Fayorites...

888 Machines 2 =Y o &y =08
ORTE@scO07tutorial: localhost.localdomain - Root [64]

EE localhost.localdomain 0 [ 18] (G55 ) ) )

Node Attributes Process Info

Attribute  Value [

PTP Tutorial 4-1




The PTP Debug Perspective (1)

+ Parallel Debug
view shows job
and processes
being debugged —

Debug view shows

threads and call —»

stack for individual
processes

Source view

line marker for all
processes

£ PTP Debug - MyMPIProject/testMPl.c - Eclipse SDK.

Fle Edit Refactor Navigate Search Run Project Window Help

=/ 0| X}

shows a current ~ i

r3v W |y Oy Qv | Ov = £ |EBPTP Debug| £ PTP Runti... EAC/C++
28 Parallel Debug &2 = 8|9 Breakpoints ¢9=Varlables £3 . 4 Expressions =8
ORTE@scO7tutorial: d & > ® 0 P @ % B 3
0 job02 o® vy r Name Value
¥ job06 & my_rank 4545765
Sog| ©Mmprocs 134515657
Ceboojs - L  source -1076822980
< §3 MyMPIProject [Parallel Application] @ dest 1076823128
- & Process 0
< 4 Thread (1] (Suspended)
= 1 main() testMP1.c:50 804890
4 testMPl.c 22§ job05:0 -e

{

int my_rank; * rank of pr

int nuR_procs; + nunber of proce M mpin
int source; + rank of sender + y

int dest = 6 7+ rank of receiver */ o stdoh
int tag = 0; * tag for sages * u stringh
char message([100];

WI_Status  status ; * retum status for rece
* start up WI *
WPI_Init(sargc, Sargv);

v find p K+
MPI_Comm_rank(MPI_COMM_WORLD, &my_rank);

© Console & 0 Memory| @ Error Log| [2. Problems

= 0| &= Outline 2

B R e~

o calc_pilint, int) : void
© main(int, char*{]) : int

Module 4

PTP Tutorial

The PTP Debug Perspective (2)

£ PTP Debug - MyMPIProject/testMPl.c - Eclipse SDK
fle Edit Refactor Navigate Search Run Project Window Help

=0 x|

+ Breakpoints view
shows breakpoints
that have been set
(more on this later)
Variables view —
shows the current
values of variabley
for the currently
selected process in
the Debug view
Outline view (from
CDT) of source

o [ Ov Qv | Ov = i |EBPTP Debug| 21 PTP Runti... FLC/C++
£8 Parallel Debug 3 —l ° 9= Variables £3 . 4{ Expressions < 8
3 ) ® 0 K o (2 ~
0 job02 0@y Name Value
'S job06 @ my_rank 4545765
@ num_procs 134515657
A . % source -1076822980
= & MyMPIProject [P @ dest 1076823128
- S 0
< 4 Thread (1] (Suspended)
= 1 main() testMPI.c:50 80489b0
2 testMPLc 22 i job05:0 = 0| 2 outline £ =0
« 3 o~
int my_rank; * rank of p % R ¥
int num_procs; * number of M mpih
int source; ’ .
» int dest = 0; K of receiver +/ H stdoh
int tag = 0; g for es * u stringh
chai message[160];

WPI_Status status ; * return status for recei
* start up WL *

WPI_Init(sarge, sargv);

o calc_pilint, int) : void
o main(int, char(]) : int

code

MPI_Comm_rank(MPI_COMM_WORLD, Smy_rank);

@ Console 3 Memory| @ Emor Log| [2. Problems

Module 4
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Stepp

The buttons in the 5 parallel Debug 22 .

Parallel Debug View
control groups of
processes

Click on the Step Over
button

Observe that all process
icons change to green,
then back to yellow

Notice that the current

line marker has moved to

the next source line

ing All Processes

‘" ®» 0 K (ro @ =0
ORTE@sc07tutorial: default:job06 - SeeT[4]
0 job02 o v+
%5 Debug 83 B v =8
+ B4 MyMPIProject [Parallel Application]
v & Process 0
v ® Thread [1] (Suspended)

= 1 main() testMPI.c:50 80489b0

[d testMPL.c 22§ job05:0 =t

* start up WPI +
WPI_Init(Sargc, Sargv);

Module 4

+ find out pre
” MPI_Comm_rank(MPI_COMM_WORLD, &my_rank);

+ find out number of esses *
MPT_Comm_size (MPT_COMM_WORLD, &num_procs);

PTP Tutorial

+

+

+

The buttons in the
Debug view are used
to control an

individual process, in e
this case process 0 Qiobaz

Click the Step Over
button

You will now see two
current line markers,
the first shows the

position of process 0,
the second shows the

positions of processy
1-3

Module 4

[E7PTP Debuig - MyMPIProject/src/MyMPIProjectic - Eclipse Platform - /home/beth/ecl/cpp0A02)~/ews, = 6] X
fle Edit Refactor Navigate Search Project Run Window Help
@ B Ov e QO
23 parallel Debug 2 =0 %er/4E w-v = BBSi BBAr@P| =0
ORTE@Local: default:job02 - Root [4] S
® 0 K o @ Name o
LURS B o my_rank 0
- @ num_procs 134515657
15 Debug 2 a =
@ source -1081228708
Bl - -
= T My ject [Parallel Application] .
~ & Process 0 (Suspended)
@ o Thread [1] (Suspended) e
o) MyMPIProject.c £ = 0|2 outine 2 “la)
WPI_Init(Sargc, &argv); 2 R e 7
. . . u mpih
*  MPI_Conn_rank(MPI_COMM_WORLD, &my_rank); u stdioh
. t ¢ u stringh
> | WPI_Comm_size(MPI_COMM WORLD, &num_procs); o calc_pi(int, int) : void
o main(int, char*{]) : int
if (my_rank 1= €) {
© Console 12 Memory| 2. Problems , # By v =0
0
Writable Smar...sert 2
PTP Tutorial 4-5




Process Sets (1)

+ Traditional debuggers apply operations to a single
process

+ Parallel debugging operations apply to a single process
or to arbitrary collections of processes

+ A process set is a means of simultaneously referring to
one or more processes

Module 4 PTP Tutorial 4-6

Process Sets (2)

+ When a parallel debug session is first started, all
processes are placed in a set, called the Root set

+ Sets are always associated with a single job
+ A job can have any number of process sets

+ A set can contain from 1 to the number of processes in
a job

Module 4 PTP Tutorial 4-7




Operations On Process Sets

+ Debug operations on the
Parallel Debug view
£ Parallel Debug 2 > @ 3 ® 0 K o @y =08
tOOIbar alWayS apply to the ORTE@sc07tutorial: default:job0g,
current set:

+ Resume, suspend, stop,
step into, step over, step
return

+ The current process set is
listed next to job name f
along Wlth number Of =1 main() testMP1.c:50 80489b0
processes in the set

+ The processes in process
set are visible in right hand
part of the view

Root set = all
processes

Module 4 PTP Tutorial 4-8

Managing Process Sets

+ The remaining icons in the toolbar of the Parallel
Debug view allow you to create, modify, and delete
process sets, and to change the current process set

Create set Remove
\ }rom set
# Parallel Debug &2 o> @ 2 2 ® 0 8 o @y, =0
ORTE@scO7tutorial: default:job06 - Root [4] \ Change
0 jobo2 o+ ¥+ | current set
5 Debug 3 > 3 D - =g Delete
~ &4 MyMPIProject [Parallel Application] set

v &2 Process 0
< @ Thread [1] (Suspended)
= 1 main() testMPI.c:50 80489b0

Module 4 PTP Tutorial 4-9




Creating A New Process Set

Select the processes
you want in the set by

BB b4 > ® 22 ® 0
ORTE@sc07tutorial: default:job06 - Root [4]
P > oFe oL

clicking and dragging,
in this case, the last
three

Click on the Create
Set button

Enter a name for the
set, in this case
workers, and click OK
You will see the view
change to display only
the selected processes

Module 4

¥ job06

~ Create a new set name

wlg &2 Please enter the new set name.

a

o~

< §% MyMPIProject [f

[\vovkers

v & Process 0 (S
< @ Thread [1]

llel Debug &2 o>
ORTE@scO7tu ault:job06 - workers [3]
£ job02

¥ job06

N4

PTP Tutorial

& 0

+

+

With the workers set
active, click the Step -
Over button

You will see only the
first current line
marker move

If all processes are now
at the same line, you
will only see one line
marker again

Module 4

Fle Edit Refactor Navigate Search Project Run Window Help

v @ |Bv Ov Qv Qv |O- | =
£ parallel Debug £
Lglefault:job04 - workers [3]
> W 37 ® 0 K| oy ¢ 0 @
£ jobo2 1o v
£ jobod &
%5 Debug 33 =n

i MyMPIProject [Parallel Application)
£ MyMPIProject [Parallel Application)

@ MyMPIProject.c 52
WPI_Init(Sargc, &argy);

+ find out proce ik +
MPI_Conn_rank (MPI_COMM_WORLD, &my_rank);
PRI IR U Ty C11 [T el o
- MPI_Comm_size(MPI_COMM_WORLD, &num_procs);
& Console 32 [ Memory [£. Problems

C-Build [MyMPIProject]
make: Nothing to be done for “all'.

PTP Tutorial

Name

=8 %Br&E WV R BBSI EBA P

Value

= 0|/ & outline

o o 12

&R e
mpih
stdioh
stringh
calc_pi(int, int) : void
main(int, chart(})
| =t o

> = e

Sl

sint




Process Registration

+ Process set commands apply to groups of
processes

+ For finer control and more detailed
information, a process can be registered and
isolated in the Debug view

+ Registered processes, including their stack
traces and threads, appear in the Debug view

+ Any number of processes can be registered,
and processes can be registered or
un-registered at any time

Module 4 PTP Tutorial 4-12

Registering A Process

:
* TO regISt?r a.processl file Edit Refactor Navigate Search Run Project Window Help
double-click its process _ | - 2% O Q|0 | = |4 -~ = [P
icon in the Parallel £ Parane) I ® 0 o'~ @ =08
Debug VieW or Select a ORTE@scO07tutorial: default:) 4 )
0 job02 oFH - +E Narr
number of processes and Groups (sets)
click on the register of processes M
bUtton %5 Debug &2 b - R A v=n :
+ The process iCOI’] WI” be ~ §3 MyMPIProject [Parallel Application] . .
< & Process 0 (Suspended) Individual e
surrounded by a bOX and = ® Thread [1] (Suspended) (registered) b e
the process appears in = 1 main() testMPI.c:63 80489e0 processes
h D b H - & Process 3 (Suspended)
the e ug view —p < @ Thread [1] (Suspended)
+ To un-register a process,
double-click on the d testMPIc % job05:0

process icon or select a
number of processes and
click on the unregister
button
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Current Line Marker

+ The current line marker is used to show the
current location of suspended processes

+ In traditional programs, there is a single
current line marker (the exception to this is
multi-threaded programs)

+ In parallel programs, there is a current line
marker for every process

+ The PTP debugger shows one current line
marker for every group of processes at the
same location

Module 4 PTP Tutorial 4-14

Colors And Markers

2 testMPlc B job05:0

The highlight color depends on
the processes suspended at WI_tnit(sargc, Sarg);
that line:
+ Blue: All registered process(es)
+ Orange: All unregistered
process(es)

+ Green: Registered or unregistered | @cosoe = 0 Memory @ Emorog  problems
process with no source line (e.g.
suspended in a library routine)

> MPI_Comn_rank(MPI_COMM_WORLD, &my_rank) ;

- MPI_Comn_size (MPI_COMM_WORLD, &num_procs);

% Multiple processes marker
The marker depends on the
type of process stopped at that |» Registered process marker
location

®» Un-registered process marker
Hover over marker for more
details about the processes % [Multiple markers at this line
suspend at that location -Suspended on unregistered process: 2
-Suspended on registered process: 1
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Breakpoints

+ Apply only to processes in the particular set that is
active in the Parallel Debug view when the breakpoint
is created

+ Breakpoints are colored depending on the active
process set and the set the breakpoint applies to:

+ Green indicates the breakpoint set is the same
as the active set.

+ Blue indicates some processes in the breakpoint set are
also in the active set (i.e. the process sets overlap)

+ Yellow indicates the breakpoint set is different from the
active set (i.e. the process sets are disjoint)

+ When the job completes, the breakpoints are
automatically removed i

> else{

) print:

- MPI_Final

Module 4 PTP Tutorial 4-16

Creating A Breakpoint

+ Se|ECt the process Set that fﬂ:aé:‘:c‘(ze[:::ri: default: ]o‘t;OérvioV!rker;iBIV -l e
the breakpoint should apply | o 19+ —
to, in this case, the workers | =& om
set -

+ Double-click on the left edge *’2" o Tt R
of an editor window, at the « 48 rocess 3 (suspended) -
line on which you want to set S bes

the breakpoint, or right click
and use the Parallel

Breakpoint» Toggle
Breakpoint context menu pUASYEIGRIN 5 ve=0

+ The breakpoint on the call to <printf (nessage, *Greetings from process %1%, my_rank);
MPI Send () ————l- | MPlisendtmessaée, s(r'l‘eu(messageHL IPI;CHAR.

dest, tag, MPI_COMM_WORLD);
} else {
printf(*Num processes: %d\n*,num_procs);
for (source = 1; source < num_procs; source++) {
MPI_Recv(message, 160, MPI_CHAR, source, tag,

Module 4 PTP Tutorial 4-17




Hitting the Breakpoint

+ Click on the Resume button

£ PTP Debug - MyMPIProject/testMPI.c - Eclipse SDK.
Fle Edit Refactor Navigate Search Run Project Window Help

. . coe @B ovan o]z . o @
in the Parallel Debug view—T—___" " * , =@
% parallel Debug > [ ® 0 K (54 @v =0 %]
+ In thIS examp|e the th ree ORTE@sc07tutorial: default:job06 - Root [4] o
4 . 0 jobo2 oFH» »@ =
worker processes have hit the |@zm
breakpoint, as indicated by
the yellow process icons and 3 Detyg R <=5
H 7 MyMPIProject [Parallel Application]
the current line marker T e e ,
+ Process 0 is still running as its o2 Tred bl Suended: oot L) G

icon is green

Module 4

= 1 main() testMPI.c:70 8048a14 at
- & Process 0
,® Thread [1] (Running)

¢ testMPLc 22 - job05:0

if (my_rank 1= 0) {
*create messa

*Greetings from process %d!*, my_rank);
that d +

* use strlen+l so tha get transmitte
] MPI_Send(message, strlen(message)+l, MPI_CHAR,
dest, tag, MPI_COMM_WORLD);
} else {
printf(“Num processes: %\n*,num_procs);
PTP Tutorial 4-18

More On Stepping

+ The Step buttons are only
enabled when all processes
in the active set are
suspended (yellow icon)

+ Switch to the set of
suspended processes (the

“_PTP Debug - MyMPIProject/testMPl.c - Eclipse SDK

In this case, process 0 is still—wmm -
running A joboz o8l @ i

file E ctor Navigate Search Run Project Window Help
z 5 v = [
1 Parallel Debug 53 > [ 0 K o~ v =8|
Na
»: job06

£ PTP Debug - MyMPIProject/testMPl.c - Eclipse SDK

File Edit Refactor Navigate Search Run Project Window Help

workers set)

+ You will now see the Step
buttons become enabled

Module 4

r3v @ ovar|o =4 v = @
% Parallel Debug &3 P 3. D ® 0 K oy F 3 @ =08 9%
ORTE@sc07tutorial: default:job06 - workers [3] =0

0 jobo2 1% v

[~
» job06

PTP Tutorial 4-19
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Breakpoint Information

+ Hover over breakpoint icon
+ Will show the sets this breakpoint applies to

+ Select Breakpoints view
+ Will show all breakpoints in all projects

9 Breakpoints 2 = Variables &f Expressions =8
% BB MY
¥ & testMPI.c [line: 70] {job03:workers}

Module 4 PTP Tutorial 4-20

Breakpoints View

+ Use the menu in the breakpoints view to group
breakpoints by type

+ Breakpoints sorted by bregkpoint set (process
set)

9 Breakpoints £ = Variables &< Expressions =0
% & o\ BBEG T
- (¥l » workers ¥ Show Full Paths
¥ & testMPI.c [line: 70] {job03:workers}

4| O1 Breakpoints

oo Select Default Working Set... | ()2 Breakpoint Types
03 Breakpoint Working Sets
Working Sets... 4 Files
[[] Show Qualified Names kw
= 6 Projects
’l 07 Resource Working Sets
-8 Advanced...
Module 4 PTP Tutorial 4-21
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Global Breakpoints

+ Apply to all processes and all jobs
+ Used for gaining control at debugger startup
+ To create a global breakpoint

+ First make sure that no jobs are selected (click in white
part of jobs view if necessary)

+ Double-click on the left edge of an editor window

+ Note that if a job is selected, the breakpoint will apply to
the current set

] if (my_rank !'=0) {
/* create message */
sprintf(message, "Greetin

Module 4 PTP Tutorial 4-22

Terminating A Debug Session

£ PTP Debug - MyMPIProject/testMPl.c - Eclipse SDK

File Edit Refactor Navigate Search Run Project Window Help

+ Click on the Terminate | .. 2 % O~ Qv |O | 2= | 4 o & (@B
icon in the Parallel —mr———r—0ea—0wH AT —ou6
Debug view to ORTE@sc07tutorial: default:job06 - Root [4]
terminate all processes | Qi EIIY
in the active set

+ Make sure the Root set |
is active if you want to | #pebug =z #7e=0
terminate all processes i MyMPIProject [Parallel Application]

£% Parallel Debug 2 i3 W 3 2 ® 0 K o~ v = 0|%B

ORTE@sc07tutorial: default:job06 - Root [4] -
0 jobo2 ol ¥ » » N
+ You can also use the °
terminate icon in the — . =

. ebu il D v e

Debug view to —_— = N
. < §- MyMPIProject [Parallel Application] °
terminate the currently | . o erocess o suspendea °
selected process < Thread [1] (suspended) —

Module 4 PTP Tutorial 4-23
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Module 5: Advanced Development

+ Objective
+ Explore advanced features of Eclipse and PTP

4+ Contents
+ Advanced Eclipse Features
+ Advanced PTP Features

Module 5 PTP Tutorial 5-0

Advanced Eclipse Concepts

+ Perspectives, views and preferences
+ Version control

+ Makefiles and autoconf

+ Task Tags

+ Searching

+ Refactoring

Module 5 PTP Tutorial 5-1




Customizing Perspectives

+ Items such as shortcuts, menu items and views may be
customized

+ Window» Customize Perspective...
+ Save changes

+ Window»Save Perspective As...
+ Close Perspective

+ Right-click on perspective title and select Close
+ Reset Perspective

+ Window» Reset Perspective resets the current
perspective to its default layout

Module 5 PTP Tutorial 5-2

Opening New Views

+ To open a view: ] 0
+ Choose Window» Show View» Other... _
¥ (= General had
+ The Show View dialog comes up Weookmarks
+ Select the view to be shown o
+ Select OK e e v
5% Outline
[Z Problems
€ Progress L
Project Explorer
I Properties
¥ Search
“ITasks
= Ant
P =C/ICH++ =
[ o ][ came |
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Workbench Preferences

+ Preferences provide a way for you to
customize your Workbench

+ By selecting Window » Preferences... or
Eclipse»Preferences... (Mac)

+ Examples of preference settings

+ Use Emacs bindings for editor keys

+ Modify editor folding defaults
+E.g., fold all macro definitions

+ Associate file types with file extensions
+E.g., *.f03 with the Fortran editor

+ Toggle automatic builds

+ Change key sequence shortcuts
+E.g., Ctrl+/ for Comment

Module 5 PTP Tutorial 5-4

Version Control (CVS)

+ Version control provided through the Project
Explorer View, in the Team context menu

+ Provides familiar actions: | L
i pen
+ Commit... | Sl oo
+ Update... (i Copy *c
| aste Synchrgmze with Repository
+ Also less used tasks: | Noame  m| Conmie =
+ Create/Apply Patch... -l W o
+ Tag as Version | oaimort. prdncorii
= & Merge...
+ Branch... | & Refresh Fs zwi’ih?oAnolherBran(hor\lemon,..
i Assign Working Sets... 1) Show Annotation
+ Merge... [ vaidate Show Hisory
i RunAs
+ Add to .cvsignore... [ Debugas

Change ASCII/Binary Property...

Compare With

Replace With Revert to Base

Show Editors
Source

| Properties Xe
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Specify Repository Locations

8n0o Add CVS Repository
+ Select Window}Open Add a new CVS Repository
- Add a new CVS Repository to the CVS Repositories view
Perspective»Other... cva

+ Select CVS Repository Exploring ‘=

then OK Host: dev.eclipse.org 3
Repository path:  fcvsroot/tools T]

+ Right-click in CVS Repositories i

View, then select vser:  [momymoud =

New » Repository Location...
+ Set Host to the hostname of S — =

remote machine @ Use defasitport
+ Set Repository path gz
+ Fill in Username and Password oo
+ Set Connection type I e T T
+ Check Save password Confiqure connection preferences.
+ Select Finish

2 (" Cancel ) ( Finish )
Module 5 PTP Tutorial 5-6
Checkout a non-Eclipse project as an
Eclipse C Project
+ Open Repository, open HEAD | New »
+ Locate project, right-click on _BerreE o
Project»Check out As... I - Tac ac Version
+ Make sure Check out as a project Tag it Existing...
configured using the New Project eno Check OutAs
Wizard is selected cvs

+ Select Finish
+ Select C»C project
+ Select Next>

+ Enter Project name

+ Under Project Types, select Makefile

8no New Project

Select a wizard

Create a new C project

zards

project
+ Ensures that CDT will use existing B seva project P’f’e(‘:p“
% Java Project from | (= Executable
makefiles Plug-in Project (= Shared Library
E““”‘ (= Static Library

+ Select Finish
+ Switch to the C/C++ Perspective

= Coroiet < Executable (XL C/C++)
> GCes < static Library(XL C/C++)
< Shared Library (XL C/C++)
» (= Makefile project
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About Makefiles and autoconf

+ Can create project Makefiles with the Makefile
Editor

+ Syntax highlighting and Outline view

+ autoconf often used to create Makefiles for
open source projects

+ Run configure manually, or from External
Tools Launch Configuration

+ Must refresh after running configure script

+ Refresh whenever file system is modified
outside of Eclipse

Module 5 PTP Tutorial 5-8

Building with Makefiles

& [Ecic++] Eacvs Repo...

+ Create a Make Target

named ‘all’ = B85 outline | @) Make Targets 2 = B

+ Right-click on the

project in Make >
Targets View

+ Select Add Make

reate a new Make targe

Target Name: |

Target N
ake Targef
+ Select Create Make Target; [l / S EaIE
+ Double click on new euld command =
make target to initiate Bulld command:
the build Build Setting

Stop on first build error.

/| Run all project builders.

Create Cancel
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Task Tags

[<) MysampleProject.c 2 =0
+ Task tags are identifiers in C/ : B
C++ comments
+ TODO is a built-in task tag L
+ The build locates task tags :
during compilation #1ncioae <ot
+ View task tags in Tasks View = Cj I
+ If it’s not shown, Window ~ @ S
> Show View » Other.. o &
Open General and select i ruee Do e
Tasks o1t et pessse P ==
+ Configure your own task tag Toomseinuk e o e 1
in Window » Preferences
+ Under C/C++, select Task
Tags
Module 5 PTP Tutorial 5-10

Searching

+ Language-based

searching
+ Search for Language
Elements
+ e_g_, C++ C|ass, Fle Search| %C/C++ Search
Function’ Method, Search string (+ = any string, ? = any character): e
Variable, Field, i e
N a m es pa Ce Slgss | Struct :f":::" far‘i:h\e :er([aratinns :“e:;nigmns
+ Can Limit search to Erumeration ) Enumerator (] amesp o
. TN Typedef Any Element.
Declarations, Definitions, *
References N —
+ Type navigation oo et ot
) Customize... Cancel
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Refactoring

+ Source-to-source transformation that
preserves behavior

+ Rename
+ Select C/C++ Perspective
+ Open a source file
+ Click in editor view on declaration of a variable

+ Select menu item Refactor» Rename
+ Or use context menu

+ Change variable name
+ Notice that change is semantic not textual

l = C/C++ - MyCproject/src/MyCproject.
File Edit | Refactor _Navigate Search Proje:

=, Renane‘ Alt+Shift+R. i &

Module 5 PTP Tutorial

800

int main(void) {
double intvalue-0,0}

Refactoring

The following changes are necessary to perform the refactoring. Source > H ‘ - ‘
Refactor [l Rename... OXR

Changes to be performed Declarations > Extract Constant... XC

™Mva Changes — . -

™

@' MyCproject.c - MyCproject/src

DT 5.0 is available in the

Eclipse “"Ganymede”

| MyCproject.c

Original Source

release, June 2008

‘ Refactored Source

#include <stdio.h>
#include <stdlib.h>

#include <stdlib.h>

' + Other refactorings that

__{static const float MYZERD = 0.0; ]

Tnt mainCvoid) {

return EXIT_SUCCESS; o

3
int foo(){
double mym

‘}

double intvnlu
puts("111Hello WOWPRIIT"Y; /% prints

|Tnt mainCvoid) {
double intvalue-MYZERO;

return EXIT_SUCCESS;

}
int foo(){
double myint-MYZERD;

putsC"T1IHello World! 11"} /% prir

9 (—<Back ) ( Next> (" Cancel ) ( Finish ) |
Module 5 PTP Tutorial

are planned:

Extract Function

Hide Member Function

Move Field or Member Function
Extract Subclass

Extract Baseclass

Separate Class

Implement Function

Declare Function

Move Function Definition
Generate Getters and Setters

5-13
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UPC Support

Select the features to install:

) v <] TutorialcD/updatesite

v CDT 4.0.3.200802251018
“J* Eclipse C/C++ Development Tools SDK 4.0.3.200802251
(§* Eclipse C/C++ GDB Hardware Debugging 4.0.3.2008022°

- 51018
W.S.ZOOSDZZSLO!&

Iy Pport 4.0.3.200802251018
“J> Eclipse CDT Testing Feature 4.0.3.200802251018

» 10U Parallel Tools Platform 2.0

+ To see UPC support in C
editor, install the optional
feature from CDT —_

+ Flletypes Of “UpC" will ( t‘MatrixMuIti.upc 23 } :
get UPC syntax high- IS A/ private variabies

lighting, content assist,
etc.

the matrix a[][]

1=0; 1<N; i++; &a[i][9])
d; j<P; j++)

a[iJ[J]=1*P+j+1;

intialize the matrix b[][]
upc_forall(j=0; j<M; j++; &b[9][31D
for (i=0; i<P; i44)
b[1][3]-3%2;

Module 5 PTP Tutorial 5-14

Advanced PTP Concepts

+ Remote resource managers
+ Debugging remotely
+ MPICHZ2, IBM PE and LoadLeveler
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Remote Resource Manager

Select Remote Tools as the
Remote service provider

8,00

ORTE Proxy Configuration

w"ec( to an ORTE proxy server
Click New... to create a new

Remote service provider: | Remote Tools % ]

location
Enter a Target Name, IP Proxy server location: emo! 4?:( New...
address or hOSt name Of the Path to proxy executable: x.x86/bin/ptp_orte_proxy Browse ( Options...
remote machine, and Multiplexing Options
credentials @None OO0 Tusunissmen Cotauaion /
Select Finish Local addre "eeees for comectng o remote host Z
_Select the Target Name you O Use pore e e
just created for Proxy =
server location if it is not ~ launchsenvt o s e
visible in the dropdown s ——
Password: [seeeed
O Public key based authentication
@ :\tw:hnnvaukcv W,\ (W
Advanced
Module 5 PTP T Cancel ) (Fimish ) 5-16
8.0.0
. ORTE Proxy Configuration
Cl ICk Browse to SeIeCt information to connect to an ORTE proxy server
the proxy server
executable SIS :
O en Root tW|st Remote service provider: Tools % ]
p . y Proxy server location: | VeryBigCluster < s _ New..
Now navigate to and ~
Path to proxy executable: x.x86/bin/ptp_orte_proxy (" Browse Options...

select the proxy
executable

Click OK

Module 5

Multiplexing Options

() None 8.0.0

Browse File /

I

Local address { S¢'e<t file

/Users/greg/Documents /workspaces/ptp_t
(0 Use port forw: —
» (> org.eclipse.ptp.macosx.pp.
v (> org.edlipse.ptp.macosx.x8
project
@ about.html
v @ bin O
Lcvsignore
» =0vs
2 ptp_mpich2_proxy
_ ptp_orte_proxy —
@ % prplib.py Cancel _ Finish
README L]

<dm

e=———> I

) Launch server m

oK

PE—
Cancel )

PTP Tuti




Using

+ Port forwarding can be
enabled to tunnel all
communication over a
single connection

+ If you don't want to us
port forwarding, your
local machine must be
accessible from the
remote machine

+ Select your local machine’s
IP address from the

Port Forwarding

800

ORTE Proxy Configuration

Enter information to connect to an ORTE proxy server

Remote service provider: | Remote Tools m

Proxy server location: local 2 New...

Path to proxy executable: x.x86/bin/ptp_orte_proxy _ Browse _ Options...
Multiplexing Options.
() None
Local address for proxy connection: 9.67.154.242 v

(® Use port forwarding

dropdown o e
+ Enter it manually if it’s not e e
visible
+ Click Finish
@ < Back Next > Cancel ( Finish \
Module 5 PTP Tutorial 5-18
.00 Debug
+ Choose remote resource Ccreat manage, and run configurations .—»i\
manager in Main tab Create a configuration to launch a parallel application in Parallel Debug Perspective &

+ Click Browse and select
sdm executable on ~
remote machine (if path
is not correct)

+ Set Debugger session
address to the address
of the machine running
the proxy agent

+ The address must be

accessible from a cluster
node

+ Click Finish

Module 5

< || Name: shallow2
filter text

1) Main (i} Resources (33 Debugger , ®: Arguments | % Source| 2

(31 Java Applicatio

er: [ SDM 2]

Ju JUnit
ju JUnit Plug-in Test

$ 0SGi Framework ™ Stop at main() on
£ Parallel Application|| | Debugger Options

S debug fail Path to debugger executable:

- D rm——
/home/greg/ptp/plugins/org.eclipse.ptp.linux.x86_2 Browse
Debugger session address:

cluster_head

8% shallow local
T Remote Java Aoplic

c

Apply ) ( Revert
Filter matched 19 of 19
2 Close Debug
PTP Tutorial 5-19
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Alternate Resource Managers

+ An MPICH2 resource manager is provided
+ Use ptp mpich2 proxy when selecting proxy executable
+ PE and LoadlLeveler

+ See help documentation that comes with PTP for
information on configuring and using

+ Debugging support for alternate resource managers will
be available in next version of PTP

Module 5 PTP Tutorial 5-20
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Module 6: Where To Go Next

+ Objective
+ How to find more information on PTP
+ Learn about other tools related to PTP
+ See PTP upcoming features
+ Contents
+ Links to other tools, including performance tools
+ Planned features for new versions of PTP
+ Additional documentation
+ How to get involved

Module 6 PTP Tutorial 6-0

Information About PTP

+ Main web site for downloads, documentation, etc.
+ http://eclipse.org/ptp
+ Developers’ wiki for designs, planning, meetings, etc.
+ http://wiki.eclipse.org/PTP
+ Mailing lists
+ Major announcements (new releases, etc.) - low volume
+ http://dev.eclipse.org/mailman/listinfo/ptp-announce
+ User discussion and queries - medium volume
+ http://dev.eclipse.org/mailman/listinfo/ptp-user
+ Developer discussions - high volume
+ http://dev.eclipse.org/mailman/listinfo/ptp-dev

Module 6 PTP Tutorial 6-1




PTP-Related Tools

+ Performance Tools Framework
+ Tuning and Analysis Utilities (TAU)
+ Photran - Fortran Development Tools

Module 6 PTP Tutorial 6-2

PTP / Performance Tools
Framework

Goal:

+ Reduce the “eclipse plumbing”
necessary to integrate tools

+ Provide integration for
instrumentation, measurement, and
analysis for a variety of performance
tools

+ Dynamic Tool Definitions:
Workflows & Ul

+ Tools and tool workflows are
specified in an XML file

+ Tools are selected and configured in
the launch configuration window ot —

+ Output is generated, managed and » o
analyzed as specified in the
workflow

Module 6 PTP Tutorial 6-3
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PTP TAU plug-ins http://

www.cs.uoregon.edu/research/tau/home.php

+ TAU (Tuning and Analysis Utilities)
+ First implementation of Performance Tools Framework

+ Eclipse plug-ins wrap TAU functions, make them
available from Eclipse

+ Compatible with Photran and CDT projects and with
PTP parallel application launching

+ Other plug-ins launch Paraprof from Eclipse too

Module 6 PTP Tutorial 6-4

Taskfinder

+ Dynamic analysis tool
available soon in PLDT 2.1

+ Profiles program counter
addresses and memory

iguratio X!

Create, manage, and run configurations o~

|
Build C, C++ or Fortran applications with performance analysis tools. Launch as sequential programs or &
use the command line for parallel execution

references via PIN tool

Name: gsort
Main ¢+ Arguments 78 Environmen Performance Analysis . P)Debugger 2
Tool Selection TF options
anai e
e fho me.

instrumentation of x86 ormance ol
Linux binaries p— R
+ Feedback on available
parallelism in loops, etc. @ sanpe size 2500 (3500
W Rate (30) 30
+ Utilizes Performance
¥ Report file runtime-ptp21-pldt-taskfinder/qsort/tisprof.out |  Browse
Tools Framework
+ UI & launch info Fiter matched 3 of 3 tem foply ]| Reter
completely specified
in XML - no code
Module 6 PTP Tutorial 6-5




Taskfinder (2)

Performance Tools Framework provides callback at end of run..

Resu Its Shown In File Edit Refactor Navigate Search Project Run Window Help
Taskfinder view | - | @ o @ o %~ 0 9~ a- | o~ o @oew) -
& v -
+ Doa ” : (5 Project Ex 82 - T B [gqsort.c &2 < scanner.c =8 goutline 2 =8
= [&)] - | @1 swap. ( &list[il, &list(il ): = o ©
dependence-free & -5 LI
b §50mp2001 M@ o stdoh
IOOp v gqsort 31:,’ swap_( &Uist[++m], &listlil] ): o stdibh 5
b i sinaries @116 if ( list(i) == [ = # CUTOFF
+ Doacross: b & Includes %] swap..{&listl "J &U“Ul )i # length
P @ Debug 11¢ o » © pivots ©
loop-carry P D
w1 stdio.h [2: Problems | 7 Tasks & Console = Propertie{ @ TaskFinder View £3 =g
dependence b §
y i X %
# CUTOFF ) ; ; @
Task Head Candic Filename LineNo frac  speedul Ispdup size  count
+ BOth m ay be # V?ng[h @ name: doall qsort.c 104 20 10 320 66 3459
Ca nd |dates © list @ name: doall qsort.c 118 18 1.0 320 1105 192
’"Se([‘orf-so' @ name: doacross gsort.c 116 38 10 13 7 6276
for ( manual ) '"e:';"""“l] [ name: doacross _gsort.c 113 12 6276
. . pard! 'D"('v" 1|3 @ name: doacross  gsort.c 17 18 10 1.0 105 192
parallelization aucksortnt * | &
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Photran

Supports Fortran in
the Eclipse workbench

Supports Fortran 77, 90,
and 95
It includes:

Syntax-highlighting editor
CVS support

GUI interface to gdb
Makefile-based
compilation

Compiler error extraction
Outline view

Open declaration

Rename and Introduce
Implicit None refactorings

Module 6

http://eclipse.org/photran

0 - Eciipse Platform

L]

fle Edt Navigate Search Project Bun Window Help
$-0-Q- [B- 8- B |® 2 |@ |2 §iv © © o [Erortran

o/
- RN e T
| _modute maataset B —
implicit none >

& Fortran Projects 5 2 Outine 52 =0

.
b gSumep | v O Mastaset

@ §>org.eclpse.photran-samp < O Taataset

Tdataset

b O Binaries type :: ° datapt
b A src-fixed-form real ® npts
integer
b (src-fortran-and-c o _real ° vaisum
b (A src-gaussian-elmination | | @ ___real ° valsum
. real mn(3) .
b & srcincludes 1 tegiem ti has_np(2) xysum
b (src-tanguage features end type Teataset ° hasnp

< i >srcine-fitting

cvsignore 1.1 (ASC!

< @ BstFitProj
“  LoadDataSet

end module Miataset
program BstFitProj
¢ ShowDataPoints

~1 1@ _use Mdataset
B « > <

b A src-modules “_SauareDistances [~
B

% Make Targets i3 =0 [ problems i3 Console Properties v =n

S M 26 emors, 0 wamings, 0 infos

Description Resource 1=

b ESorg.eclipse.photran-samples .
© FILE tag must be of type CHARACTER bug118974.1

b Swhatever2

© llegal preprocessor directive

aQ
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Useful Eclipse Tools

+ Python
+ http://pydev.sourceforge.net

+ Subversion (CVS replacement)
+ http://subclipse.tigris.org
+ Now an Eclipse Technology project

+ ... and many more!

Module 6 PTP Tutorial
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Future PTP Features

+ Multicore tools

+ Resource manager support for SLURM, PBS,
LSF, BG/P

+ Simplified runtime system interface (plus
support for other MPI runtimes)

+ Debugging support for a broad range of
architectures

+ Full remote project support (combined with
CDT)

+ Remote build and indexing
+ Remote launch/debug

+ More performance analysis tools integration

Module 6 PTP Tutorial
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PTP Publications

+ “Eclipse PTP: An Integrated Environment for the Development
of Parallel Applications,” Greg Watson, 2nd Parallel Tools
Workshop, July 2008, Stuttgart, Germany (to appear)

+ “Developing Scientific Applications Using Eclipse,” Computing
in Science & Engineering, vol. 8, no. 4, July/August 2006, pp.
50-61

+ Link on http://eclipse.org/ptp web page

+ “A Model-Based Framework for the Integration of Parallel
Tools”, Proceedings of the IEEE International Conference on
Cluster Computing, Barcelona, September 2006

+ Link on http://eclipse.org/ptp web page

+ IBM developerWorks article:

+ http://www-128.ibm.com/developerworks/edu/os-dw-os-ecl-ptp.html

+ “An Integrated Tools Platform for Multi-Core Enablement,”
Beth Tibbitts & Evelyn Duesterwald, STMCS: Second
Workshop on Software Tools for Multi-Core Systems, March
2007

+ http://www.isi.edu/~mhall/stmcs07/program.html

Module 6 PTP Tutorial 6-10

Getting Involved

+ See http://eclipse.org/ptp
+ Read the developer documentation on the wiki
+ Join the mailing lists

+ ptp-dev@eclipse.org; ptp-user@eclipse.org
+ Attend the monthly developer teleconference
+ Attend the annual workshop

+ PTP will only succeed with your participation!

Module 6 PTP Tutorial 6-11




PTP Tutorial Feedback

+ Please complete feedback form
+ Your feedback is valuable!

Thanks for attending
We hope you found it useful

Module 6 PTP Tutorial
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